[PATCH] mm: Introduce GFP_PGTABLE

2019-01-12 Thread Anshuman Khandual
All architectures have been defining their own PGALLOC_GFP as (GFP_KERNEL | __GFP_ZERO) and using it for allocating page table pages. This causes some code duplication which can be easily avoided. GFP_KERNEL allocated and cleared out pages (__GFP_ZERO) are required for page tables on any given arch

Re: [PATCH v7 10/25] ACPI / APEI: Tell firmware the estatus queue consumed the records

2019-01-12 Thread Tyler Baicar
On Fri, Jan 11, 2019 at 1:09 PM James Morse wrote: > On 11/01/2019 15:32, Tyler Baicar wrote: > > On Fri, Jan 11, 2019 at 7:03 AM Borislav Petkov wrote: > >> On Thu, Jan 10, 2019 at 04:01:27PM -0500, Tyler Baicar wrote: > >>> On Thu, Jan 10, 2019 at 1:23 PM James Morse wrote: > >> > >> +

Re: [PATCH v7 10/25] ACPI / APEI: Tell firmware the estatus queue consumed the records

2019-01-12 Thread Tyler Baicar
On Fri, Jan 11, 2019 at 7:03 AM Borislav Petkov wrote: > On Thu, Jan 10, 2019 at 04:01:27PM -0500, Tyler Baicar wrote: > > On Thu, Jan 10, 2019 at 1:23 PM James Morse wrote: > > > >> > > > >> +if (is_hest_type_generic_v2(ghes) && > > > >> ghes_ack_error(ghes->generic_v2)) > > > > > > > > Sin

Re: [PATCH] mm: Introduce GFP_PGTABLE

2019-01-12 Thread Anshuman Khandual
On 01/12/2019 05:42 PM, Matthew Wilcox wrote: > On Sat, Jan 12, 2019 at 03:56:38PM +0530, Anshuman Khandual wrote: >> All architectures have been defining their own PGALLOC_GFP as (GFP_KERNEL | >> __GFP_ZERO) and using it for allocating page table pages. > > Except that's not true. > >> +++ b/