Re: [PATCH 44/44] KVM: Opt out of generic hardware enabling on s390 and PPC

2022-11-06 Thread Anup Patel
igned-off-by: Sean Christopherson For KVM RISC-V: Acked-by: Anup Patel Thanks, Anup > --- > arch/arm64/kvm/Kconfig | 1 + > arch/mips/kvm/Kconfig | 1 + > arch/powerpc/include/asm/kvm_host.h | 1 - > arch/powerpc/kvm/powerpc.c | 5 -

Re: [PATCH 30/44] KVM: Drop kvm_arch_check_processor_compat() hook

2022-11-06 Thread Anup Patel
On Thu, Nov 3, 2022 at 4:50 AM Sean Christopherson wrote: > > Drop kvm_arch_check_processor_compat() and its support code now that all > architecture implementations are nops. > > Signed-off-by: Sean Christopherson For KVM RISC-V: Acked-by: Anup Patel Thanks, Anup > ---

Re: [PATCH 27/44] KVM: Drop kvm_arch_{init,exit}() hooks

2022-11-06 Thread Anup Patel
On Thu, Nov 3, 2022 at 4:50 AM Sean Christopherson wrote: > > Drop kvm_arch_init() and kvm_arch_exit() now that all implementations > are nops. > > No functional change intended. > > Signed-off-by: Sean Christopherson For KVM RISC-V: Acked-by: Anup Patel Thanks, Anup &g

Re: [PATCH 23/44] KVM: RISC-V: Tag init functions and data with __init, __ro_after_init

2022-11-06 Thread Anup Patel
On Thu, Nov 3, 2022 at 4:49 AM Sean Christopherson wrote: > > Now that KVM setup is handled directly in riscv_kvm_init(), tag functions > and data that are used/set only during init with __init/__ro_after_init. > > Signed-off-by: Sean Christopherson For KVM RISC-V: Acked-by: Anup

Re: [PATCH 22/44] KVM: RISC-V: Do arch init directly in riscv_kvm_init()

2022-11-06 Thread Anup Patel
> > No functional change intended. > > Signed-off-by: Sean Christopherson For KVM RISC-V: Acked-by: Anup Patel Regards, Anup > --- > arch/riscv/kvm/main.c | 18 +- > 1 file changed, 9 insertions(+), 9 deletions(-) > > diff --git a/arch/riscv/kvm/main.c b/arc

Re: [PATCH 09/44] KVM: Drop arch hardware (un)setup hooks

2022-11-06 Thread Anup Patel
On Thu, Nov 3, 2022 at 4:49 AM Sean Christopherson wrote: > > Drop kvm_arch_hardware_setup() and kvm_arch_hardware_unsetup() now that > all implementations are nops. > > No functional change intended. > > Signed-off-by: Sean Christopherson For KVM RISC-V: Acked-by: Anup

Re: [PATCH kernel] KVM: PPC: Make KVM_CAP_IRQFD_RESAMPLE platform dependent

2022-09-15 Thread Anup Patel
e > XIVE mode does not handle INTx in KVM at all. > > This moved the capability support advertising to platforms and stops > advertising it on XIVE, i.e. POWER9 and later. > > Signed-off-by: Alexey Kardashevskiy > --- > > > Or I could move this one together with KVM_

Re: [PATCH v7 21/23] KVM: Allow for different capacities in kvm_mmu_memory_cache structs

2022-06-29 Thread Anup Patel
> Signed-off-by: David Matlack > Message-Id: <20220516232138.1783324-22-dmatl...@google.com> > Signed-off-by: Paolo Bonzini For KVM RISC-V Reviewed-by: Anup Patel Tested-by: Anup Patel Regards, Anup > --- > arch/arm64/kvm/mmu.c | 2 +- > arch/riscv/kvm/mmu.c | 5 +--

Re: [PATCH 2/4] KVM: selftests: Increase UCALL_MAX_ARGS to 7

2022-06-20 Thread Anup Patel
On Mon, Jun 20, 2022 at 12:51 PM Andrew Jones wrote: > > On Sat, Jun 18, 2022 at 12:09:11AM +, Sean Christopherson wrote: > > On Fri, Jun 17, 2022, Colton Lewis wrote: > > > On Thu, Jun 16, 2022 at 02:10:06PM +0200, Andrew Jones wrote: > > > > We probably want to ensure all architectures are g

Re: [PATCH v6 21/22] KVM: Allow for different capacities in kvm_mmu_memory_cache structs

2022-05-19 Thread Anup Patel
time the > cache is topped-up. > > While here, opportunistically clean up the stack-allocated > kvm_mmu_memory_cache structs in riscv and arm64 to use designated > initializers. > > No functional change intended. > > Reviewed-by: Marc Zyngier > Signed-off-by: David Matlack Looks

Re: [PATCH v5 20/21] KVM: Allow for different capacities in kvm_mmu_memory_cache structs

2022-05-15 Thread Anup Patel
On Sat, May 14, 2022 at 1:59 AM David Matlack wrote: > > Allow the capacity of the kvm_mmu_memory_cache struct to be chosen at > declaration time rather than being fixed for all declarations. This will > be used in a follow-up commit to declare an cache in x86 with a capacity > of 512+ objects wit

Re: [PATCH] selftests: kvm: replace ternary operator with min()

2022-05-11 Thread Anup Patel
> min() is defined in tools/include/linux/kernel.h. > > Signed-off-by: Guo Zhengkui For KVM RISC-V: Acked-by: Anup Patel Thanks, Anup > --- > tools/testing/selftests/kvm/lib/aarch64/ucall.c | 4 ++-- > tools/testing/selftests/kvm/lib/riscv/ucall.c | 2 +- > tools/te

Re: [PATCH v3 20/23] KVM: Allow for different capacities in kvm_mmu_memory_cache structs

2022-04-20 Thread Anup Patel
d since then there would be no guarantee the kvm_mmu_memory_cache > struct and objects array would be laid out consecutively on the stack. > > No functional change intended. > > Signed-off-by: David Matlack Looks good to me. For KVM RISC-V: Acked-by: Anup Patel Regards,

Re: [PATCH v4 07/15] KVM: Create helper for setting a system event exit

2022-03-19 Thread Anup Patel
On Fri, Mar 11, 2022 at 11:11 PM Oliver Upton wrote: > > Create a helper that appropriately configures kvm_run for a system event > exit. > > No functional change intended. > > Suggested-by: Marc Zyngier > Signed-off-by: Oliver Upton > Acked-by: Anup Patel >

Re: [PATCH v2 21/26] KVM: Allow for different capacities in kvm_mmu_memory_cache structs

2022-03-18 Thread Anup Patel
On Fri, Mar 11, 2022 at 5:56 AM David Matlack wrote: > > Allow the capacity of the kvm_mmu_memory_cache struct to be chosen at > declaration time rather than being fixed for all declarations. This will > be used in a follow-up commit to declare an cache in x86 with a capacity > of 512+ objects wit

Re: [PATCH v3 10/19] KVM: Create helper for setting a system event exit

2022-02-22 Thread Anup Patel
On Wed, Feb 23, 2022 at 9:49 AM Oliver Upton wrote: > > Create a helper that appropriately configures kvm_run for a system event > exit. > > No functional change intended. > > Suggested-by: Marc Zyngier > Signed-off-by: Oliver Upton Looks good to me. For KVM RISC

Re: [PATCH v5 05/12] KVM: RISC-V: Use Makefile.kvm for common files

2021-11-23 Thread Anup Patel
On Sun, Nov 21, 2021 at 6:25 PM David Woodhouse wrote: > > From: David Woodhouse > > Signed-off-by: David Woodhouse Looks good to me. For KVM RISC-V, Acked-by: Anup Patel Reviewed-by: Anup Patel Thanks, Anup > --- > arch/riscv/kvm/Makefile | 6 +- > 1 file chang

Re: [PATCH v2 13/43] KVM: Rename kvm_vcpu_block() => kvm_vcpu_halt()

2021-10-22 Thread Anup Patel
andle > non-halt cases where the vCPU is not runnable. > > Rename block_ns to halt_ns to match the new function name. > > No functional change intended. > > Reviewed-by: David Matlack > Reviewed-by: Christian Borntraeger > Signed-off-by: Sean Christopherson > --- For

Re: [PATCH v2 09/43] KVM: Drop obsolete kvm_arch_vcpu_block_finish()

2021-10-22 Thread Anup Patel
stopherson For KVM RISC-V: Acked-by: Anup Patel Reviewed-by: Anup Patel Regards, Anup > --- > arch/arm64/include/asm/kvm_host.h | 1 - > arch/mips/include/asm/kvm_host.h| 1 - > arch/powerpc/include/asm/kvm_host.h | 1 - > arch/riscv/include/asm/kvm_host.h | 1 -

RE: [PATCH RFC 11/14] arm64: Move the ASID allocator code in a separate file

2019-09-16 Thread Anup Patel
> -Original Message- > From: linux-kernel-ow...@vger.kernel.org ow...@vger.kernel.org> On Behalf Of Will Deacon > Sent: Monday, September 16, 2019 11:48 PM > To: Anup Patel > Cc: Palmer Dabbelt ; guo...@kernel.org; Will Deacon > ; julien.thie...@arm.com; a

RE: [PATCH RFC 11/14] arm64: Move the ASID allocator code in a separate file

2019-09-15 Thread Anup Patel
erkeley.edu; james.mo...@arm.com; > Arnd Bergmann ; suzuki.poul...@arm.com; > marc.zyng...@arm.com; catalin.mari...@arm.com; Anup Patel > ; linux-ker...@vger.kernel.org; > r...@linux.ibm.com; Christoph Hellwig ; Atish Patra > ; julien.gr...@arm.com; g...@garyguo.net; Paul > Walmsley

Re: [RFC PATCH 0/6] ARM64: KVM: PMU infrastructure support

2015-02-16 Thread Anup Patel
Hi Christoffer, On Sun, Feb 15, 2015 at 9:03 PM, Christoffer Dall wrote: > Hi Anup, > > On Mon, Jan 12, 2015 at 09:49:13AM +0530, Anup Patel wrote: >> On Mon, Jan 12, 2015 at 12:41 AM, Christoffer Dall >> wrote: >> > On Tue, Dec 30, 2014 at 11:19:13AM +0530, Anu

Re: vexpress: Framebuffer broken with KVM enabled

2015-02-16 Thread Anup Patel
On Mon, Feb 16, 2015 at 2:43 PM, Jan Kiszka wrote: > Hi, > > next issue related to KVM/QEMU on the TK1: The guest image I'm running > gives proper framebuffer output when in emulation mode. Once KVM is > enabled, the screen is - at best - only initially updated. Sometimes I > see the famous tux im