Re: [PATCH 07/11] arm64: add basic pointer authentication support

2017-08-11 Thread Dave Martin
On Fri, Aug 11, 2017 at 08:46:28AM +0100, Yao Qi wrote: > Hi Mark, > > On 19/07/17 17:01, Mark Rutland wrote: > >+#define HWCAP_APIA (1 << 16) > > Can you rename it to HWCAP_ARM64_APIA or HWCAP_ARM_APIA? When we > use it in user space, at least in GDB, we usually do this, > > #ifndef

Re: [PATCH 07/11] arm64: add basic pointer authentication support

2017-08-11 Thread Yao Qi
Hi Mark, On 19/07/17 17:01, Mark Rutland wrote: +#define HWCAP_APIA (1 << 16) Can you rename it to HWCAP_ARM64_APIA or HWCAP_ARM_APIA? When we use it in user space, at least in GDB, we usually do this, #ifndef HWCAP_APIA #define HWCAP_APIA (1 << 16) #endif However, the code use th

Re: [PATCH 07/11] arm64: add basic pointer authentication support

2017-07-25 Thread Dave Martin
On Wed, Jul 19, 2017 at 05:01:28PM +0100, Mark Rutland wrote: > This patch adds basic support for pointer authentication, allowing > userspace to make use of APIAKey. The kernel maintains an APIAKey value > for each process (shared by all threads within), which is initialised to > a random value at

[PATCH 07/11] arm64: add basic pointer authentication support

2017-07-19 Thread Mark Rutland
This patch adds basic support for pointer authentication, allowing userspace to make use of APIAKey. The kernel maintains an APIAKey value for each process (shared by all threads within), which is initialised to a random value at exec() time. Instructions using other keys (APIBKey, APDAKey, APDBKe