On Tue, Apr 19, 2011 at 10:03 PM, rukhsana afroz
wrote:
>
>
> On Tue, Apr 19, 2011 at 9:09 PM, rukhsana afroz
> wrote:
>
>>
>>
>> On Tue, Apr 19, 2011 at 2:59 PM, Nicolas George <
>> nicolas.geo...@normalesup.org> wrote:
>>
>>> I suggest you produce your patch using the revision control tool (svn
On Tue, Apr 19, 2011 at 23:53:04 (CEST), Janne Grunau wrote:
> On Tue, Apr 19, 2011 at 07:55:52PM +0200, Reinhard Tartler wrote:
>> Instead of 'c32651d', this change produces something like
>> 'v0.7b1-1-gc32651d'
>>
>> The first part is the name of the latest tag (usually a beta release),
>> the
On Tue, Apr 19, 2011 at 9:09 PM, rukhsana afroz wrote:
>
>
> On Tue, Apr 19, 2011 at 2:59 PM, Nicolas George <
> nicolas.geo...@normalesup.org> wrote:
>
>> I suggest you produce your patch using the revision control tool (svn or
>> git), and attach it as a file to avoid its mangling.
>>
>> Hi Rona
On Tue, Apr 19, 2011 at 2:59 PM, Nicolas George <
nicolas.geo...@normalesup.org> wrote:
> I suggest you produce your patch using the revision control tool (svn or
> git), and attach it as a file to avoid its mangling.
>
> Hi Ronald and Nicolas,
Thanks for your suggestion. Now I have used git diff
I'm cross-posting to ffmpeg-devel and libav-devel, as this issue
exists in both codebases. I've attached the patch and reproduced
below. I don't have a lot of experience with the ffmpeg code base.
It originally was reported in:
https://roundup.libav.org/issue
The issue was created by the pa
---
doc/APIchanges | 14 +++---
1 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/doc/APIchanges b/doc/APIchanges
index 2c0d585..a9faaf9 100644
--- a/doc/APIchanges
+++ b/doc/APIchanges
@@ -1,13 +1,13 @@
Never assume the API of libav* to be stable unless at least 1 week has
---
libavformat/flic.c |1 -
1 files changed, 0 insertions(+), 1 deletions(-)
diff --git a/libavformat/flic.c b/libavformat/flic.c
index fcdf4c8..ad39d66 100644
--- a/libavformat/flic.c
+++ b/libavformat/flic.c
@@ -158,7 +158,6 @@ static int flic_read_header(AVFormatContext *s,
ast->
---
libavcodec/ac3enc.c |2 --
1 files changed, 0 insertions(+), 2 deletions(-)
diff --git a/libavcodec/ac3enc.c b/libavcodec/ac3enc.c
index 04e8b4f..11db4b9 100644
--- a/libavcodec/ac3enc.c
+++ b/libavcodec/ac3enc.c
@@ -1988,8 +1988,6 @@ static av_cold int set_channel_info(AC3EncodeContext *
This allows the user to set only channel_layout and not channels.
---
libavcodec/utils.c |2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/libavcodec/utils.c b/libavcodec/utils.c
index e03a4c9..1f0a0c5 100644
--- a/libavcodec/utils.c
+++ b/libavcodec/utils.c
@@ -584,6 +584
---
libavcodec/utils.c | 16
1 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/libavcodec/utils.c b/libavcodec/utils.c
index 3430366..6e6366f 100644
--- a/libavcodec/utils.c
+++ b/libavcodec/utils.c
@@ -545,14 +545,14 @@ int attribute_align_arg avcodec_open(AVCodecC
---
libavcodec/utils.c |7 +++
1 files changed, 7 insertions(+), 0 deletions(-)
diff --git a/libavcodec/utils.c b/libavcodec/utils.c
index 6e6366f..e03a4c9 100644
--- a/libavcodec/utils.c
+++ b/libavcodec/utils.c
@@ -578,6 +578,13 @@ int attribute_align_arg avcodec_open(AVCodecContext *av
If the encoder has a channel_layouts list and AVCodecContext.channel_layout
is 0, then only print a warning and let the encoder decide how to handle it.
---
libavcodec/utils.c | 28 +++-
1 files changed, 27 insertions(+), 1 deletions(-)
diff --git a/libavcodec/utils.c b
Hi Rukhsana,
On Tue, Apr 19, 2011 at 5:55 PM, rukhsana afroz
wrote:
> The following is the patch for selective arithmetic coding bypass cblk_csty:
>
> 595c595
> < static void decode_sigpass(J2kT1Context *t1, int width, int height, int
> bpno, int bandno)
> ---
>> static void decode_sigpass(J2kT1C
On Wed, Apr 13, 2011 at 1:46 PM, Michael Niedermayer wrote:
>
> i dont see a specific question in your mail, my suggestion is just to
> implement the missing feature.
> If you have specific questions ill try my best to help
>
Hi Michael,
The following is the patch for selective arithmetic coding
On Tue, Apr 19, 2011 at 10:12:10PM +0200, Diego Biurrun wrote:
> ---
> libpostproc/postprocess.c |4
> libpostproc/postprocess.h |6 --
> 2 files changed, 0 insertions(+), 10 deletions(-)
>
> diff --git a/libpostproc/postprocess.c b/libpostproc/postprocess.c
> index 73ffcb4..d7c9
On Tue, Apr 19, 2011 at 07:55:52PM +0200, Reinhard Tartler wrote:
> Instead of 'c32651d', this change produces something like
> 'v0.7b1-1-gc32651d'
>
> The first part is the name of the latest tag (usually a beta release),
> the second part are the number of commits after the latest tag and the
>
On 04/19/2011 09:20 PM, Anton Khirnov wrote:
> ---
> libavutil/Makefile |1 -
> libavutil/sha.c| 24 -
> libavutil/sha1.h | 57
>
> 3 files changed, 0 insertions(+), 82 deletions(-)
> delete mode 100644 libavu
The function currently acts differently according to a boolean flag
parameter and asks for a sample or not. Split the function into two
variants instead, one which asks for a sample and one which does not.
---
libavcodec/aac_adtstoasc_bsf.c |4 ++--
libavcodec/aacdec.c| 19 ++
---
libpostproc/postprocess.c |4
libpostproc/postprocess.h |6 --
2 files changed, 0 insertions(+), 10 deletions(-)
diff --git a/libpostproc/postprocess.c b/libpostproc/postprocess.c
index 73ffcb4..d7c99e2 100644
--- a/libpostproc/postprocess.c
+++ b/libpostproc/postprocess.c
@@
On 04/19/2011 07:55 PM, Reinhard Tartler wrote:
> Instead of 'c32651d', this change produces something like
> 'v0.7b1-1-gc32651d'
>
> The first part is the name of the latest tag (usually a beta release),
> the second part are the number of commits after the latest tag and the
> last part is the v
On Tue, Apr 19, 2011 at 09:26:13PM +0200, Anton Khirnov wrote:
> ---
> libswscale/rgb2rgb.c | 28
> libswscale/rgb2rgb.h | 10 --
> libswscale/swscale.c |8
> libswscale/swscale.h | 16
> libswscale/utils.c |7 ---
>
On Tue, Apr 19, 2011 at 09:26:12PM +0200, Anton Khirnov wrote:
> ---
> libavutil/random_seed.c |8
> 1 files changed, 0 insertions(+), 8 deletions(-)
OK
Diego
___
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailm
---
libswscale/rgb2rgb.c | 28
libswscale/rgb2rgb.h | 10 --
libswscale/swscale.c |8
libswscale/swscale.h | 16
libswscale/utils.c |7 ---
5 files changed, 0 insertions(+), 69 deletions(-)
diff --git a/libswscale/
---
libavutil/random_seed.c |8
1 files changed, 0 insertions(+), 8 deletions(-)
diff --git a/libavutil/random_seed.c b/libavutil/random_seed.c
index 6dc8d22..a1078d8 100644
--- a/libavutil/random_seed.c
+++ b/libavutil/random_seed.c
@@ -80,11 +80,3 @@ uint32_t av_get_random_seed(voi
Hi,
On Tue, Apr 19, 2011 at 3:20 PM, Anton Khirnov wrote:
> ---
> libavutil/Makefile | 1 -
> libavutil/sha.c | 24 -
> libavutil/sha1.h | 57
>
> 3 files changed, 0 insertions(+), 82 deletions(-)
> delete mod
---
libavutil/Makefile |1 -
libavutil/sha.c| 24 -
libavutil/sha1.h | 57
3 files changed, 0 insertions(+), 82 deletions(-)
delete mode 100644 libavutil/sha1.h
diff --git a/libavutil/Makefile b/libavutil/Make
On 04/19/2011 01:49 PM, Reinhard Tartler wrote:
> ---
> Changelog |5 +
> 1 files changed, 5 insertions(+), 0 deletions(-)
>
> diff --git a/Changelog b/Changelog
> index 4bc6d31..f38ef9e 100644
> --- a/Changelog
> +++ b/Changelog
> @@ -4,6 +4,11 @@ releases are sorted from youngest to ol
Instead of 'c32651d', this change produces something like
'v0.7b1-1-gc32651d'
The first part is the name of the latest tag (usually a beta release),
the second part are the number of commits after the latest tag and the
last part is the version hash prefixed with 'g' (like git).
---
version.sh |
On Tue, Apr 19, 2011 at 07:52:06PM +0200, Anton Khirnov wrote:
> Fixes make install after 3453a231a6cebe5989c213be0f9fd6c71ec5ea23.
OK
Diego
___
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailman/listinfo/libav-devel
Fixes make install after 3453a231a6cebe5989c213be0f9fd6c71ec5ea23.
---
libavcodec/Makefile |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/libavcodec/Makefile b/libavcodec/Makefile
index 784226f..f05244e 100644
--- a/libavcodec/Makefile
+++ b/libavcodec/Makefile
@@ -3,7 +
---
Changelog |5 +
1 files changed, 5 insertions(+), 0 deletions(-)
diff --git a/Changelog b/Changelog
index 4bc6d31..f38ef9e 100644
--- a/Changelog
+++ b/Changelog
@@ -4,6 +4,11 @@ releases are sorted from youngest to oldest.
version :
+- Lots of deprecated API cruft removed
+
+
+v
Hi,
On Tue, Apr 19, 2011 at 12:51 PM, Anton Khirnov wrote:
> ---
> libavcodec/Makefile | 1 -
> libavcodec/avcodec.h | 114
> +--
> libavcodec/dsputil.h | 8 ---
> libavcodec/imgconvert.c | 51 -
> libavcodec/opt
---
libavcodec/Makefile |1 -
libavcodec/avcodec.h| 114 +--
libavcodec/dsputil.h|8 ---
libavcodec/imgconvert.c | 51 -
libavcodec/opt.c| 66 ---
libavcodec/options.c|3
On Mon, 18 Apr 2011 18:20:17 -0400, Alexander Strange
wrote:
>
> On Apr 18, 2011, at 3:03 AM, Anton Khirnov wrote:
>
> > ---
> > libavcodec/avcodec.h | 19 ---
> > libavcodec/utils.c | 16
> > libavcodec/version.h |3 ---
> > 3 files changed, 0 insertions
This makes the function more flexible and allows using it in more places.
---
libavcodec/avcodec.h | 13 +++--
libavcodec/utils.c | 16
2 files changed, 15 insertions(+), 14 deletions(-)
diff --git a/libavcodec/avcodec.h b/libavcodec/avcodec.h
index df4e617..ddf8cd6
---
libavcodec/loco.c |2 +-
libavcodec/wnv1.c |8 ++--
2 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/libavcodec/loco.c b/libavcodec/loco.c
index 0733d09..9dec24d 100644
--- a/libavcodec/loco.c
+++ b/libavcodec/loco.c
@@ -248,7 +248,7 @@ static av_cold int decode_init(
On 04/18/2011 05:24 PM, Ronald S. Bultje wrote:
> Hi,
>
> On Mon, Apr 18, 2011 at 10:09 AM, Ronald S. Bultje wrote:
> [..]
>
> New patch that makes vsynth2-error also deterministic with THREADS=2.
>
> There's some races in ER but I don't care too much about this to be
> honest. Alexander, do yo
On 04/19/2011 02:49 AM, Diego Biurrun wrote:
> This fixes a lot of warnings of the sort:
> libavcodec/pcm.c:105: warning: cast discards qualifiers from pointer target
> type
> ---
> libavcodec/pcm.c |2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/libavcodec/pcm.c
On 04/19/2011 02:11 PM, Martin Storsjö wrote:
> I'd avoid xz still for some time - OS X tar can't unpack them. (Not sure
> if there will be any change to this in OS X Lion). Not that I'm the target
> audience of these release snapshots anyway though...
I wanted to replace bz2 with xz just becaus
On 04/18/2011 09:22 PM, Ronald S. Bultje wrote:
> Hi,
>
> On Sun, Apr 17, 2011 at 11:39 AM, Justin Ruggles
> wrote:
>> ---
>> This patch depends on the patch set I sent the other day.
>>
>> doc/encoders.texi | 33 ++
>> libavcodec/ac3.h |3 +-
>> libavcodec/ac3dec.h
On 04/19/2011 03:08 PM, Reinhard Tartler wrote:
> No feel free.
>
> In future, it seems to me that 3 version of the tarballs is too
> much. Let's therefore go for .tar.gz and tar.xz in the future. WDYT?
Would be ok for me =)
lu
--
Luca Barbato
Gentoo/linux
http://dev.gentoo.org/~lu_zero
On Tue, 19 Apr 2011, Reinhard Tartler wrote:
> On Tue, Apr 19, 2011 at 12:59:20 (CEST), Luca Barbato wrote:
>
> > On 04/17/2011 10:17 PM, Reinhard Tartler wrote:
> > [...]
> >
> > All ok but
> >
> >> +Download bzip2
> >> tarball
> >> +MD5
> >> +SHA1
> >> +PGP signature
> >> +Download gzip
> >
On Tue, Apr 19, 2011 at 12:59:20 (CEST), Luca Barbato wrote:
> On 04/17/2011 10:17 PM, Reinhard Tartler wrote:
> [...]
>
> All ok but
>
>> +Download bzip2
>> tarball
>> +MD5
>> +SHA1
>> +PGP signature
>> +Download gzip tarball
>> +MD5
>> +SHA1
>> +PGP signature
>
> Mind if I add libav-0.7_bet
On Tue, 19 Apr 2011, Luca Barbato wrote:
> I'd like use the Gentoo[1] convention for the versioning and possibly
> provide xz tar since it is usually nicer for the mirrors and unpacks
> faster than bz2.
I'd avoid xz still for some time - OS X tar can't unpack them. (Not sure
if there will be any
I'd like use the Gentoo[1] convention for the versioning and possibly
provide xz tar since it is usually nicer for the mirrors and unpacks
faster than bz2.
With Gentoo convention I mean using _beta, _alpha and _pre suffixes for
beta, alpha and pre releases, that would let me have a quite lean ebui
Hi,
On Tue, Apr 19, 2011 at 1:31 AM, Anton Khirnov wrote:
> On Mon, 18 Apr 2011 17:21:12 -0400, "Ronald S. Bultje"
> wrote:
>> On Mon, Apr 18, 2011 at 3:03 AM, Anton Khirnov wrote:
>> > ---
>> > libavformat/avio.h | 13 -
>> > 1 files changed, 0 insertions(+), 13 deletions(-)
>>
Hi,
On Tue, Apr 19, 2011 at 4:18 AM, Luca Barbato wrote:
> So that instead of having
> [mpegts @ 0x1280c10] Invalid timestamps stream=0, pts=6499823403,
> dts=6499824904, size=542 (that I would demote as level btw)
> we'd got
> [utils.c:1243 mpegts @ 0x1280c10] Invalid timestamps stream=0,
> pts=
Hi,
2011/4/19 Måns Rullgård :
> Alexander Stein writes:
>
>> Signed-off-by: Alexander Stein
>> ---
>> libavcodec/arm/h264pred_init_arm.c | 2 +-
>> 1 files changed, 1 insertions(+), 1 deletions(-)
>>
>> diff --git a/libavcodec/arm/h264pred_init_arm.c
>> b/libavcodec/arm/h264pred_init_arm.c
On 04/17/2011 10:17 PM, Reinhard Tartler wrote:
[...]
All ok but
> +Download bzip2 tarball
> +MD5
> +SHA1
> +PGP signature
> +Download gzip tarball
> +MD5
> +SHA1
> +PGP signature
Mind if I add libav-0.7_beta1.tar.xz ?
lu
--
Luca Barbato
Gentoo/linux
http://dev.gentoo.org/~lu_zero
_
Alexander Stein writes:
> Signed-off-by: Alexander Stein
> ---
> libavcodec/arm/h264pred_init_arm.c |2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/libavcodec/arm/h264pred_init_arm.c
> b/libavcodec/arm/h264pred_init_arm.c
> index 142f4b0..5b11b7d 100644
> --- a/l
Alexander Stein writes:
> Signed-off-by: Alexander Stein
> ---
> libavcodec/arm/h264pred_init_arm.c |2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/libavcodec/arm/h264pred_init_arm.c
> b/libavcodec/arm/h264pred_init_arm.c
> index 142f4b0..5b11b7d 100644
> --- a/l
Allow h264pred_init_arm.c to compile.
SOB: Bill Pringlemeir
>From 71b29af9c06ae252f52120bb48083038f864b613 Mon Sep 17 00:00:00 2001
From: Bill Pringlemeir
Date: Fri, 15 Apr 2011 13:09:51 -0400
Subject: [PATCH] Allow compile (on ARMV5TE at least).
---
libavcodec/arm/h264pred_init_arm.c |2
Signed-off-by: Alexander Stein
---
libavcodec/arm/h264pred_init_arm.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/libavcodec/arm/h264pred_init_arm.c
b/libavcodec/arm/h264pred_init_arm.c
index 142f4b0..5b11b7d 100644
--- a/libavcodec/arm/h264pred_init_arm.c
+++ b/lib
On 04/13/2011 03:15 AM, Ronald S. Bultje wrote:
> Hi,
>
> On Sat, Apr 9, 2011 at 11:14 PM, Luca Barbato wrote:
>> Today I planned to add to av_log() some optional features in order to
>> track file, line and function.
>>
>> I noticed some strange code introduced with this commit[1]
>>
>> if(avc &
On 04/19/2011 08:49 AM, Diego Biurrun wrote:
> This fixes a lot of warnings of the sort:
> libavcodec/pcm.c:105: warning: cast discards qualifiers from pointer target
> type
Seems ok...
--
Luca Barbato
Gentoo/linux
http://dev.gentoo.org/~lu_zero
__
On 04/19/2011 08:39 AM, Diego Biurrun wrote:
> $() is easier to nest and POSIX, which we require in other places.
> ---
> tools/clean-diff |2 +-
> tools/patcheck | 14 +++---
Ok, but might be useful applying that after the EGREP patch from Brad.
lu
--
Luca Barbato
Gentoo/linux
56 matches
Mail list logo