Re: [libav-devel] [PATCH] x86/synth_filter: remove the fma3 version ifdefs

2014-04-05 Thread James Almer
On 05/04/14 5:20 PM, Diego Biurrun wrote: > On Sat, Apr 05, 2014 at 02:00:53PM -0300, James Almer wrote: >> This fixes compilation failures with --disable-fma3 >> >> Signed-off-by: James Almer >> --- >> See https://fate.libav.org/x86_32-linux-suncc-nosse/20140405142549 >> >> libavcodec/x86/dcadsp

Re: [libav-devel] [PATCH] x86/synth_filter: remove the fma3 version ifdefs

2014-04-05 Thread Diego Biurrun
On Sat, Apr 05, 2014 at 02:00:53PM -0300, James Almer wrote: > This fixes compilation failures with --disable-fma3 > > Signed-off-by: James Almer > --- > See https://fate.libav.org/x86_32-linux-suncc-nosse/20140405142549 > > libavcodec/x86/dcadsp.asm| 2 -- > libavcodec/x86/dcadsp_init.c |

Re: [libav-devel] [PATCH v2] Documentation: Libavfilter English cleanup

2014-04-05 Thread Diego Biurrun
On Fri, Apr 04, 2014 at 05:30:50PM +0200, Katerina Barone-Adesi wrote: > --- a/doc/filters.texi > +++ b/doc/filters.texi > @@ -495,24 +490,25 @@ may be overridden (by @code{0/out-dBn}). Typical values > for the transfer > function are @code{-70/-70|-60/-20}. > > @item soft-knee > -Set the curv

Re: [libav-devel] [PATCH 7/9] tiff: use a better name and enum values for PhotometricInterpretation

2014-04-05 Thread Diego Biurrun
On Sat, Apr 05, 2014 at 02:35:44PM -0400, Justin Ruggles wrote: > --- a/libavcodec/tiff.c > +++ b/libavcodec/tiff.c > @@ -447,20 +447,31 @@ static int tiff_decode_tag(TiffContext *s) > default: > -av_log(s->avctx, AV_LOG_ERROR, "Color mode %d is not > supported\n", > -

Re: [libav-devel] [PATCH 7/9] tiff: use a better name and enum values for PhotometricInterpretation

2014-04-05 Thread Luca Barbato
On 05/04/14 20:35, Justin Ruggles wrote: > Also add additional known values and log as missing features. > --- > libavcodec/tiff.c| 45 - > libavcodec/tiff.h| 20 +++- > libavcodec/tiffenc.c | 20 ++-- > 3 fi

Re: [libav-devel] [PATCH 1/3] swscale: fix an implementation-defined unsigned-to-signed conversion

2014-04-05 Thread Luca Barbato
On 05/04/14 20:48, Justin Ruggles wrote: > --- > libswscale/swscale_unscaled.c |4 ++-- > 1 files changed, 2 insertions(+), 2 deletions(-) > The set looks fine. ___ libav-devel mailing list libav-devel@libav.org https://lists.libav.org/mailman/lis

[libav-devel] [PATCH 2/3] swscale: fix some undefined signed left shifts

2014-04-05 Thread Justin Ruggles
Based on a patch by Michael Niedermayer --- libswscale/swscale_unscaled.c |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git a/libswscale/swscale_unscaled.c b/libswscale/swscale_unscaled.c index daa6f5f..9e50d48 100644 --- a/libswscale/swscale_unscaled.c +++ b/libswscale/sw

[libav-devel] [PATCH 3/3] swscale: Set alpha to opaque for internal palettes.

2014-04-05 Thread Justin Ruggles
Fixes conversion of pal8 to rgb formats with alpha. Based on a patch by Baptiste Coudurier --- libswscale/swscale_unscaled.c | 10 +- 1 files changed, 5 insertions(+), 5 deletions(-) diff --git a/libswscale/swscale_unscaled.c b/libswscale/swscale_unscaled.c index 9e50d48..da1bde1 1006

[libav-devel] [PATCH 1/3] swscale: fix an implementation-defined unsigned-to-signed conversion

2014-04-05 Thread Justin Ruggles
--- libswscale/swscale_unscaled.c |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git a/libswscale/swscale_unscaled.c b/libswscale/swscale_unscaled.c index 3a956f4..daa6f5f 100644 --- a/libswscale/swscale_unscaled.c +++ b/libswscale/swscale_unscaled.c @@ -1187,9 +1187,9 @@ in

Re: [libav-devel] [PATCH 1/2] swscale: fix some implementation-defined signed-to-unsigned conversions

2014-04-05 Thread Justin Ruggles
Sorry, these are actually 2 separate issues that need different descriptions. I'll revise and send 2 patches with appropriate commit messages. -Justin ___ libav-devel mailing list libav-devel@libav.org https://lists.libav.org/mailman/listinfo/libav-devel

[libav-devel] [PATCH 2/2] swscale: Set alpha to opaque for internal palettes.

2014-04-05 Thread Justin Ruggles
Fixes conversion of pal8 to rgb formats with alpha. Based on a patch by Baptiste Coudurier --- libswscale/swscale_unscaled.c | 10 +- 1 files changed, 5 insertions(+), 5 deletions(-) diff --git a/libswscale/swscale_unscaled.c b/libswscale/swscale_unscaled.c index 9e50d48..da1bde1 1006

[libav-devel] [PATCH 1/2] swscale: fix some implementation-defined signed-to-unsigned conversions

2014-04-05 Thread Justin Ruggles
Partially based on a patch by Michael Niedermayer --- libswscale/swscale_unscaled.c |8 1 files changed, 4 insertions(+), 4 deletions(-) diff --git a/libswscale/swscale_unscaled.c b/libswscale/swscale_unscaled.c index 3a956f4..9e50d48 100644 --- a/libswscale/swscale_unscaled.c +++ b

[libav-devel] [PATCH 7/9] tiff: use a better name and enum values for PhotometricInterpretation

2014-04-05 Thread Justin Ruggles
Also add additional known values and log as missing features. --- libavcodec/tiff.c| 45 - libavcodec/tiff.h| 20 +++- libavcodec/tiffenc.c | 20 ++-- 3 files changed, 57 insertions(+), 28 deletions(-) diff

Re: [libav-devel] [PATCH v2] nutdec: Check malloc calls()

2014-04-05 Thread Justin Ruggles
On 04/05/2014 01:11 PM, Nidhi Makhijani wrote: > @@ -400,6 +407,10 @@ static int decode_stream_header(NUTContext *nut) > if (st->codec->extradata_size) { > st->codec->extradata = av_mallocz(st->codec->extradata_size + >FF_INPUT_BUFFER_PADDIN

[libav-devel] [PATCH v2] nutdec: Check malloc calls()

2014-04-05 Thread Nidhi Makhijani
--- libavformat/nutdec.c | 25 + 1 file changed, 21 insertions(+), 4 deletions(-) used av_freep() to avoid memory leakage diff --git a/libavformat/nutdec.c b/libavformat/nutdec.c index 6328549..33a1fc3 100644 --- a/libavformat/nutdec.c +++ b/libavformat/nutdec.c @@ -230,7

[libav-devel] [PATCH] x86/synth_filter: remove the fma3 version ifdefs

2014-04-05 Thread James Almer
This fixes compilation failures with --disable-fma3 Signed-off-by: James Almer --- See https://fate.libav.org/x86_32-linux-suncc-nosse/20140405142549 libavcodec/x86/dcadsp.asm| 2 -- libavcodec/x86/dcadsp_init.c | 2 -- 2 files changed, 4 deletions(-) diff --git a/libavcodec/x86/dcadsp.asm

Re: [libav-devel] [PATCH v2 1/2] aarch64: add armv8 CPU flag

2014-04-05 Thread Diego Biurrun
On Sat, Apr 05, 2014 at 06:17:56PM +0200, Janne Grunau wrote: > From: Janne Grunau > > --- > Makefile| 2 +- > arch.mak| 1 + > configure | 3 +++ > libavutil/aarch64/cpu.c | 5 +++-- > libavutil/aarch64/cpu.h | 1 + > libavutil/cpu.c | 2 ++

[libav-devel] [PATCH v2 2/2] aarch64: implement videodsp.prefetch

2014-04-05 Thread Janne Grunau
From: Janne Grunau 8% faster h264 decoding on Apple A7. --- libavcodec/aarch64/Makefile| 3 +++ libavcodec/aarch64/videodsp.S | 29 + libavcodec/aarch64/videodsp_init.c | 32 libavcodec/videodsp.c | 2 ++ li

[libav-devel] [PATCH v2 1/2] aarch64: add armv8 CPU flag

2014-04-05 Thread Janne Grunau
From: Janne Grunau --- Makefile| 2 +- arch.mak| 1 + configure | 3 +++ libavutil/aarch64/cpu.c | 5 +++-- libavutil/aarch64/cpu.h | 1 + libavutil/cpu.c | 2 ++ libavutil/cpu.h | 1 + 7 files changed, 12 insertions(+), 3 deletions(-

Re: [libav-devel] [PATCH 1/2] aarch64: add armv8 CPU flag

2014-04-05 Thread Diego Biurrun
On Sat, Apr 05, 2014 at 04:59:21PM +0200, Janne Grunau wrote: > On 2014-04-05 14:35:00 +0200, Diego Biurrun wrote: > > On Sat, Apr 05, 2014 at 02:16:47PM +0200, Janne Grunau wrote: > > > From: Janne Grunau > > > > > > --- > > > libavutil/aarch64/cpu.c | 3 ++- > > > libavutil/aarch64/cpu.h | 1 +

Re: [libav-devel] [PATCH 1/2] mov: read hydrogenaudio replaygain information

2014-04-05 Thread Justin Ruggles
On 04/04/2014 11:49 AM, Anton Khirnov wrote: > --- > libavformat/Makefile |2 +- > libavformat/mov.c| 99 > +- > 2 files changed, 99 insertions(+), 2 deletions(-) [...] > +static int mov_read_replaygain(MOVContext *c, AVIOContext *pb, int

Re: [libav-devel] [PATCH 1/2] aarch64: add armv8 CPU flag

2014-04-05 Thread Janne Grunau
On 2014-04-05 14:35:00 +0200, Diego Biurrun wrote: > On Sat, Apr 05, 2014 at 02:16:47PM +0200, Janne Grunau wrote: > > From: Janne Grunau > > > > --- > > libavutil/aarch64/cpu.c | 3 ++- > > libavutil/aarch64/cpu.h | 1 + > > libavutil/cpu.c | 2 ++ > > libavutil/cpu.h | 1 + > >

Re: [libav-devel] [PATCH v6 6/7] af_volume: implement replaygain clipping prevention

2014-04-05 Thread Justin Ruggles
On 04/04/2014 12:44 PM, Alessandro Ghedini wrote: > This adds a new "replaygain_noclip" option to the filter, and, if enabled, > limits the gain applied for tracks where clipping would occur. > --- > Renamed option to replaygain_noclip. > > doc/filters.texi| 5 + > libavfilter/af_vol

Re: [libav-devel] [PATCH 092/132] dsputil: Split off HuffYUV decoding bits into their own context

2014-04-05 Thread Luca Barbato
On 26/03/14 12:41, Diego Biurrun wrote: > --- Seems correct. ___ libav-devel mailing list libav-devel@libav.org https://lists.libav.org/mailman/listinfo/libav-devel

Re: [libav-devel] [PATCH 093/132] dsputil: Split off HuffYUV encoding bits into their own context

2014-04-05 Thread Luca Barbato
On 26/03/14 12:41, Diego Biurrun wrote: > --- > configure | 7 ++- > libavcodec/Makefile| 1 + > libavcodec/dsputil.c | 56 -- > libavcodec/dsputil.h | 13 - > libavcodec/huffyuv.h | 2 +

Re: [libav-devel] [PATCH 1/2] aarch64: add armv8 CPU flag

2014-04-05 Thread Diego Biurrun
On Sat, Apr 05, 2014 at 02:16:47PM +0200, Janne Grunau wrote: > From: Janne Grunau > > --- > libavutil/aarch64/cpu.c | 3 ++- > libavutil/aarch64/cpu.h | 1 + > libavutil/cpu.c | 2 ++ > libavutil/cpu.h | 1 + > 4 files changed, 6 insertions(+), 1 deletion(-) Why don't you add a

Re: [libav-devel] [PATCH 2/2] aarch64: implement videodsp.prefetch

2014-04-05 Thread Diego Biurrun
On Sat, Apr 05, 2014 at 02:16:48PM +0200, Janne Grunau wrote: > --- /dev/null > +++ b/libavcodec/aarch64/videodsp.S > @@ -0,0 +1,28 @@ > +// > +// This file is part of Libav. > +// > +// Libav is free software; you can redistribute it and/or > +// modify it under the terms of the GNU Lesser General

Re: [libav-devel] [PATCH 1/2] aarch64: add armv8 CPU flag

2014-04-05 Thread Luca Barbato
On 05/04/14 14:16, Janne Grunau wrote: > From: Janne Grunau > > --- > libavutil/aarch64/cpu.c | 3 ++- > libavutil/aarch64/cpu.h | 1 + > libavutil/cpu.c | 2 ++ > libavutil/cpu.h | 1 + > 4 files changed, 6 insertions(+), 1 deletion(-) > Looks fine. __

[libav-devel] [PATCH 2/2] aarch64: implement videodsp.prefetch

2014-04-05 Thread Janne Grunau
From: Janne Grunau 8% faster h264 decoding on Apple A7. --- libavcodec/aarch64/Makefile| 2 ++ libavcodec/aarch64/videodsp.S | 28 libavcodec/aarch64/videodsp_init.c | 32 libavcodec/videodsp.c | 2 ++ liba

[libav-devel] [PATCH 1/2] aarch64: add armv8 CPU flag

2014-04-05 Thread Janne Grunau
From: Janne Grunau --- libavutil/aarch64/cpu.c | 3 ++- libavutil/aarch64/cpu.h | 1 + libavutil/cpu.c | 2 ++ libavutil/cpu.h | 1 + 4 files changed, 6 insertions(+), 1 deletion(-) diff --git a/libavutil/aarch64/cpu.c b/libavutil/aarch64/cpu.c index 2cc2ccd..4ad19b4 100644 ---