Re: [libav-devel] [PATCH 2/2] fft-test: Reduce variable scope where sensibly possible

2014-06-25 Thread Diego Biurrun
On Wed, Jun 25, 2014 at 05:45:45PM -0700, Diego Biurrun wrote: > --- > libavcodec/fft-test.c | 79 > --- > 1 file changed, 37 insertions(+), 42 deletions(-) Ignore this. Diego ___ libav-devel mailing lis

[libav-devel] [PATCH 2/2] fft-test: Reduce variable scope where sensibly possible

2014-06-25 Thread Diego Biurrun
--- libavcodec/fft-test.c | 79 --- 1 file changed, 37 insertions(+), 42 deletions(-) diff --git a/libavcodec/fft-test.c b/libavcodec/fft-test.c index 142a61d..efc1f52 100644 --- a/libavcodec/fft-test.c +++ b/libavcodec/fft-test.c @@ -67,16 +67,15 @

[libav-devel] [PATCH 1/2] fate: Add dependencies for dct/fft/mdct/rdft tests

2014-06-25 Thread Diego Biurrun
--- libavcodec/fft-test.c | 22 ++ tests/fate/fft.mak| 32 2 files changed, 38 insertions(+), 16 deletions(-) diff --git a/libavcodec/fft-test.c b/libavcodec/fft-test.c index d0c22d0..142a61d 100644 --- a/libavcodec/fft-test.c +++ b/libavco

Re: [libav-devel] [PATCH 06/15] hevc: Add SSE4 MC functions

2014-06-25 Thread Luca Barbato
On 26/06/14 00:29, James Almer wrote: > I don't have time nor really want to deal with the init macros, but i can > help > you with the necessary changes to the asm file if needed. Would be great =) lu ___ libav-devel mailing list libav-devel@libav.or

Re: [libav-devel] [PATCH 06/15] hevc: Add SSE4 MC functions

2014-06-25 Thread James Almer
On 25/06/14 3:44 PM, Luca Barbato wrote: > On 25/06/14 20:33, James Almer wrote: >> On 24/06/14 11:26 AM, Luca Barbato wrote: >>> From: Pierre Edouard Lepere >>> >>> The functions only support x86_64. >>> >>> Fixes from Hendrik Leppkes and James Almer >>> >>> Signed-off-by: Luca Barbato >>> --- >

Re: [libav-devel] [PATCH] indeo2: rename stride to pitch for consistency with other Indeo decoders

2014-06-25 Thread Diego Biurrun
On Wed, Jun 25, 2014 at 08:29:29PM +0200, Kostya Shishkov wrote: > --- > libavcodec/indeo2.c | 16 > 1 file changed, 8 insertions(+), 8 deletions(-) I strongly vote for my patch instead to have things more, not less, consistent across the codebase. You trolled me into whipping

Re: [libav-devel] [PATCH] cosmetics: Replace "pitch" by "stride" when referring to array dimensions

2014-06-25 Thread Diego Biurrun
On Wed, Jun 25, 2014 at 08:41:38PM +0200, Luca Barbato wrote: > On 25/06/14 16:42, Diego Biurrun wrote: > > The latter is more common throughout the codebase and cannot be confused > > with audio-related pitch. > > --- > > libavcodec/dvdsubdec.c | 4 +- > > libavcodec/indeo3.c | 68 +++

Re: [libav-devel] [PATCH 3/3] x86: hevc_idct: fix number of sse registers

2014-06-25 Thread Luca Barbato
On 25/06/14 21:08, Guillaume Martres wrote: > From: plepere > > --- > libavcodec/x86/hevc_idct.asm | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/libavcodec/x86/hevc_idct.asm b/libavcodec/x86/hevc_idct.asm > index b7fb94e..aba100f 100644 > --- a/libavcodec/x86/hevc_idc

[libav-devel] [PATCH 2/3] hevc: remove unused array min_cb_addr_zs

2014-06-25 Thread Guillaume Martres
From: Gildas Cocherel --- libavcodec/hevc.h| 1 - libavcodec/hevc_ps.c | 19 +-- 2 files changed, 1 insertion(+), 19 deletions(-) diff --git a/libavcodec/hevc.h b/libavcodec/hevc.h index e74353e..5525757 100644 --- a/libavcodec/hevc.h +++ b/libavcodec/hevc.h @@ -533,7 +533,

[libav-devel] [PATCH 3/3] x86: hevc_idct: fix number of sse registers

2014-06-25 Thread Guillaume Martres
From: plepere --- libavcodec/x86/hevc_idct.asm | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavcodec/x86/hevc_idct.asm b/libavcodec/x86/hevc_idct.asm index b7fb94e..aba100f 100644 --- a/libavcodec/x86/hevc_idct.asm +++ b/libavcodec/x86/hevc_idct.asm @@ -100,7 +100,7 @@ c

Re: [libav-devel] [PATCH 0/3] More HEVC cherry-picks

2014-06-25 Thread Luca Barbato
On 25/06/14 21:08, Guillaume Martres wrote: > This set applies on top of Luca's set. > It'd be nice if someone could try to understand how > https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=ba70563d5549fdbde4c254c9334a123c439ccc30 > works exactly and fix/cherry-pick it too. > 1 and 3 could b

Re: [libav-devel] [PATCH 109/132] dv: Properly split decoder and encoder initialization

2014-06-25 Thread Luca Barbato
On 25/06/14 16:51, Diego Biurrun wrote: > --- > libavcodec/dv.c| 18 -- > libavcodec/dvdec.c | 21 - > libavcodec/dvenc.c | 13 + > 3 files changed, 33 insertions(+), 19 deletions(-) > > diff --git a/libavcodec/dv.c b/libavcodec/dv.c > index 094

Re: [libav-devel] [PATCH 15/15] hevc: Add x86 optimized idct functions

2014-06-25 Thread Guillaume Martres
On Wednesday 25 June 2014 15:31:43 James Almer wrote: > movd m0, %1d > > NASM x86_64 will complain otherwise. I cherry-picked your ffmpeg patch for doing that: https://lists.libav.org/pipermail/libav-devel/2014-June/060626.html ___ libav-devel mailing

Re: [libav-devel] [PATCH 108/132] dv: Replace a magic number by sizeof()

2014-06-25 Thread Luca Barbato
On 25/06/14 16:51, Diego Biurrun wrote: > --- > libavcodec/dv.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/libavcodec/dv.c b/libavcodec/dv.c > index 1a54c4e..0941d51 100644 > --- a/libavcodec/dv.c > +++ b/libavcodec/dv.c > @@ -311,7 +311,7 @@ av_cold int ff_dvvideo_i

Re: [libav-devel] [PATCH 01/15] hevc: Fix picture output logic

2014-06-25 Thread Guillaume Martres
On Wednesday 25 June 2014 20:42:38 Luca Barbato wrote: > On 25/06/14 17:25, Guillaume Martres wrote: > > On Tuesday 24 June 2014 16:26:40 Luca Barbato wrote: > >> if (s->sps != (HEVCSPS*)s->sps_list[s->pps->sps_id]->data) { > >> > >> +const HEVCSPS* prev_sps = s->sps; > >> > >>

Re: [libav-devel] [PATCH 106/132] dsputil: Move MMX/SSE2-optimized IDCT bits to the x86 subdirectory

2014-06-25 Thread Luca Barbato
On 25/06/14 16:51, Diego Biurrun wrote: > --- > libavcodec/dsputil.c | 27 +-- > libavcodec/dsputil.h | 2 ++ > libavcodec/x86/dsputil_init.c | 33 + > 3 files changed, 40 insertions(+), 22 deletions(-) > Probably OK. __

[libav-devel] [PATCH 0/3] More HEVC cherry-picks

2014-06-25 Thread Guillaume Martres
This set applies on top of Luca's set. It'd be nice if someone could try to understand how https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=ba70563d5549fdbde4c254c9334a123c439ccc30 works exactly and fix/cherry-pick it too. -- 1.9.1 ___ libav-devel

[libav-devel] [PATCH 1/3] hevc: fix movd parameter size in DC_ADD_INIT

2014-06-25 Thread Guillaume Martres
From: James Almer Fixes compilation with NASM x86_64 --- libavcodec/x86/hevc_idct.asm | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavcodec/x86/hevc_idct.asm b/libavcodec/x86/hevc_idct.asm index 2f9b31e..b7fb94e 100644 --- a/libavcodec/x86/hevc_idct.asm +++ b/libavcodec/

Re: [libav-devel] [PATCH 06/15] hevc: Add SSE4 MC functions

2014-06-25 Thread Luca Barbato
On 25/06/14 20:33, James Almer wrote: > On 24/06/14 11:26 AM, Luca Barbato wrote: >> From: Pierre Edouard Lepere >> >> The functions only support x86_64. >> >> Fixes from Hendrik Leppkes and James Almer >> >> Signed-off-by: Luca Barbato >> --- >> libavcodec/hevcdsp.c |6 +- >> libav

Re: [libav-devel] [PATCH 01/15] hevc: Fix picture output logic

2014-06-25 Thread Hendrik Leppkes
On Wed, Jun 25, 2014 at 1:42 PM, Luca Barbato wrote: > On 25/06/14 17:25, Guillaume Martres wrote: >> On Tuesday 24 June 2014 16:26:40 Luca Barbato wrote: >>> if (s->sps != (HEVCSPS*)s->sps_list[s->pps->sps_id]->data) { >>> +const HEVCSPS* prev_sps = s->sps; >>> s->sps = (HEV

Re: [libav-devel] [PATCH 02/15] hevc: Split MC in unidirectional and bidirectional

2014-06-25 Thread Luca Barbato
On 25/06/14 18:05, Guillaume Martres wrote: > On Tuesday 24 June 2014 16:26:41 Luca Barbato wrote: >> +const uint8_t ff_hevc_pel_weight[65] = { >> +[2] = 0, [4] = 1, [6] = 2, [8] = 3, [12] = 4, >> +[16] = 5, [24] = 6, [32] = 7, [48] = 8, [64] = 9 >> +} > > 1) Do all the compilers we ca

Re: [libav-devel] [PATCH 01/15] hevc: Fix picture output logic

2014-06-25 Thread Luca Barbato
On 25/06/14 17:25, Guillaume Martres wrote: > On Tuesday 24 June 2014 16:26:40 Luca Barbato wrote: >> if (s->sps != (HEVCSPS*)s->sps_list[s->pps->sps_id]->data) { >> +const HEVCSPS* prev_sps = s->sps; >> s->sps = (HEVCSPS*)s->sps_list[s->pps->sps_id]->data; >> +if (pre

Re: [libav-devel] [PATCH] cosmetics: Replace "pitch" by "stride" when referring to array dimensions

2014-06-25 Thread Luca Barbato
On 25/06/14 16:42, Diego Biurrun wrote: > The latter is more common throughout the codebase and cannot be confused > with audio-related pitch. > --- > libavcodec/dvdsubdec.c | 4 +- > libavcodec/indeo3.c | 68 +++ > libavcodec/indeo4.c | 4 +- > libavcodec/indeo5.c |

Re: [libav-devel] [PATCH] indeo2: rename stride to pitch for consistency with other Indeo decoders

2014-06-25 Thread Luca Barbato
On 25/06/14 20:29, Kostya Shishkov wrote: > --- > libavcodec/indeo2.c | 16 > 1 file changed, 8 insertions(+), 8 deletions(-) > Ok. ___ libav-devel mailing list libav-devel@libav.org https://lists.libav.org/mailman/listinfo/libav-de

Re: [libav-devel] [PATCH 06/15] hevc: Add SSE4 MC functions

2014-06-25 Thread James Almer
On 24/06/14 11:26 AM, Luca Barbato wrote: > From: Pierre Edouard Lepere > > The functions only support x86_64. > > Fixes from Hendrik Leppkes and James Almer > > Signed-off-by: Luca Barbato > --- > libavcodec/hevcdsp.c |6 +- > libavcodec/hevcdsp.h |3 + > libavcodec

Re: [libav-devel] [PATCH 15/15] hevc: Add x86 optimized idct functions

2014-06-25 Thread James Almer
On 24/06/14 11:26 AM, Luca Barbato wrote: > From: Pierre Edouard Lepere > > Signed-off-by: Luca Barbato > --- > libavcodec/hevc.c | 19 - > libavcodec/hevcdsp.c | 5 ++ > libavcodec/hevcdsp.h | 4 +- > libavcodec/hevcdsp_template.c | 176 +++---

[libav-devel] [PATCH] indeo2: rename stride to pitch for consistency with other Indeo decoders

2014-06-25 Thread Kostya Shishkov
--- libavcodec/indeo2.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/libavcodec/indeo2.c b/libavcodec/indeo2.c index 7df6e69..4221e9e 100644 --- a/libavcodec/indeo2.c +++ b/libavcodec/indeo2.c @@ -49,7 +49,7 @@ static inline int ir2_get_code(GetBitContext

Re: [libav-devel] [PATCH 02/15] hevc: Split MC in unidirectional and bidirectional

2014-06-25 Thread Guillaume Martres
On Tuesday 24 June 2014 16:26:41 Luca Barbato wrote: > +const uint8_t ff_hevc_pel_weight[65] = { > +[2] = 0, [4] = 1, [6] = 2, [8] = 3, [12] = 4, > +[16] = 5, [24] = 6, [32] = 7, [48] = 8, [64] = 9 > +} 1) Do all the compilers we care about support this funny syntax? 2) This is a bit w

Re: [libav-devel] [PATCH 01/15] hevc: Fix picture output logic

2014-06-25 Thread Guillaume Martres
On Tuesday 24 June 2014 16:26:40 Luca Barbato wrote: > if (s->sps != (HEVCSPS*)s->sps_list[s->pps->sps_id]->data) { > +const HEVCSPS* prev_sps = s->sps; > s->sps = (HEVCSPS*)s->sps_list[s->pps->sps_id]->data; > +if (prev_sps && !match_sps(s, s->sps, prev_sps)) > +

Re: [libav-devel] [PATCH] cosmetics: Replace "pitch" by "stride" when referring to array dimensions

2014-06-25 Thread Diego Biurrun
On Wed, Jun 25, 2014 at 07:42:51AM -0700, Diego Biurrun wrote: > --- a/libavcodec/ivi_dsp.c > +++ b/libavcodec/ivi_dsp.c > @@ -145,13 +145,13 @@ void ff_ivi_recompose53(const IVIPlaneDesc *plane, > uint8_t *dst, > if (num_bands > 3) { > b3_6 = b3_ptr[indx+1];

Re: [libav-devel] [PATCH] cljr: split decoder and encoder

2014-06-25 Thread Diego Biurrun
On Wed, Jun 25, 2014 at 04:21:58PM +0530, Nidhi Makhijani wrote: > --- a/libavcodec/cljr.c > +++ b/libavcodec/cljrenc.c > @@ -21,83 +21,13 @@ > > -#include "avcodec.h" > #include "get_bits.h" > #include "internal.h" > #include "put_bits.h" > > -#if CONFIG_CLJR_ENCODER > static av_cold int e

[libav-devel] [PATCH 107/132] mpeg: Change ff_convert_matrix() to take an MpegEncContext parameter

2014-06-25 Thread Diego Biurrun
This will come in handy during dsputil splitting. --- libavcodec/dnxhdenc.c | 4 ++-- libavcodec/mpegvideo.h | 2 +- libavcodec/mpegvideo_enc.c | 9 + 3 files changed, 8 insertions(+), 7 deletions(-) diff --git a/libavcodec/dnxhdenc.c b/libavcodec/dnxhdenc.c index 3bc2d65..e1e376

[libav-devel] [PATCH 109/132] dv: Properly split decoder and encoder initialization

2014-06-25 Thread Diego Biurrun
--- libavcodec/dv.c| 18 -- libavcodec/dvdec.c | 21 - libavcodec/dvenc.c | 13 + 3 files changed, 33 insertions(+), 19 deletions(-) diff --git a/libavcodec/dv.c b/libavcodec/dv.c index 0941d51..c915480 100644 --- a/libavcodec/dv.c +++ b/libavco

[libav-devel] THE GRAND DSPUTIL REFACTORING (act XI)

2014-06-25 Thread Diego Biurrun
Moin! The topic of today's set is IDCT. I do a bit or related cleanup and then split off the (optimized) IDCT bits off into their own context. Diego ___ libav-devel mailing list libav-devel@libav.org https://lists.libav.org/mailman/listinfo/libav-deve

[libav-devel] [PATCH 106/132] dsputil: Move MMX/SSE2-optimized IDCT bits to the x86 subdirectory

2014-06-25 Thread Diego Biurrun
--- libavcodec/dsputil.c | 27 +-- libavcodec/dsputil.h | 2 ++ libavcodec/x86/dsputil_init.c | 33 + 3 files changed, 40 insertions(+), 22 deletions(-) diff --git a/libavcodec/dsputil.c b/libavcodec/dsputil.c index 917833

[libav-devel] [PATCH 108/132] dv: Replace a magic number by sizeof()

2014-06-25 Thread Diego Biurrun
--- libavcodec/dv.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavcodec/dv.c b/libavcodec/dv.c index 1a54c4e..0941d51 100644 --- a/libavcodec/dv.c +++ b/libavcodec/dv.c @@ -311,7 +311,7 @@ av_cold int ff_dvvideo_init(AVCodecContext *avctx) /* 248DCT setup */ s-

Re: [libav-devel] [PATCH] cosmetics: Replace "pitch" by "stride" when referring to array dimensions

2014-06-25 Thread Kostya Shishkov
On Wed, Jun 25, 2014 at 07:42:51AM -0700, Diego Biurrun wrote: > The latter is more common throughout the codebase and cannot be confused > with audio-related pitch. > --- > libavcodec/dvdsubdec.c | 4 +- > libavcodec/indeo3.c | 68 +++ > libavcodec/indeo4.c | 4 +- > lib

Re: [libav-devel] Indeo4 B-frames decoding support

2014-06-25 Thread Kostya Shishkov
On Wed, Jun 25, 2014 at 03:24:04PM +0200, Diego Biurrun wrote: > On Wed, Jun 25, 2014 at 10:01:14AM +0200, Dirk Ausserhaus wrote: > > From 019230859732a5190838b81c7156378acad8b160 Mon Sep 17 00:00:00 2001 > > From: Dirk Ausserhaus > > Date: Sun, 8 Jun 2014 13:44:17 +0200 > > Subject: [PATCH] indeo

Re: [libav-devel] Indeo4 B-frames decoding support

2014-06-25 Thread Diego Biurrun
On Wed, Jun 25, 2014 at 10:01:14AM +0200, Dirk Ausserhaus wrote: > From 019230859732a5190838b81c7156378acad8b160 Mon Sep 17 00:00:00 2001 > From: Dirk Ausserhaus > Date: Sun, 8 Jun 2014 13:44:17 +0200 > Subject: [PATCH] indeo4: B-frames decoding > > --- a/libavcodec/ivi_common.c > +++ b/libavcode

Re: [libav-devel] [PATCH 04/15] hevc: Set the keyframe correctly

2014-06-25 Thread Hendrik Leppkes
On Tue, Jun 24, 2014 at 11:22 PM, Vittorio Giovara wrote: > On Tue, Jun 24, 2014 at 10:26 AM, Luca Barbato wrote: >> From: Mickaël Raulet >> >> Before it was incorrectly set always to 1. >> --- >> libavcodec/hevc.c | 1 + >> 1 file changed, 1 insertion(+) >> >> diff --git a/libavcodec/hevc.c b/

Re: [libav-devel] [PATCH] Add asfinfo tool.

2014-06-25 Thread Luca Barbato
On 25/06/14 12:16, Alexandra Hájková wrote: > The tool prints out asf file structure. > --- > libavformat/Makefile | 3 +- > tools/asfinfo.c | 533 > +++ > 2 files changed, 535 insertions(+), 1 deletion(-) > create mode 100644 tools/asfinfo.

Re: [libav-devel] [PATCH] x86: h264dsp: Fix link failure with optimizations disabled

2014-06-25 Thread Kostya Shishkov
On Wed, Jun 25, 2014 at 04:40:56AM -0700, Diego Biurrun wrote: > With optimzations disabled compilers have trouble doing dead code > elimination on 'if (foo && 0)' expressions, while 'if (0 && foo)' > still works, so use the latter to avoid problems. > > Bug-Id: 707 > --- > libavcodec/x86/h264dsp

Re: [libav-devel] [PATCH] x86: h264dsp: Fix link failure with optimizations disabled

2014-06-25 Thread Luca Barbato
On 25/06/14 13:40, Diego Biurrun wrote: > With optimzations disabled compilers have trouble doing dead code > elimination on 'if (foo && 0)' expressions, while 'if (0 && foo)' > still works, so use the latter to avoid problems. > > Bug-Id: 707 > --- > libavcodec/x86/h264dsp_init.c | 2 +- > 1 fil

[libav-devel] [PATCH] x86: h264dsp: Fix link failure with optimizations disabled

2014-06-25 Thread Diego Biurrun
With optimzations disabled compilers have trouble doing dead code elimination on 'if (foo && 0)' expressions, while 'if (0 && foo)' still works, so use the latter to avoid problems. Bug-Id: 707 --- libavcodec/x86/h264dsp_init.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/l

[libav-devel] [PATCH] cljr: split decoder and encoder

2014-06-25 Thread Nidhi Makhijani
--- libavcodec/Makefile | 4 +-- libavcodec/{cljr.c => cljrdec.c} | 76 ++-- libavcodec/{cljr.c => cljrenc.c} | 75 ++- 3 files changed, 6 insertions(+), 149 deletions(-) copy libavcodec/{cljr.c => cljrdec.c} (5

[libav-devel] [PATCH] Add asfinfo tool.

2014-06-25 Thread Alexandra Hájková
The tool prints out asf file structure. --- libavformat/Makefile | 3 +- tools/asfinfo.c | 533 +++ 2 files changed, 535 insertions(+), 1 deletion(-) create mode 100644 tools/asfinfo.c diff --git a/libavformat/Makefile b/libavformat/Makefile

Re: [libav-devel] Indeo4 B-frames decoding support

2014-06-25 Thread Kostya Shishkov
On Wed, Jun 25, 2014 at 10:01:14AM +0200, Dirk Ausserhaus wrote: > On Sat, Jun 21, 2014 at 8:41 AM, Kostya Shishkov > wrote: > > On Fri, Jun 20, 2014 at 08:46:11PM +0200, Dirk Ausserhaus wrote: > >> Here is my patch for decoding B-frames in Indeo4 at last. And another > >> patch to make things a b

Re: [libav-devel] Indeo4 B-frames decoding support

2014-06-25 Thread Dirk Ausserhaus
On Sat, Jun 21, 2014 at 8:41 AM, Kostya Shishkov wrote: > On Fri, Jun 20, 2014 at 08:46:11PM +0200, Dirk Ausserhaus wrote: >> Here is my patch for decoding B-frames in Indeo4 at last. And another >> patch to make things a bit simpler first. > > At last! > >> I suppose I have to give some explanati