Re: [libav-devel] [PATCH] mpegvideo: cosmetics: Lowercase ugly uppercase MPV_ function name prefixes

2014-08-10 Thread Luca Barbato
On 10/08/14 20:36, John Stebbins wrote: > On 08/10/2014 10:45 AM, Diego Biurrun wrote: >> --- >> libavcodec/arm/mpegvideo_arm.c | 4 +-- >> libavcodec/arm/mpegvideo_arm.h | 2 +- >> libavcodec/arm/mpegvideo_armv5te.c | 2 +- >> libavcodec/flvenc.c| 6 ++-- >> libavcodec

[libav-devel] [PATCH 1/3] idct: remove call to ff_idctdsp_init from ff_MPV_common_init

2014-08-10 Thread John Stebbins
One step in untangling the mpegvideo code and fixing some problems in the order that initialization is being done in h263dec and h261dec. --- remove ff_mpv_idct_init from svq1enc since it is not needed there. libavcodec/dnxhdenc.c | 3 +-- libavcodec/h261dec.c | 4 +++- libavcodec/h2

Re: [libav-devel] [PATCH] mpegvideo: cosmetics: Lowercase ugly uppercase MPV_ function name prefixes

2014-08-10 Thread John Stebbins
On 08/10/2014 10:45 AM, Diego Biurrun wrote: > --- > libavcodec/arm/mpegvideo_arm.c | 4 +-- > libavcodec/arm/mpegvideo_arm.h | 2 +- > libavcodec/arm/mpegvideo_armv5te.c | 2 +- > libavcodec/flvenc.c| 6 ++-- > libavcodec/h261dec.c | 16 +- > liba

Re: [libav-devel] [PATCH] mpegvideo: cosmetics: Lowercase ugly uppercase MPV_ function name prefixes

2014-08-10 Thread Luca Barbato
On 10/08/14 19:45, Diego Biurrun wrote: > --- Fine for me. ___ libav-devel mailing list libav-devel@libav.org https://lists.libav.org/mailman/listinfo/libav-devel

Re: [libav-devel] [PATCH 1/3] idct: remove call to ff_idctdsp_init from ff_MPV_common_init

2014-08-10 Thread John Stebbins
On 08/10/2014 10:53 AM, Diego Biurrun wrote: > On Sun, Aug 10, 2014 at 10:45:24AM -0700, John Stebbins wrote: >> --- a/libavcodec/mpeg4videodec.c >> +++ b/libavcodec/mpeg4videodec.c >> @@ -2546,8 +2546,11 @@ static int mpeg4_update_thread_context(AVCodecContext >> *dst, >> if (ret < 0) >>

Re: [libav-devel] [PATCH 1/3] idct: remove call to ff_idctdsp_init from ff_MPV_common_init

2014-08-10 Thread Diego Biurrun
On Sun, Aug 10, 2014 at 10:45:24AM -0700, John Stebbins wrote: > --- a/libavcodec/mpeg4videodec.c > +++ b/libavcodec/mpeg4videodec.c > @@ -2546,8 +2546,11 @@ static int mpeg4_update_thread_context(AVCodecContext > *dst, > if (ret < 0) > return ret; > > -if (CONFIG_MPEG4_DECODER

[libav-devel] [PATCH] mpegvideo: cosmetics: Lowercase ugly uppercase MPV_ function name prefixes

2014-08-10 Thread Diego Biurrun
--- libavcodec/arm/mpegvideo_arm.c | 4 +-- libavcodec/arm/mpegvideo_arm.h | 2 +- libavcodec/arm/mpegvideo_armv5te.c | 2 +- libavcodec/flvenc.c| 6 ++-- libavcodec/h261dec.c | 16 +- libavcodec/h261enc.c | 6 ++-- libavcodec/h263de

[libav-devel] [PATCH 1/3] idct: remove call to ff_idctdsp_init from ff_MPV_common_init

2014-08-10 Thread John Stebbins
One step in untangling the mpegvideo code and fixing some problems in the order that initialization is being done in h263dec and h261dec. rename ff_idct_common_init to ff_mpv_idct_init rename ff_dct_common_init to dct_init and make it static fix comment in mpeg12dec and use ff_mpv_idct_init ---

[libav-devel] [PATCH 2/3] h263dec: Fix order of initialization

2014-08-10 Thread John Stebbins
ff_MPV_common_init requires the frame dimensions which get parsed in *_decode_picture_header. --- libavcodec/h263dec.c | 25 - 1 file changed, 12 insertions(+), 13 deletions(-) diff --git a/libavcodec/h263dec.c b/libavcodec/h263dec.c index a6d16b7..c4db99e 100644 --- a/lib

[libav-devel] [PATCH 3/3] h261dec: Fix order of initialization

2014-08-10 Thread John Stebbins
ff_MPV_common_init requires the frame dimensions which get parsed in h261_decode_picture_header. --- libavcodec/h261dec.c | 10 ++ 1 file changed, 6 insertions(+), 4 deletions(-) diff --git a/libavcodec/h261dec.c b/libavcodec/h261dec.c index 88ca63d..6b358a6 100644 --- a/libavcodec/h261de

[libav-devel] [PATCH 1/3] idct: remove call to ff_idctdsp_init from ff_MPV_common_init

2014-08-10 Thread John Stebbins
One step in untangling the mpegvideo code and fixing some problems in the order that initialization is being done in h263dec and h261dec. rename ff_idct_common_init to ff_mpv_idct_init rename ff_dct_common_init to dct_init and make it static fix comment in mpeg12dec and use ff_mpv_idct_init ---

Re: [libav-devel] [PATCH] avcodec: Postpone FF_IDCT_XVIDMMX removal until the next version bump

2014-08-10 Thread Luca Barbato
On 10/08/14 15:45, Diego Biurrun wrote: > --- > > This was skipped in Anton's bump patch. > > libavcodec/version.h | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/libavcodec/version.h b/libavcodec/version.h > index f7bb8e0..b42b970 100644 > --- a/libavcodec/version.h >

Re: [libav-devel] [PATCH] configure: Don't pass MSVC compiler options -M[TD] to armasm

2014-08-10 Thread Janne Grunau
On 2014-08-10 14:43:10 +0300, Martin Storsjö wrote: > The -MD option (for enabling a dynamically linked crt) gets interpreted > as a cpp option for generating dependency information (into a file named > '-.d', when preprocessing to a pipe). We shouldn't be passing > any and all C compiler flags to

[libav-devel] [PATCH 1/3] idct: remove call to ff_idctdsp_init from ff_MPV_common_init

2014-08-10 Thread John Stebbins
One step in untangling the mpegvideo code and fixing some problems in the order that initialization is being done in h263dec and h261dec. --- libavcodec/dnxhdenc.c | 3 +-- libavcodec/h261dec.c | 4 +++- libavcodec/h263dec.c | 8 ++-- libavcodec/mpeg12dec.c | 5 +

Re: [libav-devel] [PATCH] ffv1dec: check that global parameters do not change in version 0/1

2014-08-10 Thread Diego Biurrun
On Sat, Aug 09, 2014 at 03:42:40PM +, Anton Khirnov wrote: > From: Michael Niedermayer > > Such changes are not allowed nor supported nit: Such changes are neither allowed nor supported. Diego ___ libav-devel mailing list libav-devel@libav.org htt

Re: [libav-devel] [PATCH 1/3] idct: remove call to ff_idctdsp_init from ff_MPV_common_init

2014-08-10 Thread Diego Biurrun
On Sat, Aug 09, 2014 at 04:43:57PM -0700, John Stebbins wrote: > On 08/09/2014 03:19 PM, John Stebbins wrote: > > On 08/09/2014 01:42 PM, Diego Biurrun wrote: > >> On Sat, Aug 09, 2014 at 09:25:36AM -0700, John Stebbins wrote: > >>> --- a/libavcodec/mpegvideo.c > >>> +++ b/libavcodec/mpegvideo.c >

[libav-devel] [PATCH] avcodec: Postpone FF_IDCT_XVIDMMX removal until the next version bump

2014-08-10 Thread Diego Biurrun
--- This was skipped in Anton's bump patch. libavcodec/version.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavcodec/version.h b/libavcodec/version.h index f7bb8e0..b42b970 100644 --- a/libavcodec/version.h +++ b/libavcodec/version.h @@ -133,7 +133,7 @@ #define FF_API

Re: [libav-devel] [PATCH] Announce Release 0.8.15 and 9.16

2014-08-10 Thread Diego Biurrun
On Sun, Aug 10, 2014 at 09:30:14AM -0400, Reinhard Tartler wrote: > --- > src/download | 42 +- > src/news | 25 + > 2 files changed, 46 insertions(+), 21 deletions(-) LGTM Diego ___ l

[libav-devel] [PATCH] Announce Release 0.8.15 and 9.16

2014-08-10 Thread Reinhard Tartler
--- src/download | 42 +- src/news | 25 + 2 files changed, 46 insertions(+), 21 deletions(-) diff --git a/src/download b/src/download index 67463e3..55c6029 100644 --- a/src/download +++ b/src/download @@ -223,28 +223,28 @@ our

Re: [libav-devel] [PATCH] avcodec: Instruct users to align buffers to 32-byte.

2014-08-10 Thread Hendrik Leppkes
On Sun, Aug 10, 2014 at 2:25 PM, Kieran Kunhya wrote: > On 10 August 2014 11:25, Janne Grunau wrote: >> On 2014-08-10 04:17:09 +0100, Kieran Kunhya wrote: >>> The Opus decoder in particular uses optimised float_dsp functions that >>> expect 32-byte alignment >>> --- >>> libavcodec/avcodec.h |

Re: [libav-devel] [PATCH] configure: Suggest upgrading gas-preprocessor instead of just installing

2014-08-10 Thread Janne Grunau
On 2014-08-10 16:07:48 +0300, Martin Storsjö wrote: > Older versions don't support all the features we test for now. > --- > I chose not to fold this into the other patches since it didn't really > seem to be related to them. > --- > configure | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-

Re: [libav-devel] [RFC PATCH 2/2] configure: Fix checking for and autoenabling gas-preprocessor

2014-08-10 Thread Janne Grunau
On 2014-08-10 16:02:45 +0300, Martin Storsjö wrote: > On Sun, 10 Aug 2014, Janne Grunau wrote: > > >Most of my fate configs needs to have the explicit --as removed. > > At least for armasm, the explicit --as should still work, since that > one passes all tests, so it never goes on to actually try

[libav-devel] [PATCH] configure: Suggest upgrading gas-preprocessor instead of just installing

2014-08-10 Thread Martin Storsjö
Older versions don't support all the features we test for now. --- I chose not to fold this into the other patches since it didn't really seem to be related to them. --- configure | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/configure b/configure index 684a93c..411af5e 10075

Re: [libav-devel] [RFC PATCH 2/2] configure: Fix checking for and autoenabling gas-preprocessor

2014-08-10 Thread Martin Storsjö
On Sun, 10 Aug 2014, Janne Grunau wrote: On 2014-08-10 14:14:23 +0300, Martin Storsjö wrote: On Sun, 10 Aug 2014, Janne Grunau wrote: I have no setup to test apple's gcc-4.2 with gas. Tested, almost works, requires the following fixup: -[ $target_os = "darwin" ] && gaspp_as_type="apple

Re: [libav-devel] [PATCH] avcodec: Instruct users to align buffers to 32-byte.

2014-08-10 Thread Kieran Kunhya
On 10 August 2014 11:25, Janne Grunau wrote: > On 2014-08-10 04:17:09 +0100, Kieran Kunhya wrote: >> The Opus decoder in particular uses optimised float_dsp functions that >> expect 32-byte alignment >> --- >> libavcodec/avcodec.h |2 +- >> 1 file changed, 1 insertion(+), 1 deletion(-) >> >>

Re: [libav-devel] [RFC PATCH 2/2] configure: Fix checking for and autoenabling gas-preprocessor

2014-08-10 Thread Janne Grunau
On 2014-08-10 14:14:23 +0300, Martin Storsjö wrote: > On Sun, 10 Aug 2014, Janne Grunau wrote: > > >I have no setup to test apple's gcc-4.2 with gas. > > Tested, almost works, requires the following fixup: > > -[ $target_os = "darwin" ] && gaspp_as_type="apple-$as_type" > +[ $target_os =

[libav-devel] [PATCH] configure: Don't pass MSVC compiler options -M[TD] to armasm

2014-08-10 Thread Martin Storsjö
The -MD option (for enabling a dynamically linked crt) gets interpreted as a cpp option for generating dependency information (into a file named '-.d', when preprocessing to a pipe). We shouldn't be passing any and all C compiler flags to armasm (which is a plain assembler, only with cpp bolted on

Re: [libav-devel] [PATCH] avresample: Introduce AVFrame-based API

2014-08-10 Thread Luca Barbato
On 09/08/14 23:23, Luca Barbato wrote: > --- > > Updated according the review, the AVDictionary helper will appear later, > now avresample_config() does not include avresample_open(). > > doc/APIchanges | 6 +++ > libavresample/avresample.h | 69 > libavre

Re: [libav-devel] [PATCH 04/10] http: enable icy metadata by default.

2014-08-10 Thread wm4
On Sat, 9 Aug 2014 21:22:13 +0300 (EEST) Martin Storsjö wrote: > On Thu, 31 Jul 2014, Andrew Stone wrote: > > > It won't hurt servers that don't care about the header, > > and those that do will include it by default. > > --- > > Changelog | 1 + > > doc/protocols.texi | 2 +- > > libavfo

Re: [libav-devel] [RFC PATCH 2/2] configure: Fix checking for and autoenabling gas-preprocessor

2014-08-10 Thread Martin Storsjö
On Sun, 10 Aug 2014, Janne Grunau wrote: On 2014-08-09 22:48:29 +0300, Martin Storsjö wrote: --- This goes on top of Diego's RFC patch. --- configure | 9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/configure b/configure index 4d2439e..877f240 100755 --- a/configure

Re: [libav-devel] [GASPP RFC PATCH 2/2] Undefine platform specific predefined defines when preprocessing C source for armasm

2014-08-10 Thread Janne Grunau
On 2014-08-09 22:48:48 +0300, Martin Storsjö wrote: > Since plain 'cpp' is used for preprocessing, it inherits whatever > platform specific predefined defines. > > Previously this was set on the libav configure line, such as > --as='gas-preprocessor.pl -as-type armasm -- armasm -nologo -U__ELF__ -

Re: [libav-devel] [PATCH] lavc: drop the av_fast_{re, m}alloc compatibility wrappers

2014-08-10 Thread Anton Khirnov
On Sun, 10 Aug 2014 12:37:46 +0200, Janne Grunau wrote: > On 2014-08-10 10:18:30 +, Anton Khirnov wrote: > > They were only needed until the bump. > > --- > > libavcodec/utils.c | 12 > > 1 file changed, 12 deletions(-) > > > > diff --git a/libavcodec/utils.c b/libavcodec/utils

Re: [libav-devel] [GASPP RFC PATCH 1/2] Pass -h through directly just as -v

2014-08-10 Thread Janne Grunau
On 2014-08-09 22:48:47 +0300, Martin Storsjö wrote: > This allows doing a simple no-op to test that gas-preprocessor > exists and works, since armasm doesn't have a -v option. > --- > gas-preprocessor.pl | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/gas-preprocessor.pl

Re: [libav-devel] [PATCH] lavc: drop the av_fast_{re, m}alloc compatibility wrappers

2014-08-10 Thread Janne Grunau
On 2014-08-10 10:18:30 +, Anton Khirnov wrote: > They were only needed until the bump. > --- > libavcodec/utils.c | 12 > 1 file changed, 12 deletions(-) > > diff --git a/libavcodec/utils.c b/libavcodec/utils.c > index b115da1..4253e8c 100644 > --- a/libavcodec/utils.c > +++ b/li

Re: [libav-devel] [PATCH] avcodec: Instruct users to align buffers to 32-byte.

2014-08-10 Thread Janne Grunau
On 2014-08-10 04:17:09 +0100, Kieran Kunhya wrote: > The Opus decoder in particular uses optimised float_dsp functions that expect > 32-byte alignment > --- > libavcodec/avcodec.h |2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/libavcodec/avcodec.h b/libavcodec/avcode

Re: [libav-devel] [PATCH] avcodec: Instruct users to align buffers to 32-byte.

2014-08-10 Thread Anton Khirnov
On Sun, 10 Aug 2014 04:17:09 +0100, Kieran Kunhya wrote: > The Opus decoder in particular uses optimised float_dsp functions that expect > 32-byte alignment > --- > libavcodec/avcodec.h |2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/libavcodec/avcodec.h b/libavcode

[libav-devel] [PATCH] lavc: drop the av_fast_{re, m}alloc compatibility wrappers

2014-08-10 Thread Anton Khirnov
They were only needed until the bump. --- libavcodec/utils.c | 12 1 file changed, 12 deletions(-) diff --git a/libavcodec/utils.c b/libavcodec/utils.c index b115da1..4253e8c 100644 --- a/libavcodec/utils.c +++ b/libavcodec/utils.c @@ -56,18 +56,6 @@ static int (*lockmgr_cb)(void **m

Re: [libav-devel] [RFC PATCH 2/2] configure: Fix checking for and autoenabling gas-preprocessor

2014-08-10 Thread Janne Grunau
On 2014-08-09 22:48:29 +0300, Martin Storsjö wrote: > --- > This goes on top of Diego's RFC patch. > --- > configure | 9 + > 1 file changed, 5 insertions(+), 4 deletions(-) > > diff --git a/configure b/configure > index 4d2439e..877f240 100755 > --- a/configure > +++ b/configure > @@ -37

Re: [libav-devel] [RFC PATCH 1/2] configure: Add probe identification of MS armasm

2014-08-10 Thread Janne Grunau
On 2014-08-09 22:48:28 +0300, Martin Storsjö wrote: > --- > configure | 4 > 1 file changed, 4 insertions(+) > > diff --git a/configure b/configure > index 7e3f6ff..4d2439e 100755 > --- a/configure > +++ b/configure > @@ -2881,6 +2881,10 @@ probe_cc(){ > _cflags_size="-O2 -Munroll=c

Re: [libav-devel] [PATCH] avcodec: Instruct users to align buffers to 32-byte.

2014-08-10 Thread Luca Barbato
On 10/08/14 05:17, Kieran Kunhya wrote: > The Opus decoder in particular uses optimised float_dsp functions that expect > 32-byte alignment > --- > libavcodec/avcodec.h |2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/libavcodec/avcodec.h b/libavcodec/avcodec.h > index