Re: [libav-devel] [PATCH] intreadwrite: Use the __unaligned keyword on MSVC for ARM and x86_64

2016-08-01 Thread Martin Storsjö
On Mon, 1 Aug 2016, Janne Grunau wrote: On 2016-08-01 10:09:40 +0300, Martin Storsjö wrote: AV_WN64 is meant for unaligned data, but the existing av_alias* unions (without a definition for the av_alias attribute - we don't have one for MSVC) indicate to the compiler that they would have suffici

Re: [libav-devel] [PATCH] intreadwrite: Use the __unaligned keyword on MSVC for ARM and x86_64

2016-08-01 Thread Janne Grunau
On 2016-08-01 10:09:40 +0300, Martin Storsjö wrote: > AV_WN64 is meant for unaligned data, but the existing av_alias* unions > (without a definition for the av_alias attribute - we don't have one > for MSVC) indicate to the compiler that they would have sufficient > alignment for normal access, i.e

Re: [libav-devel] [PATCH] intreadwrite: Add intermediate variables in the byteswise AV_W*() macros

2016-08-01 Thread Janne Grunau
On 2016-08-01 09:15:30 +0300, Martin Storsjö wrote: > This avoids issues with expanding the argument multiple times, > and makes sure that it is of the right type for the following shifts. > > Even if the caller of a macro could be expected not to pass parameters > that have side effects if expand

Re: [libav-devel] [PATCH 05/11] vp9mc/x86: add 16px functions (64bit only).

2016-08-01 Thread Anton Khirnov
Quoting Diego Biurrun (2016-08-01 13:48:47) > On Sat, Jul 30, 2016 at 10:02:47PM +0200, Anton Khirnov wrote: > > --- a/libavcodec/x86/vp9dsp_init.c > > +++ b/libavcodec/x86/vp9dsp_init.c > > @@ -95,7 +98,9 @@ ff_ ## avg ## _8tap_1d_ ## dir ## _ ## sz ## _ ## > > opt(uint8_t *dst, \ > >

Re: [libav-devel] [PATCH 03/11] lavc: align the linesize to 32 when AVX is enabled

2016-08-01 Thread James Almer
On 8/1/2016 8:19 AM, Diego Biurrun wrote: > On Sat, Jul 30, 2016 at 10:02:45PM +0200, Anton Khirnov wrote: >> --- >> configure | 6 +- >> libavcodec/utils.c | 4 +++- >> 2 files changed, 8 insertions(+), 2 deletions(-) > > OK > >> --- a/configure >> +++ b/configure >> @@ -5032,7 +50

Re: [libav-devel] [PATCH 08/11] vp9mc/x86: rename ff_* to ff_vp9_*

2016-08-01 Thread Diego Biurrun
On Sat, Jul 30, 2016 at 10:02:50PM +0200, Anton Khirnov wrote: > From: Clément Bœsch > > Signed-off-by: Anton Khirnov > --- > libavcodec/x86/vp9dsp_init.c | 94 > ++-- > libavcodec/x86/vp9mc.asm | 14 +++ > 2 files changed, 54 insertions(+), 54 d

Re: [libav-devel] [PATCH 05/11] vp9mc/x86: add 16px functions (64bit only).

2016-08-01 Thread Diego Biurrun
On Sat, Jul 30, 2016 at 10:02:47PM +0200, Anton Khirnov wrote: > --- a/libavcodec/x86/vp9dsp_init.c > +++ b/libavcodec/x86/vp9dsp_init.c > @@ -95,7 +98,9 @@ ff_ ## avg ## _8tap_1d_ ## dir ## _ ## sz ## _ ## > opt(uint8_t *dst, \ > mc_rep_func(put, sz, hsz, v, ssse3); \ > mc_rep_f

Re: [libav-devel] [PATCH 07/11] vp9mc/x86: rename ff_avg[48]_sse to ff_avg[48]_mmxext

2016-08-01 Thread Diego Biurrun
On Sat, Jul 30, 2016 at 10:02:49PM +0200, Anton Khirnov wrote: > From: James Almer > > pavgb is an sse integer instruction, so the mmxext flag is enough > > Signed-off-by: James Almer > Reviewed-by: "Ronald S. Bultje" > Signed-off-by: Anton Khirnov > --- > libavcodec/x86/vp9dsp_init.c | 11 +

Re: [libav-devel] [PATCH 04/11] vp9/x86: rename vp9dsp to vp9mc

2016-08-01 Thread Diego Biurrun
On Mon, Aug 01, 2016 at 01:20:39PM +0200, Diego Biurrun wrote: > On Sat, Jul 30, 2016 at 10:02:46PM +0200, Anton Khirnov wrote: > > It only contains the MC SIMD, other SIMD will go into different files. > > --- > > libavcodec/x86/Makefile | 2 +- > > libavcodec/x86/{vp9dsp.asm =>

Re: [libav-devel] [PATCH 04/11] vp9/x86: rename vp9dsp to vp9mc

2016-08-01 Thread Diego Biurrun
On Sat, Jul 30, 2016 at 10:02:46PM +0200, Anton Khirnov wrote: > It only contains the MC SIMD, other SIMD will go into different files. > --- > libavcodec/x86/Makefile | 2 +- > libavcodec/x86/{vp9dsp.asm => vp9mc.asm} | 0 > 2 files changed, 1 insertion(+), 1 deletion(-) > renam

Re: [libav-devel] [PATCH 03/11] lavc: align the linesize to 32 when AVX is enabled

2016-08-01 Thread Diego Biurrun
On Sat, Jul 30, 2016 at 10:02:45PM +0200, Anton Khirnov wrote: > --- > configure | 6 +- > libavcodec/utils.c | 4 +++- > 2 files changed, 8 insertions(+), 2 deletions(-) OK > --- a/configure > +++ b/configure > @@ -5032,7 +5036,7 @@ enabled_all dxva2 CoTaskMemFree && > enable

Re: [libav-devel] [PATCH 02/11] lavu: add LOCAL_ALIGNED_32

2016-08-01 Thread Diego Biurrun
On Sat, Jul 30, 2016 at 10:02:44PM +0200, Anton Khirnov wrote: > From: James Almer > > Signed-off-by: James Almer > Signed-off-by: Anton Khirnov > --- > configure| 5 +++-- > libavutil/internal.h | 6 ++ > 2 files changed, 9 insertions(+), 2 deletions(-) OK Diego

Re: [libav-devel] [PATCH 01/11] x86: deduplicate some constants

2016-08-01 Thread Diego Biurrun
On Sat, Jul 30, 2016 at 10:02:43PM +0200, Anton Khirnov wrote: > From: Christophe Gisquet > > Signed-off-by: Anton Khirnov > --- > libavcodec/x86/constants.c | 2 ++ > libavcodec/x86/constants.h | 3 +++ > libavcodec/x86/h264_intrapred_10bit.asm | 2 +- > libavcodec/x8

Re: [libav-devel] [PATCH 2/3] avconv_vaapi: Convert to use hw_frames_ctx only

2016-08-01 Thread Diego Biurrun
On Sun, Jul 31, 2016 at 11:25:04PM +0100, Mark Thompson wrote: > Most of the functionality here has moved into lavc. > --- > This doesn't actually work until codecs have been converted too. (Maybe this > should go at the end of the series because of that?) Probably yes. Diego __

Re: [libav-devel] [PATCH 3/3] vaapi_h264: Convert to use new VAAPI hwaccel code

2016-08-01 Thread Diego Biurrun
On Sun, Jul 31, 2016 at 11:30:02PM +0100, Mark Thompson wrote: > Also constify lots of pointers. Maybe the constification can be a separate patch? Or does it depend on the conversion? Diego ___ libav-devel mailing list libav-devel@libav.org https://lis

Re: [libav-devel] [PATCH 1/3] lavc: Rewrite VAAPI decode infrastructure

2016-08-01 Thread Diego Biurrun
On Sun, Jul 31, 2016 at 11:22:46PM +0100, Mark Thompson wrote: > > --- /dev/null > +++ b/libavcodec/vaapi_decode.h > @@ -0,0 +1,95 @@ > + > +#ifndef AVCODEC_VAAPI_DECODE_H > +#define AVCODEC_VAAPI_DECODE_H > + > +#include > + > +#include "libavutil/hwcontext.h" > +#include "libavutil/hwcontext_va

Re: [libav-devel] [PATCH 10/13] pthread_frame: use atomics for signalling threads to die

2016-08-01 Thread Julian Seward
Hi Anton, Nice to see your work on race/UB removal. I have been working on removing races from libavcodec/pthread_frame.c as part of a wider effort to remove TSan-detected races from Firefox, which uses ffmpeg-3.0.2. This is tracked starting at https://bugzilla.mozilla.org/show_bug.cgi?id=127425

Re: [libav-devel] [PATCH 10/13] pthread_frame: use atomics for signalling threads to die

2016-08-01 Thread Julian Seward
Hi Anton, Nice to see your work on race/UB removal. I have been working on removing races from libavcodec/pthread_frame.c as part of a wider effort to remove TSan-detected races from Firefox, which uses ffmpeg-3.0.2. This is tracked starting at https://bugzilla.mozilla.org/show_bug.cgi?id=127425

Re: [libav-devel] [PATCH 1/3] lavc: Rewrite VAAPI decode infrastructure

2016-08-01 Thread Mark Thompson
On 31/07/16 23:22, Mark Thompson wrote: > +void *ff_vaapi_decode_alloc_slice_buffer(AVCodecContext *avctx, > + VAAPIDecodePicture *pic, > + size_t params_size, > + const void *sli

Re: [libav-devel] [PATCH] h264dec: reset nb_slice_ctx_queued for hwaccel decoding

2016-08-01 Thread Mark Thompson
On 01/08/16 06:44, Anton Khirnov wrote: > Fixes hwaccel decoding of files with multiple slices. > > Found-By: Mark Thompson > --- > libavcodec/h264dec.c | 5 +++-- > 1 file changed, 3 insertions(+), 2 deletions(-) > > diff --git a/libavcodec/h264dec.c b/libavcodec/h264dec.c > index 0e318a5..2c5

Re: [libav-devel] [PATCH] intreadwrite: Use the __unaligned keyword on MSVC for ARM and x86_64

2016-08-01 Thread Luca Barbato
On 01/08/16 10:12, Martin Storsjö wrote: > I guess that would work as well, although it feels more like coincidence > that they happen to be similar. Or maybe not (since this MSVC attribute > came from itanium first I think). Since they're quite different > compilers I'd rather have separate blocks

Re: [libav-devel] [PATCH] intreadwrite: Use the __unaligned keyword on MSVC for ARM and x86_64

2016-08-01 Thread Martin Storsjö
On Mon, 1 Aug 2016, Luca Barbato wrote: On 01/08/16 09:09, Martin Storsjö wrote: AV_WN64 is meant for unaligned data, but the existing av_alias* unions (without a definition for the av_alias attribute - we don't have one for MSVC) indicate to the compiler that they would have sufficient alignme

Re: [libav-devel] [PATCH] intreadwrite: Use the __unaligned keyword on MSVC for ARM and x86_64

2016-08-01 Thread Luca Barbato
On 01/08/16 09:09, Martin Storsjö wrote: > AV_WN64 is meant for unaligned data, but the existing av_alias* unions > (without a definition for the av_alias attribute - we don't have one > for MSVC) indicate to the compiler that they would have sufficient > alignment for normal access, i.e. the compi

Re: [libav-devel] [PATCH] h264dec: reset nb_slice_ctx_queued for hwaccel decoding

2016-08-01 Thread Luca Barbato
On 01/08/16 07:44, Anton Khirnov wrote: > Fixes hwaccel decoding of files with multiple slices. > > Found-By: Mark Thompson > --- > libavcodec/h264dec.c | 5 +++-- > 1 file changed, 3 insertions(+), 2 deletions(-) > > diff --git a/libavcodec/h264dec.c b/libavcodec/h264dec.c > index 0e318a5..2c5

[libav-devel] [PATCH] intreadwrite: Use the __unaligned keyword on MSVC for ARM and x86_64

2016-08-01 Thread Martin Storsjö
AV_WN64 is meant for unaligned data, but the existing av_alias* unions (without a definition for the av_alias attribute - we don't have one for MSVC) indicate to the compiler that they would have sufficient alignment for normal access, i.e. the compiler is free to assume 8 byte alignment. On ARM,