Re: [libav-devel] [PATCH 1/5] av1: Add codec_id and basic demuxing support

2016-08-24 Thread James Almer
On 8/24/2016 3:52 PM, Luca Barbato wrote: > On 24/08/16 20:31, James Almer wrote: >> Was this tag added to the Matroska spec? Or was it at least suggested >> somewhere? > > The libaom sources. Fair enough. Doubt Matroska will end up going with something else if WebM already uses that. > >>

Re: [libav-devel] [PATCH] vp56: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Martin Storsjö
On Wed, 24 Aug 2016, Diego Biurrun wrote: This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- Assembly updated to match. Seems ok // Martin ___ libav-devel mailing

Re: [libav-devel] [PATCH 1/5] av1: Add codec_id and basic demuxing support

2016-08-24 Thread Luca Barbato
On 24/08/16 20:31, James Almer wrote: > Was this tag added to the Matroska spec? Or was it at least suggested > somewhere? The libaom sources. > Also, wouldn't adding this here also allow matroskaenc to mux AV1 using > stream copy? If so, there should be a line in that muxer to either > require

Re: [libav-devel] [PATCH] prores: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Martin Storsjö
On Wed, 24 Aug 2016, Diego Biurrun wrote: This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- Assembly changed to match. libavcodec/proresdsp.c | 6 +++--- libavcodec/proresdsp.h | 3 ++-

Re: [libav-devel] [PATCH 5/5] libvpx: Cast a pointer to const to squelch a warning

2016-08-24 Thread Vittorio Giovara
On Wed, Aug 24, 2016 at 1:59 PM, Luca Barbato wrote: > On 24/08/16 18:28, Diego Biurrun wrote: >> libavcodec/libvpxdec.c:100:57: warning: passing argument 3 of >> 'av_image_copy' from incompatible pointer type >> av_image_copy(picture->data, picture->linesize,

Re: [libav-devel] [PATCH] vp3: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Martin Storsjö
On Wed, 24 Aug 2016, Diego Biurrun wrote: This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- Possibly this needs some changes for ARM, which I know nothing about. No, no such changes are needed since we don't

Re: [libav-devel] [PATCH 1/2] vp8: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Martin Storsjö
On Wed, 24 Aug 2016, Diego Biurrun wrote: ptrdiff_t is the correct type for array strides and similar. --- libavcodec/vp8.c| 17 + libavcodec/vp8.h| 4 ++-- tests/checkasm/vp8dsp.c | 4 ++-- 3 files changed, 13 insertions(+), 12 deletions(-) This is probably ok

Re: [libav-devel] [PATCH 2/2] vp8: Update some stale assembly comments

2016-08-24 Thread Martin Storsjö
On Wed, 24 Aug 2016, Diego Biurrun wrote: --- libavcodec/arm/vp8dsp_armv6.S| 24 libavcodec/x86/vp8dsp.asm| 12 ++-- libavcodec/x86/vp8dsp_loopfilter.asm | 6 +++--- 3 files changed, 21 insertions(+), 21 deletions(-) Thanks, this looks ok.

Re: [libav-devel] [PATCH 1/6] vp3: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Martin Storsjö
On Wed, 24 Aug 2016, Diego Biurrun wrote: On Wed, Aug 24, 2016 at 02:10:05PM +0300, Martin Storsjö wrote: On Wed, 24 Aug 2016, Diego Biurrun wrote: > --- a/libavcodec/arm/vp3dsp_init_arm.c > +++ b/libavcodec/arm/vp3dsp_init_arm.c > @@ -23,9 +23,9 @@ > > -void ff_vp3_idct_put_neon(uint8_t

Re: [libav-devel] [PATCH 1/5] av1: Add codec_id and basic demuxing support

2016-08-24 Thread James Almer
On 8/24/2016 1:28 PM, Diego Biurrun wrote: > From: Luca Barbato > > Signed-off-by: Diego Biurrun > --- > > I feel like I'm missing a version bump somewhere.. > > libavcodec/avcodec.h| 1 + > libavcodec/codec_desc.c | 7 +++ >

Re: [libav-devel] [PATCH 4/5] libaom: Templatize code shared with libvpx to avoid code duplication

2016-08-24 Thread Luca Barbato
On 24/08/16 18:28, Diego Biurrun wrote: > diff --git a/libavcodec/libvpxenc.c b/libavcodec/libvpxenc.c > index c6c9105..4044ccd 100644 > --- a/libavcodec/libvpxenc.c > +++ b/libavcodec/libvpxenc.c > @@ -375,7 +375,7 @@ FF_ENABLE_DEPRECATION_WARNINGS > codecctl_int(avctx, VP8E_SET_CQ_LEVEL,

Re: [libav-devel] [PATCH 5/5] libvpx: Cast a pointer to const to squelch a warning

2016-08-24 Thread Luca Barbato
On 24/08/16 18:28, Diego Biurrun wrote: > libavcodec/libvpxdec.c:100:57: warning: passing argument 3 of 'av_image_copy' > from incompatible pointer type > av_image_copy(picture->data, picture->linesize, img->planes, > libavutil/imgutils.h:116:6: note: expected 'const uint8_t **' but

[libav-devel] [PATCH 5/5] libvpx: Cast a pointer to const to squelch a warning

2016-08-24 Thread Diego Biurrun
libavcodec/libvpxdec.c:100:57: warning: passing argument 3 of 'av_image_copy' from incompatible pointer type av_image_copy(picture->data, picture->linesize, img->planes, libavutil/imgutils.h:116:6: note: expected 'const uint8_t **' but argument is of type 'unsigned char **' void

[libav-devel] [PATCH 3/5] libvpx: Require at least version 1.4.0

2016-08-24 Thread Diego Biurrun
This allows dropping some compatibility ifdefs, which will simplify sharing code with the libaom wrapper. --- configure | 2 +- libavcodec/libvpx.c| 4 libavcodec/libvpxenc.c | 2 -- 3 files changed, 1 insertion(+), 7 deletions(-) diff --git a/configure b/configure index

[libav-devel] [PATCH 4/5] libaom: Templatize code shared with libvpx to avoid code duplication

2016-08-24 Thread Diego Biurrun
--- libavcodec/libaom.c | 57 +- libavcodec/libaom.c_template.c | 111 +++ libavcodec/libaom.h | 10 +-- libavcodec/{libaom.h => libaom.h_template.c} | 13 +--- libavcodec/libvpx.c

[libav-devel] [PATCH 1/5] av1: Add codec_id and basic demuxing support

2016-08-24 Thread Diego Biurrun
From: Luca Barbato Signed-off-by: Diego Biurrun --- I feel like I'm missing a version bump somewhere.. libavcodec/avcodec.h| 1 + libavcodec/codec_desc.c | 7 +++ libavformat/matroska.c | 1 + libavformat/riff.c | 1 + 4 files changed, 10

[libav-devel] AV1 decoding support through libaom

2016-08-24 Thread Diego Biurrun
I have refreshed Luca's patches to add AV1 support. They're very directly derived from the libvpx wrapper, it's mostly s/vpx/aom/, so I'm wondering if more code sharing via templating or similar is in order. Then again, IIUC, libaom is going to supplant libvpx completely, even for VP8/9. So

Re: [libav-devel] [PATCH 1/2] vp8: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Luca Barbato
On 24/08/16 14:21, Diego Biurrun wrote: > ptrdiff_t is the correct type for array strides and similar. > --- > libavcodec/vp8.c| 17 + > libavcodec/vp8.h| 4 ++-- > tests/checkasm/vp8dsp.c | 4 ++-- > 3 files changed, 13 insertions(+), 12 deletions(-) > Set

Re: [libav-devel] [PATCH 1/3] imgutils: add a function for copying image data from GPU mapped memory

2016-08-24 Thread Vittorio Giovara
On Wed, Aug 24, 2016 at 6:06 AM, Diego Biurrun wrote: > On Wed, Aug 24, 2016 at 11:24:01AM +0200, Anton Khirnov wrote: >> --- /dev/null >> +++ b/libavutil/x86/imgutils_init.c >> @@ -0,0 +1,49 @@ >> + >> +void ff_image_copy_plane_uc_from_sse4(uint8_t *dst, ptrdiff_t dst_linesize,

[libav-devel] [PATCHv4] New filter af_hdcd: High Definition Compatible Digital (HDCD) decoder

2016-08-24 Thread Burt P
A new filter that provides HDCD decoding, using libhdcd. https://github.com/bp0/libhdcd Requires ./configure --enable-libhdcd Signed-off-by: Burt P --- Changelog| 1 + configure| 4 + doc/filters.texi | 47 +++

[libav-devel] [PATCH] vp56: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Diego Biurrun
This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- Assembly updated to match. libavcodec/arm/vp6dsp_init_arm.c | 4 ++-- libavcodec/vp56.h| 4 ++-- libavcodec/vp56dsp.c | 3 ++-

[libav-devel] [PATCH] prores: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Diego Biurrun
This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- Assembly changed to match. libavcodec/proresdsp.c | 6 +++--- libavcodec/proresdsp.h | 3 ++- libavcodec/proresenc.c | 19

[libav-devel] [PATCH 2/2] vp8: Update some stale assembly comments

2016-08-24 Thread Diego Biurrun
--- libavcodec/arm/vp8dsp_armv6.S| 24 libavcodec/x86/vp8dsp.asm| 12 ++-- libavcodec/x86/vp8dsp_loopfilter.asm | 6 +++--- 3 files changed, 21 insertions(+), 21 deletions(-) diff --git a/libavcodec/arm/vp8dsp_armv6.S

[libav-devel] [PATCH 1/2] vp8: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Diego Biurrun
ptrdiff_t is the correct type for array strides and similar. --- libavcodec/vp8.c| 17 + libavcodec/vp8.h| 4 ++-- tests/checkasm/vp8dsp.c | 4 ++-- 3 files changed, 13 insertions(+), 12 deletions(-) diff --git a/libavcodec/vp8.c b/libavcodec/vp8.c index

[libav-devel] [PATCH] vp3: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Diego Biurrun
This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- Possibly this needs some changes for ARM, which I know nothing about. libavcodec/arm/vp3dsp_init_arm.c | 6 +++--- libavcodec/ppc/vp3dsp_altivec.c | 4 ++--

Re: [libav-devel] [PATCH 1/6] vp3: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Diego Biurrun
On Wed, Aug 24, 2016 at 02:10:05PM +0300, Martin Storsjö wrote: > On Wed, 24 Aug 2016, Diego Biurrun wrote: > > --- a/libavcodec/arm/vp3dsp_init_arm.c > > +++ b/libavcodec/arm/vp3dsp_init_arm.c > > @@ -23,9 +23,9 @@ > > > > -void ff_vp3_idct_put_neon(uint8_t *dest, int line_size, int16_t *data); >

Re: [libav-devel] [PATCH 6/6] prores: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Martin Storsjö
On Wed, 24 Aug 2016, Diego Biurrun wrote: This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- libavcodec/proresdsp.c | 6 +++--- libavcodec/proresdsp.h | 3 ++- libavcodec/proresenc.c |

Re: [libav-devel] [PATCH 2/6] vp56: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Martin Storsjö
On Wed, 24 Aug 2016, Diego Biurrun wrote: This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- libavcodec/arm/vp6dsp_init_arm.c | 4 ++-- libavcodec/vp56.h| 4 ++-- libavcodec/vp56dsp.c

Re: [libav-devel] [PATCH 1/6] vp3: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Martin Storsjö
On Wed, 24 Aug 2016, Diego Biurrun wrote: This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- libavcodec/arm/vp3dsp_init_arm.c | 6 +++--- libavcodec/ppc/vp3dsp_altivec.c | 4 ++-- libavcodec/vp3dsp.c

Re: [libav-devel] [PATCH 4/6] vp8: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Martin Storsjö
On Wed, 24 Aug 2016, Diego Biurrun wrote: This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. Actually, the parameter already is ptrdiff_t in most places, which is why this patch of yours actually isn't doing

[libav-devel] [PATCH 6/6] prores: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Diego Biurrun
This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- libavcodec/proresdsp.c | 6 +++--- libavcodec/proresdsp.h | 3 ++- libavcodec/proresenc.c | 19 ++-

[libav-devel] [PATCH 3/6] vp56: Separate VP5 and VP6 dsp initialization

2016-08-24 Thread Diego Biurrun
VP5 has no arch-specific optimizations (nor will it get some in the future), so it makes no sense to try to share dsp init code with VP6. --- libavcodec/arm/vp6dsp_init_arm.c | 4 +-- libavcodec/vp5.c | 1 + libavcodec/vp56.c| 1 - libavcodec/vp56.h

[libav-devel] [PATCH 1/6] vp3: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Diego Biurrun
This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- libavcodec/arm/vp3dsp_init_arm.c | 6 +++--- libavcodec/ppc/vp3dsp_altivec.c | 4 ++-- libavcodec/vp3dsp.c | 20 ++--

[libav-devel] [PATCH 2/6] vp56: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Diego Biurrun
This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- libavcodec/arm/vp6dsp_init_arm.c | 4 ++-- libavcodec/vp56.h| 4 ++-- libavcodec/vp56dsp.c | 3 ++- libavcodec/vp56dsp.h

[libav-devel] [PATCH 4/6] vp8: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Diego Biurrun
This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- libavcodec/arm/vp8dsp_armv6.S| 24 libavcodec/vp8.c | 17 + libavcodec/vp8.h

[libav-devel] more int --> ptrdiff_t type changes for stride parameters

2016-08-24 Thread Diego Biurrun
$subject came up on IRC yesterday, so I decided to work on it in the morning. Here are some patches to move us slowly into the right direction. Remember: if our hearts remain pure, we shall stamp out int as type for stride variables in our lifetimes. [PATCH 1/6] vp3: Change type of stride

[libav-devel] [PATCH 5/6] cavs: Change type of stride parameters to ptrdiff_t

2016-08-24 Thread Diego Biurrun
This avoids SIMD-optimized functions having to sign-extend their line size argument manually to be able to do pointer arithmetic. --- libavcodec/cavs.c| 18 libavcodec/cavs.h| 4 ++-- libavcodec/cavsdec.c | 2 +- libavcodec/cavsdsp.c | 55

Re: [libav-devel] [PATCH 1/3] imgutils: add a function for copying image data from GPU mapped memory

2016-08-24 Thread Diego Biurrun
On Wed, Aug 24, 2016 at 11:24:01AM +0200, Anton Khirnov wrote: > --- /dev/null > +++ b/libavutil/x86/imgutils_init.c > @@ -0,0 +1,49 @@ > + > +void ff_image_copy_plane_uc_from_sse4(uint8_t *dst, ptrdiff_t dst_linesize, > + const uint8_t *src, ptrdiff_t >

[libav-devel] [PATCH 2/3] hwcontext_dxva2: use the special UC copy for downloading frames

2016-08-24 Thread Anton Khirnov
--- libavutil/hwcontext_dxva2.c | 9 +++-- 1 file changed, 7 insertions(+), 2 deletions(-) diff --git a/libavutil/hwcontext_dxva2.c b/libavutil/hwcontext_dxva2.c index f66c0fa..da89453 100644 --- a/libavutil/hwcontext_dxva2.c +++ b/libavutil/hwcontext_dxva2.c @@ -277,8 +277,13 @@ static int

[libav-devel] [PATCH 1/3] imgutils: add a function for copying image data from GPU mapped memory

2016-08-24 Thread Anton Khirnov
See https://software.intel.com/en-us/articles/copying-accelerated-video-decode-frame-buffers --- doc/APIchanges| 4 +++ libavutil/imgutils.c | 75 +++ libavutil/imgutils.h | 18 +++ libavutil/imgutils_internal.h |

[libav-devel] [PATCH 3/3] hwcontext_vaapi: use the special UC copy for downloading frames when possible

2016-08-24 Thread Anton Khirnov
--- libavutil/hwcontext_vaapi.c | 25 + 1 file changed, 21 insertions(+), 4 deletions(-) diff --git a/libavutil/hwcontext_vaapi.c b/libavutil/hwcontext_vaapi.c index bba0c4d..a9fcf0c 100644 --- a/libavutil/hwcontext_vaapi.c +++ b/libavutil/hwcontext_vaapi.c @@ -34,6 +34,7