[libvirt] About the Windows Support ToDo Item

2008-10-10 Thread Adhyas Avasthi
I could not really understand this ToDo Item clearly. Does this mean that libvert can be installed on Windows and then support Windows Hypervisor ? Please pardon my lack of understanding, but from what I understand libvert is supposed to be installed on the hypervisor itself (either in DOM0 or in t

[libvirt] PATCH: Fix virRealloc for zero-sized alloc

2008-10-10 Thread Daniel P. Berrange
The change to use arrays instead of linked-lists exposed a tiny bug in the virReallocN function. The realloc() contract says that if size is zero, then its semantics are the same as free(). virReallocN wasn't matching this, instead returning failure, and not setting the original pointer to NULL as

[libvirt] Re: [PATCH 3/3] qemu: fix block stats for virtio and scsi

2008-10-10 Thread Daniel P. Berrange
On Fri, Oct 10, 2008 at 05:28:54PM +0200, Guido G?nther wrote: > Hi, > use qemudDiskDeviceName to determine the block device name (as suggested > by Cole). > -- Guido > +disk = vm->def->disks; > +while (disk) { > +if (STREQ(disk->dst, path)) > +break; > +disk =

[libvirt] Re: [PATCH 2/3] qemu: fix block stats for virtio and scsi

2008-10-10 Thread Daniel P. Berrange
On Fri, Oct 10, 2008 at 05:27:24PM +0200, Guido G?nther wrote: > Hi, > qemuDiskDeviceName treat's all IDE and SCSI devices as cdroms, make it > also handle disks. Make funcion arguments const. ACK Daniel -- |: Red Hat, Engineering, London -o- http://people.redhat.com/berrange/ :| |: http://l

[libvirt] Re: [PATCH 1/3] qemu: fix block stats for virtio and scsi

2008-10-10 Thread Daniel P. Berrange
On Fri, Oct 10, 2008 at 05:25:28PM +0200, Guido G?nther wrote: > Hi, > 0 looks like a valid index as returned by virDiskNameToIndex, so we > should accept it. Also the disk argument can be const. ACK Daniel -- |: Red Hat, Engineering, London -o- http://people.redhat.com/berrange/ :| |: http:

[libvirt] Re: [PATCH/RFC] kvm/qemu vs libvirtd restarts

2008-10-10 Thread Daniel P. Berrange
On Fri, Oct 10, 2008 at 05:35:04PM +0200, Guido G?nther wrote: > On Tue, Oct 07, 2008 at 05:37:52PM +0100, Daniel P. Berrange wrote: > [..snip..] > > This also needs to be implemented with the assumption that the daemon > > can & will crash any time. So putting the state-saving hooks into the > >

[libvirt] Re: [PATCH 3/3] qemu: fix block stats for virtio and scsi

2008-10-10 Thread Cole Robinson
Guido Günther wrote: > Hi, > use qemudDiskDeviceName to determine the block device name (as suggested > by Cole). > -- Guido > > From 6985fee585561b04942036d283632e7cb2bb708f Mon Sep 17 00:00:00 2001 > From: Guido Guenther <[EMAIL PROTECTED]> > Date: Thu, 2 Oct 2008 21:12:20 +0200 > Subject: [PA

[libvirt] Re: [PATCH 2/3] qemu: fix block stats for virtio and scsi

2008-10-10 Thread Cole Robinson
Guido Günther wrote: > Hi, > qemuDiskDeviceName treat's all IDE and SCSI devices as cdroms, make it > also handle disks. Make funcion arguments const. > -- Guido > ACK. Thanks, Cole -- Libvir-list mailing list Libvir-list@redhat.com https://www.redhat.com/mailman/listinfo/libvir-list

[libvirt] Re: [PATCH 1/3] qemu: fix block stats for virtio and scsi

2008-10-10 Thread Cole Robinson
Guido Günther wrote: > Hi, > 0 looks like a valid index as returned by virDiskNameToIndex, so we > should accept it. Also the disk argument can be const. > -- Guido > ACK, needed to accommodate recent change to virDiskNameToIndex at the least. Thanks, Cole -- Libvir-list mailing list Libvir-li

[libvirt] Re: [PATCH/RFC] kvm/qemu vs libvirtd restarts

2008-10-10 Thread Guido Günther
On Tue, Oct 07, 2008 at 05:37:52PM +0100, Daniel P. Berrange wrote: [..snip..] > This also needs to be implemented with the assumption that the daemon > can & will crash any time. So putting the state-saving hooks into the > qemudShutdown() method won't be sufficient. We need to write out the > st

[libvirt] [PATCH 3/3] qemu: fix block stats for virtio and scsi

2008-10-10 Thread Guido Günther
Hi, use qemudDiskDeviceName to determine the block device name (as suggested by Cole). -- Guido >From 6985fee585561b04942036d283632e7cb2bb708f Mon Sep 17 00:00:00 2001 From: Guido Guenther <[EMAIL PROTECTED]> Date: Thu, 2 Oct 2008 21:12:20 +0200 Subject: [PATCH] support virtio and scsi disks in qe

[libvirt] [PATCH 2/3] qemu: fix block stats for virtio and scsi

2008-10-10 Thread Guido Günther
Hi, qemuDiskDeviceName treat's all IDE and SCSI devices as cdroms, make it also handle disks. Make funcion arguments const. -- Guido >From 3204259d61af4eee8436ccaea66469544f929613 Mon Sep 17 00:00:00 2001 From: Guido Guenther <[EMAIL PROTECTED]> Date: Fri, 10 Oct 2008 17:14:15 +0200 Subject: [PATC

Re: [libvirt] PATCH: Support SDL configuration for QEMU driver

2008-10-10 Thread Jim Meyering
"Daniel P. Berrange" <[EMAIL PROTECTED]> wrote: ... > diff --git a/src/qemu_conf.c b/src/qemu_conf.c ... > +#define ADD_ENV_SPACE \ > +do {\ > +if (qenvc == qenva) {

[libvirt] [PATCH 1/3] qemu: fix block stats for virtio and scsi

2008-10-10 Thread Guido Günther
Hi, 0 looks like a valid index as returned by virDiskNameToIndex, so we should accept it. Also the disk argument can be const. -- Guido >From 084dcc24ce4ec3a7561eaf2a090cdb45a97e9a56 Mon Sep 17 00:00:00 2001 From: Guido Guenther <[EMAIL PROTECTED]> Date: Fri, 10 Oct 2008 17:13:33 +0200 Subject: [P

Re: [libvirt] [PATCH] qemu: fix block stats for virtio and scsi

2008-10-10 Thread Guido Günther
On Tue, Oct 07, 2008 at 03:03:10PM -0400, Cole Robinson wrote: > Guido Günther wrote: > > On Thu, Oct 02, 2008 at 09:06:25PM +0100, Daniel P. Berrange wrote: > >> I think this needs to use the virDiskNameToIndex() method to > >> extract the index instead. > > Corrected pach attached. I don't know h

Re: [libvirt] [PATCH 3/3] Domain events - test harness

2008-10-10 Thread Daniel Veillard
On Thu, Oct 09, 2008 at 06:57:41PM +0100, Daniel P. Berrange wrote: > On Thu, Oct 09, 2008 at 11:24:47AM -0400, Ben Guthro wrote: > > This test app prints domain events as they are emitted. > > I was not sure where it belonged in the tree - so this is > > not in the context of the rest of the libvi

Re: [libvirt] [PATCH] Unify most error reporting (ver 2)

2008-10-10 Thread Daniel P. Berrange
On Fri, Oct 10, 2008 at 03:16:09PM +0200, Jim Meyering wrote: > Jim Meyering <[EMAIL PROTECTED]> wrote: > > > "Daniel P. Berrange" <[EMAIL PROTECTED]> wrote: > > ... > >> Some parts of qemu supply it, many other parts do not since they > >> have no access to the virDomainPtr object. This is one of

Re: [libvirt] [PATCH] Unify most error reporting (ver 2)

2008-10-10 Thread Daniel Veillard
On Fri, Oct 10, 2008 at 03:16:09PM +0200, Jim Meyering wrote: > Jim Meyering <[EMAIL PROTECTED]> wrote: > > > "Daniel P. Berrange" <[EMAIL PROTECTED]> wrote: > Here's the change to adjust src/test.c. > Two change sets: > - Fix the "make check" failure by adjusting uses of testError, > includin

Re: [libvirt] [PATCH] Unify most error reporting (ver 2)

2008-10-10 Thread Jim Meyering
Jim Meyering <[EMAIL PROTECTED]> wrote: > "Daniel P. Berrange" <[EMAIL PROTECTED]> wrote: > ... >> Some parts of qemu supply it, many other parts do not since they >> have no access to the virDomainPtr object. This is one of the >> reasons for deprecating this field - it was impossible to reliably

Re: [libvirt] libvirt - Configure fails with error message

2008-10-10 Thread Daniel P. Berrange
On Fri, Oct 10, 2008 at 02:58:55PM +0200, Ricardo Tiago wrote: > Hi, > > When i try to run configure it fails asking me to install the gnutls > library, which is already installed. > > Output from configure: > > checking for struct _xmlURI.query_raw... no > checking gnutls/gnutls.h usability...

[libvirt] libvirt - Configure fails with error message

2008-10-10 Thread Ricardo Tiago
Hi, When i try to run configure it fails asking me to install the gnutls library, which is already installed. Output from configure: checking for struct _xmlURI.query_raw... no checking gnutls/gnutls.h usability... yes checking gnutls/gnutls.h presence... yes checking for gnutls/gnutls.h... yes

Re: [libvirt] [PATCH] Unify most error reporting (ver 2)

2008-10-10 Thread Jim Meyering
"Daniel P. Berrange" <[EMAIL PROTECTED]> wrote: ... > Some parts of qemu supply it, many other parts do not since they > have no access to the virDomainPtr object. This is one of the > reasons for deprecating this field - it was impossible to reliably > provide it when raising errors. > > In this p

Re: [libvirt] [PATCH] Unify most error reporting (ver 2)

2008-10-10 Thread Daniel P. Berrange
On Fri, Oct 10, 2008 at 11:59:34AM +0200, Jim Meyering wrote: > "Daniel P. Berrange" <[EMAIL PROTECTED]> wrote: > > > On Fri, Oct 10, 2008 at 11:47:49AM +0200, Jim Meyering wrote: > >> Daniel Veillard <[EMAIL PROTECTED]> wrote: > >> > >> > On Thu, Oct 09, 2008 at 11:44:02AM -0400, Cole Robinson wr

Re: [libvirt] [PATCH 1/2] Update MinGW specfile

2008-10-10 Thread Richard W.M. Jones
This part of the patch (but not 2/2) was committed. Rich. -- Richard Jones, Emerging Technologies, Red Hat http://et.redhat.com/~rjones virt-p2v converts physical machines to virtual machines. Boot with a live CD or over the network (PXE) and turn machines into Xen guests. http://et.redhat.com

Re: [libvirt] [PATCH] Unify most error reporting (ver 2)

2008-10-10 Thread Jim Meyering
"Daniel P. Berrange" <[EMAIL PROTECTED]> wrote: > On Fri, Oct 10, 2008 at 11:47:49AM +0200, Jim Meyering wrote: >> Daniel Veillard <[EMAIL PROTECTED]> wrote: >> >> > On Thu, Oct 09, 2008 at 11:44:02AM -0400, Cole Robinson wrote: >> >> Daniel Veillard wrote: >> >> > On Wed, Oct 08, 2008 at 08:35:38

Re: [libvirt] [PATCH] Unify most error reporting (ver 2)

2008-10-10 Thread Daniel P. Berrange
On Fri, Oct 10, 2008 at 11:47:49AM +0200, Jim Meyering wrote: > Daniel Veillard <[EMAIL PROTECTED]> wrote: > > > On Thu, Oct 09, 2008 at 11:44:02AM -0400, Cole Robinson wrote: > >> Daniel Veillard wrote: > >> > On Wed, Oct 08, 2008 at 08:35:38PM +0100, Daniel P. Berrange wrote: > > > > Hum, this

Re: [libvirt] [PATCH] Unify most error reporting (ver 2)

2008-10-10 Thread Jim Meyering
Daniel Veillard <[EMAIL PROTECTED]> wrote: > On Thu, Oct 09, 2008 at 11:44:02AM -0400, Cole Robinson wrote: >> Daniel Veillard wrote: >> > On Wed, Oct 08, 2008 at 08:35:38PM +0100, Daniel P. Berrange wrote: >> >>> One side question: is src/xmlrpc.{c,h} even used? And >> >>> if not, can it be remov

Re: [libvirt] PATCH: Disable QEMU drive caching

2008-10-10 Thread Daniel Veillard
On Thu, Oct 09, 2008 at 12:03:28PM -0500, Anthony Liguori wrote: > I've been persuaded. Relying on the host's integrity for guest data > integrity is not a good idea by default. I don't think we should use > cache=off to address this though. I've sent a patch and started a > thread on qemu

Re: [libvirt] Re: [Fedora-xen] input on F10 virtualization release notes

2008-10-10 Thread Daniel P. Berrange
On Wed, Oct 08, 2008 at 06:11:03PM +0300, Pasi K?rkk?inen wrote: > On Tue, Oct 07, 2008 at 09:55:49AM -0700, Dale Bewley wrote: > > I've been working on the virtualization release notes[1] for Fedora 10 > > these past several days, and I'm looking for input from those in the > > know. The advances

[libvirt] Re: input on F10 virtualization release notes

2008-10-10 Thread Karsten 'quaid' Wade
On Tue, 2008-10-07 at 09:55 -0700, Dale Bewley wrote: > > I added a lot of content quickly yesterday, and the page structure > is by no means solid, but there is a pending freeze[2] on October > 10th. The actual freeze for wiki content is today. The 10 Oct. deadline is for when Docs have to g

[libvirt] Re: [Fedora-xen] input on F10 virtualization release notes

2008-10-10 Thread Pasi Kärkkäinen
On Tue, Oct 07, 2008 at 09:55:49AM -0700, Dale Bewley wrote: > I've been working on the virtualization release notes[1] for Fedora 10 > these past several days, and I'm looking for input from those in the > know. The advances coming out of the Emerging Technologies projects and > Fedora in general

Re: [libvirt] [PATCH] cleanup virDomainCreateLinux into virDomainDefineXML

2008-10-10 Thread Daniel Veillard
On Thu, Oct 09, 2008 at 09:32:47PM +0100, Daniel P. Berrange wrote: > On Thu, Oct 09, 2008 at 05:16:37PM +0200, Daniel Veillard wrote: > > As promised in the libvirt-qpid thread, virDomainCreateLinux() call > > name makes no sense (anymore), and it should be renamed, i guess since > > virDomainCr

Re: [libvirt] [PATCH] fix index creation for disks > {sd,hd,xvd,vd}z

2008-10-10 Thread Daniel Veillard
On Wed, Oct 08, 2008 at 06:23:05PM -0700, Chris Wright wrote: > Calling virDiskNameToIndex with a disk name > {sd,hd,xvd,vd}z, such as > vdaa, generates a bogus index. Account for iterations through the loop. > > Old behaviour: > vda -> 0 > vdz -> 25 > vdaa -> 0 > vdaz -> 25 > > New behaviour: >

Re: [libvirt] [PATCH] Unify most error reporting (ver 2)

2008-10-10 Thread Daniel Veillard
On Thu, Oct 09, 2008 at 11:44:02AM -0400, Cole Robinson wrote: > Daniel Veillard wrote: > > On Wed, Oct 08, 2008 at 08:35:38PM +0100, Daniel P. Berrange wrote: > >>> One side question: is src/xmlrpc.{c,h} even used? And > >>> if not, can it be removed? > >> It is not used at this time. It was for t