Re: [libvirt] [PATCH] Support for 3d Acceleration in video tag

2009-08-19 Thread Pritesh Kothari
true, will add a element called acceleration/ cause there are some features for 2d acceleration as well, so that will take care of 3d and 2d acceleration both. will post a patch soon with the above changes in it. Reposting the patch with changes mentioned above. Regards, Pritesh commit

Re: [libvirt] [PATCH] Support for defining/dumping video device in VirtualBox

2009-08-19 Thread Pritesh Kothari
On Thursday 13 August 2009 20:50:25 Daniel P. Berrange wrote: On Mon, Aug 10, 2009 at 01:55:03PM +0200, Pritesh Kothari wrote: Hi All, I have added support for defining/dumping video device in VirtualBox. The patch for the same is attached here. Also this patch depends on the earlier

Re: [libvirt] [PATCH 01/20] Secret manipulation step 1: Public API

2009-08-19 Thread Daniel Veillard
On Sun, Aug 16, 2009 at 10:47:54PM +0200, Miloslav Trmač wrote: This patch adds a secret as a separately managed object, using a special-purpose API to transfer the secret values between nodes and libvirt users. Okay, interesting... Rather than add explicit accessors for attributes of

Re: [libvirt] [PATCH 01/20] Secret manipulation step 1: Public API

2009-08-19 Thread Daniel P. Berrange
On Wed, Aug 19, 2009 at 11:21:58AM +0200, Daniel Veillard wrote: On Sun, Aug 16, 2009 at 10:47:54PM +0200, Miloslav Trma?? wrote: This patch adds a secret as a separately managed object, using a special-purpose API to transfer the secret values between nodes and libvirt users. Okay,

Re: [libvirt] [PATCH 01/20] Secret manipulation step 1: Public API

2009-08-19 Thread Miloslav Trmac
- Daniel Veillard veill...@redhat.com wrote: On Sun, Aug 16, 2009 at 10:47:54PM +0200, Miloslav Trmač wrote: Rather than add explicit accessors for attributes of secrets, and hard-code the secrets are related to storage volumes association in the API, the API uses XML to manipulate the

[libvirt] Integrating MAC address based filtering into libvirt

2009-08-19 Thread Gerhard Stenzel
Hello, I am currently investigating the possibility to implement MAC address based filtering in libvirt and was wondering if there is any related effort going on and what people in general would think about that. Here is a description of my current prototype implementation: I have a small setup

Re: [libvirt] Integrating MAC address based filtering into libvirt

2009-08-19 Thread Daniel P. Berrange
On Wed, Aug 19, 2009 at 02:11:14PM +0200, Gerhard Stenzel wrote: Hello, I am currently investigating the possibility to implement MAC address based filtering in libvirt and was wondering if there is any related effort going on and what people in general would think about that. Great, we

Re: [libvirt] Integrating MAC address based filtering into libvirt

2009-08-19 Thread Gerhard Stenzel
On Wed, 2009-08-19 at 13:35 +0100, Daniel P. Berrange wrote: On Wed, Aug 19, 2009 at 02:11:14PM +0200, Gerhard Stenzel wrote: ... I think this extra XML element is probably redundant - we should always do MAC filtering at all times, on all bridges. Not simply those used in a virtual network,

Re: [libvirt] [PATCH 01/20] Secret manipulation step 1: Public API

2009-08-19 Thread Daniel Veillard
On Wed, Aug 19, 2009 at 10:34:38AM +0100, Daniel P. Berrange wrote: On Wed, Aug 19, 2009 at 11:21:58AM +0200, Daniel Veillard wrote: On Sun, Aug 16, 2009 at 10:47:54PM +0200, Miloslav Trma?? wrote: This patch adds a secret as a separately managed object, using a special-purpose API to

Re: [libvirt] [PATCH 01/20] Secret manipulation step 1: Public API

2009-08-19 Thread Daniel Veillard
On Wed, Aug 19, 2009 at 05:36:27AM -0400, Miloslav Trmac wrote: - Daniel Veillard veill...@redhat.com wrote: On Sun, Aug 16, 2009 at 10:47:54PM +0200, Miloslav Trmač wrote: Rather than add explicit accessors for attributes of secrets, and hard-code the secrets are related to storage

Re: [libvirt] OpenVZ : The restriction of domain name should be addressed

2009-08-19 Thread Ryota Ozaki
On Fri, Jul 24, 2009 at 11:44 PM, Anton Protopopovasp...@gmail.com wrote: 2009/7/24 Daniel P. Berrange berra...@redhat.com We should make use of this --name parameter then - I guess it didn't exist when we first wrote the driver. It is useful to users to have separate ID vs Name parameters -

Re: [libvirt] [PATCH 01/20] Secret manipulation step 1: Public API

2009-08-19 Thread Daniel Veillard
On Wed, Aug 19, 2009 at 05:36:27AM -0400, Miloslav Trmac wrote: - Daniel Veillard veill...@redhat.com wrote: +virSecretPtrvirSecretDefineXML (virConnectPtr conn, + const char *xml); Let's add an unsigned int flags

[libvirt] FYI: Updated QEMU driver docs on security model

2009-08-19 Thread Daniel P. Berrange
FYI, I just pushed the following patch to the repo which adds documentation to the website for all the security model related aspects of libvirt's QEMU driver. It should appear here shortly http://libvirt.org/drvqemu.html Regards, Daniel diff --git a/docs/drvqemu.html.in

Re: [libvirt] [PATCH 03/20] Secret manipulation step 3: Public API implementation

2009-08-19 Thread Daniel Veillard
On Sun, Aug 16, 2009 at 10:47:56PM +0200, Miloslav Trmač wrote: Changes since the second submission: - Update for the changed public API - s/secret_id/uuid/g - use unsigned char * for secret value [...] +/** + * virConnectListSecrets: + * @conn: virConnect connection + * @uuids: Pointer to

Re: [libvirt] [PATCH 05/20] Secret manipulation step 5: RPC client

2009-08-19 Thread Daniel Veillard
On Sun, Aug 16, 2009 at 10:47:58PM +0200, Miloslav Trmač wrote: Changes since the second submission: - Update for the changed public API - s/secret_id/uuid/g - use unsigned char * for secret value --- src/datatypes.h |1 + src/remote_internal.c | 323

Re: [libvirt] [PATCH 06/20] Secret manipulation step 6: RPC dispatcher

2009-08-19 Thread Daniel Veillard
On Sun, Aug 16, 2009 at 10:47:59PM +0200, Miloslav Trmač wrote: Changes since the second submission: - Update for the changed public API - s/secret_id/uuid/g - use unsigned char * for secret value like for 04/20 , this will need some regeneration for the new flags args but otherwise fine

Re: [libvirt] [PATCH 02/20] Secret manipulation step 2: Internal API

2009-08-19 Thread Miloslav Trmac
- Daniel Veillard veill...@redhat.com wrote: On Sun, Aug 16, 2009 at 10:47:55PM +0200, Miloslav Trmač wrote: /** + * virSecretFreeName: + * @secret_: a secret object + * + * Destroy the vol object, this is just used by the vol hash callback. + * Returns 0 in case of success and

Re: [libvirt] [PATCH 05/20] Secret manipulation step 5: RPC client

2009-08-19 Thread Miloslav Trmac
- Daniel Veillard veill...@redhat.com wrote: On Sun, Aug 16, 2009 at 10:47:58PM +0200, Miloslav Trmač wrote: +static virDrvOpenStatus +remoteSecretOpen (virConnectPtr conn, + virConnectAuthPtr auth, + int flags) +{ +if (inside_daemon) +

Re: [libvirt] [PATCH 05/20] Secret manipulation step 5: RPC client

2009-08-19 Thread Daniel P. Berrange
On Wed, Aug 19, 2009 at 09:49:45AM -0400, Miloslav Trmac wrote: - Daniel Veillard veill...@redhat.com wrote: On Sun, Aug 16, 2009 at 10:47:58PM +0200, Miloslav Trma?? wrote: +static virDrvOpenStatus +remoteSecretOpen (virConnectPtr conn, + virConnectAuthPtr auth,

Re: [libvirt] FYI: Updated QEMU driver docs on security model

2009-08-19 Thread Mark McLoughlin
On Wed, 2009-08-19 at 14:32 +0100, Daniel P. Berrange wrote: FYI, I just pushed the following patch to the repo which adds documentation to the website for all the security model related aspects of libvirt's QEMU driver. It should appear here shortly http://libvirt.org/drvqemu.html Looks

Re: [libvirt] [PATCH 07/20] Secret manipulation step 7: Local driver

2009-08-19 Thread Daniel Veillard
On Sun, Aug 16, 2009 at 10:48:00PM +0200, Miloslav Trmač wrote: This implementation stores the secrets in an unencrypted text file, for simplicity in implementation and debugging. (Symmetric encryption, e.g. using gpgme, will not be difficult to add. Because the TLS private key used by

Re: [libvirt] [PATCH 08/20] Secret manipulation step 8: Add virsh commands

2009-08-19 Thread Daniel Veillard
On Sun, Aug 16, 2009 at 10:48:01PM +0200, Miloslav Trmač wrote: Changes since the second submission: - Change some command names to better follow the conventions - Update for the changed public API - Print (potentially auto-generated) secret UUID on successful secret-define -

Re: [libvirt] [PATCH 09/20] Secret manipulation step 9: Rebuild API docs

2009-08-19 Thread Daniel Veillard
On Sun, Aug 16, 2009 at 10:48:02PM +0200, Miloslav Trmač wrote: This commit represents results of (make -C docs api) - if this patch does not apply, just re-run the command. The API data gathered by this commit is necessary to make step 10 (Python bindings) usable. Okay, I usually don't

Re: [libvirt] [PATCH 07/20] Secret manipulation step 7: Local driver

2009-08-19 Thread Miloslav Trmac
- Daniel Veillard veill...@redhat.com wrote: On Sun, Aug 16, 2009 at 10:48:00PM +0200, Miloslav Trmač wrote: This implementation stores the secrets in an unencrypted text file, for simplicity in implementation and debugging. (Symmetric encryption, e.g. using gpgme, will not be

Re: [libvirt] [PATCH 10/20] Secret manipulation step 10: Add Python API

2009-08-19 Thread Daniel Veillard
On Sun, Aug 16, 2009 at 10:48:03PM +0200, Miloslav Trmač wrote: okay, @@ -714,6 +725,12 @@ def nameFixup(name, classe, type, file): elif name[0:18] == virInterfaceLookup: func = name[3:] func = string.lower(func[0:1]) + func[1:] +elif name[0:15] ==

Re: [libvirt] [PATCH] Small fixes for qemu save compression.

2009-08-19 Thread Daniel Veillard
On Mon, Aug 17, 2009 at 12:37:31PM +0200, Chris Lalancette wrote: Fix up a small memory leak pointed out by DanB; I was forgetting to release memory allocated to driver-saveImageFormat. Also add the save_image_format and security entries to the augeas lens. ACK ! Daniel -- Daniel

Re: [libvirt] FYI: Updated QEMU driver docs on security model

2009-08-19 Thread Gene Czarcinski
On Wednesday 19 August 2009 10:01:59 Mark McLoughlin wrote: +h3a name=securitydacPOSIX DAC users/groups/a/h3 + +p + In the session instance, the POSIX DAC model restricts QEMU virtual Should expand the acronym, it's pretty obscure I agree ... DAC and MAC are terms of art

Re: [libvirt] [PATCH 01/20] Secret manipulation step 1: Public API

2009-08-19 Thread Daniel P. Berrange
On Sun, Aug 16, 2009 at 10:47:54PM +0200, Miloslav Trma?? wrote: This patch adds a secret as a separately managed object, using a special-purpose API to transfer the secret values between nodes and libvirt users. Rather than add explicit accessors for attributes of secrets, and hard-code

Re: [libvirt] FYI: Updated QEMU driver docs on security model

2009-08-19 Thread Daniel P. Berrange
On Wed, Aug 19, 2009 at 03:01:59PM +0100, Mark McLoughlin wrote: On Wed, 2009-08-19 at 14:32 +0100, Daniel P. Berrange wrote: FYI, I just pushed the following patch to the repo which adds documentation to the website for all the security model related aspects of libvirt's QEMU driver. It

Re: [libvirt] [PATCH 0/1] Multipath pool support

2009-08-19 Thread Dave Allan
Dave Allan wrote: Daniel P. Berrange wrote: On Thu, Jul 23, 2009 at 02:53:48PM -0400, Dave Allan wrote: Daniel P. Berrange wrote: It doesn't currently allow configuration of multipathing, so for now setting the multipath configuration will have to continue to be done as part of the host