Re: [libvirt] [PATCH 5/6] Set the default machine as pseries for PPC64

2012-12-20 Thread Li Zhang
On Fri, Dec 21, 2012 at 10:27 AM, Li Zhang wrote: > > On Thu, Dec 20, 2012 at 6:31 PM, Daniel P. Berrange > wrote: > >> On Thu, Dec 20, 2012 at 02:02:26PM +0800, Li Zhang wrote: >> > From: Li Zhang >> > >> > pseries machine type is preferred for ppc64. >> > This patch is to set pseries as the d

Re: [libvirt] [PATCH 0/8] Fix PowerPC CPU driver

2012-12-20 Thread Li Zhang
Hi Jiri, Thanks for fix the problems. We also have redefined POWER CPU driver and introduce features. I will send out the patch later, and I think there are some conflicts with your patches. Can you help review my patch and put it to your series? Thanks. :) On Fri, Dec 21, 2012 at 8:01 AM, Jir

Re: [libvirt] [PATCH 0/6] BUG fix for PowerPC.

2012-12-20 Thread Li Zhang
On Fri, Dec 21, 2012 at 7:28 AM, Eric Blake wrote: > On 12/19/2012 11:02 PM, Li Zhang wrote: > > From: Li Zhang > > > > This patch series is to fix bugs on PowerPC we found when testing > > libvirt. > > > > Li Zhang (6): > > Set std VGA model as default model for ppc64. > > Use -machine opti

Re: [libvirt] [PATCH 5/6] Set the default machine as pseries for PPC64

2012-12-20 Thread Li Zhang
On Thu, Dec 20, 2012 at 6:31 PM, Daniel P. Berrange wrote: > On Thu, Dec 20, 2012 at 02:02:26PM +0800, Li Zhang wrote: > > From: Li Zhang > > > > pseries machine type is preferred for ppc64. > > This patch is to set pseries as the default machine type. > > > > Signed-off-by: Li Zhang > > --- > >

Re: [libvirt] [PATCH 6/6] Use help string "-device driver, " when getting additional caps.

2012-12-20 Thread Li Zhang
On Thu, Dec 20, 2012 at 6:32 PM, Daniel P. Berrange wrote: > On Thu, Dec 20, 2012 at 02:02:27PM +0800, Li Zhang wrote: > > From: Li Zhang > > > > QEMU of upstream and PPC64 can support "-device driver,?", > > But the help string is "-device driver,help", > > > > This patch is to replace "-device

Re: [libvirt] [PATCH 2/6] Use -machine option for PPC64

2012-12-20 Thread Li Zhang
On Thu, Dec 20, 2012 at 6:28 PM, Daniel P. Berrange wrote: > On Thu, Dec 20, 2012 at 02:02:23PM +0800, Li Zhang wrote: > > From: Li Zhang > > > > On PPC64 platform, it sets USB option in -machine option. It is > > set as the following: > > -machine pseries,usb=off > > > > This will disable USB,

[libvirt] [test-API][PATCH] managedsave: change the checking method about bypass cache

2012-12-20 Thread hongming
Check whether the O_DIRECT flag is in use on the managed save file during the duration of the managed save, since that is the real effect of the current implementation of the --bypass-cache flag. --- repos/managedsave/managedsave.py | 66 +++-- 1 files changed, 34

[libvirt] [PATCH] blockjob: fix memleak that prevented block pivot

2012-12-20 Thread Eric Blake
https://bugzilla.redhat.com/show_bug.cgi?id=888426 The code for doing a block-copy was supposed to track the destination file in drive->mirror, but was set up to do all mallocs prior to starting the copy so that OOM wouldn't leave things partially started. However, the wrong variable was being wri

[libvirt] [PATCH 0/8] Fix PowerPC CPU driver

2012-12-20 Thread Jiri Denemark
Current PowerPC driver is too complicated and mostly wrong as it was apparently created from x86 driver and not properly addapted for PowerPC architecture. More details about the issues are described in individual patches. Jiri Denemark (8): cpu: Introduce cpuModelIsAllowed internal API cpu: M

[libvirt] [PATCH 6/8] cpu: Reimplement PowerPCDecode

2012-12-20 Thread Jiri Denemark
PowerPC CPUs are either identical or incompatible and thus we just need to look up the right model for given PVR without pretending we have several candidates which we may choose from. The function is also renamed as ppcDecode to match other functions in PowerPC CPU driver. --- src/cpu/cpu_powerp

[libvirt] [PATCH 7/8] cpu: Remove hardcoded list of PowerPC models

2012-12-20 Thread Jiri Denemark
The cpu_map.xml file is there to separate CPU model definitions from the code. Having the only interesting data for PowerPC models only in the source code. This patch moves this data to the XML file and removes the hardcoded list completely. --- src/cpu/cpu_map.xml | 5 ++ src/cpu/cpu_powerpc.

[libvirt] [PATCH 5/8] cpu: Reimplement PowerPCBaseline

2012-12-20 Thread Jiri Denemark
Baseline API is supposed to return guest CPU definition that can be used on any of the provided host CPUs. Since PowerPC CPUs are either identical or incompatible, the API just needs to check that all provided CPUs are identical. Previous implementation was completely bogus. The function is also r

[libvirt] [PATCH 3/8] cpu: Fix PowerPCNodeData

2012-12-20 Thread Jiri Denemark
Make getting node CPU data for PowerPC unsupported on other architectures. The function is also renamed as ppcNodeData to match other functions in PowerPC CPU driver. --- src/cpu/cpu_powerpc.c | 26 ++ 1 file changed, 10 insertions(+), 16 deletions(-) diff --git a/src/cpu/

[libvirt] [PATCH 8/8] cpu: Rename PowerPCUpdate and PowerPCDataFree functions

2012-12-20 Thread Jiri Denemark
For consistency with other functions in PowerPC CPU driver, the two functions are renamed as ppcUpdate and ppcDataFree, respectively. --- src/cpu/cpu_powerpc.c | 9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/src/cpu/cpu_powerpc.c b/src/cpu/cpu_powerpc.c index 967fa6e..

[libvirt] [PATCH 2/8] cpu: Make comparing PowerPC CPUs easier to read

2012-12-20 Thread Jiri Denemark
Revert the condition to make it easier to read. The function is also renamed as ppcCompare to match other functions in PowerPC CPU driver. --- src/cpu/cpu_powerpc.c | 13 ++--- 1 file changed, 6 insertions(+), 7 deletions(-) diff --git a/src/cpu/cpu_powerpc.c b/src/cpu/cpu_powerpc.c index

[libvirt] [PATCH 4/8] cpu: Fix loading PowerPC vendor from cpu_map.xml

2012-12-20 Thread Jiri Denemark
When ppcVendorLoad fails to parse the vendor element for whatever reason, it is supposed to ignore it and return 0 rather than -1. The patch also removes PowerPC vendor string from the XML as it is not actually used for anything. --- src/cpu/cpu_map.xml | 7 --- src/cpu/cpu_powerpc.c | 30 +

[libvirt] [PATCH 1/8] cpu: Introduce cpuModelIsAllowed internal API

2012-12-20 Thread Jiri Denemark
The API can be used to check if the model is on the supported models list, which needs to be done in several places. --- src/cpu/cpu.c | 17 + src/cpu/cpu.h | 5 + src/cpu/cpu_generic.c | 19 +-- src/cpu/cpu_x86.c | 11 +-- 4 files c

Re: [libvirt] [PATCH 0/6] BUG fix for PowerPC.

2012-12-20 Thread Eric Blake
On 12/19/2012 11:02 PM, Li Zhang wrote: > From: Li Zhang > > This patch series is to fix bugs on PowerPC we found when testing > libvirt. > > Li Zhang (6): > Set std VGA model as default model for ppc64. > Use -machine option for PPC64 > Remove QEMU_CAPS_NO_ACPI capability for non-x86 plat

Re: [libvirt] Coverity scan

2012-12-20 Thread Eric Blake
On 12/20/2012 08:25 AM, John Ferlan wrote: > > First allow me to introduce myself - I'm John Ferlan a new Red Hat employee > (3 weeks). I came from the closed world at HP where for the last 7 years I > worked in a group developing/supporting HP's Integrity Virtual Machine > software prior to i

Re: [libvirt] [PATCH 2/2] util: add missing error log messages when failing to get netlink VFINFO

2012-12-20 Thread Eric Blake
On 12/20/2012 01:01 PM, Laine Stump wrote: > This patch fixes the lack of error messages when libvirt fails to find > VFINFO in a returned netlinke response message. > > https://bugzilla.redhat.com/show_bug.cgi?id=827519#c10 is an example > of the error message that was previously logged when the

Re: [libvirt] [PATCH 1/2] util: fix functions that retrieve SRIOV VF info

2012-12-20 Thread Eric Blake
On 12/20/2012 01:01 PM, Laine Stump wrote: > This patch resolves: > > https://bugzilla.redhat.com/show_bug.cgi?id=889319 > > > Of course we also need to continue working on systems with older > kernels, so that one bit of code is compiled conditionally. The one > time this could cause problem

[libvirt] [PATCH 1/2] util: fix functions that retrieve SRIOV VF info

2012-12-20 Thread Laine Stump
This patch resolves: https://bugzilla.redhat.com/show_bug.cgi?id=889319 When assigning an SRIOV virtual function to a guest using "intelligent PCI passthrough" (, which sets the MAC address and vlan tag of the VF before passing its info to qemu), libvirt first learns the current MAC address and

[libvirt] [PATCH 2/2] util: add missing error log messages when failing to get netlink VFINFO

2012-12-20 Thread Laine Stump
This patch fixes the lack of error messages when libvirt fails to find VFINFO in a returned netlinke response message. https://bugzilla.redhat.com/show_bug.cgi?id=827519#c10 is an example of the error message that was previously logged when the IFLA_VFINFO_LIST object was missing from the netlink

[libvirt] [PATCH 0/2] account for change in netlink kernel ABI

2012-12-20 Thread Laine Stump
The first of these two patches changes libvirt to account for a change in netlink's kernel ABI that happened upstream several months ago. The second patch adds in error logs to the functions that failed after the kernel change. Laine Stump (2): util: fix functions that retrieve SRIOV VF info u

Re: [libvirt] [PATCH 1/1] Add sysinfo data and enable virSysinfoRead test case for POWER

2012-12-20 Thread Eric Blake
On 12/20/2012 03:46 AM, Daniel P. Berrange wrote: > On Thu, Dec 20, 2012 at 10:31:05AM +0800, Li Zhang wrote: >> From: Li Zhang >> >> This patch is to enable virSysinfoRead test case for POWER, >> and provide sysinfo data on POWER. > > Excellent, thanks for improving the tests ! > >> >> Signed-o

Re: [libvirt] Release of libvirt-1.0.1

2012-12-20 Thread Eric Blake
[trimming libvirt-announce from cc] On 12/19/2012 04:03 PM, Jason Helfman wrote: > I will be committing this to the FreeBSD portstree this week. One item that > has held this up for me was repeated build failures. > > In looking through the code, I found out that perl was introduced as a > build

[libvirt] [PATCH] security: fix #endif comment in security_stack.h

2012-12-20 Thread Ján Tomko
--- Pushed under the trivial rule. --- src/security/security_stack.h |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/src/security/security_stack.h b/src/security/security_stack.h index 4ba55f7..b38f9a9 100644 --- a/src/security/security_stack.h +++ b/src/security/securit

Re: [libvirt] [PATCH 3/5] conf: Don't format cputune element when not needed

2012-12-20 Thread Martin Kletzander
On 12/18/2012 12:39 PM, Osier Yang wrote: > On 2012年12月18日 19:20, Martin Kletzander wrote: >> On 12/18/2012 04:01 AM, Osier Yang wrote: >>> On 2012年12月17日 23:17, Martin Kletzander wrote: Commit 60b176c3d0f0d5037acfa5e27c7753f657833a0b introduced a bug that when editing an XML with cputune

[libvirt] Coverity scan

2012-12-20 Thread John Ferlan
First allow me to introduce myself - I'm John Ferlan a new Red Hat employee (3 weeks). I came from the closed world at HP where for the last 7 years I worked in a group developing/supporting HP's Integrity Virtual Machine software prior to it being outsourced to India this past May. I primaril

Re: [libvirt] [PATCH] conf: cpu: Fix to escape cpu model, vendor_id and vendor

2012-12-20 Thread Daniel P. Berrange
On Thu, Dec 20, 2012 at 05:33:20PM +0900, Ken ICHIKAWA wrote: > This patch fixes a problem that encoded xml special charas > of cpu model, vendor_id and vendor are saved as decoded xml > special charas. > > If I define model name including encoded xml special charas > in domain XML like below: >

Re: [libvirt] [PATCH 1/1] Add sysinfo data and enable virSysinfoRead test case for POWER

2012-12-20 Thread Daniel P. Berrange
On Thu, Dec 20, 2012 at 10:31:05AM +0800, Li Zhang wrote: > From: Li Zhang > > This patch is to enable virSysinfoRead test case for POWER, > and provide sysinfo data on POWER. Excellent, thanks for improving the tests ! > > Signed-off-by: Li Zhang > Reviewed-by: Viktor Mihajlovski > > --- >

Re: [libvirt] [PATCH 1/6] Set std VGA model as default model for ppc64.

2012-12-20 Thread Daniel P. Berrange
On Thu, Dec 20, 2012 at 02:02:22PM +0800, Li Zhang wrote: > From: Li Zhang > > Cirrus VGA model is not supported on ppc64 currently. > It needs to set std VGA model as the default model. > > Signed-off-by: Li Zhang > --- > src/conf/domain_conf.c |2 ++ > 1 file changed, 2 insertions(+) >

Re: [libvirt] [PATCH 6/6] Use help string "-device driver, " when getting additional caps.

2012-12-20 Thread Daniel P. Berrange
On Thu, Dec 20, 2012 at 02:02:27PM +0800, Li Zhang wrote: > From: Li Zhang > > QEMU of upstream and PPC64 can support "-device driver,?", > But the help string is "-device driver,help", > > This patch is to replace "-device driver,?" with "-device driver,". > > Signed-off-by: Li Zhang > --- >

Re: [libvirt] [PATCH 5/6] Set the default machine as pseries for PPC64

2012-12-20 Thread Daniel P. Berrange
On Thu, Dec 20, 2012 at 02:02:26PM +0800, Li Zhang wrote: > From: Li Zhang > > pseries machine type is preferred for ppc64. > This patch is to set pseries as the default machine type. > > Signed-off-by: Li Zhang > --- > src/conf/capabilities.c |6 ++ > 1 file changed, 6 insertions(+) >

Re: [libvirt] [PATCH 4/6] Support all backend serial devices for pSeries guest

2012-12-20 Thread Daniel P. Berrange
On Thu, Dec 20, 2012 at 02:02:25PM +0800, Li Zhang wrote: > From: Li Zhang > > Currently, it only considers PTY backend serial devices for pseries. > It need to support all kinds of serial devices. > > This patch is to fix the problem which is that it doesn't work > when specifying source type a

Re: [libvirt] [PATCH 3/6] Remove QEMU_CAPS_NO_ACPI capability for non-x86 platform

2012-12-20 Thread Daniel P. Berrange
On Thu, Dec 20, 2012 at 02:02:24PM +0800, Li Zhang wrote: > From: Li Zhang > > ACPI is only supported on x86 platform, PPC can't support it. > So QEMU_CAPS_NO_ACPI shouldn't be set. > > This patch is to remove QEMU_CAPS_NO_ACPI capability for > non-x86 platform. > > Signed-off-by: Li Zhang > -

Re: [libvirt] [PATCH 2/6] Use -machine option for PPC64

2012-12-20 Thread Daniel P. Berrange
On Thu, Dec 20, 2012 at 02:02:23PM +0800, Li Zhang wrote: > From: Li Zhang > > On PPC64 platform, it sets USB option in -machine option. It is > set as the following: > -machine pseries,usb=off > > This will disable USB, which avoids creating one USB controller > implicitly in the platform's i

[libvirt] [PATCH] conf: cpu: Fix to escape cpu model, vendor_id and vendor

2012-12-20 Thread Ken ICHIKAWA
This patch fixes a problem that encoded xml special charas of cpu model, vendor_id and vendor are saved as decoded xml special charas. If I define model name including encoded xml special charas in domain XML like below: >< domain xml definition file is saved as >< After