Re: [libvirt] [PATCHv2] bhyve: domainCreateXML

2014-04-20 Thread Roman Bogorodskiy
Roman Bogorodskiy wrote: I'm going to push that with my comments squashed in, if no objections. Pushed; sorry for the delay. Roman Bogorodskiy pgpxOZ4k1fRmz.pgp Description: PGP signature -- libvir-list mailing list libvir-list@redhat.com https://www.redhat.com/mailman/listinfo/libvir-list

[libvirt] [PATCH 1/2] util: introduce virDirRead wrapper for readdir

2014-04-20 Thread Natanael Copa
Introduce a wrapper for readdir. This helps us make sure that we always set errno before calling readdir and it will make sure errors are properly logged. Signed-off-by: Natanael Copa nc...@alpinelinux.org --- src/util/virfile.c | 14 ++ src/util/virfile.h | 3 +++ 2 files changed,

[libvirt] [PATCH 2/2] nodeinfo: use virDirRead API

2014-04-20 Thread Natanael Copa
This makes sure that errno is reset before readdir is called, even if the loop does a 'continue'. This fixes issue with musl libc which sets errno on sscanf. The following 'continue' makes the errno be set before calling readdir. Signed-off-by: Natanael Copa nc...@alpinelinux.org ---

[libvirt] [PATCH v2] bhyve: implement PCI address allocation

2014-04-20 Thread Roman Bogorodskiy
Changes from v1: - Reserve slot 1 for LPC PCI-ISA bridge, used by console device - Respect addresses provided by user in domain xml file - Fix tests so 'make check' passes Roman Bogorodskiy (1): bhyve: implement PCI address allocation po/POTFILES.in |

[libvirt] [PATCH v2] bhyve: implement PCI address allocation

2014-04-20 Thread Roman Bogorodskiy
Automatically allocate PCI addresses for devices instead of hardcoding them in the driver code. The current allocation schema is to dedicate an entire slot for each devices. Also, allow having arbitrary number of devices. --- po/POTFILES.in | 1 +

Re: [libvirt] [PATCHv2 0/6] Utility functions for storing uninstalled location

2014-04-20 Thread Nehal J Wani
Ping! Once this gets through, the custom leases API will get through, and then the virNetworkGetDHCPLeases and virNetworkGetDHCPLeasesForMAC APIs will be introduced. On Tue, Mar 25, 2014 at 1:53 PM, Nehal J Wani nehaljw.k...@gmail.com wrote: When libvirtd is run from a build directory without

[libvirt] [PATCH] Fix typos in src/*

2014-04-20 Thread Nehal J Wani
Fix minor typos in source comments --- src/esx/esx_driver.c|2 +- src/esx/esx_storage_backend_iscsi.c |2 +- src/esx/esx_storage_driver.c|2 +- src/interface/interface_backend_netcf.c |2 +- src/interface/interface_backend_udev.c |2 +-

[libvirt] [PATCH 00/18] Get rid of virStorageFileMetadata

2014-04-20 Thread Peter Krempa
Peter Krempa (18): qemu: unexport qemuDiskChainCheckBroken util: storagefile: Always store raw backing name in the metadata util: storage: Don't force path canonicalization when loading metadata util: storage: Remove obsolete argument virStorageFileGetMetadataInternal util: storage:

[libvirt] [PATCH 09/18] util: virstoragefile: Don't use backingStore directly

2014-04-20 Thread Peter Krempa
As a temporary step to allow killing of the backingStore field of struct virStorageFileMetadata the recursive metadata retrieval function will be converted not to use the field in the lookup process. --- src/util/virstoragefile.c | 11 --- 1 file changed, 8 insertions(+), 3 deletions(-)

[libvirt] [PATCH 05/18] util: storage: Move checking of the actual backing image to the worker

2014-04-20 Thread Peter Krempa
Move the code checking the presence of the backing file to the recursive worker function instead of the metadata parser. The recursive worker will later be changed to parse more than just local files and this change will help the separation. --- src/util/virstoragefile.c | 63

[libvirt] [PATCH 06/18] storage: util: Clean up arguments of virStorageFileGetMetadataInternal

2014-04-20 Thread Peter Krempa
Avoid passing lot of arguments into guts of metadata retrieval to fill the actual structure. Temporarily fill the structure before passing it down to the actual metadata extractor. This will later help the inversion of the steps taken to extract the metadata so that this function can be fully

[libvirt] [PATCH 17/18] util: virstoragefile: Don't mangle data stored about directories

2014-04-20 Thread Peter Krempa
Don't remove detected metadata about directory based storage volumes. --- src/util/virstoragefile.c | 7 ++- tests/virstoragetest.c| 3 +++ 2 files changed, 5 insertions(+), 5 deletions(-) diff --git a/src/util/virstoragefile.c b/src/util/virstoragefile.c index 37cda8e..8d5ef2f 100644

[libvirt] [PATCH 16/18] storage: Move disk-backingChain to the recursive disk-src.backingStore

2014-04-20 Thread Peter Krempa
Switch over to storing of the backing chain as a recursive virStorageSource structure. This is a string based move. Currently the first element will be present twice in the backing chain as currently the retrieval function stores the parent in the newly detected chain. This will be fixed later.

[libvirt] [PATCH 03/18] util: storage: Don't force path canonicalization when loading metadata

2014-04-20 Thread Peter Krempa
Avoid breaking gluster volumes that don't have local representation. Use the provided name when canonicalization fails. Broken by commit 79f11b35 Fixes: $ virsh pool-start glusterpool error: Failed to start pool glusterpool error: unable to resolve 'asdf': No such file or directory ---

[libvirt] [PATCH 13/18] maint: Switch over from struct virStorageFileMetadata to virStorageSource

2014-04-20 Thread Peter Krempa
Replace the old structure with the new one. This change is a trivial name change operation (along with change of the freeing function). --- src/conf/domain_conf.c| 4 +-- src/conf/domain_conf.h| 2 +- src/qemu/qemu_domain.c| 2 +-

[libvirt] [PATCH 15/18] util: virstoragefile: Rename backingMeta to backingStore

2014-04-20 Thread Peter Krempa
To conform with the naming of the planed XML output rename the metadata variable name. s/backingMeta/backingStore/g --- src/conf/domain_conf.c| 6 +++--- src/qemu/qemu_driver.c| 8 src/util/virstoragefile.c | 12 +-- src/util/virstoragefile.h | 2 +-

[libvirt] [PATCH 12/18] util: storagefile: Add fields from virStorageMetadata to virStorageSource

2014-04-20 Thread Peter Krempa
Add the required fields that are missing from the new structure that will allow us to switch the storage file metadata code entirely to the new structure. Add relPath and relDir and the raw backing store name. Also allow creating linked lists of virStorageSourcePtrs to express backing chains. ---

[libvirt] [PATCH 07/18] util: storage: Rename path to relPath in virStorageFileMetadata

2014-04-20 Thread Peter Krempa
To allow future change of virStorageFileMetadata to virStorageSource we need to store a full path in the path variable as rest of the code expects it to be a full path. Rename the path field to relPath to keep tracking the info but allowing a real path field. --- src/util/virstoragefile.c | 22

[libvirt] [PATCH 18/18] util: storage: Invert the way recursive metadata retrieval works

2014-04-20 Thread Peter Krempa
To avoid having the root of a backing chain present twice in the list we need to invert the working of virStorageFileGetMetadataRecurse. Until now the recursive worker created a new backing chain element from the name and other information passed as arguments. This required us to pass the data of

[libvirt] [PATCH 11/18] util: storagefile: Add function to free a virStorageSourcePrt

2014-04-20 Thread Peter Krempa
Add a free function as some parts of the code will allocate the structure. --- src/libvirt_private.syms | 1 + src/util/virstoragefile.c | 11 +++ src/util/virstoragefile.h | 1 + 3 files changed, 13 insertions(+) diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms index

[libvirt] [PATCH 01/18] qemu: unexport qemuDiskChainCheckBroken

2014-04-20 Thread Peter Krempa
The function isn't used in any other source file. Move it so that it doesn't need a declaration. --- src/qemu/qemu_domain.c | 44 ++-- src/qemu/qemu_domain.h | 2 -- 2 files changed, 22 insertions(+), 24 deletions(-) diff --git a/src/qemu/qemu_domain.c

[libvirt] [PATCH 08/18] util: storagefile: Rename canonPath to path in virStorageFileMetadata

2014-04-20 Thread Peter Krempa
As for the previous patch, this change is needed to achieve compatibility with all the existing code, where we expect a fully qualified path of local files to be present. --- src/util/virstoragefile.c | 18 +++ src/util/virstoragefile.h | 2 +- tests/virstoragetest.c| 56

[libvirt] [PATCH 14/18] util: virstorage: Kill struct virStorageFileMetadata

2014-04-20 Thread Peter Krempa
Remove the now unused pieces of the structure. --- src/libvirt_private.syms | 1 - src/util/virstoragefile.c | 23 --- src/util/virstoragefile.h | 37 - 3 files changed, 61 deletions(-) diff --git a/src/libvirt_private.syms

[libvirt] [PATCH 02/18] util: storagefile: Always store raw backing name in the metadata

2014-04-20 Thread Peter Krempa
Don't use the backingStoreRaw as a indication of broken chains. Fill it always and tweak the broken image chain detector to avoid changing the semantics. The new semantics to detect a broken chain is the presence of string in backingStoreRaw but the lack of the backing chain metadata structure in

[libvirt] [PATCH 04/18] util: storage: Remove obsolete argument virStorageFileGetMetadataInternal

2014-04-20 Thread Peter Krempa
As we already pass the whole structure down the call path there's no need to return some stuff in a separate argument. Remove the argument and call tweakers to avoid breaking semantics. virStorageFileGetMetadataFromBuf will be refactored later along with the storage driver. ---

[libvirt] Fwd: libvirt-php: 0.4.8 tag is missing

2014-04-20 Thread Doug Goldstein
Hi Michal, I sent the below message to the libvirt mailing list back on June 11th 2013 but never received a response from anyone. I just checked and the tag is still missing. Can you possibly push this tag as it looks like you are maintaining this project now. Thank you. -- Doug Goldstein

Re: [libvirt] libvirt-libxl driver defaulting to tap disk and not working (ubuntu 12.10 + xen 4.5 + libvirt 1.2.3 + openstack)

2014-04-20 Thread Tian, Shuangtai
Hi ,John , You are right , this problem is solved when use the default driver, But I found the blktap in xen4.5 was not a module, it seems a library, am I right? And the VM also cannot start, I am not familiar whit xen, did you ever meet the below error, Thanks for helping me so much! 328

Re: [libvirt] libvirt-libxl driver defaulting to tap disk and not working (ubuntu 12.10 + xen 4.5 + libvirt 1.2.3 + openstack)

2014-04-20 Thread Tian, Shuangtai
Hi, Jim The blktap seems not a module in xen 4.5, when I tried the load it , can not find the module, is there something wrong I did? BTW ,I compiled the xen4.5 by myself. Thanks ! -Original Message- From: Jim Fehlig [mailto:jfeh...@suse.com] Sent: Friday, April 18, 2014 11:52 PM To:

Re: [libvirt] [PATCH] virsh: Make secret's usage can be modified if the usage isn't used

2014-04-20 Thread Li, Yang
Ping! When a secret's usage is specified, for example: secret ephemeral='no' private='no' uuid540c56d1-f4b3-5031-b76d-33e99e9b5c64/uuid usage type='volume' volume/tmp/test/volume /usage /secret If another volume '/tmp/test1' isn't used, the current secret's usage can bo

Re: [libvirt] [PATCH] virsh: Separate 'create'/'modify' message for secret-define

2014-04-20 Thread Li, Yang
On Fri, Apr 18, 2014 at 12:20:26 +0200, Martin Kletzander wrote: On Fri, Apr 18, 2014 at 04:27:10AM -0400, Li Yang wrote: The current message of secret-define always be: Secret 09a9736f-eedb-449c-9983-80d0ab67393f created even you just modify the secret, perhaps this may puzzle uses.