This function used to set a alias name for RNG device, usage just
like other named qemuAssignDevice***Alias functions.
Signed-off-by: Luyao Huang
---
src/qemu/qemu_command.c | 25 -
src/qemu/qemu_command.h | 1 +
2 files changed, 25 insertions(+), 1 deletion(-)
diff --g
rename qemuBuildRNGDeviceArgs to qemuBuildRNGDevStr, we need this function
to build a cmdline.
Signed-off-by: Luyao Huang
---
src/qemu/qemu_command.c | 33 -
src/qemu/qemu_command.h | 4
2 files changed, 20 insertions(+), 17 deletions(-)
diff --git a/src/qe
Signed-off-by: Luyao Huang
---
src/conf/domain_audit.c | 2 +-
src/conf/domain_audit.h | 7 +++
src/libvirt_private.syms | 1 +
3 files changed, 9 insertions(+), 1 deletion(-)
diff --git a/src/conf/domain_audit.c b/src/conf/domain_audit.c
index fcf9df7..159ebf5 100644
--- a/src/conf/domain
We need a new function to build a RNG device object, and need a
function to build a props which will be used in qemuMonitorJSONAddObject.
Signed-off-by: Luyao Huang
---
src/qemu/qemu_monitor_json.c | 58
src/qemu/qemu_monitor_json.h | 5
2 files
the 3 functions are:
virDomainRNGInsert: Insert a RNG device to vm->def.
virDomainRNGRemove: remove a RNG device in vm->def.
virDomainRNGFind: find a RNG device in vm->def.
Signed-off-by: Luyao Huang
---
src/conf/domain_conf.c | 44
src/conf/domain_co
We have enough patches for hotunplug RNG device, maybe we can
implement live hotunplug of a RNG device.
Signed-off-by: Luyao Huang
---
src/qemu/qemu_driver.c | 4 +-
src/qemu/qemu_hotplug.c | 97 -
src/qemu/qemu_hotplug.h | 4 +-
3 files changed
Signed-off-by: Luyao Huang
---
src/libvirt_private.syms | 5 +
1 file changed, 5 insertions(+)
diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms
index aa776b4..deab4cf 100644
--- a/src/libvirt_private.syms
+++ b/src/libvirt_private.syms
@@ -375,7 +375,12 @@ virDomainPMSuspende
These 2 functions just do some basic check and then call
qemuMonitorJSONAttachRNGDev and qemuMonitorDelObject to
help us.
Signed-off-by: Luyao Huang
---
src/qemu/qemu_monitor.c | 43 +++
src/qemu/qemu_monitor.h | 7 +++
2 files changed, 50 insertions(
We didn't set a id when we build RNG device cmdline before.
Give a id to every RNG device and we can hotunplug it via
QMP cmd device_del.
Signed-off-by: Luyao Huang
---
src/qemu/qemu_command.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/src/qemu/qemu_command.
We have enough patches for hotplug RNG device, maybe we can
implement live hotplug of a RNG device.
Signed-off-by: Luyao Huang
---
src/qemu/qemu_driver.c | 8 -
src/qemu/qemu_hotplug.c | 92 +
src/qemu/qemu_hotplug.h | 3 ++
3 files changed,
qemu side functions, call virDomainRNGInsert and virDomainRNGRemove
to help us.
Signed-off-by: Luyao Huang
---
src/qemu/qemu_hotplug.c | 23 +++
src/qemu/qemu_hotplug.h | 7 +++
2 files changed, 30 insertions(+)
diff --git a/src/qemu/qemu_hotplug.c b/src/qemu/qemu_hotpl
virDomainRNGEquals is a func which check if two rng device
are the same.
Signed-off-by: Luyao Huang
---
src/conf/domain_conf.c | 34 ++
src/conf/domain_conf.h | 3 +++
2 files changed, 37 insertions(+)
diff --git a/src/conf/domain_conf.c b/src/conf/domain_conf.c
qemu already support hot-plug and hot-unplug RNG device.
These patch will make libvirt support hot-plug/unplug RNG device for qemu
driver.
Luyao Huang (12):
qemu: introduce a new func qemuAssignDeviceRNGAlias for rng device
qemu: rename qemuBuildRNGDeviceArgs to qemuBuildRNGDevStr and change
[please, do not top-post on technical lists. And, can you teach your
mailer to wrap long lines. Thanks.]
At Fri, 2 Jan 2015 15:36:19 +,
Narayanan, Krishnaprasad wrote:
>
> Hi Martin,
>
> Thanks for your reply. Please correct me if I am wrong here.
>
> The latest version of libvirt genera
Hello all,
I am using libvirt version 1.1.1 on one of the nodes which has several VMs.
When I used virsh dommemstat , I am getting the following flags:
actual, swap_in and rss. I am not able to get the unused memory that is
associated with the virtual machine.
Can I kindly know is there a docu
Hi Martin,
Thanks for your reply. Please correct me if I am wrong here.
The latest version of libvirt generates the following flags with respect to
memory
a) swap_in
b) swap_out
c) major_fault
d) minor_fault
e) unused
f) available
g) actual_balloon
h) rss
I assumed that the "unused" flag repr
On Wed, Dec 31, 2014 at 01:36:21AM +, Narayanan, Krishnaprasad wrote:
Hallo all,
I am using libvirt version 1.1.1 on one of the nodes which has several VMs. When I executed the
command, virsh dommemstat , I am getting the following flags as output:
actual, swap_in and rss. The API does no
17 matches
Mail list logo