[libvirt] [PATCH] qemu: Allow spaces in disk serial

2015-02-23 Thread Michal Privoznik
There's been a bug report appearing on the qemu-devel list, that libvirt is unable to pass spaces in disk serial number [1]. Not only our RNG schema forbids that, the code is not prepared either. However, with a bit of escaping (if needed) we can allow spaces there. 1:

Re: [libvirt] [PATCH] qemu: fix ifindex array reported to systemd

2015-02-23 Thread Daniel P. Berrange
On Fri, Feb 20, 2015 at 04:05:22PM -0500, Laine Stump wrote: Commit f7afeddc added code to report to systemd an array of interface indexes for all tap devices used by a guest. Unfortunately it not only didn't add code to report the ifindexes for macvtap interfaces (interface type='direct') or

[libvirt] Plan for next release

2015-02-23 Thread Daniel Veillard
Oops, Feb is really short and I got caught, I think if we want a release by beginning of March, i.e. next week we need to enter freeze ASAP. So I'm suggesting to start the freeze tomorrow, for a release on Monday if everything goes well ! Hope this suits everybody, thanks, Daniel --

[libvirt] [PATCH v2 1/2] Support virDomainGetIOThreadsInfo and virDomainIOThreadsInfoFree

2015-02-23 Thread John Ferlan
Add support for the libvirt_virDomainGetIOThreadsInfo method. This code mostly follows the libvirt_virDomainGetVcpuPinInfo method, but also takes some from the libvirt_virNodeGetCPUMap method with respect to building the cpumap into the returned tuple rather than two separate tuples which vcpu

[libvirt] [PATCH v2 2/2] Support virDomainSetIOThreads

2015-02-23 Thread John Ferlan
Support the libvirt_virDomainSetIOThreads method using code that mimics the existing libvirt_virDomainPinVcpuFlags method The following is a sample session assuming guest 'iothr-gst' has IOThreads configured (it's currently running, too) import libvirt con=libvirt.open(qemu:///system)

[libvirt] [PATCH 3/3] qemu: Pass file descriptor when using TPM passthrough

2015-02-23 Thread Stefan Berger
Pass the TPM file descriptor to QEMU via command line. Instead of passing /dev/tpm0 we now pass /dev/fdset/10 and the additional parameters -add-fd set=10,fd=20. This addresses the use case when QEMU is started with non-root privileges and QEMU cannot open /dev/tpm0 for example. Signed-off-by:

[libvirt] [PATCH 1/3] utils: Implement virCommandPassFDGetFDIndex

2015-02-23 Thread Stefan Berger
Implement virCommandPassFDGetFDIndex to determine the index a given file descriptor will have when passed to the child process. When this function is called, a flag is set to prevent the reordering of the file descriptors. Signed-off-by: Stefan Berger stef...@linux.vnet.ibm.com ---

[libvirt] [PATCH 2/3] qemu: Move TPM command line build code into own function

2015-02-23 Thread Stefan Berger
Move the TPM command line build code into its own function. Signed-off-by: Stefan Berger stef...@linux.vnet.ibm.com --- src/qemu/qemu_command.c | 37 + 1 file changed, 25 insertions(+), 12 deletions(-) diff --git a/src/qemu/qemu_command.c

[libvirt] [PATCH] network_conf: Forbid commas in DNS TXT

2015-02-23 Thread Michal Privoznik
https://bugzilla.redhat.com/show_bug.cgi?id=1151942 While the restriction doesn't have origin in any RFC, it matters to us while constructing the dnsmasq config file (or command line previously). For better picture, this is how the corresponding part of network XML look like: dns forwarder

[libvirt] [PATCH v2 0/2] Python bindings for IOThreads

2015-02-23 Thread John Ferlan
v1 here: http://www.redhat.com/archives/libvir-list/2015-February/msg00684.html Changes in v2: * Return an empty list when there are no IOThreads found * Fix alloc/cleanup logic to match review comments * Used PyObject *error = NULL like the GetCPUStats code in order to return either

Re: [libvirt] [PATCH v3 0/9] qemu: Add quorum support to libvirt

2015-02-23 Thread Matthias Gatto
On Tue, Feb 10, 2015 at 4:43 PM, Matthias Gatto matthias.ga...@outscale.com wrote: The purpose of these patches is to introduce quorum for libvirt I've try to follow this proposal: http://www.redhat.com/archives/libvir-list/2014-May/msg00533.html This feature ask for 6 task: 1) Allow a

[libvirt] [PATCH] SRIOV NIC offload feature discovery

2015-02-23 Thread James Chapman
Adding functionality to libvirt that will allow it query the ethtool interface for the availability of certain NIC HW offload features Here is an example of the feature XML definition: device namenet_eth4_90_e2_ba_5e_a5_45/name

Re: [libvirt] [PATCH] SRIOV NIC offload feature discovery

2015-02-23 Thread Chapman, James P
Thanks for your feedback folks, v2 to follow. Thanks James -Original Message- From: Daniel P. Berrange [mailto:berra...@redhat.com] Sent: Monday, February 16, 2015 11:47 AM To: Chapman, James P Cc: libvir-list@redhat.com Subject: Re: [libvirt] [PATCH] SRIOV NIC offload feature

[libvirt] [PATCHv2] SRIOV NIC offload feature discovery

2015-02-23 Thread James Chapman
Adding functionality to libvirt that will allow it query the ethtool interface for the availability of certain NIC HW offload features Here is an example of the feature XML definition: device namenet_eth4_90_e2_ba_5e_a5_45/name

Re: [libvirt] [PATCH 1/5] Remove bootloader option from QEMU

2015-02-23 Thread John Ferlan
On 02/18/2015 11:39 AM, Ján Tomko wrote: It was only supported by xenner, for which we removed support in commit de9be0a. Remove the code generating this command line option, refuse to parse it and delete the outdated tests. https://bugzilla.redhat.com/show_bug.cgi?id=1176050 ---

Re: [libvirt] [PATCH 2/5] Remove code handling the QEMU_CAPS_DOMID capability

2015-02-23 Thread John Ferlan
On 02/18/2015 11:39 AM, Ján Tomko wrote: This option is xenner-only, and we dropped support for xenner in commit de9be0a. --- src/qemu/qemu_command.c | 5 + tests/qemuxml2argvtest.c | 5 + tests/qemuxmlnstest.c| 5 + 3 files changed, 3 insertions(+), 12 deletions(-)

[libvirt] [PATCH 3/3 v3] Add midonet virtual port type support to qemu

2015-02-23 Thread Antoni Segura Puimedon
Use the utilities introduced in the previous patches so the qemu driver is able to create tap devices that are bound (and unbound on domain destroyal) to Midonet virtual ports. Signed-off-by: Antoni Segura Puimedon toni+libv...@midokura.com --- src/conf/domain_conf.h | 1 +

[libvirt] [PATCH 1/3 v3] utilities for supporting midonet virtualports

2015-02-23 Thread Antoni Segura Puimedon
Adds the port type definitions and methods that will be used to bind interfaces to the Midonet virtual ports. virtnetdevmidonet.c adds the way to bind and unbind the ports by calling into the Midonet Host Agent control command line (installed with the midolman package). Signed-off-by: Antoni

[libvirt] [PATCH v3] Add support for Midonet virtual ports

2015-02-23 Thread Antoni Segura Puimedon
Up until now, to plug VMs into the Midonet virtual networks it was necessary to use the 'last resort' 'ethernet' type. That implied having the domain tainted and having to deal witht the tap lifecycle outside of libvirt/VM lifecycle. With the patches I submit, a new virtualport type will be

[libvirt] [PATCH 2/3 v3] Schema and docs for the midonet virtualport type

2015-02-23 Thread Antoni Segura Puimedon
Midonet is an opensource virtual networking that over lays the IP network between hypervisors. Currently, such networks can be made with the openvswitch virtualport type. This patch, defines the schema and documentation that will serve as basis for the follow up patches that will add support to

Re: [libvirt] [PATCH] Add ability to set rlimits at container boot

2015-02-23 Thread Richard Weinberger
Ryan, Am 23.02.2015 um 18:37 schrieb Ryan Cleere: Richard, I have to disagree that it should require idmap. It is true that without idmap the container can freely set it's own rlimits, but I believe this functionality could be useful to containers that don't run /sbin/init. What I mean

Re: [libvirt] [PATCH] qemu: bulk stats: implement (cpu) tune group.

2015-02-23 Thread John Ferlan
On 02/11/2015 09:22 AM, Francesco Romani wrote: Management applications, like oVirt, may need to setup cpu quota limits to enforce QoS for VMs. For this purpose, management applications also need to check how VMs are behaving with respect to CPU quota. This data is avaialble using the

Re: [libvirt] [PATCH 0/3] s390: rework and prevent default usb controller

2015-02-23 Thread John Ferlan
On 02/18/2015 10:44 AM, Stefan Zimmermann wrote: Stefan Zimmermann (3): Prevent default creation of usb controller on s390 and s390x Adjust s390 test cases by removing usb device instances Rework s390 architecture checking src/qemu/qemu_command.c

[libvirt] [PATCH] qemu: don't fill in nicindexes if unneeded

2015-02-23 Thread Laine Stump
The patch I posted failed to pass make check for two reasons: 1) There are valid use cases when the interface object is type='ethernet' but has no ifname. Apparently if you provide an ifup script name for -netdev but don't specify a tap device name, qemu will create a tap device for you, and in

Re: [libvirt] [PATCHv4 02/10] conf: support backend domain name in disk and network devices

2015-02-23 Thread Eric Blake
On 02/19/2015 08:22 PM, Marek Marczykowski-Górecki wrote: From: Marek Marczykowski marma...@invisiblethingslab.com At least Xen supports backend drivers in another domain (aka driver domain). This patch introduces XML config option for such setting as 'domain' attribute of 'source' element.

Re: [libvirt] SR-IOV with libvirt

2015-02-23 Thread Laine Stump
On 02/20/2015 05:33 PM, Florin Stingaciu wrote: Hello, For the last little while I've been trying to configure a VM with a passthrough interface using SR-IOV. I've managed to configure SR-IOV on the hypervisor correctly. I'm working with a Mellanox ConnectX3 card with two infiniband ports

Re: [libvirt] Exact meaning of nativeMode attribute in vlan tags

2015-02-23 Thread Robson, James
To clarify the behaviour of open vswitch: With either of the native modes selected, a packet that comes in to the switch without a vlan header will be placed in the native vlan and the header added before the packet is forwarded. With nativeMode='tagged', a packet in the native vlan will be sent

Re: [libvirt] [PATCH] qemu: Allow spaces in disk serial

2015-02-23 Thread Eric Blake
On 02/23/2015 04:39 AM, Michal Privoznik wrote: There's been a bug report appearing on the qemu-devel list, that libvirt is unable to pass spaces in disk serial number [1]. Not only our RNG schema forbids that, the code is not prepared either. However, with a bit of escaping (if needed) we can

Re: [libvirt] [libvirt-python PATCH 1/2] Support virDomainGetIOThreadsInfo and virDomainIOThreadsInfoFree

2015-02-23 Thread Eric Blake
On 02/20/2015 12:15 PM, John Ferlan wrote: ... Obviously it wasn't very clear to me how the PyList* interactions work exactly w/r/t Py_XDECREF - I was trying to copy other uses, but didn't do a great job at that. I was just happy that I got results that worked Don't feel too bad; we have

Re: [libvirt] [PATCHv2] Clarify behavior or virDomainDetachDevice

2015-02-23 Thread Eric Blake
On 02/20/2015 07:56 AM, Ján Tomko wrote: Document that a complete device definition should be used and a partial match can lead to the device being detached. https://bugzilla.redhat.com/show_bug.cgi?id=872028 --- src/libvirt-domain.c | 14 ++ tools/virsh.pod | 9

Re: [libvirt] [PATCH] Clarify behavior or virDomainDetachDevice

2015-02-23 Thread Eric Blake
On 02/20/2015 04:39 AM, Ján Tomko wrote: Doucment that not all attributes are used for matching. s/Doucment/Document/ https://bugzilla.redhat.com/show_bug.cgi?id=872028 --- src/libvirt-domain.c | 5 + tools/virsh.pod | 4 +++- 2 files changed, 8 insertions(+), 1 deletion(-)

Re: [libvirt] [PATCH 1/3 v3] utilities for supporting midonet virtualports

2015-02-23 Thread Antoni Segura Puimedon
On Tue, Feb 24, 2015 at 2:20 AM, YAMAMOTO Takashi yamam...@valinux.co.jp wrote: Adds the port type definitions and methods that will be used to bind interfaces to the Midonet virtual ports. virtnetdevmidonet.c adds the way to bind and unbind the ports by calling into the Midonet Host

Re: [libvirt] [PATCH 1/3 v3] utilities for supporting midonet virtualports

2015-02-23 Thread Laine Stump
On 02/23/2015 08:48 PM, YAMAMOTO Takashi wrote: On Tue, Feb 24, 2015 at 2:20 AM, YAMAMOTO Takashi yamam...@valinux.co.jp wrote: Adds the port type definitions and methods that will be used to bind interfaces to the Midonet virtual ports. virtnetdevmidonet.c adds the way to bind and unbind

Re: [libvirt] [PATCH] qemu: don't fill in nicindexes if unneeded

2015-02-23 Thread John Ferlan
On 02/23/2015 03:12 PM, Laine Stump wrote: The patch I posted failed to pass make check for two reasons: 1) There are valid use cases when the interface object is type='ethernet' but has no ifname. Apparently if you provide an ifup script name for -netdev but don't specify a tap device

Re: [libvirt] [PATCH 1/3 v3] utilities for supporting midonet virtualports

2015-02-23 Thread YAMAMOTO Takashi
On Tue, Feb 24, 2015 at 2:20 AM, YAMAMOTO Takashi yamam...@valinux.co.jp wrote: Adds the port type definitions and methods that will be used to bind interfaces to the Midonet virtual ports. virtnetdevmidonet.c adds the way to bind and unbind the ports by calling into the Midonet Host

Re: [libvirt] [PATCH 1/3 v3] utilities for supporting midonet virtualports

2015-02-23 Thread YAMAMOTO Takashi
Adds the port type definitions and methods that will be used to bind interfaces to the Midonet virtual ports. virtnetdevmidonet.c adds the way to bind and unbind the ports by calling into the Midonet Host Agent control command line (installed with the midolman package). Signed-off-by:

Re: [libvirt] [PATCH 3/5] Make -boot arg generation more readable

2015-02-23 Thread John Ferlan
On 02/18/2015 11:39 AM, Ján Tomko wrote: If we combine the boot order on the command line with other boot options, we prepend order= in front of it. Instead of checking if the number of added arguments is between 0 and 2, separate the buffers for boot order and options and prepend boot

Re: [libvirt] [PATCH 5/5] Use virBufferTrim when generating boot options

2015-02-23 Thread John Ferlan
On 02/18/2015 11:39 AM, Ján Tomko wrote: Instead of tracking the number of added parameters, add a comma at the end of each one unconditionally and trim the trailing one at the end. --- src/qemu/qemu_command.c | 27 --- 1 file changed, 8 insertions(+), 19

Re: [libvirt] [PATCH 4/5] Rename boot_buf to boot_opts

2015-02-23 Thread John Ferlan
On 02/18/2015 11:39 AM, Ján Tomko wrote: --- src/qemu/qemu_command.c | 26 +- 1 file changed, 13 insertions(+), 13 deletions(-) ACK John -- libvir-list mailing list libvir-list@redhat.com https://www.redhat.com/mailman/listinfo/libvir-list

Re: [libvirt] [PATCH v3] Add support for Midonet virtual ports

2015-02-23 Thread John Ferlan
On 02/23/2015 03:54 PM, Antoni Segura Puimedon wrote: Up until now, to plug VMs into the Midonet virtual networks it was necessary to use the 'last resort' 'ethernet' type. That implied having the domain tainted and having to deal witht the tap lifecycle outside of libvirt/VM lifecycle.