Re: [libvirt] [PATCH v3 09/14] migration: refactor: refactor parameter compatibility checks

2015-10-01 Thread Nikolay Shirokovskiy
On 30.09.2015 16:38, Jiri Denemark wrote: > On Fri, Sep 18, 2015 at 18:05:47 +0300, Nikolay Shirokovskiy wrote: >> Move virDomainMigrateUnmanagedProto* expected params list check into >> function itself and use common virTypedParamsCheck for this purpose. >> >> Signed-off-by: Nikolay

Re: [libvirt] [PATCH v3 10/14] migration: merge all proto branches into single function

2015-10-01 Thread Nikolay Shirokovskiy
On 30.09.2015 16:38, Jiri Denemark wrote: > On Fri, Sep 18, 2015 at 18:05:48 +0300, Nikolay Shirokovskiy wrote: >> Finally on this step we get what we were aimed for - toURI{1, 2} (and >> migration{*} APIs too) now can work thru V3_PARAMS protocol. Execution path >> goes thru unchanged

Re: [libvirt] [PATCH v2 2/3] qemu: Add support for gic-version machine option

2015-10-01 Thread Pavel Fedin
Hello! > > And also we could add some another boolean, which would allow to disable > > in-kernel GIC > emulation > >(kernel_irqchip=off). This works with any machine type, BTW, not only with > >ARM. Something > like >kvm='off'/>. > > > > I don't know what that is. Is that only GIC related?

[libvirt] [PATCH] qemu: Add conditions for qemu-kvm use on ppc64

2015-10-01 Thread Andrea Bolognani
qemu-kvm can be used to run ppc64 guests on ppc64le hosts and vice versa, since the hardware is actually the same and the endianness is chosen by the guest kernel. Up until now, however, libvirt didn't allow the use of qemu-kvm to run guests if their endianness didn't match the host's. Resolves:

Re: [libvirt] [PATCH v2 0/3] Add support for gic-version machine option

2015-10-01 Thread Pavel Fedin
Hello! > I think Cole wanted to know more like how it can be useful for end > users. Since I see GIC as something similar to APIC, I'm guessing the > usefulness won't be directly visible, but should help. About what > exactly it does or what are the differences between, that I cannot > help

[libvirt] [PATCH 5/5] qemu: Use memory-backing-file only when needed

2015-10-01 Thread Martin Kletzander
We are using memory-backing-file even when it's not needed, for example if user requests hugepages for mamory backing, but does not specify any pagesize, neither memory node pinning. This causes migrations to fail when migrating from older libvirt that did not do this. So similarly to commit

[libvirt] [PATCH 0/5] Fix migration from older libvirt with hugepages

2015-10-01 Thread Martin Kletzander
Since libvirt is able to use memory-backend-{ram,file}, we were using it unconditionally, then we realized it might break migration from older libvirt, so we fixed the memory-backend-ram, but forgot about memory-backend-file. This series fixes the file backend as well and uses the

[libvirt] [PATCH 2/5] qemu: Move memory size detection to the top of the function

2015-10-01 Thread Martin Kletzander
To get rid of very long line and make it more readable. Signed-off-by: Martin Kletzander --- src/qemu/qemu_command.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/src/qemu/qemu_command.c b/src/qemu/qemu_command.c index f303a4b5bd1e..492313cbcba9

[libvirt] nested HVM in libxl againagain.

2015-10-01 Thread Alvin Starr
A while back I posted a patch to add nested HVM to libvirt and libxl. Something made me think the patch got accepted and incorporated into libvirt(It must have been the sleep deprivation). I noticed that the latest still does not support nested hvm(under xen). Should I try posting a patch

[libvirt] [PATCH 1/5] qemu: Move simplification variable to begining of the function

2015-10-01 Thread Martin Kletzander
Signed-off-by: Martin Kletzander --- src/qemu/qemu_command.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/qemu/qemu_command.c b/src/qemu/qemu_command.c index bb1835c2f5f1..f303a4b5bd1e 100644 --- a/src/qemu/qemu_command.c +++

[libvirt] [PATCH] tests: Check GIC-related XMLs in qemuxml2xmltest

2015-10-01 Thread Martin Kletzander
Signed-off-by: Martin Kletzander --- This is based on the GIC-support series from Pavel Fedin with the fixups mentioned there as well: https://www.redhat.com/archives/libvir-list/2015-September/msg01067.html .../qemuxml2argvdata/qemuxml2argv-aarch64-gic.xml | 30

Re: [libvirt] [PATCH] docs: Add Cuckoo Sandbox into apps.html

2015-10-01 Thread Andrea Bolognani
On Thu, 2015-10-01 at 14:33 +0200, Martin Kletzander wrote: > Signed-off-by: Martin Kletzander > --- > docs/apps.html.in | 14 ++ > 1 file changed, 14 insertions(+) > > diff --git a/docs/apps.html.in b/docs/apps.html.in > index 86b301660df3..2ee24bb382f9 100644

[libvirt] [PATCH] docs: Add Cuckoo Sandbox into apps.html

2015-10-01 Thread Martin Kletzander
Signed-off-by: Martin Kletzander --- docs/apps.html.in | 14 ++ 1 file changed, 14 insertions(+) diff --git a/docs/apps.html.in b/docs/apps.html.in index 86b301660df3..2ee24bb382f9 100644 --- a/docs/apps.html.in +++ b/docs/apps.html.in @@ -441,5 +441,19 @@

[libvirt] [PATCH 3/5] qemu: Extract -mem-path building into its own function

2015-10-01 Thread Martin Kletzander
That function is called qemuBuildMemPathStr() and will be used in other places in the future. The change in the test suite is proper due to the fact that -mem-prealloc makes only sense with -mem-path (from qemu documentation -- html/qemu-doc.html). Signed-off-by: Martin Kletzander

[libvirt] [PATCH 4/5] qemu: Add -mem-path even with numa

2015-10-01 Thread Martin Kletzander
Of course this will be used only in case we don't need the memory-backend-file backend, so it should not fire until later. Signed-off-by: Martin Kletzander --- src/qemu/qemu_command.c | 4 1 file changed, 4 insertions(+) diff --git a/src/qemu/qemu_command.c

[libvirt] [PATCH RESEND] Distribute only generated virkeymaps.h

2015-10-01 Thread Martin Kletzander
We are distributing virkeymaps.h and all the tools needed to rebuild that file. On top of that, we are generating that file into the $(srcdir) and that sometimes fails for me when trying to do make dist in VPATH on rawhide fedora. And we don't clean the file when maintainer-clean make target is

Re: [libvirt] nested HVM in libxl againagain.

2015-10-01 Thread Martin Kletzander
On Thu, Oct 01, 2015 at 09:23:30AM -0400, Alvin Starr wrote: A while back I posted a patch to add nested HVM to libvirt and libxl. Something made me think the patch got accepted and incorporated into libvirt(It must have been the sleep deprivation). I noticed that the latest still does not

[libvirt] [libvirt-php][PATCH 0/8] Couple of mem leak fixes

2015-10-01 Thread Michal Privoznik
So, after I reviewed [1] I realized how big memory leaks we have there... 1: https://www.redhat.com/archives/libvir-list/2015-September/msg01045.html Since there is nobody to review, I'm pushing this. Michal Privoznik (8): libvirt_network_get_information: Be more tolerant to missing info

Re: [libvirt] [PATCH v3 09/14] migration: refactor: refactor parameter compatibility checks

2015-10-01 Thread Jiri Denemark
On Thu, Oct 01, 2015 at 16:48:44 +0300, Nikolay Shirokovskiy wrote: > > > On 01.10.2015 12:30, Jiri Denemark wrote: > > On Thu, Oct 01, 2015 at 10:34:49 +0300, Nikolay Shirokovskiy wrote: > >> > >> > >> On 30.09.2015 16:38, Jiri Denemark wrote: > >>> On Fri, Sep 18, 2015 at 18:05:47 +0300,

Re: [libvirt] nested HVM in libxl againagain.

2015-10-01 Thread Alvin Starr
The thread goes back quite a ways to May of 2014. I am looking to try and find the patch I posted but I just can't. So I guess I did not post it( I need to get more sleep ). I have a version rebuilt against the latest version pulled from git. I will run the standard tests against it and post

Re: [libvirt] [libvirt-php] free xml resources in get_string_from_xpath

2015-10-01 Thread Michal Privoznik
On 30.09.2015 20:14, Vasiliy Tolstov wrote: > 30 сент. 2015 г. 16:23 пользователь "Michal Privoznik" > написал: >> >> >> > Big thanks! If XML parser does not panic when cleaning null variables this > is more preferred. > Can somebody regenerate site docs for this binding

Re: [libvirt] [PATCH] docs: Add Cuckoo Sandbox into apps.html

2015-10-01 Thread Andrea Bolognani
On Thu, 2015-10-01 at 16:14 +0200, Martin Kletzander wrote: > > Plus the whole last sentence looks like some words went missing... > > Maybe take another look at it. > > How about "And libvirt is one of the backends that can be used for > the > isolated environment." ? Much better :) ACK --

Re: [libvirt] [PATCH] docs: Add Cuckoo Sandbox into apps.html

2015-10-01 Thread Martin Kletzander
On Thu, Oct 01, 2015 at 03:11:56PM +0200, Andrea Bolognani wrote: On Thu, 2015-10-01 at 14:33 +0200, Martin Kletzander wrote: Signed-off-by: Martin Kletzander --- docs/apps.html.in | 14 ++ 1 file changed, 14 insertions(+) diff --git a/docs/apps.html.in

[libvirt] [libvirt-php][PATCH 5/8] LONGLONG_INIT: Reformat

2015-10-01 Thread Michal Privoznik
This is purely just to fulfil my OCD, so that the code can be formatted better. Signed-off-by: Michal Privoznik --- src/libvirt-php.c | 30 +++--- 1 file changed, 15 insertions(+), 15 deletions(-) diff --git a/src/libvirt-php.c b/src/libvirt-php.c

[libvirt] [libvirt-php][PATCH 6/8] virConnectGetHostname: free returned value

2015-10-01 Thread Michal Privoznik
It's caller responsibility to free the returned value when no longer needed. Signed-off-by: Michal Privoznik --- src/libvirt-php.c | 9 - 1 file changed, 8 insertions(+), 1 deletion(-) diff --git a/src/libvirt-php.c b/src/libvirt-php.c index 4d0785a..36cb8b9 100644

[libvirt] [libvirt-php][PATCH 7/8] virDomainGetXMLDesc: Free returned value

2015-10-01 Thread Michal Privoznik
It's caller responsibility to free the returned value when no longer needed. Moreover, some functions are rewritten so that they use the fancy APIs we have (e.g. virDomainAttachDeviceFlags instead of dumping domain XML, appending new disk there and defining again). Signed-off-by: Michal Privoznik

[libvirt] [libvirt-php][PATCH 3/8] examples: Rework a bit to resolve some warnings

2015-10-01 Thread Michal Privoznik
Not only you should not use virDomain object as index to an array in PHP where only strings and integers are allowed, you should avoid mixing types passed to domain_get_info(). At some point a domain name is passed, then virDomain is passed ... Signed-off-by: Michal Privoznik

[libvirt] [libvirt-php][PATCH 8/8] virNodeDeviceGetXMLDesc: Free returned value

2015-10-01 Thread Michal Privoznik
It's caller responsibility to free the returned value when no longer needed. Signed-off-by: Michal Privoznik --- src/libvirt-php.c | 39 +-- 1 file changed, 33 insertions(+), 6 deletions(-) diff --git a/src/libvirt-php.c

[libvirt] [libvirt-php][PATCH 2/8] examples: Resolve some warnings

2015-10-01 Thread Michal Privoznik
So, I have a couple of networks and while testing the examples I've noticed that there are some warnings being printed out: [Wed Sep 30 15:53:13 2015] PHP Notice: Undefined index: forward_dev in /home/zippy/work/libvirt/libvirt-php.git/examples/index.php on line 283 [Wed Sep 30 15:53:13 2015]

Re: [libvirt] [PATCH v3 09/14] migration: refactor: refactor parameter compatibility checks

2015-10-01 Thread Nikolay Shirokovskiy
On 01.10.2015 12:30, Jiri Denemark wrote: > On Thu, Oct 01, 2015 at 10:34:49 +0300, Nikolay Shirokovskiy wrote: >> >> >> On 30.09.2015 16:38, Jiri Denemark wrote: >>> On Fri, Sep 18, 2015 at 18:05:47 +0300, Nikolay Shirokovskiy wrote: Move virDomainMigrateUnmanagedProto* expected params

Re: [libvirt] [libvirt-python PATCH 00/23] Cleanup of the libvirt-python C code

2015-10-01 Thread Pavel Hrdina
On Sat, Sep 26, 2015 at 10:52:27AM -0400, John Ferlan wrote: > > > On 09/24/2015 10:01 AM, Pavel Hrdina wrote: > > This patch series tries to cleanup the libvirt-python C code and also make > > it > > more readable. It also fixes places, where we didn't checked for return > > values > > and

Re: [libvirt] [PATCH] qemu: Add conditions for qemu-kvm use on ppc64

2015-10-01 Thread Jiri Denemark
On Thu, Oct 01, 2015 at 14:47:11 +0200, Andrea Bolognani wrote: > qemu-kvm can be used to run ppc64 guests on ppc64le hosts and vice > versa, since the hardware is actually the same and the endianness > is chosen by the guest kernel. > > Up until now, however, libvirt didn't allow the use of

[libvirt] [libvirt-php][PATCH 1/8] libvirt_network_get_information: Be more tolerant to missing info

2015-10-01 Thread Michal Privoznik
This function is really build in a way that only NATed networks can pass the function. Any other networks (and there's plenty of them) will make it fail immediately. So while we are in PHP, we can utilize array_key_exist() function and thus just fill just those info that we know for now.

[libvirt] [libvirt-php][PATCH 4/8] Don't free() in RECREATE_STRING_WITH_E

2015-10-01 Thread Michal Privoznik
It's harder to track which variables were free()-d if the free() call is hidden in the macro. Moreover, since we don't have a wrapper over free() that will set the pointer to NULL, we may end up double freeing something. Signed-off-by: Michal Privoznik --- src/libvirt-php.c

Re: [libvirt] [PATCH] qemu: Add conditions for qemu-kvm use on ppc64

2015-10-01 Thread Andrea Bolognani
On Thu, 2015-10-01 at 17:00 +0200, Jiri Denemark wrote: > I wonder if this case shouldn't somehow fall into the hostarch == > guestarch case, via something like > native_kvm = ARCH_CANONICAL(hostarch) == ARCH_CANONICAL(guestarch), > but > probably not since it maybe non-trivial (and depending on

[libvirt] [PATCH] add nested HVM to libxl

2015-10-01 Thread Alvin Starr
--- docs/schemas/domaincommon.rng | 10 ++ src/conf/domain_conf.c| 6 ++ src/conf/domain_conf.h| 2 ++ src/libxl/libxl_conf.c| 35 +++ 4 files changed, 53 insertions(+) diff --git a/docs/schemas/domaincommon.rng

[libvirt] [PATCH] nestedhvm for libxl

2015-10-01 Thread Alvin Starr
This patch adds a nestedhvm directive to the lxm features to allow libxl to create a nested HVM. It also has mask_svm_npt to allow the created HVM to have the svm/npt bits masked so that it cannot in turn run up an nested hvm. Alvin Starr (1): add nested HVM to libxl

Re: [libvirt] [PATCH 5/5] qemu: Use memory-backing-file only when needed

2015-10-01 Thread John Ferlan
On 10/01/2015 08:10 AM, Martin Kletzander wrote: > We are using memory-backing-file even when it's not needed, for example > if user requests hugepages for mamory backing, but does not specify any ^^ Different body part altogether ;-) > pagesize, neither

Re: [libvirt] [PATCH 1/5] qemu: Move simplification variable to begining of the function

2015-10-01 Thread John Ferlan
NIT: $subj: "beginning" On 10/01/2015 08:10 AM, Martin Kletzander wrote: > Signed-off-by: Martin Kletzander > --- > src/qemu/qemu_command.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > ACK John -- libvir-list mailing list libvir-list@redhat.com

Re: [libvirt] [PATCH 2/5] qemu: Move memory size detection to the top of the function

2015-10-01 Thread John Ferlan
On 10/01/2015 08:10 AM, Martin Kletzander wrote: > To get rid of very long line and make it more readable. > > Signed-off-by: Martin Kletzander > --- > src/qemu/qemu_command.c | 4 +++- > 1 file changed, 3 insertions(+), 1 deletion(-) > ACK John although you could

Re: [libvirt] [PATCH 3/5] qemu: Extract -mem-path building into its own function

2015-10-01 Thread John Ferlan
On 10/01/2015 08:10 AM, Martin Kletzander wrote: > That function is called qemuBuildMemPathStr() and will be used in > other places in the future. The change in the test suite is proper due > to the fact that -mem-prealloc makes only sense with -mem-path (from > qemu documentation --

Re: [libvirt] [PATCH 4/5] qemu: Add -mem-path even with numa

2015-10-01 Thread John Ferlan
On 10/01/2015 08:10 AM, Martin Kletzander wrote: > Of course this will be used only in case we don't need the > memory-backend-file backend, so it should not fire until later. > So if I'm reading things right... when building the numa string, if it's determine that "-object" and

[libvirt] genprotocol.pl generates unstable output

2015-10-01 Thread Olaf Hering
If the same source gets built twice the resulting files may differ. One example is this: ... [ 305s] /usr/bin/perl -w ./rpc/genprotocol.pl /usr/bin/rpcgen -c \ [ 305s]remote/remote_protocol.x ./remote/remote_protocol.c ... [ 577s]

Re: [libvirt] [PATCH v2 2/3] qemu: Add support for gic-version machine option

2015-10-01 Thread Pavel Fedin
Hello! > Indentation's off here. Damn, sorry, overlooked... > Also before this patch we would allow def->gic_version == 2 for any > machine type. I don't have a problem with this since GIC doesn't make > sense anywhere else then on ARM machines, I'm OK with this. I used 0 for 'no version

Re: [libvirt] [PATCH v2 2/3] qemu: Add support for gic-version machine option

2015-10-01 Thread Martin Kletzander
On Thu, Oct 01, 2015 at 09:53:00AM +0300, Pavel Fedin wrote: Hello! > Indentation's off here. Damn, sorry, overlooked... Also before this patch we would allow def->gic_version == 2 for any machine type. I don't have a problem with this since GIC doesn't make sense anywhere else then on ARM

Re: [libvirt] [PATCH v2 0/3] Add support for gic-version machine option

2015-10-01 Thread Pavel Fedin
Hello! > Can you explain what this setting actually does? Of course. It allows to choose GIC version used by ARM 'virt' machine. By default it's 2, but you can now set it to 3. Actually, initially i proposed another machine type, like 'virt-v3', IMHO this would be more logical because this

Re: [libvirt] [PATCH 0/6] Fix some Coverity issues

2015-10-01 Thread Jim Fehlig
On 09/23/2015 05:18 PM, John Ferlan wrote: Newer Coverity (7.7.0) found a couple real issues and a few more false positives. There's still a few more to be resolved, but still trying to figure them out... libxlDomainMigrationPrepare - claim is args is leaked. Although it seems to be

Re: [libvirt] [PATCH v2 0/3] Add support for gic-version machine option

2015-10-01 Thread Martin Kletzander
On Thu, Oct 01, 2015 at 10:00:13AM +0300, Pavel Fedin wrote: Hello! Can you explain what this setting actually does? Of course. It allows to choose GIC version used by ARM 'virt' machine. By default it's 2, but you can now set it to 3. Actually, initially i proposed another machine type,

Re: [libvirt] [PATCH v3 09/14] migration: refactor: refactor parameter compatibility checks

2015-10-01 Thread Jiri Denemark
On Thu, Oct 01, 2015 at 10:34:49 +0300, Nikolay Shirokovskiy wrote: > > > On 30.09.2015 16:38, Jiri Denemark wrote: > > On Fri, Sep 18, 2015 at 18:05:47 +0300, Nikolay Shirokovskiy wrote: > >> Move virDomainMigrateUnmanagedProto* expected params list check into > >> function itself and use