Re: [libvirt] [PATCH v2 0/3] vz: implement some API calls

2015-10-20 Thread Dmitry Guryanov
On 10/19/2015 10:02 PM, Maxim Nestratov wrote: v1-v2 change: - removed vzConnectGetType - addressed comments on vzConnectGetMaxVcpus Maxim Nestratov (3): vz: implement connectGetMaxVcpus API calls vz: implement API calls of nodeGetxxx family vz: implement some domain API calls

Re: [libvirt] [PATCH 2/2] Prefer STREQ and STRNEQ

2015-10-20 Thread Ishmanpreet Khera
Ping? On Wed, Oct 7, 2015 at 11:02 PM, Ishmanpreet Khera wrote: > new syntax-check rule for !STREQ and !STRNEQ so that > we don't end up in the same situation again. > > Signed-off-by: Ishmanpreet Kaur Khera > --- > cfg.mk | 18

Re: [libvirt] gem install ruby-libvirt fails on FreeBSD 10.2

2015-10-20 Thread Roman Bogorodskiy
Rickard von Essen wrote: > Hi, > > Installing the ruby-libvirt gem fails on FreeBSD 10.2 since it can't locate > the lib and include dir. Installing with: > gem install ruby-libvirt -- > --with-libvirt-include=/usr/local/include/libvirt > --with-libvirt-lib=/usr/local/lib/libvirt.so > works

Re: [libvirt] [PATCH 1/2] Prefer STREQ and STRNEQ

2015-10-20 Thread Michal Privoznik
On 07.10.2015 19:31, Ishmanpreet Khera wrote: > use STRNEQ instead of !STREQ to remove inconsistency. > > Signed-off-by: Ishmanpreet Kaur Khera > --- > src/bhyve/bhyve_driver.c | 2 +- > src/conf/network_conf.c | 4 ++-- >

[libvirt] [PATCH] bhyve: implement domainGetOSType

2015-10-20 Thread Roman Bogorodskiy
--- src/bhyve/bhyve_driver.c | 22 ++ 1 file changed, 22 insertions(+) diff --git a/src/bhyve/bhyve_driver.c b/src/bhyve/bhyve_driver.c index d44cf2c..efba0ae 100644 --- a/src/bhyve/bhyve_driver.c +++ b/src/bhyve/bhyve_driver.c @@ -465,6 +465,27 @@

[libvirt] [PATCH 2/4] qemu: hostdev: Unify naming for qemuDomainReAttachHost*Devices()

2015-10-20 Thread Andrea Bolognani
No functional changes. --- src/qemu/qemu_hostdev.c | 4 ++-- src/qemu/qemu_hostdev.h | 2 +- src/qemu/qemu_hotplug.c | 4 ++-- 3 files changed, 5 insertions(+), 5 deletions(-) diff --git a/src/qemu/qemu_hostdev.c b/src/qemu/qemu_hostdev.c index a4409d6..ec708c8 100644 ---

Re: [libvirt] [PATCH 06/10] qemu: command: Move dimm device checks from formatter to checker

2015-10-20 Thread John Ferlan
On 10/16/2015 08:11 AM, Peter Krempa wrote: > Aggregate the checks of the dimm device into the verification function > rather than having them in the formatter. > --- > src/qemu/qemu_command.c | 65 ++ > src/qemu/qemu_command.h | 4 +-- >

[libvirt] [PATCHv4 2/2] netlink: add support for multi-part netlink messages.

2015-10-20 Thread Maxim Perevedentsev
Such messages do not have NLMSG_ERROR or NLMSG_DONE type but they are valid responses. We test 'multi-partness' by looking for NLM_F_MULTI flag. --- Difference to v1: fixed comment style. src/util/virnetlink.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git

[libvirt] [PATCHv4 0/2] Added waiting for DAD to finish for bridge address.

2015-10-20 Thread Maxim Perevedentsev
This is a fix for commit db488c79173b240459c7754f38c3c6af9b432970 dnsmasq main process which is relied on when waiting for DAD to complete exits without actually waiting for DAD. This is dnsmasq daemon's task. It seems to be a race that DAD finished before dnsmasq main process exited. The above

Re: [libvirt] [PATCH 0/3] NEWS: Split releases by year

2015-10-20 Thread Martin Kletzander
On Fri, Oct 16, 2015 at 10:20:56AM +0200, Andrea Bolognani wrote: On Fri, 2015-10-16 at 09:47 +0200, Martin Kletzander wrote: On Thu, Oct 15, 2015 at 04:12:07PM +0200, Andrea Bolognani wrote: > As agreed, I've followed up with the cleanups by splitting > the huge news.html.in file into

[libvirt] [PATCH 0/4] qemu: hostdev: Unify naming

2015-10-20 Thread Andrea Bolognani
I was working on the QEMU hostdev code and the inconsistent naming used kept making things just that little harder for me to follow, so I unified it. Cheers. Andrea Bolognani (4): qemu: hostdev: Unify naming for qemuPrepareHost*Devices() qemu: hostdev: Unify naming for

[libvirt] [PATCH 4/4] qemu: hostdev: Introduce qemuUpdateActiveHostDevices()

2015-10-20 Thread Andrea Bolognani
This calls the PCI-, USB- and SCSI-specific functions just like qemuPrepareHostDevices() and qemuDomainReAttachHostDevices() already do. Update qemuProcessReconnect() to use the new function. --- src/qemu/qemu_hostdev.c | 18 ++ src/qemu/qemu_hostdev.h | 2 ++

[libvirt] [PATCH 1/4] qemu: hostdev: Unify naming for qemuPrepareHost*Devices()

2015-10-20 Thread Andrea Bolognani
No functional changes. --- src/qemu/qemu_hostdev.c | 40 src/qemu/qemu_hostdev.h | 22 +++--- src/qemu/qemu_hotplug.c | 9 - 3 files changed, 35 insertions(+), 36 deletions(-) diff --git a/src/qemu/qemu_hostdev.c

[libvirt] [PATCH 3/4] qemu: hostdev: Unify naming for qemuUpdateActiveHost*Devices()

2015-10-20 Thread Andrea Bolognani
No functional changes. --- src/qemu/qemu_hostdev.c | 12 ++-- src/qemu/qemu_hostdev.h | 12 ++-- src/qemu/qemu_process.c | 6 +++--- 3 files changed, 15 insertions(+), 15 deletions(-) diff --git a/src/qemu/qemu_hostdev.c b/src/qemu/qemu_hostdev.c index ec708c8..d395271 100644

Re: [libvirt] [PATCH v2] lxc: fuse mount for /proc/cpuinfo

2015-10-20 Thread Serge Hallyn
Just a one-time announcement - beside the git tree at github.com/hallyn/libresource there is also a mailing list now at https://lists.linuxcontainers.org/listinfo/libresource-devel I don't really intend to be a driving developer on it, but will happily review and discuss and help where I can.

Re: [libvirt] [PATCH 07/10] qemu: domain: Remove memory device check from post parse callback

2015-10-20 Thread John Ferlan
On 10/16/2015 08:11 AM, Peter Krempa wrote: > We check that is present when we have memory devices at the > time we start the VM or add the device, so we can remove it from the > post parse callback to be more tolerant to users. > --- > src/qemu/qemu_domain.c | 8 > 1 file changed, 8

[libvirt] [PATCH v2] use STRNEQ instead of !STREQ and new syntax-check rule to avoid !STREQ and !STRNEQ

2015-10-20 Thread Ishmanpreet Kaur Khera
used STRNEQ instead of !STREQ to remove inconsistency and intoduced new syntax-check rule for !STREQ and !STRNEQ so that we don't end up in the same situation again. Signed-off-by: Ishmanpreet Kaur Khera --- cfg.mk| 18 ++

Re: [libvirt] [PATCH 0/3] NEWS: Split releases by year

2015-10-20 Thread Andrea Bolognani
On Tue, 2015-10-20 at 17:21 +0200, Martin Kletzander wrote: > > > 2) syntax-check fails with this series, but that's not because > > > there > > > would be anything wrong with the files you've added, it's > > > just an > > > exclusion rule missing them. > > > > Thanks for spotting that,

[libvirt] [PATCHv4 1/2] network: added waiting for DAD to finish for bridge address.

2015-10-20 Thread Maxim Perevedentsev
This is a fix for commit db488c79173b240459c7754f38c3c6af9b432970 dnsmasq main process exits without waiting for DAD, this is dnsmasq daemon's task. So we periodically poll the kernel using netlink and check whether there are any IPv6 addresses assigned to bridge which have 'tentative' state.

Re: [libvirt] [PATCH v2 7/12] storage: Refactor and fix virStorageBackendCreateExecCommand

2015-10-20 Thread John Ferlan
Ping or should I just resend what's left rather than 3 adjusted and inserted patches? Tks, John On 10/14/2015 02:01 PM, John Ferlan wrote: > Refactor the code to handle the NETFS pool separately from other pool > types. When the original code was developed (commit id 'e1f27784') > the

Re: [libvirt] [PATCH 08/10] conf: Prepare making memory device target node optional

2015-10-20 Thread John Ferlan
On 10/16/2015 08:11 AM, Peter Krempa wrote: > Adjust the config code so that it does not enforce that target memory > node is specified. To avoid breakage, adjust the qemu memory hotplug > config checker to disallow such config for now. > --- > docs/formatdomain.html.in | 5 +++-- >

Re: [libvirt] [PATCH 04/10] qemu: command: Always execute memory device formatter

2015-10-20 Thread John Ferlan
On 10/16/2015 08:11 AM, Peter Krempa wrote: > Since we already make sure before that the domain configuration is > valid we may execute it always at the cost of doing 0 iterations of the > for loop. > > This patch will simplify later refactor as it will avoid whitespace > changes. > --- >

Re: [libvirt] [PATCH 05/10] qemu: domain: Add common function to perform memory hotplug checks

2015-10-20 Thread John Ferlan
On 10/16/2015 08:11 AM, Peter Krempa wrote: > Add a function that will aggregate various checks related to memory > hotplug so that they aren't scattered accross various parts of the > code. > --- > src/qemu/qemu_command.c | 26 ++--- > src/qemu/qemu_domain.c | 77 >

[libvirt] [PATCHv2 0/3] improve the error report for virNodeAllocPages and virNodeGetFreePages

2015-10-20 Thread Luyao Huang
v1: https://www.redhat.com/archives/libvir-list/2015-September/msg01054.html v2: -improve the error message -improve the code struct -add a new patch for rework the exist way to check node and page size Luyao Huang (3): util: split the virNumaGetHugePageInfoPath into separate function util:

[libvirt] [PATCH 2/3] util: move the pagesize and node check and error report to one place

2015-10-20 Thread Luyao Huang
Just like 1c24cfe9, check the pagesize and numa node if we cannot find the hugepage path. And improve the error message again. After this patch: # virsh allocpages --pagesize 2047 --pagecount 1 --cellno 0 error: operation failed: page size 2047 is not available on node 0 # virsh allocpages

[libvirt] [PATCHv2 1/3] util: split the virNumaGetHugePageInfoPath into separate function

2015-10-20 Thread Luyao Huang
https://bugzilla.redhat.com/show_bug.cgi?id=1265114 When pass 0 page_size to virNumaGetHugePageInfoPath function, we will get fail like this: error : virFileReadAll:1358 : Failed to read file '/sys/devices/system/node/node0/hugepages/': Is a directory Because when the page_size is 0 the

[libvirt] [PATCHv2 3/3] util: Produce friendlier error message to user

2015-10-20 Thread Luyao Huang
Commit 1c24cfe9 fix the problem in virNumaSetPagePoolSize, this patch just like it and fix the issue in another function. when user use freepages and specify a invalid node or page size, will get error like this: # virsh freepages 0 1 error: Failed to open file

Re: [libvirt] [PATCH 02/10] conf: Turn targetNode in struct virDomainMemoryDef to signed

2015-10-20 Thread John Ferlan
On 10/16/2015 08:11 AM, Peter Krempa wrote: > Later on, we will need to know whether the user specified the target > node or not. Turn the variable into a signed value. We already treat it > as signed in various parts of the qemu driver. > --- > src/conf/domain_conf.c | 10 ++ >

Re: [libvirt] [PATCH 01/10] conf: Make @def const in virDomainDefGetMemoryInitial

2015-10-20 Thread John Ferlan
On 10/16/2015 08:11 AM, Peter Krempa wrote: > Keep const correctness and allow to use this function in cases where > @def is const in the caller. > --- > src/conf/domain_conf.c | 2 +- > src/conf/domain_conf.h | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) > All because the new

Re: [libvirt] [PATCH 03/10] qemu: command: Make qemuBuildMemoryBackendStr usable without NUMA

2015-10-20 Thread John Ferlan
On 10/16/2015 08:11 AM, Peter Krempa wrote: > Make the function usable so that -1 can be passed to it as cell ID so > that we can later enable memory hotplug on non-NUMA guests for certain > architectures. > > I've inspected all functions that take guestNode as an argument to > verify that they

Re: [libvirt] [PATCH 02/10] conf: Turn targetNode in struct virDomainMemoryDef to signed

2015-10-20 Thread Peter Krempa
On Tue, Oct 20, 2015 at 09:36:29 -0400, John Ferlan wrote: > > > On 10/16/2015 08:11 AM, Peter Krempa wrote: > > Later on, we will need to know whether the user specified the target > > node or not. Turn the variable into a signed value. We already treat it > > as signed in various parts of the