[libvirt] Entering freeze for libvirt-1.3.0

2015-12-02 Thread Daniel Veillard
As planned I have tagged RC1 in git and pushed signed tarball and rpms to the usual place: ftp://libvirt.org/libvirt/ there is significant changes in this release so people are really encouraged to give it a good try. I will try to push rc2 possibly in the week-end and shooting for a

Re: [libvirt] [PATCH 1/3] conf: Reposition adding SCSI controller for SCSI hostdev hotplug

2015-12-02 Thread John Ferlan
On 12/02/2015 03:27 AM, Boris Fiuczynski wrote: > On 12/02/2015 01:16 AM, John Ferlan wrote: >> >> >> On 11/30/2015 06:05 AM, Boris Fiuczynski wrote: >> >> [...] >> >>> diff --git a/src/conf/domain_conf.c b/src/conf/domain_conf.c >>> index cbfc41e..69cfd0f 100644 >>> --- a/src/conf/domain_conf.c

Re: [libvirt] [PATCH 1/3] conf: Reposition adding SCSI controller for SCSI hostdev hotplug

2015-12-02 Thread Boris Fiuczynski
On 12/02/2015 04:08 PM, John Ferlan wrote: On 12/02/2015 03:27 AM, Boris Fiuczynski wrote: On 12/02/2015 01:16 AM, John Ferlan wrote: On 11/30/2015 06:05 AM, Boris Fiuczynski wrote: [...] diff --git a/src/conf/domain_conf.c b/src/conf/domain_conf.c index cbfc41e..69cfd0f 100644 ---

Re: [libvirt] [PATCH 1/3] conf: Reposition adding SCSI controller for SCSI hostdev hotplug

2015-12-02 Thread John Ferlan
On 12/02/2015 11:37 AM, Boris Fiuczynski wrote: [...] >> So, what if qemuDomainFindOrCreateSCSIDiskController checked the "found" >> cont in the first loop for "cont->info.alias". If it doesn't exist, then >> fall through under the "assumption" that the controller was added by >> some other

[libvirt] [PATCH 02/10] pci: Remove 'reprobe' parameter from virPCIDeviceUnbind()

2015-12-02 Thread Andrea Bolognani
The value is not inspected inside the function, so it makes more sense for the caller to change the device's setting explicitly. --- src/util/virpci.c | 10 ++ src/util/virpci.h | 2 +- tests/virpcitest.c | 2 +- 3 files changed, 8 insertions(+), 6 deletions(-) diff --git

[libvirt] [PATCH 07/10] hostdev: Delay reattach of VFIO devices

2015-12-02 Thread Andrea Bolognani
When reattaching VFIO devices to the host, we have to be careful not to end up in a situation where ownership of the IOMMU group is shared between the hosts and a domain, as doing so will result in host crashes. If a PCI device is not safe for reattach, as detected by

[libvirt] [PATCH 03/10] pci: Introduce virPCIStubDriver enumeration

2015-12-02 Thread Andrea Bolognani
This replaces the virPCIKnownStubs string array that was used internally for stub driver validation. Advantages: * possible values are well-defined * typos in driver names will be detected at compile time * avoids having several copies of the same string around * no error checking

[libvirt] [PATCH 08/10] hostdev: Clean up delayed VFIO devices

2015-12-02 Thread Andrea Bolognani
When we determine that a VFIO device can be safely reattached to the host, we have to also reattach all devices we might have delayed earlier in order to clean up properly. The new function virHostdevExpandPCIDeviceListIOMMUGroups() helps by adding inactive devices that are part of the same IOMMU

[libvirt] [PATCH 09/10] hostdev: Devices have already been marked as inactive

2015-12-02 Thread Andrea Bolognani
We mark all VFIO devices as inactive after we've detached them from the domain, so that step doesn't need to be performed afterwards. --- src/util/virhostdev.c | 8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/src/util/virhostdev.c b/src/util/virhostdev.c index

[libvirt] [PATCH 05/10] hostdev: Simplify virHostdevIsPCIDeviceUsed()

2015-12-02 Thread Andrea Bolognani
This function, previously called virHostdevIsPCINodeDeviceUsed(), was written to work both when used on its own and when used with virPCIDeviceAddressIOMMUGroupIterate(); as a consequence, it was slightly more convoluted than it needed to be. Rework it to perform a single task (checking that a

[libvirt] [PATCH 06/10] hostdev: Check for safety before detaching VFIO devices

2015-12-02 Thread Andrea Bolognani
The newly-introduced virHostdevIsPCIDeviceSafeForDetach() function checks against all problematic situations that can arise when detaching a PCI device from the host for VFIO device assignment. Some of the checks are simply reintroduced after being removed when reworking

[libvirt] [PATCH 04/10] pci: Introduce virPCIDeviceIOMMUGroupIterate()

2015-12-02 Thread Andrea Bolognani
This is a straightforward wrapper around virPCIDeviceAddressIOMMUGroupIterate() that will make some code less awkward to write later on. --- src/libvirt_private.syms | 1 + src/util/virpci.c| 26 ++ src/util/virpci.h| 8 ++-- 3 files changed, 33

[libvirt] [PATCH 10/10] hostdev: Tidy up after changes to VFIO device handling

2015-12-02 Thread Andrea Bolognani
Add a couple of useful debug messages, update comments to reflect recent changes, use the proper case for VFIO in variable names and fix parameter alignment in a function definition. --- src/util/virhostdev.c | 27 --- 1 file changed, 16 insertions(+), 11 deletions(-)

Re: [libvirt] [PATCH] network: selectively disable -Wcast-align in virNetDevParseDadStatus

2015-12-02 Thread Jim Fehlig
On 12/02/2015 03:27 AM, Daniel P. Berrange wrote: > On Tue, Dec 01, 2015 at 05:49:10PM -0700, Jim Fehlig wrote: >> On 11/30/2015 09:18 PM, Jim Fehlig wrote: >>> On 11/26/2015 08:10 AM, Ian Campbell wrote: Commit 0f7436ca54c9 "network: wait for DAD to finish for bridge IPv6 addresses"

[libvirt] Block replication driver

2015-12-02 Thread Simon Kollberg
Hi! I'm working on supporting a new FT/HA solution for qemu called COLO (http://wiki.qemu.org/Features/COLO). The part that is currently being focused on for libvirt integration is Block Replication (http://wiki.qemu.org/Features/BlockReplication) which enables guest state synchronization for

[libvirt] [PATCH 00/10] VFIO fixes for PCI devices

2015-12-02 Thread Andrea Bolognani
This series is my attempt at fixing https://bugzilla.redhat.com/show_bug.cgi?id=1272300 In its current state, it's missing test cases covering the new functionality[1] and it's known not to handle properly one situation[2], but I'd like to get some feedback on my current work and now that I

[libvirt] [PATCH] add a nodnsmasq option for networks

2015-12-02 Thread Serge Hallyn
Some people want to define a libvirt network but have dns served by another daemon. Libvirt used to support that, but hasn't for several years. Two long-open bugs on this are https://bugzilla.redhat.com/show_bug.cgi?id=636115 https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/584862 I'm

[libvirt] [PATCH] storage: Attempt to refresh volume after successful wipe volume

2015-12-02 Thread John Ferlan
https://bugzilla.redhat.com/show_bug.cgi?id=1270709 When a volume wipe is successful, a volume refresh should be done afterwards to update any volume data that may be used in future volume commands, such as volume resize. For a raw file volume, a wipe would truncate the file and a followup

Re: [libvirt] [PATCH v2 2/2] libxl: implement virDomainInterfaceStats

2015-12-02 Thread Jim Fehlig
On 12/02/2015 06:02 AM, Joao Martins wrote: > > On 12/02/2015 12:45 AM, Jim Fehlig wrote: >> On 11/23/2015 11:57 AM, Joao Martins wrote: >>> Introduce support for domainInterfaceStats API call for querying >>> network interface statistics. Consequently it also enables the >>> use of `virsh

Re: [libvirt] [PATCH] fix LSB part of virtlogd runlevel script

2015-12-02 Thread Martin Kletzander
On Wed, Dec 02, 2015 at 08:52:28AM +0100, Olaf Hering wrote: On Wed, Dec 02, Martin Kletzander wrote: But seeing this patch, we should also fix other init scripts, I believe. I, personally, see only the same problem in src/locking/virtlockd.init.in, but I didn't use the script you used.

Re: [libvirt] [PATCH 1/3] conf: Reposition adding SCSI controller for SCSI hostdev hotplug

2015-12-02 Thread Boris Fiuczynski
On 12/02/2015 01:16 AM, John Ferlan wrote: On 11/30/2015 06:05 AM, Boris Fiuczynski wrote: [...] diff --git a/src/conf/domain_conf.c b/src/conf/domain_conf.c index cbfc41e..69cfd0f 100644 --- a/src/conf/domain_conf.c +++ b/src/conf/domain_conf.c @@ -16285,6 +16285,9 @@

Re: [libvirt] [PATCH v2 00/10] Make loading domains with invalid XML possible

2015-12-02 Thread lhuang
On 12/02/2015 01:35 AM, Martin Kletzander wrote: We always had to deal with new parsing errors in a weird way. All of them needed to go into functions starting the domains. That messes up the code, it's confusing to newcomers and so on. I once had an idea that we can handle this stuff. We

[libvirt] [libvirt-perl][PATCH] Add VIR_FROM_LOGGING constant

2015-12-02 Thread Michal Privoznik
Signed-off-by: Michal Privoznik --- Virt.xs | 1 + lib/Sys/Virt/Error.pm | 4 2 files changed, 5 insertions(+) diff --git a/Virt.xs b/Virt.xs index c7cce27..db04fc2 100644 --- a/Virt.xs +++ b/Virt.xs @@ -8239,6 +8239,7 @@ BOOT:

Re: [libvirt] [PATCH v2 00/10] Make loading domains with invalid XML possible

2015-12-02 Thread Martin Kletzander
On Wed, Dec 02, 2015 at 04:46:20PM +0800, lhuang wrote: On 12/02/2015 01:35 AM, Martin Kletzander wrote: We always had to deal with new parsing errors in a weird way. All of them needed to go into functions starting the domains. That messes up the code, it's confusing to newcomers and so

Re: [libvirt] [PATCH] add a nodnsmasq option for networks

2015-12-02 Thread Laine Stump
On 12/02/2015 02:50 PM, Serge Hallyn wrote: Some people want to define a libvirt network but have dns served by another daemon. Libvirt used to support that, but hasn't for several years. Two long-open bugs on this are https://bugzilla.redhat.com/show_bug.cgi?id=636115

Re: [libvirt] [PATCH] add a nodnsmasq option for networks

2015-12-02 Thread Serge Hallyn
Quoting Laine Stump (la...@laine.org): > On 12/02/2015 02:50 PM, Serge Hallyn wrote: > >Some people want to define a libvirt network but have dns served > >by another daemon. Libvirt used to support that, but hasn't for > >several years. Two long-open bugs on this are > > >

[libvirt] [PATCH 1/3] storage: Add virCheckFlags to virStorageBackendRBDDeleteVol

2015-12-02 Thread John Ferlan
The initial commit '74951eade' did not include the proper check for whether any flags are supported by the driver. Even though the driver doesn't support VIR_STORAGE_VOL_DELETE_ZEROED, it still checks and allows the processing to continue Also add the new VIR_STORAGE_VOL_DELETE_WITH_SNAPSHOTS

[libvirt] [PATCH 0/3] Add delete-snapshots option to virsh commands

2015-12-02 Thread John Ferlan
Commit id '3c7590e0' added the ability to delete snapshots for rbd backends, but did not provide the virsh commands in order to handle that option. The first two patches fix a couple of minor nits - not using virCheckFlags in virStorageBackendRBDDeleteVol even though the flags are used. Also, the

[libvirt] [PATCH 3/3] virsh: Add --delete-snapshots flag for undefine and vol-delete

2015-12-02 Thread John Ferlan
https://bugzilla.redhat.com/show_bug.cgi?id=1281710 Commit id '3c7590e0a' added the flag to the rbd backend, but provided no means via virsh to use the flag. This patch adds a '--delete-snapshots' option to both the "undefine" and "vol-delete" commands. For "undefine", the flag is combined with

[libvirt] [PATCH 2/3] libvirt: Add virStorageVolDeleteFlags to virStorageVolDelete

2015-12-02 Thread John Ferlan
Although they've been present for quite a while, they weren't added to the API definition, so add them there to make it clearer. Currently only the RBD backend even checks for any flags. Signed-off-by: John Ferlan --- src/libvirt-storage.c | 2 +- 1 file changed, 1

Re: [libvirt] [PATCH v2] libxl: add p2p migration

2015-12-02 Thread Jim Fehlig
On 11/10/2015 08:32 AM, Joao Martins wrote: > Introduce support for VIR_MIGRATE_PEER2PEER in libxl driver > for supporting migration in Openstack. Most of the changes > occur at the source and no modifications at the receiver. > > In P2P mode there is only the Perform phase so we must handle > the

Re: [libvirt] Sign up for wiki?

2015-12-02 Thread Daniel P. Berrange
On Sun, Nov 29, 2015 at 01:26:48AM -0800, Scott Bronson wrote: > Hi, I'd like to update > http://wiki.libvirt.org/page/Networking#Forwarding_Incoming_Connections > > The python script is now a broken link, and there's a better one at > https://github.com/saschpe/libvirt-hook-qemu > > Username of

[libvirt] volume download/upload but for snapshots

2015-12-02 Thread Vasiliy Tolstov
Hi! I'm happy with libvirt volume download/upload ability, but also i need to download snapshot, what is the best way to do that? Define volume from snapshot? Or write libvirt function for this? -- Vasiliy Tolstov, e-mail: v.tols...@selfip.ru -- libvir-list mailing list libvir-list@redhat.com

Re: [libvirt] [PATCH 1/3] conf: Reposition adding SCSI controller for SCSI hostdev hotplug

2015-12-02 Thread Boris Fiuczynski
On 12/01/2015 05:21 PM, John Ferlan wrote: On 11/30/2015 06:05 AM, Boris Fiuczynski wrote: This patch reverts a part of commit 0d8b24f6b. With commits 0d8b24g6 and 0785966d automatically adding a required controller g6 ? I assume you meant f6b... yes had been moved from the domain xml

Re: [libvirt] [PATCH] network: selectively disable -Wcast-align in virNetDevParseDadStatus

2015-12-02 Thread Daniel P. Berrange
On Tue, Dec 01, 2015 at 05:49:10PM -0700, Jim Fehlig wrote: > On 11/30/2015 09:18 PM, Jim Fehlig wrote: > > On 11/26/2015 08:10 AM, Ian Campbell wrote: > >> Commit 0f7436ca54c9 "network: wait for DAD to finish for bridge IPv6 > >> addresses" > >> results in: > >> > >> CC

Re: [libvirt] [PATCH v2 00/10] Make loading domains with invalid XML possible

2015-12-02 Thread lhuang
On 12/02/2015 05:13 PM, Martin Kletzander wrote: On Wed, Dec 02, 2015 at 04:46:20PM +0800, lhuang wrote: On 12/02/2015 01:35 AM, Martin Kletzander wrote: We always had to deal with new parsing errors in a weird way. All of them needed to go into functions starting the domains. That

Re: [libvirt] [libvirt-perl][PATCH] Add VIR_FROM_LOGGING constant

2015-12-02 Thread Daniel P. Berrange
On Wed, Dec 02, 2015 at 10:01:09AM +0100, Michal Privoznik wrote: > Signed-off-by: Michal Privoznik > --- > Virt.xs | 1 + > lib/Sys/Virt/Error.pm | 4 > 2 files changed, 5 insertions(+) ACK, but please add to Changes too to mention the addition

Re: [libvirt] [PATCH] libxl: add support for mounts in HVM guests

2015-12-02 Thread Cedric Bosdonnat
On Tue, 2015-12-01 at 21:59 -0700, Jim Fehlig wrote: > On 12/01/2015 08:04 AM, Cédric Bosdonnat wrote: > > Xen HVM guests are running a QEMU, libxl allows passing QEMU parameters > > in the d_config.b_info.extra list. Take advantage of that to implement > > support for 9pfs mounts. For this to

Re: [libvirt] [PATCH v2 2/2] libxl: implement virDomainInterfaceStats

2015-12-02 Thread Joao Martins
On 12/02/2015 12:45 AM, Jim Fehlig wrote: > On 11/23/2015 11:57 AM, Joao Martins wrote: >> Introduce support for domainInterfaceStats API call for querying >> network interface statistics. Consequently it also enables the >> use of `virsh domifstat ` command plus >> seeing the interfaces names

Re: [libvirt] [PATCH v2 1/2] libxl: rename libxlConsoleCallback

2015-12-02 Thread Joao Martins
On 12/02/2015 12:08 AM, Jim Fehlig wrote: > On 11/23/2015 11:56 AM, Joao Martins wrote: >> . to a more generic name i.e. libxlDomainStartCallback, >> since it will now cover another case other than the console. >> >> Signed-off-by: Joao Martins >> --- >>

Re: [libvirt] [PATCH 00/21] Support NBD for tunnelled migration

2015-12-02 Thread Pavel Boldin
Ping. May I have your attention guys? Pavel On Wed, Nov 18, 2015 at 8:12 PM, Pavel Boldin wrote: > The provided patchset implements NBD disk migration over a tunnelled > connection provided by libvirt. > > The migration source instructs QEMU to NBD mirror drives into the