Re: [libvirt] [PATCH v2] qemu: set fake reboot flag only in acpi mode

2016-07-16 Thread John Ferlan
On 07/14/2016 07:08 AM, Nikolay Shirokovskiy wrote: > First this fixes the same issue as e2b86f580. Only difference is > that reboot is done via shutdown function with reboot semantics. > > Second 8be502fd tells us that we need to always set fake reboot > flag if shutdown/reboot will trigger shu

[libvirt] Minor compile failure on OSX for libvirt 2.0.0

2016-07-16 Thread Justin Clift
Hi all, There's a minor compile failure on OSX with libvirt 2.0.0: CC util/libvirt_util_la-virtime.lo CC util/libvirt_util_la-virtpm.lo util/virsystemd.c:524:26: error: use of undeclared identifier 'MSG_NOSIGNAL' if (sendmsg(fd, &mh, MSG_NOSIGNAL) < 0)

Re: [libvirt] qemu: migration: shall we abort migration while the guest is rebooting?

2016-07-16 Thread Zhangbo (Oscar)
>>> Hi all: >>> Here's the steps we produce the problem: >>> 1 reboot guest with the flag of >VIR_DOMAIN_REBOOT_ACPI_POWER_BTN >>> 2 sleep 1 second (so that the guest is still rebooting, although the API >>already returned.) >>> 3 migrate the guest >>> >>> The problem is that : the gues

[libvirt] [PATCH v4 3/4] perf: add more perf events support

2016-07-16 Thread Qiaowei Ren
With current perf framework, this patch adds support to more perf events, including cache misses, cache references, cpu cycles, instrctions, etc.. Signed-off-by: Qiaowei Ren --- docs/formatdomain.html.in | 24 ++ docs/schemas/domaincommon.rng | 4

[libvirt] [PATCH v4 4/4] perf: add description for new events in virsh.pod

2016-07-16 Thread Qiaowei Ren
This patch add 'domstats --perf' description for new events in virsh.pod. Signed-off-by: Qiaowei Ren --- tools/virsh.pod | 4 1 file changed, 4 insertions(+) diff --git a/tools/virsh.pod b/tools/virsh.pod index d7cd10e..da7f24f 100644 --- a/tools/virsh.pod +++ b/tools/virsh.pod @@ -909,6 +

Re: [libvirt] [PATCH 1/1] perf: add more perf events support

2016-07-16 Thread Ren, Qiaowei
> -Original Message- > From: John Ferlan [mailto:jfer...@redhat.com] > Sent: Wednesday, July 13, 2016 4:02 AM > To: Ren, Qiaowei ; libvir-list@redhat.com > Cc: Peter Krempa > Subject: Re: [libvirt] [PATCH 1/1] perf: add more perf events support > > > > On 06/29/2016 08:10 PM, Qiaowei R

[libvirt] [PATCH v4 0/4] perf: add more perf events support

2016-07-16 Thread Qiaowei Ren
With current perf framework, this patchset refactor virPerfEventEnable() for general purpose and add more perf events support based on this change, including cache misses, cache references, cpu cycles, instrctions, etc.. Changes since v3: * separate the patch into 4 patches. * update virsh.pod

[libvirt] [PATCH v4 1/4] perf: rename qemuDomainGetStatsPerfRdt()

2016-07-16 Thread Qiaowei Ren
This patch rename qemuDomainGetStatsPerfRdt() to qemuDomainGetStatsPerfOneEvent() and update qemuDomainGetStatsPerf() based on this change for multiple/general purpose. Signed-off-by: Qiaowei Ren --- src/qemu/qemu_driver.c | 19 +++ 1 file changed, 7 insertions(+), 12 deletions(-

[libvirt] [PATCH v4 2/4] perf: introduce a static attr table and refactor virPerfEventEnable() for general purpose

2016-07-16 Thread Qiaowei Ren
This patch creates some sort of static table/matrix that would be able to convert the VIR_PERF_EVENT_* into their respective "attr.type" and "attr.config", so that virPerfEventEnable() doesn't have the switch the calling function passes by value the 'type'. This change is for general purpose in fut