On 13.10.2016 00:03, Alberto Ruiz wrote:
> Support for custom dhcp wide and per host leasetime.
>
> It is specified as a child tag for :
>
> 24h
> ...
>
>
> And as an attribute for :
>
>
>
>
> These are the different notations:
>
> -1 (infinite/unlimited lease)
> 120 (seconds are
On Tue, Oct 11, 2016 at 05:13:57PM -0300, Ivan Baldo wrote:
No time to read manpages at home heheh (qemu-img check -r all repaired it very
well though).
If you have just a note that's not supposed to be part of the commit
message, you can put it after
---
^^^ these and it will be part of
On 13.10.2016 05:38, John Ferlan wrote:
>
>
> On 10/05/2016 03:30 AM, Michal Privoznik wrote:
>> Now that our cells in test driver are huge pages aware, we can
>> implement virNodeAllocPages. Basically there's just one catch. If
>> users specify startCell == -1, they want the huge pages change to
On 13.10.2016 05:12, John Ferlan wrote:
>
>
> On 10/05/2016 03:30 AM, Michal Privoznik wrote:
>> In d18c7d7124 we have tried to implement virNodeGetFreePages API
>> to test driver. And for a very limited definition of success we
>> have succeeded. But, we can do better. Firstly, we can teach our
On Wed, Oct 12, 2016 at 09:48:07AM +0200, Peter Krempa wrote:
> On Wed, Oct 12, 2016 at 15:04:53 +1100, Sam Bobroff wrote:
> > At the moment, guests that are backed by hugepages in the host are
> > only able to use policy to control the placement of those hugepages
> > on a per-(guest-)CPU basis. P
On Wed, Oct 12, 2016 at 10:27:50AM +0200, Martin Kletzander wrote:
> On Wed, Oct 12, 2016 at 03:04:53PM +1100, Sam Bobroff wrote:
> >At the moment, guests that are backed by hugepages in the host are
> >only able to use policy to control the placement of those hugepages
> >on a per-(guest-)CPU basi
On 10/12/2016 09:22 AM, Viktor Mihajlovski wrote:
> -BEGIN PGP SIGNED MESSAGE-
> Hash: SHA1
>
> On 12.10.2016 14:42, Peter Krempa wrote:
>> On Wed, Oct 12, 2016 at 14:06:14 +0200, Viktor Mihajlovski wrote:
>>> Currently, the virVcpuInfo returned by virDomainGetVcpus() will
>>> always rep
On 10/10/2016 10:07 AM, Nitesh Konkar wrote:
>
> Nitesh Konkar (2):
> virsh: Fix commas in manpage to enhance readability.
> virsh: Fix typos in manpage
>
> tools/virsh.pod | 24
> 1 file changed, 12 insertions(+), 12 deletions(-)
>
ACK and pushed.
Thanks.
John
On 10/10/2016 04:15 PM, Sławek Kapłoński wrote:
> This new function can be used to check if e.g. name of XML node don't
s/don't/doesn't/
> contains forbidden chars like "/" or new-line.
s/new-line/'\n'
> ---
> src/util/virxml.c | 18 ++
> src/util/virxml.h | 4
> 2 file
On 10/05/2016 03:30 AM, Michal Privoznik wrote:
> Now that our cells in test driver are huge pages aware, we can
> implement virNodeAllocPages. Basically there's just one catch. If
> users specify startCell == -1, they want the huge pages change to
> be stretched over all the nodes. Therefore we
On 10/05/2016 03:30 AM, Michal Privoznik wrote:
> In d18c7d7124 we have tried to implement virNodeGetFreePages API
> to test driver. And for a very limited definition of success we
> have succeeded. But, we can do better. Firstly, we can teach our
> internal representation of a NUMA cell that the
On 10/05/2016 03:30 AM, Michal Privoznik wrote:
> Consider the following scenario:
>
> virsh # freecell --all
> 0: 2048 KiB
> 1: 4096 KiB
>
> Total: 6144 KiB
>
> virsh # freecell 0
> 0: 2048 KiB
>
> virsh # freecell 1
> 1: 4096 K
On 10/05/2016 03:30 AM, Michal Privoznik wrote:
> We have inclination to calling our loop variables i, j, k, not u.
>
> Signed-off-by: Michal Privoznik
> ---
> src/test/test_driver.c | 22 +++---
> 1 file changed, 11 insertions(+), 11 deletions(-)
>
ACK
John
--
libvir-list
On Tue, 2016-10-11 at 10:58 -0400, Dawid Zamirski wrote:
> On Tue, 2016-10-11 at 16:22 +0200, Martin Kletzander wrote:
> > On Wed, Sep 28, 2016 at 01:41:35PM -0400, Dawid Zamirski wrote:
> >
> > The allocation is not guarded by any lock, so there's still a
> > race. I
> > think there should be a
On 09/29/2016 11:15 AM, Jiri Denemark wrote:
On Fri, Sep 23, 2016 at 15:51:12 -0400, Jason J. Herne wrote:
On 09/23/2016 08:05 AM, Jiri Denemark wrote:
The host-model part of the XML will show the result of
query-cpu-model-expansion on "host" model, or the result of querying the
hardware direct
Support for custom dhcp wide and per host leasetime.
It is specified as a child tag for :
24h
...
And as an attribute for :
These are the different notations:
-1 (infinite/unlimited lease)
120 (seconds are the default unit, 120 seconds is the minimum, if less is
specified it will
On Wed, Oct 12, 2016 at 02:12:41PM +0200, Pavel Hrdina wrote:
Pavel Hrdina (17):
qemu_process: move qemuProcessStartValidateGraphics to correct place
qemu_command: remove xenner leftover from video device code
tests: fix some QXL capability combinations that don't make sense
qemu_capabilities
On Wed, Oct 12, 2016 at 02:12:58PM +0200, Pavel Hrdina wrote:
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1369633
Signed-off-by: Pavel Hrdina
---
Changes in v2:
- added bugzilla into commit message
docs/formatdomain.html.in | 3 +-
src/qemu/qemu_domain.c
On 12.10.2016 00:08, Peter Krempa wrote:
> See patch 6/6.
>
>
> Peter Krempa (6):
> util: bitmap: Make bitmaps const in virBitmapNewData and
> virBitmapDataToString
> virsh: domain: Fix broken indentation in virshCPUCountCollect
> virsh: Fix xpath queries for retrieving vcpu count
> v
On Wed, Oct 12, 2016 at 02:12:57PM +0200, Pavel Hrdina wrote:
There are two video devices with models without VGA compatibility mode.
They are primary used as secondary video devices, but in some cases it
is required to use them also as primary video devices.
Signed-off-by: Pavel Hrdina
---
Ne
07-Oct-16 20:09, Olga Krishtal пишет:
On 24/09/16 00:12, John Ferlan wrote:
On 09/23/2016 11:56 AM, Olga Krishtal wrote:
On 21/09/16 19:17, Maxim Nestratov wrote:
20 сент. 2016 г., в 23:52, John Ferlan написал(а):
On 09/15/2016 03:32 AM, Olga Krishtal wrote:
Hi everyone, we would like to
On Wed, Oct 12, 2016 at 02:12:55PM +0200, Pavel Hrdina wrote:
This improves commit 706b5b6277 in a way that we check qemu capabilities
instead of what architecture we are running on to detect whether we can
use *virtio-vga* model or not. This is not a case only for arm/aarch64.
Signed-off-by: P
On Wed, Oct 12, 2016 at 02:12:47PM +0200, Pavel Hrdina wrote:
We generally uses QEMU_CASP_DEVICE_$NAME to probe for existence of some
s/CASP/CAPS/
device and QEMU_CAPS_$NAME_$PROP to probe for existence of some property
of that device.
Signed-off-by: Pavel Hrdina
---
Changes in v2:
- no
On Wed, Oct 12, 2016 at 09:20:29AM -0400, John Ferlan wrote:
>
>
> On 10/12/2016 06:40 AM, Erik Skultety wrote:
> > On Tue, Oct 11, 2016 at 05:25:49PM -0400, John Ferlan wrote:
> >> https://bugzilla.redhat.com/show_bug.cgi?id=1357416
> >>
> >> Rather than return a 0 or -1 and the *result string,
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On 12.10.2016 14:42, Peter Krempa wrote:
> On Wed, Oct 12, 2016 at 14:06:14 +0200, Viktor Mihajlovski wrote:
>> Currently, the virVcpuInfo returned by virDomainGetVcpus() will
>> always report a state of VIR_VCPU_RUNNING for each defined domain
>> vcpu
On Wed, Oct 12, 2016 at 14:06:14 +0200, Viktor Mihajlovski wrote:
> Currently, the virVcpuInfo returned by virDomainGetVcpus() will always
> report a state of VIR_VCPU_RUNNING for each defined domain vcpu even if
> the vcpu is currently in the halted state.
>
> As the monitor interface is in fact
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1369633
Signed-off-by: Pavel Hrdina
---
Changes in v2:
- added bugzilla into commit message
docs/formatdomain.html.in | 3 +-
src/qemu/qemu_domain.c | 3 +-
.../qemuxml2argv-video-v
Commit 21373feb added support for primary virtio-vga device but it was
checking for virtio-gpu. Let's check for existence of virtio-vga if we
want to use it.
Virtio video device is currently represented by three different models
*virtio-gpu-device*, *virtio-gpu-pci* and *virtio-vga*. The first t
Signed-off-by: Pavel Hrdina
---
Changes in v2:
- removed switch that checked whether video type is supported, it is handled
by previous patch
src/qemu/qemu_command.c | 35 ---
1 file changed, 16 insertions(+), 19 deletions(-)
diff --git a/src/qemu/qemu_c
Signed-off-by: Pavel Hrdina
---
ACKed
src/qemu/qemu_command.c | 143 +---
1 file changed, 76 insertions(+), 67 deletions(-)
diff --git a/src/qemu/qemu_command.c b/src/qemu/qemu_command.c
index e590f2b..64b603d 100644
--- a/src/qemu/qemu_command.c
+++
Runtime validation that depend on qemu capabilities should be moved
into qemuProcessStartValidateXML.
Signed-off-by: Pavel Hrdina
---
Changes in v2:
- now it only moves the validation, there is no other side effect
src/qemu/qemu_command.c | 33 +
src/qemu/qe
This patch simplifies QEMU capabilities for QXL video device. QEMU
exposes this device as *qxl-vga* and *qxl* and they are both the same
device with the same set of parameters, the only difference is that
*qxl-vga* includes VGA compatibility.
Based on QEMU code they are tied together so it's safe
Signed-off-by: Pavel Hrdina
---
New in v2
src/qemu/qemu_command.c | 30 +++---
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/src/qemu/qemu_command.c b/src/qemu/qemu_command.c
index 64b603d..97e6e37 100644
--- a/src/qemu/qemu_command.c
+++ b/src/qemu/qem
This improves commit 706b5b6277 in a way that we check qemu capabilities
instead of what architecture we are running on to detect whether we can
use *virtio-vga* model or not. This is not a case only for arm/aarch64.
Signed-off-by: Pavel Hrdina
---
ACKed
Changes in v2:
- improved commit me
If QEMU in question supports QMP, this capability is set if
QEMU_CAPS_DEVICE_QXL was set based on existence of "-device qxl". If
libvirt needs to parse *help*, because there is no QMP support, it
checks for existence of "-vga qxl", but it also parses output of
"-device ?" and sets QEMU_CAPS_DEVICE_
All definition validation that doesn't depend on qemu capabilities
and was allowed previously as valid definition should be placed into
qemuDomainDefValidate.
The check whether video type is supported or not was based on an enum
that translates type into model. Use switch to ensure that if new
vi
If one of QEMU_CAPS_DEVICE_QXL_VGA or QEMU_CAPS_DEVICE_QXL is set the
other one will always be set as well because both devices are tied
together in QEMU.
The change of args files is caused by the presence of capability
QEMU_CAPS_DEVICE_VIDEO_PRIMARY which means it's safe to use
"-device qxl-vga"
Pavel Hrdina (17):
qemu_process: move qemuProcessStartValidateGraphics to correct place
qemu_command: remove xenner leftover from video device code
tests: fix some QXL capability combinations that don't make sense
qemu_capabilities: join capabilities for qxl and qxl-vga devices
qemu_capab
Qemu supports *xen* video device only with XEN and this code was part
of xenner code. We dropped support for xenner in commit de9be0a.
Before this patch if you used 'xen' video type you ended up with
domain without any video device at all. Now we don't allow to start
such domain.
Signed-off-by:
We generally uses QEMU_CASP_DEVICE_$NAME to probe for existence of some
device and QEMU_CAPS_$NAME_$PROP to probe for existence of some property
of that device.
Signed-off-by: Pavel Hrdina
---
Changes in v2:
- no it only renames the capability
src/qemu/qemu_capabilities.c | 2 +-
src/qemu/
There are two video devices with models without VGA compatibility mode.
They are primary used as secondary video devices, but in some cases it
is required to use them also as primary video devices.
Signed-off-by: Pavel Hrdina
---
New in v2, it was removed from next patch.
src/qemu/qemu_command
Before this patch we've checked qemu capabilities for video devices
only while constructing qemu command line using "-device" option.
Since we support qemu only if "-device" option is present we can use
the same capabilities to check also video devices while using "-vga"
option to construct qemu c
Signed-off-by: Pavel Hrdina
---
New in v2
src/qemu/qemu_capabilities.c | 2 +
.../qemucapabilitiesdata/caps_1.2.2.x86_64.replies | 30 ++
.../qemucapabilitiesdata/caps_1.3.1.x86_64.replies | 28 ++
.../qemucapabilitiesdata/caps_1.4.2.x86_64.replies | 30 ++
Signed-off-by: Pavel Hrdina
---
New in v2, this was moved out of another patch.
src/qemu/qemu_process.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/src/qemu/qemu_process.c b/src/qemu/qemu_process.c
index a4bc082..ea60941 100644
--- a/src/qemu/qemu_process.c
+++ b/src
Adding a field to the domain's private vcpu object to hold the halted
state information.
Adding two functions in support of the halted state:
- qemuDomainGetVcpuHalted: retrieve the halted state from a
private vcpu object
- qemuDomainRefreshVcpuHalted: obtain the per-vcpu halted states
via qemu
Refresh the VCPU halted states in API functions returning domain
VCPU state information to make sure it's current. This affects
qemuDomainGetVcpus and qemuDomainGetStatsVcpu
Signed-off-by: Viktor Mihajlovski
Reviewed-by: Bjoern Walk
Reviewed-by: Hao QingFeng
Signed-off-by: Boris Fiuczynski
--
QEMU virtual CPUs can assume a halted state, which - depending on
the architecture - can indicate whether a CPU is in use by the
guest operating system.
A new VCPU state halted is introduced in preparation of the
support in the QEMU driver (and optionally others where deemed
appropriate).
Signed-
Currently, the virVcpuInfo returned by virDomainGetVcpus() will always
report a state of VIR_VCPU_RUNNING for each defined domain vcpu even if
the vcpu is currently in the halted state.
As the monitor interface is in fact reporting the accurate state, it is
rather easy to transport this informatio
Extended the qemuMonitorCPUInfo with a halted flag. Extract the halted
flag for both text and JSON monitor.
Signed-off-by: Viktor Mihajlovski
Signed-off-by: Boris Fiuczynski
---
V3 Changes:
- redundant comments removed
- halted default set to false, so original behavior is retained
src/qemu/qe
On Tue, Oct 11, 2016 at 03:44:45PM -0400, Dawid Zamirski wrote:
On Tue, 2016-10-11 at 10:58 -0400, Dawid Zamirski wrote:
On Tue, 2016-10-11 at 16:22 +0200, Martin Kletzander wrote:
> On Wed, Sep 28, 2016 at 01:41:35PM -0400, Dawid Zamirski wrote:
>
> I don't understand how vbox works, but if i
2016-10-12 5:19 GMT+03:00 Michal Privoznik :
> Unfortunately, I don't have a setup to try this out. The code looks
> okay, however the commit you are referring to says that there might be
> some problems with storing memory into RBD image. So is that the case?
> Because if it is, we might not want
On Wed, Oct 12, 2016 at 05:09:44PM +0800, Michal Privoznik wrote:
On 11.10.2016 20:53, Martin Kletzander wrote:
To go with the Deregister version as well.
Signed-off-by: Martin Kletzander
---
src/libvirt_private.syms | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/libvirt_private.syms
On 11.10.2016 20:53, Martin Kletzander wrote:
> There should be one more reference because it is being kept in the list
> of callbacks as an opaque. We also unref it properly using
> virObjectFreeCallback.
>
> Signed-off-by: Martin Kletzander
> ---
> src/conf/object_event.c | 4 +++-
> 1 file c
On 11.10.2016 20:53, Martin Kletzander wrote:
> This way we get reference counting and we can get rid of locking
> function.
>
> Signed-off-by: Martin Kletzander
> ---
> src/bhyve/bhyve_driver.c | 2 +-
> src/conf/object_event.c| 99
> +++--
On 11.10.2016 20:53, Martin Kletzander wrote:
> If the last event callback is unregistered while the event loop is
> dispatching, it is only marked as deleted, but not removed. The number
> of callbacks is more than zero in that case, so the timer is not
> removed. Because it can be removed in th
On 11.10.2016 20:53, Martin Kletzander wrote:
> To go with the Deregister version as well.
>
> Signed-off-by: Martin Kletzander
> ---
> src/libvirt_private.syms | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms
> index d92d3d865307..fd6
On 11.10.2016 20:53, Martin Kletzander wrote:
> There is a repeating pattern of code that removes the timer if it's not
> needed. So let's move it to a new function. We'll also use it later.
>
> Signed-off-by: Martin Kletzander
> ---
> src/conf/object_event.c | 34 ++---
On 10/12/2016 10:13 AM, Peter Krempa wrote:
On Mon, Sep 26, 2016 at 13:16:00 -0400, Corey S. McQuay wrote:
Currently Libvirt allows attempts to migrate read only disks. Qemu cannot
handle this as read only
disks cannot be written to on the destination system. The end result is a
cryptic error
On Wed, Oct 12, 2016 at 03:04:53PM +1100, Sam Bobroff wrote:
At the moment, guests that are backed by hugepages in the host are
only able to use policy to control the placement of those hugepages
on a per-(guest-)CPU basis. Policy applied globally is ignored.
Such guests would use and
a block
On Mon, Sep 26, 2016 at 13:16:00 -0400, Corey S. McQuay wrote:
> Currently Libvirt allows attempts to migrate read only disks. Qemu cannot
> handle this as read only
> disks cannot be written to on the destination system. The end result is a
> cryptic error message
> and a failed migration.
>
>
On Wed, Oct 12, 2016 at 15:04:53 +1100, Sam Bobroff wrote:
> At the moment, guests that are backed by hugepages in the host are
> only able to use policy to control the placement of those hugepages
> on a per-(guest-)CPU basis. Policy applied globally is ignored.
>
> Such guests would use and
> a
61 matches
Mail list logo