Re: [libvirt] [PATCH 03/15] tests: qemucaps: Update ppc64 replies for qemu 2.6.0 release

2016-10-20 Thread Peter Krempa
On Thu, Oct 20, 2016 at 14:22:54 -0500, Eric Blake wrote: > On 10/20/2016 10:24 AM, Peter Krempa wrote: > > From: Andrea Bolognani > > > > Sync up to the released version of qemu. > > > > Signed-off-by: Peter Krempa > > --- > >

Re: [libvirt] [PATCH] virt-wireshark.m4: Defer $(prefix) substitution

2016-10-20 Thread Michal Privoznik
On 20.10.2016 22:33, Andrea Bolognani wrote: > On Thu, 2016-10-20 at 15:54 +0800, Michal Privoznik wrote: >> The problem with evaluating $(prefix) in configure phase is that >> autoconf does a lot of magic with this variable. Firstly, if the >> --prefix argument is not set for the configure

Re: [libvirt] [RFC] Toward a better NEWS file

2016-10-20 Thread Michal Privoznik
On 19.10.2016 19:58, Daniel P. Berrange wrote: > On Wed, Oct 19, 2016 at 01:53:41PM +0200, Andrea Bolognani wrote: >> Hi, >> >> > > Why don't we simply have a NEWS file in GIT, and require that > non-trivial commits or patch series include an update to NEWS, > so the NEWS file gets populated at

Re: [libvirt] [PATCH v10 3/4] qemu: Add a secret object to/for a chardev tcp with secret

2016-10-20 Thread John Ferlan
[...] >> >> @@ -8546,6 +8561,18 @@ qemuBuildSerialCommandLine(virLogManagerPtr >> logManager, >> >> /* Use -chardev with -device if they are available */ >> if (virQEMUCapsSupportsChardev(def, qemuCaps, serial)) { >> +qemuDomainChardevPrivatePtr chardevPriv =

Re: [libvirt] [PATCH 15/15] qemu: command: Add debug option for gluster volumes

2016-10-20 Thread Eric Blake
On 10/20/2016 10:25 AM, Peter Krempa wrote: > From: Prasanna Kumar Kalever > > Propagate the selected or default level to qemu if it's supported. > > Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1376009 > > Signed-off-by: Prasanna Kumar Kalever

Re: [libvirt] [PATCH 14/15] qemu: conf: add option for tuning debug logging level

2016-10-20 Thread Eric Blake
On 10/20/2016 10:25 AM, Peter Krempa wrote: > From: Prasanna Kumar Kalever > > This helps in selecting log level of the gluster gfapi, output to stderr. > The option is 'gluster_debug_level', can be tuned by editing > '/etc/libvirt/qemu.conf' > > Debug levels ranges

Re: [libvirt] [PATCH 11/15] qemu: capabilities: Detect support for gluster debug setting

2016-10-20 Thread Eric Blake
On 10/20/2016 10:25 AM, Peter Krempa wrote: > From: Prasanna Kumar Kalever > > Teach qemu driver to detect whether qemu supports specifying debug level > for gluster volumes. > > Signed-off-by: Prasanna Kumar Kalever > Signed-off-by:

Re: [libvirt] [PATCH 10/15] qemu: capabilities: Add support for QMP schema introspection

2016-10-20 Thread Eric Blake
On 10/20/2016 10:25 AM, Peter Krempa wrote: > Allow detecting capabilities according to the qemu QMP schema. This is > necessary as sometimes the availability of certain options depends on > the presence of a field in the schema. > > This patch adds support for loading the QMP schema when

Re: [libvirt] [PATCH v10 2/4] domain: Add optional 'tls' attribute for TCP chardev

2016-10-20 Thread John Ferlan
[...] + + Since 2.4.0, the optional attribute + tls can be used to control whether a serial chardev + TCP communication channel would utilize a hypervisor configured + TLS X.509 certificate environment in order to encrypt the data +

Re: [libvirt] [PATCH 02/15] qemu: monitor: Add code to retrieve and store QMP schema data

2016-10-20 Thread Eric Blake
On 10/20/2016 10:24 AM, Peter Krempa wrote: > Call 'query-qmp-schema' and store the returned types in a hash table > keyed by the 'name' field so that the capabilities code can traverse it. > --- > src/qemu/qemu_monitor.c | 11 > src/qemu/qemu_monitor.h | 2 ++ >

Re: [libvirt] [PATCH 03/15] tests: qemucaps: Update ppc64 replies for qemu 2.6.0 release

2016-10-20 Thread Eric Blake
On 10/20/2016 10:24 AM, Peter Krempa wrote: > From: Andrea Bolognani > > Sync up to the released version of qemu. > > Signed-off-by: Peter Krempa > --- > .../qemucapabilitiesdata/caps_2.6.0.ppc64le.replies | 21 > +++-- >

Re: [libvirt] [PATCH 09/15] tests: qemucaps: Temporarily remove 'query-qmp-schema' from test data

2016-10-20 Thread Eric Blake
On 10/20/2016 10:25 AM, Peter Krempa wrote: > Remove the command from the supported commands list temporarily so that > QMP introspection code can be added without breaking tests and having to > tweak the test data in the same commit. > > This will be later reverted and test data will be added.

Re: [libvirt] [PATCH 05/15] tests: qemucaps: Add QMP introspection data for qemu 2.5.0 on x86

2016-10-20 Thread Eric Blake
On 10/20/2016 10:24 AM, Peter Krempa wrote: > From: Pavel Hrdina > > Add output of 'query-qmp-schema' to the capabilities test. > > Signed-off-by: Peter Krempa > --- > .../qemucapabilitiesdata/caps_2.5.0.x86_64.replies | 7545 > >

[libvirt] [REPOST] regarding cgroup v2 support in libvirt

2016-10-20 Thread Tejun Heo
(reposting w/ libvir-list cc'd, sorry about the delay in reposting, was traveling and then on vacation) Hello, Daniel. How have you been? We (facebook) are deploying cgroup v2 and internally use libvirt to manage virtual machines, so I'm trying to add cgroup v2 support to libvirt. Because

Re: [libvirt] [PATCH 02/15] qemu: monitor: Add code to retrieve and store QMP schema data

2016-10-20 Thread Eric Blake
On 10/20/2016 10:24 AM, Peter Krempa wrote: > Call 'query-qmp-schema' and store the returned types in a hash table > keyed by the 'name' field so that the capabilities code can traverse it. > --- > src/qemu/qemu_monitor.c | 11 > src/qemu/qemu_monitor.h | 2 ++ >

Re: [libvirt] [PATCH 01/15] util: json: add helper to iterate and steal members of json array

2016-10-20 Thread Eric Blake
On 10/20/2016 10:24 AM, Peter Krempa wrote: > Simplifies cases where JSON array members need to be transferred to a > different structure. > --- > src/libvirt_private.syms | 1 + > src/util/virjson.c | 36 > src/util/virjson.h | 6 ++ > 3

Re: [libvirt] on shutdown

2016-10-20 Thread Martin Kletzander
On Thu, Oct 20, 2016 at 11:26:09AM +0200, Ruben Kerkhof wrote: Hi all, virsh(1) has this to say about virsh shutdown: "The exact behavior of a domain when it shuts down is set by the on_shutdown parameter in the domain's XML definition." on_shutdown isn't documented in

Re: [libvirt] [PATCH v10 2/4] domain: Add optional 'tls' attribute for TCP chardev

2016-10-20 Thread Pavel Hrdina
On Thu, Oct 20, 2016 at 10:28:04AM -0400, John Ferlan wrote: > > > On 10/20/2016 02:51 AM, Pavel Hrdina wrote: > > On Wed, Oct 19, 2016 at 04:53:54PM -0400, John Ferlan wrote: > >> Add an optional "tls='yes|no'" attribute for a TCP chardev. > >> > >> For QEMU, this will allow for disabling the

[libvirt] [PATCH 05/15] tests: qemucaps: Add QMP introspection data for qemu 2.5.0 on x86

2016-10-20 Thread Peter Krempa
From: Pavel Hrdina Add output of 'query-qmp-schema' to the capabilities test. Signed-off-by: Peter Krempa --- .../qemucapabilitiesdata/caps_2.5.0.x86_64.replies | 7545 1 file changed, 7545 insertions(+) diff --git

[libvirt] [PATCH 00/15] qemu: Add QMP schema introspection and use it to add gluster debug setting

2016-10-20 Thread Peter Krempa
Add support for QMP schema introspection along with test data adding and fixup and use it to detect support for gluster debug setting in qemu. Thanks to Andrea and Pavel for gathering test data for me so I don't have to compile multiple qemu versions or deal with minority architectures. (I

[libvirt] [PATCH 02/15] qemu: monitor: Add code to retrieve and store QMP schema data

2016-10-20 Thread Peter Krempa
Call 'query-qmp-schema' and store the returned types in a hash table keyed by the 'name' field so that the capabilities code can traverse it. --- src/qemu/qemu_monitor.c | 11 src/qemu/qemu_monitor.h | 2 ++ src/qemu/qemu_monitor_json.c | 67

[libvirt] [PATCH 15/15] qemu: command: Add debug option for gluster volumes

2016-10-20 Thread Peter Krempa
From: Prasanna Kumar Kalever Propagate the selected or default level to qemu if it's supported. Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1376009 Signed-off-by: Prasanna Kumar Kalever Signed-off-by: Peter Krempa

[libvirt] [PATCH 11/15] qemu: capabilities: Detect support for gluster debug setting

2016-10-20 Thread Peter Krempa
From: Prasanna Kumar Kalever Teach qemu driver to detect whether qemu supports specifying debug level for gluster volumes. Signed-off-by: Prasanna Kumar Kalever Signed-off-by: Peter Krempa ---

[libvirt] [PATCH 10/15] qemu: capabilities: Add support for QMP schema introspection

2016-10-20 Thread Peter Krempa
Allow detecting capabilities according to the qemu QMP schema. This is necessary as sometimes the availability of certain options depends on the presence of a field in the schema. This patch adds support for loading the QMP schema when detecting qemu capabilities and adds a very simple query

[libvirt] [PATCH 09/15] tests: qemucaps: Temporarily remove 'query-qmp-schema' from test data

2016-10-20 Thread Peter Krempa
Remove the command from the supported commands list temporarily so that QMP introspection code can be added without breaking tests and having to tweak the test data in the same commit. This will be later reverted and test data will be added. The aarch64 code is special as it calls additional

[libvirt] [PATCH 14/15] qemu: conf: add option for tuning debug logging level

2016-10-20 Thread Peter Krempa
From: Prasanna Kumar Kalever This helps in selecting log level of the gluster gfapi, output to stderr. The option is 'gluster_debug_level', can be tuned by editing '/etc/libvirt/qemu.conf' Debug levels ranges 0-9, with 9 being the most verbose, and 0 representing no

[libvirt] [PATCH 04/15] tests: qemucaps: Update aarch64 gicv2 replies for qemu 2.6.0 release

2016-10-20 Thread Peter Krempa
From: Andrea Bolognani Sync up to the released version of qemu. Signed-off-by: Peter Krempa --- tests/qemucapabilitiesdata/caps_2.6.0-gicv2.aarch64.replies | 13 - tests/qemucapabilitiesdata/caps_2.6.0-gicv2.aarch64.xml | 2 +- 2 files

[libvirt] [PATCH 03/15] tests: qemucaps: Update ppc64 replies for qemu 2.6.0 release

2016-10-20 Thread Peter Krempa
From: Andrea Bolognani Sync up to the released version of qemu. Signed-off-by: Peter Krempa --- .../qemucapabilitiesdata/caps_2.6.0.ppc64le.replies | 21 +++-- tests/qemucapabilitiesdata/caps_2.6.0.ppc64le.xml | 4 +++- 2 files

[libvirt] [PATCH 01/15] util: json: add helper to iterate and steal members of json array

2016-10-20 Thread Peter Krempa
Simplifies cases where JSON array members need to be transferred to a different structure. --- src/libvirt_private.syms | 1 + src/util/virjson.c | 36 src/util/virjson.h | 6 ++ 3 files changed, 43 insertions(+) diff --git

Re: [libvirt] [PATCH] xenFormatXLDisk: Fix commas for arguments

2016-10-20 Thread Michal Privoznik
On 20.10.2016 22:27, Ján Tomko wrote: > On Thu, Oct 20, 2016 at 10:16:05PM +0800, Michal Privoznik wrote: >> instead of: >> >> virBufferAdd(buf, "arg1,"); >> virBufferAdd(buf, "arg2"); >> >> lets have: >> >> virBufferAdd(buf, "arg1"); >> virBufferAdd(buf, ",arg2"); >> > > Why? Because it's

Re: [libvirt] [PATCH] virt-wireshark.m4: Defer $(prefix) substitution

2016-10-20 Thread Andrea Bolognani
On Thu, 2016-10-20 at 15:54 +0800, Michal Privoznik wrote: > The problem with evaluating $(prefix) in configure phase is that > autoconf does a lot of magic with this variable. Firstly, if the > --prefix argument is not set for the configure script, the > variable will have value "NONE". Wait,

[libvirt] [PATCH] xenFormatXLDisk: Fix commas for arguments

2016-10-20 Thread Michal Privoznik
instead of: virBufferAdd(buf, "arg1,"); virBufferAdd(buf, "arg2"); lets have: virBufferAdd(buf, "arg1"); virBufferAdd(buf, ",arg2"); Signed-off-by: Michal Privoznik --- src/xenconfig/xen_xl.c | 32 1 file changed, 16 insertions(+), 16

Re: [libvirt] [PATCH v10 2/4] domain: Add optional 'tls' attribute for TCP chardev

2016-10-20 Thread John Ferlan
On 10/20/2016 02:51 AM, Pavel Hrdina wrote: > On Wed, Oct 19, 2016 at 04:53:54PM -0400, John Ferlan wrote: >> Add an optional "tls='yes|no'" attribute for a TCP chardev. >> >> For QEMU, this will allow for disabling the host config setting of the >> 'chardev_tls' for a domain chardev channel by

Re: [libvirt] [PATCH] xenFormatXLDisk: Fix commas for arguments

2016-10-20 Thread Ján Tomko
On Thu, Oct 20, 2016 at 10:16:05PM +0800, Michal Privoznik wrote: instead of: virBufferAdd(buf, "arg1,"); virBufferAdd(buf, "arg2"); lets have: virBufferAdd(buf, "arg1"); virBufferAdd(buf, ",arg2"); Why? Jan signature.asc Description: Digital signature -- libvir-list mailing list

Re: [libvirt] [PATCH 1/2] util: qemu: make qemuSafeSerialParamValue function usable by other drivers

2016-10-20 Thread Mikhail Feoktistov
On 20.10.2016 14:09, Maxim Nestratov wrote: Rename qemuSafeSerialParamValue to virSafeSerialParamValue and move it to utils Signed-off-by: Maxim Nestratov --- src/libvirt_private.syms | 1 + src/qemu/qemu_command.c | 19 +-- src/util/virutil.c

Re: [libvirt] [PATCH v4 0/3] Forbid new-line char in name of networks

2016-10-20 Thread Sławek Kapłoński
Hello, -- Best regards / Pozdrawiam Sławek Kapłoński sla...@kaplonski.pl On Thu, 20 Oct 2016, Michal Privoznik wrote: > On 20.10.2016 04:57, Sławek Kapłoński wrote: > > v3: http://www.redhat.com/archives/libvir-list/2016-October/msg00627.html > > > > Differences in v4: > > * function to check

Re: [libvirt] [PATCH 2/2] vz: support setting disk serial number

2016-10-20 Thread Mikhail Feoktistov
On 20.10.2016 14:09, Maxim Nestratov wrote: Signed-off-by: Maxim Nestratov --- src/vz/vz_sdk.c | 19 +++ src/vz/vz_utils.c | 5 - 2 files changed, 19 insertions(+), 5 deletions(-) diff --git a/src/vz/vz_sdk.c b/src/vz/vz_sdk.c index

[libvirt] [PATCH 0/2] qemu: util: vz: support setting disk serial number

2016-10-20 Thread Maxim Nestratov
The first patch is a preparation moving qemuSafeSerialParamValue to util, the second implements disk serial number setting in vz driver. Maxim Nestratov (2): util: qemu: make qemuSafeSerialParamValue function usable by other drivers vz: support setting disk serial number

[libvirt] [PATCH 2/2] vz: support setting disk serial number

2016-10-20 Thread Maxim Nestratov
Signed-off-by: Maxim Nestratov --- src/vz/vz_sdk.c | 19 +++ src/vz/vz_utils.c | 5 - 2 files changed, 19 insertions(+), 5 deletions(-) diff --git a/src/vz/vz_sdk.c b/src/vz/vz_sdk.c index b5b0197..f27441d 100644 --- a/src/vz/vz_sdk.c +++

[libvirt] [PATCH 1/2] util: qemu: make qemuSafeSerialParamValue function usable by other drivers

2016-10-20 Thread Maxim Nestratov
Rename qemuSafeSerialParamValue to virSafeSerialParamValue and move it to utils Signed-off-by: Maxim Nestratov --- src/libvirt_private.syms | 1 + src/qemu/qemu_command.c | 19 +-- src/util/virutil.c | 16 src/util/virutil.h

Re: [libvirt] [PATCH 00/10] qemu: agent: bugfix and improvments

2016-10-20 Thread Nikolay Shirokovskiy
ping On 04.10.2016 09:56, Nikolay Shirokovskiy wrote: > Patch 1 fixes the bug I dealt with. > Patches 2-3 is a somewhat protection from similar bugs. > Patches 5-6 drop error flag from the agent altogether, so >now there are less places for bugs to lurk. > Rest patches cleanup loop function.

Re: [libvirt] [PATCH 1/3] util: Add function to check if string contains some illegal chars

2016-10-20 Thread Michal Privoznik
On 20.10.2016 04:57, Sławek Kapłoński wrote: > This new function can be used to check if e.g. name of XML > node don't contains forbidden chars like "/" or "\n". > --- > src/libvirt_private.syms | 1 + > src/util/virxml.c| 28 > src/util/virxml.h| 3

Re: [libvirt] [PATCH v4 0/3] Forbid new-line char in name of networks

2016-10-20 Thread Michal Privoznik
On 20.10.2016 04:57, Sławek Kapłoński wrote: > v3: http://www.redhat.com/archives/libvir-list/2016-October/msg00627.html > > Differences in v4: > * function to check string moved from src/util/virstring to src/util/virxml > > Sławek Kapłoński (3): > util: Add function to check if string

Re: [libvirt] [PATCH 2/3] Use new util function to check network name

2016-10-20 Thread Michal Privoznik
On 20.10.2016 04:57, Sławek Kapłoński wrote: > New util function virXMLNodeHasIllegalChars is now used to test if > parsed network contains illegal char '/' in it's name. > --- > src/conf/network_conf.c | 5 + > 1 file changed, 1 insertion(+), 4 deletions(-) > > diff --git

Re: [libvirt] [PATCH 3/3] Forbid new-line char in name of new networks

2016-10-20 Thread Michal Privoznik
On 20.10.2016 04:57, Sławek Kapłoński wrote: > New line character in name of network is now forbidden because it > mess virsh output and can be confusing for users. > Validation of name is done in network driver, after parsing XML to avoid > problems with dissappeared network which was already

[libvirt] on shutdown

2016-10-20 Thread Ruben Kerkhof
Hi all, virsh(1) has this to say about virsh shutdown: "The exact behavior of a domain when it shuts down is set by the on_shutdown parameter in the domain's XML definition." on_shutdown isn't documented in https://libvirt.org/formatdomain.html Is the virsh(1) manpage wrong? Kind regards,

[libvirt] [PATCH jenkins-ci] Remove builders for Fedora 21/22 and add 24

2016-10-20 Thread Daniel P. Berrange
Signed-off-by: Daniel P. Berrange --- Pushed as a CI build fix due to RPM spec dropping 21/22 projects/libosinfo.yaml | 3 +-- projects/libvirt-cim.yaml | 3 +-- projects/libvirt-glib.yaml| 3 +-- projects/libvirt-perl.yaml| 3 +--

[libvirt] [PATCH] virt-wireshark.m4: Defer $(prefix) substitution

2016-10-20 Thread Michal Privoznik
The problem with evaluating $(prefix) in configure phase is that autoconf does a lot of magic with this variable. Firstly, if the --prefix argument is not set for the configure script, the variable will have value "NONE". Wait, wat? Secondly, even autoconf scripts then have special cases for when

Re: [libvirt] [PATCH] xl: don't output (null) target in domxml-to-native

2016-10-20 Thread Michal Privoznik
On 20.10.2016 02:23, John Ferlan wrote: > > > On 10/19/2016 06:10 AM, Cédric Bosdonnat wrote: >> When converting a domain xml containing a CDROM device without >> any attached source, don't add a target=(null) to the libxl config >> disk definition: xen doesn't like it at all and would fail to

Re: [libvirt] [RFC] Toward a better NEWS file

2016-10-20 Thread Andrea Bolognani
On Wed, 2016-10-19 at 21:40 +0200, Martin Kletzander wrote: > > > I understood it like this: > > >   > > >   - stop generating NEWS file > > >   - populate NEWS file with notable features/bug-fixes along with the > > > changes themselves > > >   - use NEWS to make nice news.html > >  > > Why

Re: [libvirt] [PATCH v10 2/4] domain: Add optional 'tls' attribute for TCP chardev

2016-10-20 Thread Pavel Hrdina
On Thu, Oct 20, 2016 at 08:51:45AM +0200, Pavel Hrdina wrote: > On Wed, Oct 19, 2016 at 04:53:54PM -0400, John Ferlan wrote: > > Add an optional "tls='yes|no'" attribute for a TCP chardev. > > > > For QEMU, this will allow for disabling the host config setting of the > > 'chardev_tls' for a

Re: [libvirt] [PATCH v10 3/4] qemu: Add a secret object to/for a chardev tcp with secret

2016-10-20 Thread Pavel Hrdina
On Wed, Oct 19, 2016 at 04:53:55PM -0400, John Ferlan wrote: > Add the secret object prior to the chardev tcp so the 'passwordid=' can > be added if the domain XML has a for the chardev TLS. > > Signed-off-by: John Ferlan > --- > src/qemu/qemu_command.c

Re: [libvirt] [PATCH v10 2/4] domain: Add optional 'tls' attribute for TCP chardev

2016-10-20 Thread Pavel Hrdina
On Wed, Oct 19, 2016 at 04:53:54PM -0400, John Ferlan wrote: > Add an optional "tls='yes|no'" attribute for a TCP chardev. > > For QEMU, this will allow for disabling the host config setting of the > 'chardev_tls' for a domain chardev channel by setting the value to "no" or > to attempt to use a