[libvirt] [PATCH] qemu: Make sure shmem memory is shared

2016-11-09 Thread Martin Kletzander
Even though using /dev/shm/asdf as the backend, we still need to make the mapping shared. The original patch forgot to add that parameter. Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1392031 Signed-off-by: Martin Kletzander --- src/qemu/qemu_command.c

[libvirt] [PATCH 2/2 v2] conf: List only online cpus for virsh emulatorpin

2016-11-09 Thread Nitesh Konkar
Currently when the vcpu placement is static and cpuset is not specified, CPU Affinity under virsh emulatorpin shows 0..CPUMAX. This patchset will result in display of only online CPU's under CPU Affinity on linux. Signed-off-by: Nitesh Konkar ---

[libvirt] [PATCH 1/2 v2] conf: List only online cpus for virsh vcpupin

2016-11-09 Thread Nitesh Konkar
Currently when the vcpu placement is static and cpuset is not specified, CPU Affinity under virsh vcpupin shows 0..CPUMAX. This patchset will result in display of only online CPU's under CPU Affinity on linux. Signed-off-by: Nitesh Konkar --- src/conf/domain_conf.c

[libvirt] [PATCH 0/2 v2] List only online cpus for vcpupin/emulatorpin when vcpu placement static

2016-11-09 Thread Nitesh Konkar
Currently when the vcpu placement is static and cpuset is not specified, CPU Affinity shows 0.. CPUMAX. This patchset will result in display of only online CPU's under CPU Affinity on linux. Nitesh Konkar (2): conf: List only online cpus for virsh vcpupin conf: List only online cpus for

Re: [libvirt] [PATCH 0/4] introduce virCheckControllerGoto to simplify cgroup controller check

2016-11-09 Thread Chen Hanxiao
At 2016-11-04 11:09:16, "Chen Hanxiao" wrote: >We had a lot of codes use the same style of cgroup controller check. >This series introduce macro virCheckControllerGoto >to simplify these kinds of check. > ping Regards, - Chen -- libvir-list mailing list

Re: [libvirt] [PATCH 1/4] conf: Allow specifying only the slot number for hotpluggable memory

2016-11-09 Thread John Ferlan
On 11/03/2016 02:12 AM, Peter Krempa wrote: > Simplify handling of the 'dimm' address element by allowing to specify > the slot number only. This will allow libvirt to allocate slot numbers > before starting qemu. > --- > src/conf/domain_conf.c | 18 >

Re: [libvirt] [PATCH 2/4] qemu: process: detect if dimm aliases are broken on reconnect

2016-11-09 Thread John Ferlan
On 11/03/2016 02:12 AM, Peter Krempa wrote: > Detect on reconnect to a running qemu VM whether the alias of a > hotpluggable memory device (dimm) does not match the dimm slot number > where it's connected to. This is necessary as qemu is actually > considering the alias as machine ABI used to

Re: [libvirt] [PATCH 4/4] qemu: Generate memory device aliases according to slot number

2016-11-09 Thread John Ferlan
On 11/03/2016 02:12 AM, Peter Krempa wrote: > The memory device alias needs to be treated as machine ABI as qemu is > using it in the migration stream for section labels. To simplify this > generate the alias from the slot number unless an existing broken > configuration is detected. > > With

Re: [libvirt] [PATCH 3/4] qemu: Assign slots to memory devices prior to usage

2016-11-09 Thread John Ferlan
On 11/03/2016 02:12 AM, Peter Krempa wrote: > As with other devices assign the slot number right away when adding the > device. This will make the slot numbers static as we do with other > addressing elements and it will ultimately simplify allocation of the > alias in a static way which does

Re: [libvirt] [PATCH v6 10/17] qemu: auto-add pcie-root-port/dmi-to-pci-bridge controllers as needed

2016-11-09 Thread Laine Stump
On 11/09/2016 09:19 AM, Andrea Bolognani wrote: On Mon, 2016-11-07 at 14:50 -0500, Laine Stump wrote: Previously libvirt would only add pci-bridge devices automatically when an address was requested for a device that required a legacy PCI slot and none was available. This patch expands that

Re: [libvirt] [PATCH] xen: remove legacy hack for RHEL-5 Xen

2016-11-09 Thread Pavel Hrdina
On Wed, Nov 09, 2016 at 05:30:02PM +, Daniel P. Berrange wrote: > We dropped support for RHEL-5 vintage Xen a while ago, > but forgot to remove some of the hacks for it. > > Signed-off-by: Daniel P. Berrange > --- > configure.ac | 8 >

Re: [libvirt] [PATCH] configure: remove fallback check for parted

2016-11-09 Thread Pavel Hrdina
On Wed, Nov 09, 2016 at 05:29:50PM +, Daniel P. Berrange wrote: > Since we no longer support building on RHEL-5, we can > drop the non-pkg-config based check for parted. > > Signed-off-by: Daniel P. Berrange > --- > configure.ac | 12 > 1 file changed, 12

Re: [libvirt] [PATCH v6 14/17] [ACKED] qemu: try to put ich9 sound device at 00:1B.0

2016-11-09 Thread Andrea Bolognani
On Mon, 2016-11-07 at 14:50 -0500, Laine Stump wrote: > Real Q35 hardware has an ICH9 chip that includes several integrated > devices at particular addresses (see the file docs/q35-chipset.cfg in > the qemu source). libvirt already attempts to put the first two sets > of ich9 USB2 controllers it

Re: [libvirt] [PATCH] lxc.conf: s/QEMU/LXC

2016-11-09 Thread Daniel P. Berrange
On Wed, Nov 09, 2016 at 06:18:48PM +0100, Michal Privoznik wrote: > There's one copy paste error where a comment mentions QEMU > instead of LXC driver. > > Signed-off-by: Michal Privoznik > --- > src/lxc/lxc.conf | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > >

[libvirt] [PATCH] xen: remove legacy hack for RHEL-5 Xen

2016-11-09 Thread Daniel P. Berrange
We dropped support for RHEL-5 vintage Xen a while ago, but forgot to remove some of the hacks for it. Signed-off-by: Daniel P. Berrange --- configure.ac | 8 src/xen/xen_hypervisor.c | 6 +- src/xen/xm_internal.c| 9 ++--- 3 files changed, 3

[libvirt] [PATCH] configure: remove fallback check for parted

2016-11-09 Thread Daniel P. Berrange
Since we no longer support building on RHEL-5, we can drop the non-pkg-config based check for parted. Signed-off-by: Daniel P. Berrange --- configure.ac | 12 1 file changed, 12 deletions(-) diff --git a/configure.ac b/configure.ac index b4292ba..3ff4c42

[libvirt] [PATCH] lxc.conf: s/QEMU/LXC

2016-11-09 Thread Michal Privoznik
There's one copy paste error where a comment mentions QEMU instead of LXC driver. Signed-off-by: Michal Privoznik --- src/lxc/lxc.conf | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/lxc/lxc.conf b/src/lxc/lxc.conf index 8df4601..318a536 100644 ---

Re: [libvirt] [PATCH v6 13/17] [ACKED] qemu: add a USB3 controller to Q35 domains by default

2016-11-09 Thread Andrea Bolognani
On Mon, 2016-11-07 at 14:50 -0500, Laine Stump wrote: > Previously we added a set of EHCI+UHCI controllers to Q35 machines to > mimic real hardware as closely as possible, but recent discussions > have pointed out that the nec-usb-xhci (USB3) controller is much more > virtualization-friendly (uses

Re: [libvirt] [PATCH] qemu: Fix double free when live-attaching shmem

2016-11-09 Thread Martin Kletzander
On Wed, Nov 09, 2016 at 05:55:34PM +0100, Pavel Hrdina wrote: On Wed, Nov 09, 2016 at 05:43:49PM +0100, Martin Kletzander wrote: Function qemuDomainAttachShmemDevice() steals the device data if the hotplug was successful, but the condition checked for unsuccessful execution otherwise.

Re: [libvirt] [PATCH v6 12/17] [ACKED] qemu: don't force-add a dmi-to-pci-bridge just on principle

2016-11-09 Thread Andrea Bolognani
On Mon, 2016-11-07 at 14:50 -0500, Laine Stump wrote: > Now the a dmi-to-pci-bridge is automatically added just as it's needed > (when a pci-bridge is being added), we no longer have any need to > force-add one to every single Q35 domain. > --- > src/qemu/qemu_domain.c

Re: [libvirt] [PATCH v2 2/9] caps: Add new capability for the iotune group name

2016-11-09 Thread John Ferlan
On 11/07/2016 04:56 PM, John Ferlan wrote: > Add the capability to detect if the qemu binary can support the feature > to use throttling.group. > > Signed-off-by: John Ferlan > --- > src/qemu/qemu_capabilities.c| 2 ++ >

Re: [libvirt] [PATCH] qemu: Fix double free when live-attaching shmem

2016-11-09 Thread Pavel Hrdina
On Wed, Nov 09, 2016 at 05:43:49PM +0100, Martin Kletzander wrote: > Function qemuDomainAttachShmemDevice() steals the device data if the > hotplug was successful, but the condition checked for unsuccessful > execution otherwise. > > Signed-off-by: Martin Kletzander > --- >

Re: [libvirt] [PATCH] qemu: Fix double free when live-attaching shmem

2016-11-09 Thread Michal Privoznik
On 09.11.2016 17:43, Martin Kletzander wrote: > Function qemuDomainAttachShmemDevice() steals the device data if the > hotplug was successful, but the condition checked for unsuccessful > execution otherwise. > > Signed-off-by: Martin Kletzander > --- >

[libvirt] [PATCH] qemu: Fix double free when live-attaching shmem

2016-11-09 Thread Martin Kletzander
Function qemuDomainAttachShmemDevice() steals the device data if the hotplug was successful, but the condition checked for unsuccessful execution otherwise. Signed-off-by: Martin Kletzander --- src/qemu/qemu_driver.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)

Re: [libvirt] [PATCH 4/8] admin: Introduce virAdmConnectGetLoggingOutputs

2016-11-09 Thread John Ferlan
On 11/01/2016 06:27 AM, Erik Skultety wrote: > Enable libvirt users to query logging output settings. > > Signed-off-by: Erik Skultety > --- > daemon/admin.c | 52 > + > include/libvirt/libvirt-admin.h | 4 >

Re: [libvirt] [PATCH 3/8] daemon: Hook up the virLog{Get, Set}DefaultOutput to the daemon's init routine

2016-11-09 Thread John Ferlan
On 11/01/2016 06:27 AM, Erik Skultety wrote: > Now that virLog{Get,Set}DefaultOutput routines are introduced we can wire them > up to the daemon's logging initialization code. As part of this process, > refactor the daemonSetupLoggingDefaults method, since the code isn't > particularly easy to

Re: [libvirt] [PATCH 8/8] virt-admin: Wire-up the logging APIs

2016-11-09 Thread John Ferlan
On 11/01/2016 06:27 AM, Erik Skultety wrote: > Finally, now that all APIs have been introduced, wire them up to virt-admin > and introduce dmn-log-info and dmn-log-define commands. > > Signed-off-by: Erik Skultety > --- > tools/virt-admin.c | 141 >

Re: [libvirt] [PATCH v6 11/17] [RFC] qemu: if pci-bridge is in PCIe config w/o dmi-to-pci-bridge, add it

2016-11-09 Thread Andrea Bolognani
On Mon, 2016-11-07 at 14:50 -0500, Laine Stump wrote: > I'm undecided if it is worthwhile to add this... >  > Up until now it has been legal to have something like this in the xml: >  >    >    >  > (for example, see the existing test case > "usb-controller-default-q35").  This is handled in >

Re: [libvirt] [PATCH 7/8] admin: Introduce virAdmConnectSetLoggingFilters

2016-11-09 Thread John Ferlan
On 11/01/2016 06:27 AM, Erik Skultety wrote: > Enable libvirt users to modify logging filters of a daemon from outside. > > Signed-off-by: Erik Skultety > --- > daemon/admin.c | 10 ++ > include/libvirt/libvirt-admin.h | 4 >

Re: [libvirt] [PATCH 6/8] admin: Introduce virAdmConnectSetLoggingOutputs

2016-11-09 Thread John Ferlan
On 11/01/2016 06:27 AM, Erik Skultety wrote: > Enable libvirt users to modify daemon's logging output settings from outside. > If an empty set is passed, a default logging output will be used the same way > as it would be in case writing an empty string to the libvirtd.conf > > Signed-off-by:

Re: [libvirt] [PATCH 5/8] admin: Introduce virAdmConnectGetLoggingFilters

2016-11-09 Thread John Ferlan
On 11/01/2016 06:27 AM, Erik Skultety wrote: > Enable libvirt users to query logging filter settings. > > Signed-off-by: Erik Skultety > --- > daemon/admin.c | 52 > + > include/libvirt/libvirt-admin.h | 4 >

Re: [libvirt] [PATCH 2/8] virlog: Introduce virLog{Get, Set}DefaultOutput

2016-11-09 Thread John Ferlan
On 11/01/2016 06:27 AM, Erik Skultety wrote: > The reason why we need something like this lies in the daemon's config where > we > treat the @log_outputs variable (but not just this one) the very same way in > cases where the variable was explicitly set to an empty string or wasn't set > at >

Re: [libvirt] [PATCH 1/8] daemon: Introduce daemonSetLoggingDefaults

2016-11-09 Thread John Ferlan
On 11/01/2016 06:27 AM, Erik Skultety wrote: > This patch moves the code responsible for setting up logging defaults to a > separate function to enhance the readability a bit more. This code movement > is also meant as a preparation phase for a future refactor of the affected > hunks. > >

Re: [libvirt] [PATCH v2 00/15] qemu: Add QMP introspection and gluster debug support

2016-11-09 Thread Pavel Hrdina
On Wed, Nov 02, 2016 at 05:13:32PM +0100, Peter Krempa wrote: > Now that the release is out, I fixed the few things pointed out. > > Andrea Bolognani (5): > tests: qemucaps: Update ppc64 replies for qemu 2.6.0 release > tests: qemucaps: Update aarch64 gicv2 replies for qemu 2.6.0 release >

Re: [libvirt] [PATCH v2 10/15] qemu: capabilities: Add support for QMP schema introspection

2016-11-09 Thread Pavel Hrdina
On Wed, Nov 02, 2016 at 05:13:42PM +0100, Peter Krempa wrote: > Allow detecting capabilities according to the qemu QMP schema. This is > necessary as sometimes the availability of certain options depends on > the presence of a field in the schema. > > This patch adds support for loading the QMP

[libvirt] [PATCH v5 3/7] virnetsocket: improve search for default SSH key

2016-11-09 Thread Pino Toscano
Add a couple of helper functions to check whether one of the default names of SSH keys (as documented in ssh-keygen(1)) exists, and use them to specify a key for the libssh2 transport if none was passed. --- src/rpc/virnetclient.c | 61 +- 1 file

[libvirt] [PATCH v5 4/7] libssh_transport: add new libssh-based transport

2016-11-09 Thread Pino Toscano
Implement a new libssh transport, which uses libssh to communicate with remote hosts, and add all the build system stuff (search of libssh, private symbols, etc) to built it. This new transport supports all the common ssh authentication methods, making use of libvirt's auth callbacks for

[libvirt] [PATCH v5 7/7] docs: fix default value for sshauth option of libssh2/libssh

2016-11-09 Thread Pino Toscano
Both transports include "password" in their default authentication methods. --- docs/remote.html.in | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/docs/remote.html.in b/docs/remote.html.in index c28a505..9d3c2ec 100644 --- a/docs/remote.html.in +++ b/docs/remote.html.in

[libvirt] [PATCH v5 6/7] spec: enable libssh transport on Fedora

2016-11-09 Thread Pino Toscano
--- libvirt.spec.in | 10 ++ 1 file changed, 10 insertions(+) diff --git a/libvirt.spec.in b/libvirt.spec.in index a2c2f2f..cb4a26d 100644 --- a/libvirt.spec.in +++ b/libvirt.spec.in @@ -80,6 +80,7 @@ %define with_firewalld 0%{!?_without_firewalld:0} %define with_libssh2

[libvirt] [PATCH v5 5/7] remote: expose a new libssh transport

2016-11-09 Thread Pino Toscano
Implement in virtNetClient and VirNetSocket the needed functions to expose a new libssh transport, providing all the options that the libssh2 transport supports. --- docs/remote.html.in| 35 ++--- src/remote/remote_driver.c | 41 +++ src/rpc/virnetclient.c | 106

[libvirt] [PATCH v5 1/7] virNetSocket: allow to not close FD

2016-11-09 Thread Pino Toscano
Add an internal variable to mark the FD as "not owned" by the virNetSocket, in case the internal implementation takes the actual ownership of the descriptor; this avoids a warning when closing the socket, as the FD would be invalid. --- src/rpc/virnetsocket.c | 5 - 1 file changed, 4

[libvirt] [PATCH v5 0/7] New libssh transport

2016-11-09 Thread Pino Toscano
Hi, this series introduces a new libssh transport in libvirt, based on the libssh C library. This library supports what libssh2 does, and more: - easier API for known_hosts handling (there's a ticket upstream to request extensions for it, but what is implemented now works well) - potential

[libvirt] [PATCH v5 2/7] virerror: add error for libssh transport

2016-11-09 Thread Pino Toscano
Add a new error domain and number for a new libssh-based transport. --- include/libvirt/virterror.h | 2 ++ src/util/virerror.c | 9 - 2 files changed, 10 insertions(+), 1 deletion(-) diff --git a/include/libvirt/virterror.h b/include/libvirt/virterror.h index efe83aa..2efee8f

Re: [libvirt] [PATCH v2 01/15] util: json: add helper to iterate and steal members of json array

2016-11-09 Thread Pavel Hrdina
On Wed, Nov 02, 2016 at 05:13:33PM +0100, Peter Krempa wrote: > Simplifies cases where JSON array members need to be transferred to a > different structure. > --- > > Notes: > v2: > - iterate from beginning > - add option to keep array member in the array without breaking iteration >

Re: [libvirt] [PATCH v6 10/17] qemu: auto-add pcie-root-port/dmi-to-pci-bridge controllers as needed

2016-11-09 Thread Andrea Bolognani
On Mon, 2016-11-07 at 14:50 -0500, Laine Stump wrote: > Previously libvirt would only add pci-bridge devices automatically > when an address was requested for a device that required a legacy PCI > slot and none was available. This patch expands that support to > dmi-to-pci-bridge (which is needed

Re: [libvirt] [PATCH v2 00/19] Redo website layout and branding

2016-11-09 Thread Daniel P. Berrange
On Wed, Nov 09, 2016 at 11:23:21AM +0100, Martin Kletzander wrote: > On Tue, Nov 08, 2016 at 04:44:46PM +, Daniel P. Berrange wrote: > > On Tue, Nov 08, 2016 at 04:11:05PM +0100, Martin Kletzander wrote: > > > On Tue, Nov 08, 2016 at 01:50:33PM +, Daniel P. Berrange wrote: > > > > On Tue,

Re: [libvirt] [PATCH v2 00/19] Redo website layout and branding

2016-11-09 Thread Martin Kletzander
On Tue, Nov 08, 2016 at 04:44:46PM +, Daniel P. Berrange wrote: On Tue, Nov 08, 2016 at 04:11:05PM +0100, Martin Kletzander wrote: On Tue, Nov 08, 2016 at 01:50:33PM +, Daniel P. Berrange wrote: > On Tue, Nov 08, 2016 at 02:48:07PM +0100, Martin Kletzander wrote: > > the stuff in has

Re: [libvirt] [PATCH] test driver: Deny some operations on inactive domains

2016-11-09 Thread Martin Kletzander
On Tue, Nov 08, 2016 at 09:53:20AM +0100, Michal Privoznik wrote: Some operations like reboot, save, coreDump, blockStats, ifaceStats make sense iff domain is running. While it is technically possible for our test driver to return success regardless of domain state, we should copy constraints