On 03/10/2017 04:10 PM, John Ferlan wrote:
> Rework the helpers/APIs to use the FCHost and SCSIHost adapter types.
> Continue to realign the code for shorter lines.
>
> Signed-off-by: John Ferlan
> ---
> src/conf/storage_conf.c | 112
> ++--
> 1 file c
On 03/10/2017 04:10 PM, John Ferlan wrote:
> Rework the helpers/APIs to use the FCHost and SCSIHost adapter types.
> Continue to realign the code for shorter lines.
>
> Signed-off-by: John Ferlan
> ---
> src/conf/storage_adapter_conf.c | 140
>
> 1 file c
On 03/10/2017 04:10 PM, John Ferlan wrote:
> Create typedef'd substructures and rework typedef to utilize.
Oh, sure. After I spewed all the passive-aggressive-critique about the
anonymous structs, *NOW* you fix it :-P
ACK!
--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.
On 03/10/2017 04:10 PM, John Ferlan wrote:
> Rather than have lots of ugly inline code create helpers to try and
> make things more readable. While creating the helpers realign the code
> as necessary.
[same opinionated commentary about this being semi-pointless code churn :-P]
>
> Signed-off-by:
On 03/10/2017 04:10 PM, John Ferlan wrote:
> Rather than have lots of ugly inline code create helpers to try and
s/code create/code, create/ (it took me a second to parse it - at first my
brain wanted to understand that there had been ugly inline code that was
creating helpers (whatever *that*
On 03/11/2017 10:34 AM, Laine Stump wrote:
> On 03/10/2017 04:10 PM, John Ferlan wrote:
>> https://bugzilla.redhat.com/show_bug.cgi?id=1428209
>>
>> Commit id 'bb74a7ffe' neglected to check that both the parent_wwnn
>> parent_wwpn are in the XML if one or the other is similar to how
>> the node dev
Ah, but wait! I ACKed this too soon! *This* is the patch that's renaming the
functions. It should be changing the arguments in some cases too (and at least
one of the names seems wrong).
On 03/10/2017 04:10 PM, John Ferlan wrote:
> Rename the API's to remove the storage pool source pieces
Yeah
On 03/10/2017 04:10 PM, John Ferlan wrote:
> Move code from storage_conf into storage_adapter_conf
>
> Pure code motion
>
> Signed-off-by: John Ferlan
ACK. (Function naming vs argument type is inconsistent, but again I'm assuming
that will be fixed later, and this patch was purposefully done wit
On 03/10/2017 04:10 PM, John Ferlan wrote:
> Rather than use virXPathString, pass along an virXPathNode and alter
> the parsing to use virXMLPropString.
Just so I understand the reasoning correctly - you're not doing this so you can
use virXMLPropString() instead of virXPathString(), but just so
Add an entry about virt-host-validate bhyve support and
update the driver's page.
---
docs/drvbhyve.html.in | 13 -
docs/news.xml | 10 +-
2 files changed, 21 insertions(+), 2 deletions(-)
diff --git a/docs/drvbhyve.html.in b/docs/drvbhyve.html.in
index da6f1e0b2..64a1
Michal Privoznik wrote:
> On 02/25/2017 02:30 PM, Roman Bogorodskiy wrote:
> > Add bhyve support to virt-host-validate(1). It checks for the
> > essential kernel modules to be available so that user can actually
> > start VMs, have networking and console access.
> >
> > It uses the kldnext(2)/k
On 03/10/2017 04:10 PM, John Ferlan wrote:
> Split out the code that munges through the storage pool adapter into
> helpers - it's about to be moved into it's own source file.
>
> This is purely code motion at this point.
>
> Signed-off-by: John Ferlan
> ---
> src/conf/storage_conf.c | 455
> +++
On 03/10/2017 04:10 PM, John Ferlan wrote:
> The function is actually in virutil.c, but prototyped in virfile.h.
> This patch fixes that by renaming the function to virWaitForDevices,
> adding the prototype in virutil.h and libvirt_private.syms, and then
> changing the callers to use the new name.
On 03/10/2017 04:10 PM, John Ferlan wrote:
> Rename the API's to remove the storage pool source pieces
>
> Signed-off-by: John Ferlan
> ---
> src/conf/storage_adapter_conf.c | 14 +++---
> src/conf/storage_adapter_conf.h | 14 +++---
> src/conf/storage_conf.c | 8
On 03/10/2017 04:10 PM, John Ferlan wrote:
> https://bugzilla.redhat.com/show_bug.cgi?id=1428209
>
> Commit id 'bb74a7ffe' neglected to check that both the parent_wwnn
> parent_wwpn are in the XML if one or the other is similar to how
> the node device code checked (commit id '2b13361bc').
>
> If o
On 03/10/2017 04:10 PM, John Ferlan wrote:
> Commit id 'bb74a7ffe' added some new fields to search for a fchost by
> parent wwnn/wwpn or parent_fabric_name, but neglected to validate that
> the data within the fields was valid at parse time. This could lead to
> eventual failure at run time, so rat
16 matches
Mail list logo