https://bugzilla.redhat.com/show_bug.cgi?id=1373783
Signed-off-by: Jiri Denemark
---
tools/virsh.pod | 8 +++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/tools/virsh.pod b/tools/virsh.pod
index 01453be600..a03f64a262 100644
--- a/tools/virsh.pod
+++ b/tools/virsh.pod
@@ -17
When destroying a domain libvirt marks it internally with a
beingDestroyed flag to make sure the qemuDomainDestroyFlags API itself
cleans up after the domain rather than letting an uninformed EOF handler
do it. However, when the domain is being started at the moment libvirt
was asked to destroy it,
Requesting an automated switch to a post-copy migration (using
--timeout-postcopy) without actually enabling post-copy migration (using
--postcopy) doesn't really do anything. Let's make this dependency
explicit to avoid unexpected behavior.
https://bugzilla.redhat.com/show_bug.cgi?id=1455023
Sig
On 09/08/2017 10:51 AM, Daniel P. Berrange wrote:
On Fri, Sep 08, 2017 at 10:48:10AM -0500, Brijesh Singh wrote:
So I could see a flow like the following:
The flow looks good
1. mgmt tool calls virConnectGetCapabilities. This returns an XML
document that includes the followi
On 09/08/17 17:51, Daniel P. Berrange wrote:
> On Fri, Sep 08, 2017 at 10:48:10AM -0500, Brijesh Singh wrote:
>> I am looking at [1] to get the feel for how do we model it in the XML.
>> As you can see I am using ad-hoc to create the sev-guest
>> object. Currently, sev-guest object accepts the fo
Hi Daniel,
On 09/08/2017 09:52 AM, Daniel P. Berrange wrote:
On Fri, Sep 08, 2017 at 01:45:06PM +, Relph, Richard wrote:
A few answers in line…
On 9/8/17, 8:16 AM, "Daniel P. Berrange" wrote:
On Fri, Sep 08, 2017 at 06:57:30AM -0500, Brijesh Singh wrote:
> Hi All,
>
On Fri, Sep 08, 2017 at 10:48:10AM -0500, Brijesh Singh wrote:
> > So I could see a flow like the following:
>
>
> The flow looks good
>
> >
> >
> >1. mgmt tool calls virConnectGetCapabilities. This returns an XML
> > document that includes the following
> >
> >
> >
From: Wim ten Have
This patch converts NUMA configurations between the Xen libxl
configuration file format and libvirt's XML format.
XML HVM domain configuration:
From: Wim ten Have
This patch extends guest domain administration adding support to advertise
node sibling distances when configuring HVM numa guests.
NUMA (non-uniform memory access), a method of configuring a cluster of nodes
within a single multiprocessing system such that it shares processor
From: Wim ten Have
This patch renames virDomainNumaDefCPUFormat(), by adding XML, into
virDomainNumaDefCPUFormatXML(). So that it meets its peer Parse
sibling virDomainNumaDefCPUParseXML() and matches vir*XML() function
naming conventions.
Signed-off-by: Wim ten Have
---
Changes on v3:
- Clean
From: Wim ten Have
Add libvirtd NUMA cell domain administration functionality to
describe underlying cell id sibling distances in full fashion
when configuring HVM guests.
Schema updates are made to docs/schemas/cputypes.rng enforcing domain
administration to follow the syntax below the numa cel
From: Wim ten Have
This patch generates a NUMA distance-aware libxl description from the
information extracted from a NUMA distance-aware libvirt XML file.
By default, if no NUMA node distance information is supplied in the
libvirt XML file, this patch uses the distances 10 for local and 20 for
On Fri, Sep 08, 2017 at 01:45:06PM +, Relph, Richard wrote:
> A few answers in line…
>
> On 9/8/17, 8:16 AM, "Daniel P. Berrange" wrote:
>
> On Fri, Sep 08, 2017 at 06:57:30AM -0500, Brijesh Singh wrote:
> > Hi All,
> >
> > (sorry for the long message)
> >
> > CPUs
---
src/qemu/qemu_driver.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/qemu/qemu_driver.c b/src/qemu/qemu_driver.c
index 6255d89310..c742e505c4 100644
--- a/src/qemu/qemu_driver.c
+++ b/src/qemu/qemu_driver.c
@@ -16816,7 +16816,7 @@ qemuDomainBlockCopyValidateMirror(vir
From: Wim ten Have
Test a bidirectional xen-xl domxml to and from native for numa
support administration as brought under this patch series.
Signed-off-by: Wim ten Have
---
.../test-fullvirt-vnuma-autocomplete.cfg | 26 +++
.../test-fullvirt-vnuma-autocomplete.xml | 85
Probably could have gone by the trivial rule.
Guido Günther (3):
storagefile: fix defintion vs definition typo
qemu_driver: fix existance vs existence typo
virnetserver: fix mesage vs message typo
src/qemu/qemu_driver.c| 2 +-
src/rpc/virnetserver.c| 2 +-
src/util/virstoragefile.c
---
src/util/virstoragefile.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/util/virstoragefile.c b/src/util/virstoragefile.c
index fbc8245f35..e94ad32f09 100644
--- a/src/util/virstoragefile.c
+++ b/src/util/virstoragefile.c
@@ -3253,7 +3253,7 @@
virStorageSourcePar
On Mon, 4 Sep 2017 08:49:33 +0200
Martin Kletzander wrote:
> On Fri, Sep 01, 2017 at 04:31:50PM +0200, Wim ten Have wrote:
> >On Thu, 31 Aug 2017 16:36:58 +0200
> >Martin Kletzander wrote:
> >
> >> On Thu, Aug 31, 2017 at 04:02:38PM +0200, Wim Ten Have wrote:
> >> >From: Wim ten Have
> >> >
---
src/rpc/virnetserver.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/rpc/virnetserver.c b/src/rpc/virnetserver.c
index c02db74c46..2b76daab55 100644
--- a/src/rpc/virnetserver.c
+++ b/src/rpc/virnetserver.c
@@ -133,7 +133,7 @@ static int virNetServerProcessMsg(virNetS
A few answers in line…
On 9/8/17, 8:16 AM, "Daniel P. Berrange" wrote:
On Fri, Sep 08, 2017 at 06:57:30AM -0500, Brijesh Singh wrote:
> Hi All,
>
> (sorry for the long message)
>
> CPUs from AMD EPYC family supports Secure Encrypted Virtualization (SEV)
> feature -
On Fri, Sep 08, 2017 at 06:57:30AM -0500, Brijesh Singh wrote:
> Hi All,
>
> (sorry for the long message)
>
> CPUs from AMD EPYC family supports Secure Encrypted Virtualization (SEV)
> feature - the feature allows running encrypted VMs. To enable the feature,
> I have been submitting patches to L
On Fri, Sep 08, 2017 at 11:06:08AM +0200, Martin Kletzander wrote:
> On Thu, Sep 07, 2017 at 03:48:13PM +0200, Erik Skultety wrote:
> > So we refer to terms 'persistent' and 'transient' across the whole man
> > page, without explicitly stating that domain created via the 'create'
> > command is in
So we refer to the terms 'persistent' and 'transient' across the whole
man page, without describing it further, but more importantly, how the
create command affects it, i.e. explicitly stating that domain created
via the 'create' command are going to be transient or persistent,
depending on whether
Hi All,
(sorry for the long message)
CPUs from AMD EPYC family supports Secure Encrypted Virtualization (SEV)
feature - the feature allows running encrypted VMs. To enable the feature,
I have been submitting patches to Linux kernel [1], Qemu [2] and OVMF [3].
We have been making some good progres
On Thu, Sep 07, 2017 at 03:48:14PM +0200, Erik Skultety wrote:
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1368753
Signed-off-by: Erik Skultety
---
tools/virsh.pod | 22 +-
1 file changed, 13 insertions(+), 9 deletions(-)
diff --git a/tools/virsh.pod b/tools/virsh.
For vhost-user ports, Open vSwitch acts as the server and QEMU the client.
When OVS crashed or restart, QEMU shoule be reconnect to OVS.
Signed-off-by: ZhiPeng Lu
---
docs/formatdomain.html.in | 6 +++--
docs/schemas/domaincommon.rng | 5
src/
On Thu, Sep 07, 2017 at 03:48:13PM +0200, Erik Skultety wrote:
So we refer to terms 'persistent' and 'transient' across the whole man
page, without explicitly stating that domain created via the 'create'
command is in fact transient and will vanish once destroyed.
Signed-off-by: Erik Skultety
-
On Thu, Sep 07, 2017 at 03:47:51PM +0200, Erik Skultety wrote:
Since commit @ae2163f8, only active client connections or running
domains are allowed to inhibit daemon shutdown. The man page however
wasn't updated appropriately.
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1325066
Signe
This patch pass event error up to the place where we can
use it. Error is passed only for sync blockjob event mode
as we can't use the error in async mode. In async mode we
just pass the event details to the client thru event API
but current blockjob event API can not carry extra parameter.
---
sr
---
src/qemu/qemu_blockjob.c | 14 +---
src/qemu/qemu_blockjob.h | 3 ++-
src/qemu/qemu_driver.c| 4 ++--
src/qemu/qemu_migration.c | 55 +--
4 files changed, 54 insertions(+), 22 deletions(-)
diff --git a/src/qemu/qemu_blockjob.c b/src/
So that you can see nice report on migration:
"error: operation failed: migration of disk sda failed: No space left on device"
diff from v2:
1. split into 2 patches
2. change formal documentation where it is present accordingly
3. add variable initialization for safety
Nikolay Shiro
Ouch, I don't escape test patch [1] in message body so
is is applied together with the main patch. Be careful.
On 08.09.2017 10:16, Nikolay Shirokovskiy wrote:
> Patch aeda1b8c needs some enhancement.
>
> 1. Shutdown event is delivired on reboot too and we don't want
> to set willhangup flag is t
Patch aeda1b8c needs some enhancement.
1. Shutdown event is delivired on reboot too and we don't want
to set willhangup flag is this case.
2. There is a next race condition.
- EOF is delivered in event loop thread
- qemuMonitorSend is called on client behalf and waits for notification
on me
33 matches
Mail list logo