On Thu, Feb 21, 2019 at 21:44:34 +0300, David Kiarie wrote:
> it looks sensible that the copyright notice on the affected files in
> updated as in this patch so as to also cover another party who hugely
> participated in writing the code.
I must point out that you specifically asked us to remove y
The tests/cputestdata/cpu-parse.sh script has been broken since the
cpu_map.xml file was split into several XMLs.
Signed-off-by: Jiri Denemark
---
tests/cputestdata/cpu-cpuid.py | 8 +++-
1 file changed, 3 insertions(+), 5 deletions(-)
diff --git a/tests/cputestdata/cpu-cpuid.py b/tests/cpu
The previous patch made it possible to split multiple commands by
adding newline, but not to split a long single command. The sequence
backslash-newline was being used as if it were a quoted newline
character, rather than completely elided the way the shell does.
Signed-off-by: Eric Blake
---
to
No good feature is complete without tests ;)
Signed-off-by: Eric Blake
---
Maybe I should squash all three patches into one?
tests/virshtest.c | 7 +++
1 file changed, 7 insertions(+)
diff --git a/tests/virshtest.c b/tests/virshtest.c
index 7fb701d580..d77d3d81d4 100644
--- a/tests/virsht
On 2/21/19 12:56 PM, Daniel P. Berrangé wrote:
> On Thu, Feb 21, 2019 at 03:39:15PM +0100, Erik Skultety wrote:
>> Hi,
>> I'm starting this thread in order to continue with the ongoing efforts to
>> bring actual integration testing to libvirt. Currently, the status quo is
>> that
>> we build lib
I wanted to do a demonstration with virsh batch mode, which
takes multiple commands all packed into a single argument:
$ virsh -c test:///default 'echo a; echo b;'
a
b
but that produced a really long line, so I tried to make it
more legible:
$ virsh -c test:///default '
echo a;
echo b;
'
e
On 2/21/19 9:39 AM, Erik Skultety wrote:
> Hi,
> I'm starting this thread in order to continue with the ongoing efforts to
> bring actual integration testing to libvirt. Currently, the status quo is that
> we build libvirt (along with our unit test suite) using different OS-flavoured
> VMs in ci
Signed-off-by: David Kiarie
---
src/xenconfig/xen_xl.c | 1 +
src/xenconfig/xen_xl.h | 1 +
tests/xlconfigtest.c | 1 +
3 files changed, 3 insertions(+)
diff --git a/src/xenconfig/xen_xl.c b/src/xenconfig/xen_xl.c
index accfc3a..8029579 100644
--- a/src/xenconfig/xen_xl.c
+++ b/src/xenconfig/x
it looks sensible that the copyright notice on the affected files in
updated as in this patch so as to also cover another party who hugely
participated in writing the code.
David Kiarie (1):
src/xenconfig: update copyright notice
src/xenconfig/xen_xl.c | 1 +
src/xenconfig/xen_xl.h | 1 +
tes
On Thu, Feb 21, 2019 at 03:39:15PM +0100, Erik Skultety wrote:
> Hi,
> I'm starting this thread in order to continue with the ongoing efforts to
> bring actual integration testing to libvirt. Currently, the status quo is that
> we build libvirt (along with our unit test suite) using different OS-fl
On 2/20/19 4:10 PM, John Ferlan wrote:
On 2/18/19 6:21 PM, Laine Stump wrote:
dnsmasq documentation says that the *IPv4* prefix/network
address/broadcast address sent to dhcp clients will be automatically
determined by dnsmasq by looking at the interface it's listening on,
so the original libvi
On 2/21/19 9:50 AM, Peter Krempa wrote:
> The new utility macros are useful for variables we put on the stack but
> require some cleanup. The most prominent of those is virBuffer which is
> used almost exclusively in that way.
>
> Signed-off-by: Peter Krempa
> ---
> src/util/viralloc.h | 32
On 2/20/19 4:10 PM, John Ferlan wrote:
On 2/18/19 6:21 PM, Laine Stump wrote:
This fixes a bug that has been present since the original version of
the function was pushed in commit 1ab80f3 on Nov. 26 2010 (by me). The
virSocketAddr::len was not being set.
Apparently until now we were always ca
Currently only a single global parser is used for all commands. This
means that every command accepts every argument which is undesirable as
users don't know what to pass. It also prevents the parser from
generating useful help information.
Python's argparse module supports multi-command binaries
For example to prevent Xen being installed on any s390x
xen:
default-s390x:
deb: libxen-dev
Fedora: xen-devel
Or the inverse to only install Xen on x86_64 on Debian, but allow
it on all archs on Fedora
xen:
deb-x86_64: libxen-dev
Fedora: xen-devel
Note that the architect
Changed in v4:
- Pull in change to use argparse sub-parsers
- Refactor way architecture specific package rules are stored
to be in the main package mappings data
Changed in v3:
- Remove sheepdog more generally
- Use .format() style printf
- Split config to cross-build.yml
- Make gluster
On 2/20/19 9:53 AM, Eric Blake wrote:
> Split out an internal helper that produces format into a
> virBuffer, similar to what domain_conf.c does, and making
> the next patch easier to write.
>
> Signed-off-by: Eric Blake
> ---
> src/conf/snapshot_conf.c | 103 ++--
The new utility macros are useful for variables we put on the stack but
require some cleanup. The most prominent of those is virBuffer which is
used almost exclusively in that way.
Signed-off-by: Peter Krempa
---
src/util/viralloc.h | 32 +++-
1 file changed, 31 inser
The messages reference testBufEscapeN instead of testBufEscapeRegex.
Signed-off-by: Peter Krempa
---
tests/virbuftest.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tests/virbuftest.c b/tests/virbuftest.c
index 5bffe94c95..547438c646 100644
--- a/tests/virbuftest.c
+++
First 4 patches clean up existing mess.
Note that this series both fixes and then deletes virBufferEscapeN.
The split is deliberate, so that if somebody needs virBufferEscapeN
in the future they can revert the removal and get a working version.
Peter Krempa (7):
util: buffer: Remove misleading
The function was used only in the tests, remove it.
Signed-off-by: Peter Krempa
---
src/libvirt_private.syms | 1 -
src/util/virbuffer.c | 93
src/util/virbuffer.h | 2 -
tests/virbuftest.c | 41 --
4 files changed, 137 del
'virBufferFreeAndReset' does not free the top level structure itself.
Additionally we almost exclusively use stack'd buffers rather than
pointers.
Signed-off-by: Peter Krempa
---
src/util/virbuffer.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/src/util/virbuffer.h b/src/util/virbuffer.h
Most of the code base is fairly consistent about using the name
'uuidstr' when dealing with a formatted human-readable form, and
'uuid' when dealing with the smaller raw bytes form. Fix
snapshot_conf to comply, as well as reducing the scope of a human
string to only the error message that needs it.
To be squashed into the previous patch.
Best viewed with --patience
---
src/qemu/qemu_capabilities.c | 177 ++-
src/qemu/qemu_capabilities.h | 177 ++-
2 files changed, 180 insertions(+), 174 deletions(-)
diff --git a/src/qemu/qemu_c
The deprecated capabilities are duplicated in the virQEMUCapsDeprecated
array. Remove the copies in the current array.
---
src/qemu/qemu_capabilities.c | 131 --
src/qemu/qemu_capabilities.h | 131 --
.../disk-secinfo-upgrade-out.xm
Add a function that will convert the "name" attributes from the passed
nodes to QEMU capabilities.
Signed-off-by: Ján Tomko
---
src/qemu/qemu_capabilities.c | 51 +---
1 file changed, 35 insertions(+), 16 deletions(-)
diff --git a/src/qemu/qemu_capabilities.c b/s
Stop testing whether we format the deprecated capabilities back
for the files where the input and output differ.
Capabilities with separate output files are left alone, since we
will still need to parse files contating them correctly, we just
don't have to format them back.
Signed-off-by: Ján Tom
Remove some code duplication.
Signed-off-by: Ján Tomko
---
src/qemu/qemu_capabilities.c | 2 +-
src/qemu/qemu_capabilities.h | 4
src/qemu/qemu_domain.c | 16 ++--
tests/qemucaps2xmltest.c | 17 +++--
4 files changed, 10 insertions(+), 29 deletions(-)
di
Ján Tomko (8):
DO NOT PUSH: allow skipping selected lines in group-qemu-caps.pl
Introduce virQEMUCapsDeprecated array
Split out virQEMUCapsSetFromNodes
Use virQEMUCapsSetFromNodes where possible
qemustatusxml2xmltests: remove deprecated qemu capabilities
virQEMUCapsSetFromNodes: Skip se
Hi,
I'm starting this thread in order to continue with the ongoing efforts to
bring actual integration testing to libvirt. Currently, the status quo is that
we build libvirt (along with our unit test suite) using different OS-flavoured
VMs in ci.centos.org. Andrea put a tremendous amount of work to
On Sun, Feb 17, 2019 at 05:04:05PM +0400, Roman Bogorodskiy wrote:
Signed-off-by: Roman Bogorodskiy
---
docs/news.xml | 10 ++
1 file changed, 10 insertions(+)
diff --git a/docs/news.xml b/docs/news.xml
index 8d6d58ae6a..e0c9c3590f 100644
--- a/docs/news.xml
+++ b/docs/news.xml
@@ -59,6
On Sun, Feb 17, 2019 at 05:04:04PM +0400, Roman Bogorodskiy wrote:
Document ability to specify LCP PCI-ISA bridge PCI address.
Signed-off-by: Roman Bogorodskiy
---
docs/drvbhyve.html.in | 22 ++
1 file changed, 22 insertions(+)
diff --git a/docs/drvbhyve.html.in b/docs/drvbh
On Sun, Feb 17, 2019 at 05:04:03PM +0400, Roman Bogorodskiy wrote:
When domain configuration requires the 'isa' controller to be present,
automatically add it on domain post-parse stage.
Now, as this controller is always available when needed, it's not
necessary to implicitly add it to the bhyve
On Sun, Feb 17, 2019 at 05:04:02PM +0400, Roman Bogorodskiy wrote:
Support modeling of the 'isa' controller for bhyve. When controller is
not present in the domain XML, but domain requires it to be there (e.g.
because bootrom is used), implicitly add addition of this controller to
the command lin
On Sun, Feb 17, 2019 at 05:04:01PM +0400, Roman Bogorodskiy wrote:
Add a bhyveDomainDefNeedsISAController() helper function
which by domain configuration determines whether LPC controller is
required or not.
Signed-off-by: Roman Bogorodskiy
---
src/bhyve/bhyve_command.c | 5 +
src/bhyve/bhy
On Sun, Feb 17, 2019 at 05:04:00PM +0400, Roman Bogorodskiy wrote:
Introduce 'isa' controller type. The only supported model
now is 'isa-bridge'. In domain XML it looks this way:
...
...
Currently, this is needed for the bhyve driver to allow choosing a
specific PCI address
36 matches
Mail list logo