On 5/8/19 11:22 PM, Alex Williamson wrote:
I thought there was a request to make this more specific to migration
by renaming it to something like migration_version. Also, as an
so this attribute may not only include a mdev device's parent device info and
mdev type, but also include numeric s
On Thu, May 09, 2019 at 11:38:34AM +0800, Alex Williamson wrote:
> On Wed, 8 May 2019 23:10:55 -0400
> Yan Zhao wrote:
>
> > On Thu, May 09, 2019 at 05:22:42AM +0800, Alex Williamson wrote:
> > > On Wed, 8 May 2019 07:27:40 -0400
> > > Yan Zhao wrote:
> > >
> > > > On Wed, May 08, 2019 at 05:
On Wed, 8 May 2019 23:10:55 -0400
Yan Zhao wrote:
> On Thu, May 09, 2019 at 05:22:42AM +0800, Alex Williamson wrote:
> > On Wed, 8 May 2019 07:27:40 -0400
> > Yan Zhao wrote:
> >
> > > On Wed, May 08, 2019 at 05:18:26AM +0800, Alex Williamson wrote:
> > > > On Sun, 5 May 2019 21:49:04 -040
On Thu, May 09, 2019 at 05:22:42AM +0800, Alex Williamson wrote:
> On Wed, 8 May 2019 07:27:40 -0400
> Yan Zhao wrote:
>
> > On Wed, May 08, 2019 at 05:18:26AM +0800, Alex Williamson wrote:
> > > On Sun, 5 May 2019 21:49:04 -0400
> > > Yan Zhao wrote:
> > >
> > > > version attribute is used
This brings about a couple of benefits:
- use of VIR_AUTOUNREF() simplifies several callers
- Fixes a todo about virDomainMomentObjList not being polymorphic enough
Signed-off-by: Eric Blake
---
src/conf/moment_conf.h| 5 -
src/conf/snapshot_conf.h | 1 -
cfg.mk
Peter rightly complained that my attempt to leave a todo in
virdomainmomentobjlist.c about not being polymorphic enough gives no
incentive to get it fixed later once incremental backups are in, so
instead fix it now. My v9 backup patches will be changed similarly to
the changes to snapshot shown h
VIR_CLASS_NEW insists that descendents of virObject have 'parent' as
the name of their inherited member at offset 0. While it would be
possible to write a new class-creation macro that takes the actual
field name, and rewrite VIR_CLASS_NEW to call the new macro with the
hard-coded name 'parent', so
VIR_CLASS_NEW insists that descendents of virObject have 'parent' as
the name of their inherited member at offset 0. While it would be
possible to write a new class-creation macro that takes the actual
field name 'current', and rewrite VIR_CLASS_NEW to call the new macro
with the hard-coded name 'p
In preparation for making virDomainSnapshotDef a descendant of
virObject, it is time to fix all callers that allocate an object to
use virDomainSnapshotDefNew() instead of VIR_ALLOC(). Fortunately,
there aren't very many :)
Signed-off-by: Eric Blake
---
src/conf/snapshot_conf.h | 1 +
src/conf
On Wed, 8 May 2019 07:27:40 -0400
Yan Zhao wrote:
> On Wed, May 08, 2019 at 05:18:26AM +0800, Alex Williamson wrote:
> > On Sun, 5 May 2019 21:49:04 -0400
> > Yan Zhao wrote:
> >
> > > version attribute is used to check two mdev devices' compatibility.
> > >
> > > The key point of this vers
On Wed, May 08, 2019 at 06:21:21PM +0200, Olaf Hering wrote:
> On Wed, Apr 03, Ján Tomko wrote:
>
> > Since all our supported platforms include at least yajl 2.0.4,
> > use pkg-config to detect the library and set the minimum to 2.0.3.
>
> In case SLE_12 is on the list of supported platforms, thi
On Wed, Apr 03, Ján Tomko wrote:
> Since all our supported platforms include at least yajl 2.0.4,
> use pkg-config to detect the library and set the minimum to 2.0.3.
In case SLE_12 is on the list of supported platforms, this kicked it
off of the list. SLE_12 (and Leap 42.3) comes with version 2.
Daniel P. Berrangé writes:
> On Tue, May 07, 2019 at 10:47:06AM +0200, Markus Armbruster wrote:
>
>> > The Golang JSON parser decodes JSON numbers to float64 by default so
>> > will have this precision limitation too, though at least they provide
>> > a backdoor for custom parsing from the origin
* Markus Armbruster (arm...@redhat.com) wrote:
> Eric Blake writes:
>
> > On 5/7/19 4:39 AM, Daniel P. Berrangé wrote:
> >
> >>> JSON is terrible at interoperability, so good luck with that.
> >>>
> >>> If you reduce your order to "the commonly used JSON libraries we know",
> >>> we can talk.
> >
Eric Blake writes:
> On 5/7/19 4:39 AM, Daniel P. Berrangé wrote:
>
>>> JSON is terrible at interoperability, so good luck with that.
>>>
>>> If you reduce your order to "the commonly used JSON libraries we know",
>>> we can talk.
>>
>> I don't particularly want us to rely on semantics of small
On Wed, May 08, 2019 at 06:50:33PM +0800, Dr. David Alan Gilbert wrote:
> * Yan Zhao (yan.y.z...@intel.com) wrote:
> > This feature implements the version attribute for Intel's vGPU mdev
> > devices.
> >
> > version attribute is rw.
> > It's used to check device compatibility for two mdev devices.
On Tue, May 07, 2019 at 05:27:53PM +0800, Cornelia Huck wrote:
> On Sun, 5 May 2019 21:51:02 -0400
> Yan Zhao wrote:
>
> > This feature implements the version attribute for Intel's vGPU mdev
> > devices.
> >
> > version attribute is rw.
> > It's used to check device compatibility for two mdev d
On Tue, May 07, 2019 at 05:19:54PM +0800, Cornelia Huck wrote:
> On Sun, 5 May 2019 21:49:04 -0400
> Yan Zhao wrote:
>
> > version attribute is used to check two mdev devices' compatibility.
> >
> > The key point of this version attribute is that it's rw.
> > User space has no need to understan
On Wed, May 08, 2019 at 05:18:26AM +0800, Alex Williamson wrote:
> On Sun, 5 May 2019 21:49:04 -0400
> Yan Zhao wrote:
>
> > version attribute is used to check two mdev devices' compatibility.
> >
> > The key point of this version attribute is that it's rw.
> > User space has no need to underst
* Yan Zhao (yan.y.z...@intel.com) wrote:
> This feature implements the version attribute for Intel's vGPU mdev
> devices.
>
> version attribute is rw.
> It's used to check device compatibility for two mdev devices.
> version string format and length are private for vendor driver. vendor
> driver i
20 matches
Mail list logo