[libvirt] [PATCH 5/6] docs: Deprecate CPU model runnability guarantees

2019-06-24 Thread Eduardo Habkost
Document that CPU model runnability guarantees won't apply to unversioned CPU models anymore. Signed-off-by: Eduardo Habkost --- Cc: libvir-list@redhat.com --- qemu-deprecated.texi | 19 +++ 1 file changed, 19 insertions(+) diff --git a/qemu-deprecated.texi

Re: [libvirt] [PATCH libvirt-python] Fix regression in lxcOpenNamespace

2019-06-24 Thread Sergei Turchanov
Hello! Two weeks passed and still this fix not applied. Is no one interested fixing it? Wrong mailing list? Anything? Please, answer. On 10.06.2019 13:45, Sergei Turchanov wrote: This fixes regression caused by the 1d39dbaf637db03f6e597ed56b96aa065710b4a1 fdlist[i] erroneously was replaced

[libvirt] [PATCH 2/2] test_driver: use virDomainNetDefPtr instead of virDomainNetDef *

2019-06-24 Thread Ilias Stamatis
Signed-off-by: Ilias Stamatis --- src/test/test_driver.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/src/test/test_driver.c b/src/test/test_driver.c index d3bc6e7bce..868dadd682 100755 --- a/src/test/test_driver.c +++ b/src/test/test_driver.c @@ -3433,7 +3433,7 @@

[libvirt] [PATCH 0/2] test_driver: A couple of small changes in testDomainInterfaceAddresses

2019-06-24 Thread Ilias Stamatis
Ilias Stamatis (2): test_driver: use addr_offset for non-network infs too test_driver: use virDomainNetDefPtr instead of virDomainNetDef * src/test/test_driver.c | 12 +--- 1 file changed, 5 insertions(+), 7 deletions(-) -- 2.22.0 -- libvir-list mailing list libvir-list@redhat.com

[libvirt] [PATCH 1/2] test_driver: use addr_offset for non-network infs too

2019-06-24 Thread Ilias Stamatis
The addr_offset can be used even for the hard-coded addresses in an attempt to always return unique ips. Signed-off-by: Ilias Stamatis --- src/test/test_driver.c | 8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/src/test/test_driver.c b/src/test/test_driver.c index

Re: [libvirt] [PATCH v2] test_driver: implement virNetworkGetDHCPLeases

2019-06-24 Thread Ilias Stamatis
On Mon, Jun 24, 2019 at 9:10 PM Ilias Stamatis wrote: > > Signed-off-by: Ilias Stamatis > --- > src/test/test_driver.c | 141 + > 1 file changed, 141 insertions(+) > > diff --git a/src/test/test_driver.c b/src/test/test_driver.c > index

[libvirt] [PATCH v2] test_driver: implement virNetworkGetDHCPLeases

2019-06-24 Thread Ilias Stamatis
Signed-off-by: Ilias Stamatis --- src/test/test_driver.c | 141 + 1 file changed, 141 insertions(+) diff --git a/src/test/test_driver.c b/src/test/test_driver.c index 4b1f2724a0..180940f859 100755 --- a/src/test/test_driver.c +++ b/src/test/test_driver.c

[libvirt] [PATCH 3/3] conf: domain: Restore XPath context after virSecurityDeviceLabelDefParseXML

2019-06-24 Thread Peter Krempa
The function modifies the context but did not care to restore it back. If a was used on a disk, the would not be parsed. Signed-off-by: Peter Krempa --- src/conf/domain_conf.c | 1 + tests/qemustatusxml2xmldata/modern-out.xml | 12 +++- 2 files changed, 12

[libvirt] [PATCH 1/3] tests: qemustatusxml2xml: Split out the output file for 'modern' test

2019-06-24 Thread Peter Krempa
Upcomming patch will add an example which changes output-only. Signed-off-by: Peter Krempa --- tests/qemustatusxml2xmldata/modern-out.xml | 471 - 1 file changed, 470 insertions(+), 1 deletion(-) mode change 12 => 100644 tests/qemustatusxml2xmldata/modern-out.xml diff

[libvirt] [PATCH 2/3] tests: qemustatusxml2xml: Add a seclabel for a disk with privateData

2019-06-24 Thread Peter Krempa
Adding a seclabel breaks the output by improperly handling the XPath context and thus not being able to parse the . Signed-off-by: Peter Krempa --- tests/qemustatusxml2xmldata/modern-in.xml | 3 +++ tests/qemustatusxml2xmldata/modern-out.xml | 15 --- 2 files changed, 7

[libvirt] [PATCH 0/3] conf: Fix parsing of (blockdev-add saga)

2019-06-24 Thread Peter Krempa
The parser for the seclabel would mess up context leaving disk source private data unparsed. Peter Krempa (3): tests: qemustatusxml2xml: Split out the output file for 'modern' test tests: qemustatusxml2xml: Add a seclabel for a disk with privateData conf: domain: Restore XPath context after

Re: [libvirt] [PATCH 1/1] virpci: report dev->name in virPCIGetHeaderType error message

2019-06-24 Thread Andrea Bolognani
On Fri, 2019-06-21 at 12:58 -0300, Daniel Henrique Barboza wrote: > Trivial change. Adding the name of the device that has an > unknown PCI header type in that function helps when debugging > PCI code. > > Signed-off-by: Daniel Henrique Barboza > --- > src/util/virpci.c | 3 ++- > 1 file

[libvirt] [PATCH 9/9] qemu: monitor: Add APIs for 'blockdev-create'

2019-06-24 Thread Peter Krempa
The 'blockdev-create' starts a job which creates a storage volume using the given protocol or formats an existing (added) volume with one of the supported storage formats. This patch adds the monitor interaction bits. Signed-off-by: Peter Krempa --- src/qemu/qemu_monitor.c | 30

[libvirt] [PATCH 5/9] qemu: monitor: Add support for 'job-cancel' command

2019-06-24 Thread Peter Krempa
This belongs to the new job management API which can manage also non-block based jobs. Signed-off-by: Peter Krempa --- src/qemu/qemu_monitor.c | 12 src/qemu/qemu_monitor.h | 4 src/qemu/qemu_monitor_json.c | 22 ++ src/qemu/qemu_monitor_json.h |

[libvirt] [PATCH 8/9] qemu: monitor: Implement support for 'JOB_STATUS_CHANGE' event

2019-06-24 Thread Peter Krempa
This new event is a superset of the BLOCK_JOB* events and also covers jobs which don't bind to a VM disk. In this patch the monitor part is implemented. Signed-off-by: Peter Krempa --- src/qemu/qemu_monitor.c | 13 + src/qemu/qemu_monitor.h | 9 +

[libvirt] [PATCH 7/9] qemu: monitor: Add infrastructure for 'query-jobs'

2019-06-24 Thread Peter Krempa
Signed-off-by: Peter Krempa --- src/qemu/qemu_monitor.c | 23 + src/qemu/qemu_monitor.h | 49 +++ src/qemu/qemu_monitor_json.c | 79 + src/qemu/qemu_monitor_json.h | 6 ++

[libvirt] [PATCH 6/9] qemu: monitor: Add support for 'job-complete' command

2019-06-24 Thread Peter Krempa
This belongs to the new job management API which can manage also non-block based jobs. Signed-off-by: Peter Krempa --- src/qemu/qemu_monitor.c | 12 src/qemu/qemu_monitor.h | 4 src/qemu/qemu_monitor_json.c | 22 ++ src/qemu/qemu_monitor_json.h |

[libvirt] [PATCH 4/9] qemu: monitor: Add support for 'job-dismiss' command

2019-06-24 Thread Peter Krempa
This belongs to the new job management API for generic jobs. The dismiss command is meant to remove a concluded job after we were able to get the final status. Signed-off-by: Peter Krempa --- src/qemu/qemu_monitor.c | 12 src/qemu/qemu_monitor.h | 4

[libvirt] [PATCH 3/9] qemu: monitor: Add new fields for 'blockdev-mirror' command

2019-06-24 Thread Peter Krempa
Allow using the delayed dismiss of the job so that we can reap the state even if libvirtd was not running when qemu emitted the job completion event. Signed-off-by: Peter Krempa --- src/qemu/qemu_migration.c| 2 +- src/qemu/qemu_monitor.c | 9 + src/qemu/qemu_monitor.h |

[libvirt] [PATCH 2/9] qemu: monitor: Add new fields for 'block-commit' command

2019-06-24 Thread Peter Krempa
Allow using the node name to specify the base and top of the 'commit' operation, allow specifying explicit job name and add support for delayed dismiss of the job so that we can reap the state even if libvirtd was not running when qemu emitted the job completion event. Signed-off-by: Peter Krempa

[libvirt] [PATCH 0/9] qemu: monitor: Pepare APIs for blockdev (blockdev-add saga)

2019-06-24 Thread Peter Krempa
This contains set of monitor adjustments needed for supporting the block job APIs with -blockdev. Note that the last patch does not contain tests as there is a extensive testsuite added with the actual formatter of the JSON properties which are used with that API which will be posted later. I

[libvirt] [PATCH 1/9] qemu: monitor: Add new fields for 'block-stream' command

2019-06-24 Thread Peter Krempa
Allow using the node name to specify the base of the 'stream' operation, allow specifying explicit job name and add support for delayed dismiss of the job so that we can reap the state even if libvirtd was not running when qemu emitted the job completion event. Signed-off-by: Peter Krempa ---

[libvirt] [PATCH 08/10] qemu: hotplug: Use storage chain helpers in qemuDomainRemoveDiskDevice

2019-06-24 Thread Peter Krempa
Use the new helpers for removing the backing chain in case when -blockdev is used. For -drive this function has a local implementation. Signed-off-by: Peter Krempa --- src/qemu/qemu_hotplug.c | 19 +-- 1 file changed, 13 insertions(+), 6 deletions(-) diff --git

[libvirt] [PATCH 09/10] qemu: hotplug: qemu: hotplug: Use storage chain helpers in qemuDomainChangeMediaBlockdev

2019-06-24 Thread Peter Krempa
As this conversion removes the last use of qemuHotplugDiskSource* functions we can remove all of them now. Signed-off-by: Peter Krempa --- src/qemu/qemu_hotplug.c | 188 ++-- 1 file changed, 7 insertions(+), 181 deletions(-) diff --git

[libvirt] [PATCH 10/10] qemu: hotplug: Remove rest of source backend if hotplug fails

2019-06-24 Thread Peter Krempa
When changing media using blockdev-add we need to remove the leftovers if we didn't succeed plugging in the full chain or closing the tray. Otherwise the data structures will be freed and thus the backing chain members will never be unplugged. Signed-off-by: Peter Krempa ---

[libvirt] [PATCH 06/10] qemu: command: get rid of 'cleanup' in qemuBuildDiskSourceCommandLine

2019-06-24 Thread Peter Krempa
Signed-off-by: Peter Krempa --- src/qemu/qemu_command.c | 22 -- 1 file changed, 8 insertions(+), 14 deletions(-) diff --git a/src/qemu/qemu_command.c b/src/qemu/qemu_command.c index 1ae8a00352..7a7497686a 100644 --- a/src/qemu/qemu_command.c +++ b/src/qemu/qemu_command.c @@

[libvirt] [PATCH 03/10] qemu: Introduce new set of helpers for attaching and detaching storage chains

2019-06-24 Thread Peter Krempa
These are meant to replace the ad-hoc helpers qemuHotplugDiskSourceAtttach... and the open-coded version in qemu_command.c for use in command line generation. The functions for preparing for attach of chains unfortunately need to be in qemu_command.c as they use function defined by that file and

[libvirt] [PATCH 02/10] qemu: hotplug: Handle copy-on-read filter separate from rest of backing chain

2019-06-24 Thread Peter Krempa
We use only one copy-on-read filter per disk, so we should handle it separately from the chain. Signed-off-by: Peter Krempa --- src/qemu/qemu_hotplug.c | 46 ++--- 1 file changed, 25 insertions(+), 21 deletions(-) diff --git a/src/qemu/qemu_hotplug.c

[libvirt] [PATCH 00/10] qemu: Refactor disk hotplug code for better reuse with blockdev (blockdev-add saga)

2019-06-24 Thread Peter Krempa
Move around few of the helpers which deal with disk addition and removal and fix a potential bug in the blockdev media change routine. The refactors will allow simplify a corner case of using blockdev such as if the disk frontend is unplugged the backends can be unplugged only after blockjobs

[libvirt] [PATCH 05/10] qemu: command: Use VIR_AUTO infrastructure in qemuBuildDiskSourceCommandLine

2019-06-24 Thread Peter Krempa
Signed-off-by: Peter Krempa --- src/qemu/qemu_command.c | 11 --- 1 file changed, 4 insertions(+), 7 deletions(-) diff --git a/src/qemu/qemu_command.c b/src/qemu/qemu_command.c index acfec8a1bb..1ae8a00352 100644 --- a/src/qemu/qemu_command.c +++ b/src/qemu/qemu_command.c @@ -2560,8

[libvirt] [PATCH 04/10] qemu: command: Use storage chain helpers in commandline generator

2019-06-24 Thread Peter Krempa
Replace the open-coded local implementation with qemuBuildStorageSourceChainAttachPrepare(Drive|Blockdev). Signed-off-by: Peter Krempa --- src/qemu/qemu_command.c | 34 +++--- 1 file changed, 7 insertions(+), 27 deletions(-) diff --git a/src/qemu/qemu_command.c

[libvirt] [PATCH 07/10] qemu: hotplug: Use storage chain helpers in qemuDomainAttachDiskGeneric

2019-06-24 Thread Peter Krempa
Replace the use of qemuHotplugDiskSourceAttach* helpers with qemuBuildStorageSourceChainAttachPrepare(Blockdev|Drive). Signed-off-by: Peter Krempa --- src/qemu/qemu_hotplug.c | 19 +++ 1 file changed, 11 insertions(+), 8 deletions(-) diff --git a/src/qemu/qemu_hotplug.c

[libvirt] [PATCH 01/10] qemu: block: Move and rename qemuHotplugRemoveStorageSourcePrepareData

2019-06-24 Thread Peter Krempa
Move it to qemu_block.c and call it qemuBlockStorageSourceDetachPrepare. It will be reused in other parts as well. Signed-off-by: Peter Krempa --- src/qemu/qemu_block.c | 57 + src/qemu/qemu_block.h | 4 +++ src/qemu/qemu_hotplug.c | 63

Re: [libvirt] [Qemu-devel] [PATCH] deprecate -mem-path fallback to anonymous RAM

2019-06-24 Thread Markus Armbruster
Igor Mammedov writes: > On Mon, 24 Jun 2019 10:17:33 +0200 > Markus Armbruster wrote: > >> Igor Mammedov writes: >> >> > Fallback might affect guest or worse whole host performance >> > or functionality if backing file were used to share guest RAM >> > with another process. >> > >> > Patch

Re: [libvirt] [Qemu-devel] [PATCH] deprecate -mem-path fallback to anonymous RAM

2019-06-24 Thread Igor Mammedov
On Mon, 24 Jun 2019 10:36:55 +0100 Daniel P. Berrangé wrote: > On Mon, Jun 24, 2019 at 10:17:33AM +0200, Markus Armbruster wrote: > > Igor Mammedov writes: > > > > > Fallback might affect guest or worse whole host performance > > > or functionality if backing file were used to share guest

Re: [libvirt] [Qemu-devel] [PATCH] deprecate -mem-path fallback to anonymous RAM

2019-06-24 Thread Igor Mammedov
On Mon, 24 Jun 2019 10:17:33 +0200 Markus Armbruster wrote: > Igor Mammedov writes: > > > Fallback might affect guest or worse whole host performance > > or functionality if backing file were used to share guest RAM > > with another process. > > > > Patch deprecates fallback so that we could

Re: [libvirt] [Qemu-devel] [PATCH] deprecate -mem-path fallback to anonymous RAM

2019-06-24 Thread Daniel P . Berrangé
On Mon, Jun 24, 2019 at 10:17:33AM +0200, Markus Armbruster wrote: > Igor Mammedov writes: > > > Fallback might affect guest or worse whole host performance > > or functionality if backing file were used to share guest RAM > > with another process. > > > > Patch deprecates fallback so that we

Re: [libvirt] [PATCH] RFC: maint: Sort public symbols within a release

2019-06-24 Thread Daniel P . Berrangé
On Fri, Jun 21, 2019 at 02:18:23PM -0500, Eric Blake wrote: > In libvirt_private.syms, we have a policy of keeping blocks of symbols > sorted by name - in fact, we enforce it during 'make check' with our > check-symsorting rule calling out to a perl script. But > libvirt_public.syms has been more

Re: [libvirt] [Qemu-devel] [PATCH] deprecate -mem-path fallback to anonymous RAM

2019-06-24 Thread Markus Armbruster
Igor Mammedov writes: > Fallback might affect guest or worse whole host performance > or functionality if backing file were used to share guest RAM > with another process. > > Patch deprecates fallback so that we could remove it in future > and ensure that QEMU will provide expected behavior and