Re: [PATCH v2] docs: Document reserved PCI addresses for QEMU

2020-04-23 Thread Laine Stump
On 4/21/20 2:00 PM, Michal Privoznik wrote: >From time to time we are asked which PCI addresses are reserved in QEMU. Let's document them in one place, it's easier than reconstructing the list from the code each time. Signed-off-by: Michal Privoznik --- diff to v1: - All Laine's comment

Re: [libvirt PATCH] CONTRIBUTING: Include information on build dependencies

2020-04-23 Thread Laine Stump
On 4/21/20 1:16 PM, Laine Stump wrote: On 4/20/20 6:54 AM, Andrea Bolognani wrote: libvirt depends on a ton of packages, so trying to install them all by using the classic approach of repeatedly running configure and reacting to each failure by installing the corresponding missing package will

[PATCH v2] news: Include new DHCP network feature

2020-04-23 Thread Julio Faracco
This commit includes an entry for new network DHCP lease time information inside news.xml. Signed-off-by: Julio Faracco --- docs/news.xml | 10 ++ 1 file changed, 10 insertions(+) diff --git a/docs/news.xml b/docs/news.xml index 956018b512..9c36f3bd51 100644 --- a/docs/news.xml +++

[libvirt-php] libvirt_list_storagepools() gives an error if all the storage pools on the host node are active

2020-04-23 Thread Fernando Casas Schössow
Hi, While using the function libvirt_list_storagepools() I found that if all the storage pools on the host node are active, the function doesn't return the list of storage pools but it gives the following error instead: names in virConnectListDefinedStoragePools must not be NULL Expected

Re: [PATCH] qemu: Move interlocking of blockjobs and checkpoints after liveness check

2020-04-23 Thread Pavel Mores
On Thu, Apr 23, 2020 at 04:13:43PM +0200, Peter Krempa wrote: > qemuDomainSupportsCheckpointsBlockjobs checks if the > QEMU_CAPS_INCREMENTAL_BACKUP capability is supported to do the > interlocking. Capabilities are not present when the VM isn't running > though which would create false errors. >

Re: [libvirt-ci RFC PATCH 00/13] Introduce a new global TOML config file for lcitool

2020-04-23 Thread Andrea Bolognani
On Wed, 2020-04-22 at 15:28 +0200, Erik Skultety wrote: > This series is trying to consolidate the number of config files we currently > recognize under ~/.config/lcitool to a single global TOML config file. Thanks > to this effort we can expose more seetings than we previously could which will >

Re: [PATCH 5/5] backup: Store error message for failed backups

2020-04-23 Thread Eric Blake
On 4/16/20 4:55 AM, Peter Krempa wrote: If a backup job fails midway it's hard to figure out what happened as it's running asynchronous. Use the VIR_DOMAIN_JOB_ERRMSG job statistics field to pass through the error from the first failed backup-blockjob so that both the consumer of the

Re: [PATCH 4/5] qemu: domain: Add 'errmsg' field to qemuDomainJobInfo

2020-04-23 Thread Eric Blake
On 4/16/20 4:55 AM, Peter Krempa wrote: The field can be used by jobs to add an optional error message to a completed (failed) job. Signed-off-by: Peter Krempa --- src/qemu/qemu_domain.c | 3 +++ src/qemu/qemu_domain.h | 2 ++ 2 files changed, 5 insertions(+) Reviewed-by: Eric Blake

Re: [PATCH 3/5] API: Add VIR_DOMAIN_JOB_ERRMSG domain job statistics field

2020-04-23 Thread Eric Blake
On 4/16/20 4:55 AM, Peter Krempa wrote: In some cases it's useful to report the error which caused the domain job to fail. Add an optional field for holding the error message so that it can be later retrieved from statistics of a completed job. Add the field name macro and code for extracting

Re: [PATCH] qemu: Move interlocking of blockjobs and checkpoints after liveness check

2020-04-23 Thread Eric Blake
On 4/23/20 9:13 AM, Peter Krempa wrote: qemuDomainSupportsCheckpointsBlockjobs checks if the QEMU_CAPS_INCREMENTAL_BACKUP capability is supported to do the interlocking. Capabilities are not present when the VM isn't running though which would create false errors. Move the checks after the

[PATCH 2/8] qemuhotplugtest: detach: Add expected 'object-del' to disk-scsi-multipath case

2020-04-23 Thread Peter Krempa
The test verifies unplug of a disk with the persistent reservations helper. The 'object-del' used to remove the helper was not mentioned in the list of expected commands. Signed-off-by: Peter Krempa --- tests/qemuhotplugtest.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git

[PATCH 5/8] qemucapabilitiesdata: riscv: Remove call to 'query-machines'

2020-04-23 Thread Peter Krempa
The riscv capabilities code doesn't use the data. Signed-off-by: Peter Krempa --- .../caps_3.0.0.riscv32.replies| 42 --- .../caps_3.0.0.riscv64.replies| 42 --- .../caps_4.0.0.riscv32.replies| 42

[PATCH 4/8] qemumonitortestutils: Make test monitor failures more prominent

2020-04-23 Thread Peter Krempa
Until now we've tried to report errors from the test monitor code by passing them back as failures from the qemu we simulate. This doesn't work well in cases when the monitor logic does not detect failures or has fallback code. Additionally there isn't much use for continuing the test execution

[PATCH 3/8] qemuhotplugtest: cpu: x86-modern-individual: Remove invalid test case

2020-04-23 Thread Peter Krempa
One of the test cases attempted to use test data meant for modern qemu without asserting the 'modern' flag. Since that changes the commands used to query state it won't work with data meant for the modern case. Remove the invalid test case. Signed-off-by: Peter Krempa ---

[PATCH 8/8] qemumonitortestutils: Enforce consumption of all items in test monitor

2020-04-23 Thread Peter Krempa
To prevent unexpected situations where a change in code would stop looking at some of the tested commands go unnoticed add a mechanism to force consumption of all test items. Since there are a few tests which would be hard to fix add also a mechanism to opt-out of the check. Signed-off-by: Peter

[PATCH 6/8] qemuhotplugtest: Remove 'drive_del' expectation from failed cases

2020-04-23 Thread Peter Krempa
On failure 'drive_del' is not issued. Signed-off-by: Peter Krempa --- tests/qemuhotplugtest.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/tests/qemuhotplugtest.c b/tests/qemuhotplugtest.c index 8afe7f7faa..65867a0122 100644 --- a/tests/qemuhotplugtest.c +++

[PATCH 7/8] qemumonitortestutils: Store a string identifying test monitor entry

2020-04-23 Thread Peter Krempa
For each test monitor entry store an optional string which will allow to identify it. This will be used later when checking that all registered monitor commands were used. Signed-off-by: Peter Krempa --- tests/qemuagenttest.c| 17 - tests/qemumonitortestutils.c | 10

[PATCH 0/8] tests: qemumonitor: Make fake qemu monitor failures more obvious

2020-04-23 Thread Peter Krempa
See patch 4 and 8 for details. Peter Krempa (8): tests: monitor: Rename qemuMonitorReportError to qemuMonitorTestAddErrorResponse qemuhotplugtest: detach: Add expected 'object-del' to disk-scsi-multipath case qemuhotplugtest: cpu: x86-modern-individual: Remove invalid test case

[PATCH 1/8] tests: monitor: Rename qemuMonitorReportError to qemuMonitorTestAddErrorResponse

2020-04-23 Thread Peter Krempa
It's a method of the test monitor and it adds a response to the monitor output. The original qemuMonitorTestAddErrorResponse method is renamed to qemuMonitorTestAddErrorResponseInternal Signed-off-by: Peter Krempa --- tests/qemuagenttest.c| 14 +++--- tests/qemumonitortestutils.c | 82

Re: [libvirt PATCH 3/3] qemu: block: external snapshot-delete implementation for straightforward cases

2020-04-23 Thread Pavel Mores
On Wed, Apr 22, 2020 at 03:49:57PM +0200, Peter Krempa wrote: > On Thu, Apr 16, 2020 at 17:07:35 +0200, Pavel Mores wrote: > > On Fri, Apr 03, 2020 at 05:56:59PM +0200, Pavel Mores wrote: > > > On Tue, Mar 31, 2020 at 12:06:15PM +0200, Peter Krempa wrote: > > > > On Tue, Mar 31, 2020 at 11:18:29

Re: [PATCH] news: Include new DHCP network feature

2020-04-23 Thread Julio Faracco
Em qui., 23 de abr. de 2020 às 11:10, Michal Privoznik escreveu: > > On 4/23/20 3:19 PM, Julio Faracco wrote: > > This commit includes an entry for new network DHCP lease time > > information inside news.xml. > > > > Signed-off-by: Julio Faracco > > --- > > docs/news.xml | 12 > >

Re: [PATCH] news: Include new DHCP network feature

2020-04-23 Thread Michal Privoznik
On 4/23/20 3:19 PM, Julio Faracco wrote: This commit includes an entry for new network DHCP lease time information inside news.xml. Signed-off-by: Julio Faracco --- docs/news.xml | 12 1 file changed, 12 insertions(+) diff --git a/docs/news.xml b/docs/news.xml index

[PATCH] qemu: Move interlocking of blockjobs and checkpoints after liveness check

2020-04-23 Thread Peter Krempa
qemuDomainSupportsCheckpointsBlockjobs checks if the QEMU_CAPS_INCREMENTAL_BACKUP capability is supported to do the interlocking. Capabilities are not present when the VM isn't running though which would create false errors. Move the checks after the liveness check in block job implementations.

[PATCH] news: Include new DHCP network feature

2020-04-23 Thread Julio Faracco
This commit includes an entry for new network DHCP lease time information inside news.xml. Signed-off-by: Julio Faracco --- docs/news.xml | 12 1 file changed, 12 insertions(+) diff --git a/docs/news.xml b/docs/news.xml index 956018b512..3a013ffbbd 100644 --- a/docs/news.xml +++

[PATCH 2/4] tests: more fine-granular tests for virtio-options

2020-04-23 Thread Bjoern Walk
Add separate tests for individual options and devices for virtio-options to have the ability to do more fine-granular testing of various combinations. Also, add negative tests for unavailable capabilities. Reviewed-by: Boris Fiuczynski Signed-off-by: Bjoern Walk ---

[PATCH 3/4] qemu: move virtio capability validation

2020-04-23 Thread Bjoern Walk
Move capability validation of virtio options from command line generation to post-parse device validation where it belongs. Signed-off-by: Bjoern Walk --- src/qemu/qemu_command.c | 41 ++-- src/qemu/qemu_validate.c | 70 +++--

[PATCH 0/4] move validation of virtio options

2020-04-23 Thread Bjoern Walk
Move validation of virtio options (iommu, ats, packed) from QEMU command line generation to domain validation. As a drive-by, increase the granularity of tests for virtio options. Bjoern Walk (4): tests: use latest caps for virtio-options test tests: more fine-granular tests for

[PATCH 4/4] qemu: command: make qemuBuildVirtioOptionsStr void

2020-04-23 Thread Bjoern Walk
Now that qemuBuildVirtioOptionsStr can not fail anymore, remove its return value and make it void. Signed-off-by: Bjoern Walk --- src/qemu/qemu_command.c | 38 +- 1 file changed, 13 insertions(+), 25 deletions(-) diff --git a/src/qemu/qemu_command.c

[PATCH 1/4] tests: use latest caps for virtio-options test

2020-04-23 Thread Bjoern Walk
Convert the virtio-options test in qemuxml2argv and qemuxml2xml to use the latest available QEMU capabilities. Reviewed-by: Boris Fiuczynski Signed-off-by: Bjoern Walk --- .../virtio-options.x86_64-latest.args | 69 +++ tests/qemuxml2argvdata/virtio-options.xml | 5

Re: [PATCH v3 0/2] Include lease time option into DHCP settings

2020-04-23 Thread Julio Faracco
Hi Michal, Sure! I will copy you to review the content. Feel free to change (for anyone who wants also). Thanks Laine and Daniel for other comments too. I forgot to mention them previously. -- Julio Cesar Faracco Em qui., 23 de abr. de 2020 às 06:01, Michal Privoznik escreveu: > > On 4/22/20

[libvirt-perl PATCH 3/3] gitlab: add a simple job that publishes the API docs as HTML

2020-04-23 Thread Daniel P . Berrangé
The Perl modules have inline POD docs. This can be converted to HTML and published as a GitLab artifact. The rendered HTML is kind of ugly but improving this is left as an exercise for the future. Signed-off-by: Daniel P. Berrangé --- .gitlab-ci.yml | 14 ++ 1 file changed, 14

[libvirt-perl PATCH 0/3] gitlab: introduce CI coverage

2020-04-23 Thread Daniel P . Berrangé
This series introduces CI jobs for the Perl binding, enabling the switch over to use of Merge Requests with pre-merge build validation. Daniel P. Berrangé (3): Build: bump min perl to 5.16.0 gitlab: add CI jobs for validating build across platforms gitlab: add a simple job that publishes

[libvirt-perl PATCH 2/3] gitlab: add CI jobs for validating build across platforms

2020-04-23 Thread Daniel P . Berrangé
This introduces CI jobs that replace the current jobs used on Jenkins for every platform except FreeBSD. A merge request workflow requires the user to fork the primary git repo into their personal namespace. In general the changes need to be tested against the current libvirt git master. If the

[libvirt-perl PATCH 1/3] Build: bump min perl to 5.16.0

2020-04-23 Thread Daniel P . Berrangé
Based on the supported platforms list, the oldest Perl we need to support is from RHEL-7, version 5.16.0 Signed-off-by: Daniel P. Berrangé --- Build.PL | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Build.PL b/Build.PL index ca3c786..7764e41 100755 --- a/Build.PL +++

[PATCH] networkxml2xmltest: Complete renaming of @actual

2020-04-23 Thread Michal Privoznik
In 97a0aa2467 the @actual variable was renamed to @confactual. However, the commit missed non-Linux case resulting in a broken build. Signed-off-by: Michal Privoznik --- Pushed under trivial and build-breaker rules. tests/networkxml2conftest.c | 2 +- 1 file changed, 1 insertion(+), 1

Re: [PATCH v1 0/7] add Spectre related PowerPC features

2020-04-23 Thread Daniel Henrique Barboza
Ping On 4/16/20 6:24 PM, Daniel Henrique Barboza wrote: Hi, This series implements 3 Spectre related PowerPC features that were added back in QEMU 2.12: - CFPC: Cache Flush on Privilege Change - SBBC: Speculation Barrier Bounds Checking - IBS: Indirect Branch Speculation These options

Re: [PATCH 0/4] qemuhotplugtest: Fix timeouts

2020-04-23 Thread Michal Privoznik
On 4/23/20 11:40 AM, Peter Krempa wrote: The test takes too long for no good reason. One was caused by the compiler inlining too much and second one was a deliberate decision. Peter Krempa (4): qemuDomainGetUnplugTimeout: Add G_GNUC_NO_INLINE mock:qemuDomainGetUnplugTimeout: Remove unused

[PATCH 2/4] mock:qemuDomainGetUnplugTimeout: Remove unused attribute for '@vm'

2020-04-23 Thread Peter Krempa
'@vm' is used to use a different timeout for ppc64 guests. Signed-off-by: Peter Krempa --- tests/qemuhotplugmock.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/tests/qemuhotplugmock.c b/tests/qemuhotplugmock.c index 8e5b07788d..8fe7fe7448 100644 ---

[PATCH 3/4] mock: qemuDomainGetUnplugTimeout: Decrease timeout

2020-04-23 Thread Peter Krempa
We always queue the DEVICE_DELETED events before successful return from the command so that tests are reliable. This means we can decrease the unplug timeout as it's guaranteed to be executed in correct order. According to my testing it shaves off ~450ms of test run: real0m0.721s vs. real

[PATCH 4/4] qemuhotplugtest: detach: Remove commands which are not issued

2020-04-23 Thread Peter Krempa
The 'human-monitor-command' equates to the 'drive-del' command issued by the hotplug code on successful detach of a device. This means that it's not issued for failed attempts and thus should not be added to the expected list. Unfortunately our test monitor doesn't ensure that all expected

[PATCH 1/4] qemuDomainGetUnplugTimeout: Add G_GNUC_NO_INLINE

2020-04-23 Thread Peter Krempa
The function is mocked in qemuhotplugmock.so. Recent clang versions decided to inline it so the mock stopped working resulting in qemuhotplugtest wasting 15 seconds waiting for timeouts. Signed-off-by: Peter Krempa --- src/qemu/qemu_hotplug.c | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH 0/4] qemuhotplugtest: Fix timeouts

2020-04-23 Thread Peter Krempa
The test takes too long for no good reason. One was caused by the compiler inlining too much and second one was a deliberate decision. Peter Krempa (4): qemuDomainGetUnplugTimeout: Add G_GNUC_NO_INLINE mock:qemuDomainGetUnplugTimeout: Remove unused attribute for '@vm' mock:

Re: [libvirt PATCH 3/5] Remove all usage of virRun

2020-04-23 Thread Michal Privoznik
On 4/22/20 6:52 PM, Ján Tomko wrote: Catch the individual usage not removed in previous commits. Signed-off-by: Ján Tomko --- src/lxc/lxc_driver.c | 5 +++-- src/qemu/qemu_domain.c | 16 src/security/security_apparmor.c | 11 +++

Re: [libvirt PATCH 0/5] Remove virRun in favor of virCommand

2020-04-23 Thread Michal Privoznik
On 4/22/20 6:52 PM, Ján Tomko wrote: Ján Tomko (5): openvz: switch from virRun to virCommand vmware: use virCommand instead of virRun Remove all usage of virRun util: remove references to virRun/virExec util: remove virRun src/libvirt_private.syms | 1 -

Re: [PATCH v3 0/2] Include lease time option into DHCP settings

2020-04-23 Thread Michal Privoznik
On 4/22/20 10:05 PM, Julio Faracco wrote: This series is based on latest series from Nehal. It includes a new entry called under and from scope. This was implemented to include independent lease time for each line and dnsmasq option. So, users are able to define one lease time for ranges and

Re: [PATCH v3 2/2] tests: Add tests for to cover dnsmasq settings

2020-04-23 Thread Michal Privoznik
On 4/22/20 10:05 PM, Julio Faracco wrote: New tests are required to cover some new XML syntax entry for option. This includes schema testing and other features like unit attribute and lease value. This commit includes hostsfile checks adding new files for each test case that is manipulating

Re: [PATCH v3 1/2] conf: Add option for settings

2020-04-23 Thread Michal Privoznik
On 4/22/20 10:05 PM, Julio Faracco wrote: If an user is trying to configure a dhcp neetwork settings, it is not possible to change the leasetime of a range or a host entry. This is available using dnsmasq extra options, but they are associated with dhcp-range or dhcp-hosts fields. This patch

Re: [all PATCH v2] gitlab: add CI job for validating DCO signoff

2020-04-23 Thread Andrea Bolognani
On Wed, 2020-04-22 at 18:31 +0100, Daniel P. Berrangé wrote: > +# Check that all commits are signed-off for the DCO. > +# Skip on "libvirt" namespace, since we only need to run > +# this test on developer's personal forks from which > +# merge requests are submitted > +check-dco: > + stage:

Re: [PATCH] news: Document new Xen hypervisor features

2020-04-23 Thread Andrea Bolognani
On Wed, 2020-04-22 at 11:55 -0600, Jim Fehlig wrote: > On 4/22/20 11:06 AM, Andrea Bolognani wrote: > > [1] Although it will never be a full rename, because it still need to > > handle libxl:// connection URLs. > > libxl:// was never supported. DV rightly pointed out that introducing >