[PATCH v2 2/3] xenconfig: add support for 'permissive' option of a PCI device

2020-04-24 Thread Marek Marczykowski-Górecki
Add support for xl.cfg(5) pci device 'permissive' option in domXML-to-xenconfig converter. And a test for it. Signed-off-by: Marek Marczykowski-Górecki --- Changes in v2: - new patch --- src/libxl/xen_common.c | 51 +---

[PATCH v2 1/3] libxl: Add 'permissive' option for PCI devices

2020-04-24 Thread Marek Marczykowski-Górecki
From: Simon Gaiser By setting the permissive flag the Xen guest access to the PCI config space is not filtered. This might be a security risk, but it's required for some devices and the IOMMU and interrupt remapping should (mostly?) contain it. Because of it (and that the attribute is Xen only),

[PATCH v2 3/3] xenconfig: add support for 'seize' option of a PCI device

2020-04-24 Thread Marek Marczykowski-Górecki
Add support for xl.cfg(5) pci device 'seize' option in domXML-to-xenconfig converter. And a test for it. It is functional equivalent of 'managed' attribute of a hostdev, so map it directly. Signed-off-by: Marek Marczykowski-Górecki --- Changes in v2: - new patch --- src/libxl/xen_common.c

Re: [PATCH 0/4] move validation of virtio options

2020-04-24 Thread Daniel Henrique Barboza
On 4/23/20 10:15 AM, Bjoern Walk wrote: Move validation of virtio options (iommu, ats, packed) from QEMU command line generation to domain validation. As a drive-by, increase the granularity of tests for virtio options. Thanks for contributing with the move of validation code. The new

Re: [PATCH v5 0/4] introduction of migration_version attribute for VFIO live migration

2020-04-24 Thread Dr. David Alan Gilbert
* Yan Zhao (yan.y.z...@intel.com) wrote: > On Tue, Apr 21, 2020 at 08:08:49PM +0800, Tian, Kevin wrote: > > > From: Yan Zhao > > > Sent: Tuesday, April 21, 2020 10:37 AM > > > > > > On Tue, Apr 21, 2020 at 06:56:00AM +0800, Alex Williamson wrote: > > > > On Sun, 19 Apr 2020 21:24:57 -0400 > > > >

Re: [PATCH 0/5] Xen: Add support for xl.cfg passthrough setting

2020-04-24 Thread Jim Fehlig
On 4/24/20 4:57 AM, Marek Marczykowski-Górecki wrote: On Fri, Apr 17, 2020 at 04:29:34PM -0600, Jim Fehlig wrote: Hi All, Note: This series is based on Marek's patches adding support for e820_host https://www.redhat.com/archives/libvir-list/2020-April/msg00633.html which I've ACK'ed, but am

Re: [libvirt PATCH v4 1/3] add QEMU_CAPS_TCG_DISABLED and probe conditionally

2020-04-24 Thread tobin
On 2020-04-24 11:31, Michal Privoznik wrote: On 4/22/20 11:50 PM, Tobin Feldman-Fitzthum wrote: Only probe QEMU binary with accel=tcg if TCG is not disabled. Similarly, only add a VIR_DOMAIN_VIRT_QEMU guest if TCG is available. Signed-off-by: Tobin Feldman-Fitzthum ---

Re: [libvirt PATCH v4 3/3] add virQEMUCapsProbeQMPTCGState function to set QEMU_CAPS_TCG_DISABLED

2020-04-24 Thread Michal Privoznik
On 4/24/20 9:58 AM, Peter Krempa wrote: On Wed, Apr 22, 2020 at 17:50:44 -0400, Tobin Feldman-Fitzthum wrote: Add virQEMUCapsProbeQMPTCGState to set TCG_DISABLED cap if version is > 2.10, KVM is enabled, and tcg-accel is not present in qom-list-types result. Signed-off-by: Tobin

Re: [libvirt PATCH v4 1/3] add QEMU_CAPS_TCG_DISABLED and probe conditionally

2020-04-24 Thread Michal Privoznik
On 4/22/20 11:50 PM, Tobin Feldman-Fitzthum wrote: Only probe QEMU binary with accel=tcg if TCG is not disabled. Similarly, only add a VIR_DOMAIN_VIRT_QEMU guest if TCG is available. Signed-off-by: Tobin Feldman-Fitzthum --- src/qemu/qemu_capabilities.c | 22 ++

Re: [PATCH 4/4] util: qcow2GetExtensions: Remove support for 'data file' extension

2020-04-24 Thread Eric Blake
On 4/24/20 10:18 AM, Peter Krempa wrote: On Fri, Apr 24, 2020 at 09:52:00 -0500, Eric Blake wrote: On 4/24/20 4:24 AM, Peter Krempa wrote: The implementation was never finished in libvirt. Remove it. Signed-off-by: Peter Krempa --- src/util/virstoragefile.c | 19 ++- 1

Re: [PATCH] virStorageSourceParseNBDColonString: Rewrite to match what qemu does

2020-04-24 Thread Peter Krempa
On Fri, Apr 24, 2020 at 10:02:49 -0500, Eric Blake wrote: > On 4/24/20 7:04 AM, Peter Krempa wrote: > > Our implementation wasn't quite able to parse everything that qemu does. > > This patch rewrites the parser to a code that semantically resembles the > > combination of 'nbd_parse_filename' and

Re: [PATCH 4/4] util: qcow2GetExtensions: Remove support for 'data file' extension

2020-04-24 Thread Peter Krempa
On Fri, Apr 24, 2020 at 09:52:00 -0500, Eric Blake wrote: > On 4/24/20 4:24 AM, Peter Krempa wrote: > > The implementation was never finished in libvirt. Remove it. > > > > Signed-off-by: Peter Krempa > > --- > > src/util/virstoragefile.c | 19 ++- > > 1 file changed, 2

[libvirt PATCH] travis: explicitly include gnutls to ensure it is updated

2020-04-24 Thread Daniel P . Berrangé
Travis includes gnutls in the default package set, but it is an outdated version linkng to an incompatible libffi version. The 'update: true' stanza causes the brew toolchain to be updated but not the installed formula. It is possible to run 'brew upgrade' to update installed formula, but this is

Re: [libvirt-php] libvirt_list_storagepools() gives an error if all the storage pools on the host node are active

2020-04-24 Thread Fernando Casas Schössow
I can confirm the problem is fixed in current master. Thanks and have a great weekend! On vie, abr 24, 2020 at 4:49 PM, Fernando Casas Schössow wrote: Hi Michal, Thanks for quick reply. Let me pull from master, rebuild the container and test it. I will report back with the result. Thanks,

Re: [PATCH] virStorageSourceParseNBDColonString: Rewrite to match what qemu does

2020-04-24 Thread Eric Blake
On 4/24/20 7:04 AM, Peter Krempa wrote: Our implementation wasn't quite able to parse everything that qemu does. This patch rewrites the parser to a code that semantically resembles the combination of 'nbd_parse_filename' and 'inet_parse' methods in qemu to be able to parse the strings in an

Re: [PATCH 4/4] util: qcow2GetExtensions: Remove support for 'data file' extension

2020-04-24 Thread Eric Blake
On 4/24/20 4:24 AM, Peter Krempa wrote: The implementation was never finished in libvirt. Remove it. Signed-off-by: Peter Krempa --- src/util/virstoragefile.c | 19 ++- 1 file changed, 2 insertions(+), 17 deletions(-) Shouldn't we at least recognize if there is a qcow2

Re: [libvirt-php] libvirt_list_storagepools() gives an error if all the storage pools on the host node are active

2020-04-24 Thread Fernando Casas Schössow
Hi Michal, Thanks for quick reply. Let me pull from master, rebuild the container and test it. I will report back with the result. Thanks, Fernando On vie, abr 24, 2020 at 4:16 PM, Michal Privoznik wrote: On 4/23/20 11:02 PM, Fernando Casas Schössow wrote: Hi, While using the function

Re: [PATCH 4/8] qemumonitortestutils: Make test monitor failures more prominent

2020-04-24 Thread Michal Privoznik
On 4/23/20 5:22 PM, Peter Krempa wrote: Until now we've tried to report errors from the test monitor code by passing them back as failures from the qemu we simulate. This doesn't work well in cases when the monitor logic does not detect failures or has fallback code. Additionally there isn't

Re: [PATCH 0/8] tests: qemumonitor: Make fake qemu monitor failures more obvious

2020-04-24 Thread Michal Privoznik
On 4/23/20 5:21 PM, Peter Krempa wrote: See patch 4 and 8 for details. Peter Krempa (8): tests: monitor: Rename qemuMonitorReportError to qemuMonitorTestAddErrorResponse qemuhotplugtest: detach: Add expected 'object-del' to disk-scsi-multipath case qemuhotplugtest: cpu:

Re: [libvirt-php] libvirt_list_storagepools() gives an error if all the storage pools on the host node are active

2020-04-24 Thread Michal Privoznik
On 4/23/20 11:02 PM, Fernando Casas Schössow wrote: Hi, While using the function libvirt_list_storagepools() I found that if all the storage pools on the host node are active, the function doesn't return the list of storage pools but it gives the following error instead: Hey, I've switched

Re: [PATCH v2 0/5] qemu: spport AIO interface io_uring

2020-04-24 Thread Pavel Mores
On Tue, Apr 21, 2020 at 08:19:33PM +0800, Han Han wrote: > Changes from v1: > - Separate the news XML patch from the docs patch > - More details in the descrition of news XML > - Change bus type of unit tests XML from ide to virtio > - Fix missing spaces in docs patch > - Reorder the sequence of

[PATCH] virStorageSourceParseNBDColonString: Rewrite to match what qemu does

2020-04-24 Thread Peter Krempa
Our implementation wasn't quite able to parse everything that qemu does. This patch rewrites the parser to a code that semantically resembles the combination of 'nbd_parse_filename' and 'inet_parse' methods in qemu to be able to parse the strings in an equivalent manner. The only thing that

Re: [PATCH v3 1/2] conf: Add option for settings

2020-04-24 Thread John Ferlan
On 4/22/20 4:05 PM, Julio Faracco wrote: > If an user is trying to configure a dhcp neetwork settings, it is not > possible to change the leasetime of a range or a host entry. This is > available using dnsmasq extra options, but they are associated with > dhcp-range or dhcp-hosts fields. This

Re: [PATCH 0/5] Xen: Add support for xl.cfg passthrough setting

2020-04-24 Thread Marek Marczykowski-Górecki
On Fri, Apr 17, 2020 at 04:29:34PM -0600, Jim Fehlig wrote: > Hi All, > > Note: This series is based on Marek's patches adding support for e820_host > > https://www.redhat.com/archives/libvir-list/2020-April/msg00633.html > > which I've ACK'ed, but am waiting to commit until this related

Re: [PATCH 2/4] util: Remove 'externalDataStore' field from virStorageSource

2020-04-24 Thread Ján Tomko
On a Friday in 2020, Peter Krempa wrote: It's not used for anything so we don't need to extract it. Signed-off-by: Peter Krempa --- src/util/virstoragefile.c | 41 --- src/util/virstoragefile.h | 3 --- 2 files changed, 44 deletions(-) Reviewed-by: Ján

Re: [PATCH 3/4] util: Remove 'externalDataStoreRaw' field from virStorageSource

2020-04-24 Thread Ján Tomko
On a Friday in 2020, Peter Krempa wrote: It's not used for anything so we don't need to extract it. Signed-off-by: Peter Krempa --- src/util/virstoragefile.c | 14 ++ src/util/virstoragefile.h | 2 -- 2 files changed, 2 insertions(+), 14 deletions(-) Reviewed-by: Ján Tomko Jano

Re: [PATCH 4/4] util: qcow2GetExtensions: Remove support for 'data file' extension

2020-04-24 Thread Ján Tomko
On a Friday in 2020, Peter Krempa wrote: The implementation was never finished in libvirt. Remove it. Signed-off-by: Peter Krempa --- src/util/virstoragefile.c | 19 ++- 1 file changed, 2 insertions(+), 17 deletions(-) Reviewed-by: Ján Tomko Jano signature.asc

Re: [PATCH 1/4] security: Remove labelling of 'externalDataStore'

2020-04-24 Thread Ján Tomko
On a Friday in 2020, Peter Krempa wrote: The feature was never completed and is not really being pursued. Remove the storage driver integration. s/storage/security/ Signed-off-by: Peter Krempa --- src/security/security_dac.c | 15 --- src/security/security_selinux.c | 17

[PATCH 3/4] util: Remove 'externalDataStoreRaw' field from virStorageSource

2020-04-24 Thread Peter Krempa
It's not used for anything so we don't need to extract it. Signed-off-by: Peter Krempa --- src/util/virstoragefile.c | 14 ++ src/util/virstoragefile.h | 2 -- 2 files changed, 2 insertions(+), 14 deletions(-) diff --git a/src/util/virstoragefile.c b/src/util/virstoragefile.c

[PATCH 1/4] security: Remove labelling of 'externalDataStore'

2020-04-24 Thread Peter Krempa
The feature was never completed and is not really being pursued. Remove the storage driver integration. Signed-off-by: Peter Krempa --- src/security/security_dac.c | 15 --- src/security/security_selinux.c | 17 + src/security/virt-aa-helper.c | 4 3

[PATCH 4/4] util: qcow2GetExtensions: Remove support for 'data file' extension

2020-04-24 Thread Peter Krempa
The implementation was never finished in libvirt. Remove it. Signed-off-by: Peter Krempa --- src/util/virstoragefile.c | 19 ++- 1 file changed, 2 insertions(+), 17 deletions(-) diff --git a/src/util/virstoragefile.c b/src/util/virstoragefile.c index 32ca481cc0..6dc9d1f016

[PATCH 0/4] Remove unfinished support for external data store of qcow2 files

2020-04-24 Thread Peter Krempa
The implementation was never finished properly. Since there isn't any push to finish it either, let's remove the code so that it doesn't keep rotting. Peter Krempa (4): security: Remove labelling of 'externalDataStore' util: Remove 'externalDataStore' field from virStorageSource util:

[PATCH 2/4] util: Remove 'externalDataStore' field from virStorageSource

2020-04-24 Thread Peter Krempa
It's not used for anything so we don't need to extract it. Signed-off-by: Peter Krempa --- src/util/virstoragefile.c | 41 --- src/util/virstoragefile.h | 3 --- 2 files changed, 44 deletions(-) diff --git a/src/util/virstoragefile.c

[PATCH] schema: backup: Make 'exportname' and 'exportbitmap' independent

2020-04-24 Thread Peter Krempa
Both are optional but don't have to be specified together. Fix the schema. https://bugzilla.redhat.com/show_bug.cgi?id=1826746 Suggested-by: Yi Sun Signed-off-by: Peter Krempa --- Pushed as trivial. docs/schemas/domainbackup.rng | 2 ++ 1 file changed, 2 insertions(+) diff --git

Re: [libvirt PATCH v4 3/3] add virQEMUCapsProbeQMPTCGState function to set QEMU_CAPS_TCG_DISABLED

2020-04-24 Thread Peter Krempa
On Wed, Apr 22, 2020 at 17:50:44 -0400, Tobin Feldman-Fitzthum wrote: > Add virQEMUCapsProbeQMPTCGState to set TCG_DISABLED cap if version > is > 2.10, KVM is enabled, and tcg-accel is not present in > qom-list-types result. > > Signed-off-by: Tobin Feldman-Fitzthum > --- >

Re: [PATCH v2] docs: Document reserved PCI addresses for QEMU

2020-04-24 Thread Michal Privoznik
On 4/24/20 3:46 AM, Laine Stump wrote: On 4/21/20 2:00 PM, Michal Privoznik wrote: >From time to time we are asked which PCI addresses are reserved in QEMU. Let's document them in one place, it's easier than reconstructing the list from the code each time. Signed-off-by: Michal Privoznik ---

Re: [PATCH 3/3] Add version info on domaincaps doc

2020-04-24 Thread Peter Krempa
On Wed, Apr 15, 2020 at 11:34:06 +, Sebastian Mitterle wrote: > 1. Add 'since 5.10' as commonly used in formatdomain to avoid >misunderstandings if element is not present (Is it not supported >because of my version or because of my environment?) > > Signed-off-by: Sebastian Mitterle

Re: [PATCH 2/3] Improve Disk image chains documentation

2020-04-24 Thread Peter Krempa
On Wed, Apr 15, 2020 at 11:34:05 +, Sebastian Mitterle wrote: > 1. Use 'setup' consistently as noun, 'set up' as verb > 2. Use path variables like '$IMAGE_PATH' consistently >like in Troubleshooting to improve readability > 3. Remove ':' from field names > 4. Change phrasing in sentences I

Re: [PATCH 1/3] Improve blockpull man entry

2020-04-24 Thread Peter Krempa
On Wed, Apr 15, 2020 at 11:34:04 +, Sebastian Mitterle wrote: > 1. Mention usage of `--base` and `--bandwidth` and fix cmd syntax. > 2. Explain valid arguments for `base`. > 3. Move explanation for `--keep-relative` to end considering it >less frequent use case because libvirt doesn't

Re: [PATCH v2] news: Include new DHCP network feature

2020-04-24 Thread Michal Privoznik
On 4/24/20 1:56 AM, Julio Faracco wrote: This commit includes an entry for new network DHCP lease time information inside news.xml. Signed-off-by: Julio Faracco --- docs/news.xml | 10 ++ 1 file changed, 10 insertions(+) Reviewed-by: Michal Privoznik and pushed. Thanks for

Re: [PATCH v2 1/5] qemu_capabilities: Introduce QEMU_CAPS_AIO_IO_URING

2020-04-24 Thread Peter Krempa
On Wed, Apr 22, 2020 at 16:55:17 +0800, Han Han wrote: > OK. Get it I've stripped out all of the 'replies' files changes from this patch and pushed the series.

Re: [libvirt-ci RFC PATCH 00/13] Introduce a new global TOML config file for lcitool

2020-04-24 Thread Erik Skultety
On Thu, Apr 23, 2020 at 06:46:09PM +0200, Andrea Bolognani wrote: > On Wed, 2020-04-22 at 15:28 +0200, Erik Skultety wrote: > > This series is trying to consolidate the number of config files we currently > > recognize under ~/.config/lcitool to a single global TOML config file. > > Thanks > > to