Re: [libvirt PATCH 6/7] nodedev: Handle inactive mdevs with the same UUID

2021-08-03 Thread Jonathon Jongsma
On Tue, Aug 3, 2021 at 6:24 AM Boris Fiuczynski wrote: > > On 8/2/21 5:30 PM, Jonathon Jongsma wrote: > > On Fri, Jul 30, 2021 at 8:01 AM Boris Fiuczynski > > wrote: > >> > >> On 7/30/21 9:48 AM, Michal Prívozník wrote: > >>> On 7/29/21 9:27 PM, Jonathon Jongsma wrote: > On Thu, Jul 29,

[libvirt PATCH 6/6] util: fix typo

2021-08-03 Thread Ján Tomko
Signed-off-by: Ján Tomko --- src/util/virprocess.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/util/virprocess.c b/src/util/virprocess.c index d946ac37f4..9b428bc623 100644 --- a/src/util/virprocess.c +++ b/src/util/virprocess.c @@ -402,7 +402,7 @@ pid_t

[libvirt PATCH 3/6] rpm: restart modular daemons on upgrade

2021-08-03 Thread Daniel P . Berrangé
The daemons all need restarting to ensure they pick up the newly installed code. Signed-off-by: Daniel P. Berrangé --- libvirt.spec.in | 69 + 1 file changed, 69 insertions(+) diff --git a/libvirt.spec.in b/libvirt.spec.in index

[libvirt PATCH 6/6] rpm: use direct remote connection for Fedora >= 35 / RHEL >= 9

2021-08-03 Thread Daniel P . Berrangé
Signed-off-by: Daniel P. Berrangé --- libvirt.spec.in | 8 +++- 1 file changed, 7 insertions(+), 1 deletion(-) diff --git a/libvirt.spec.in b/libvirt.spec.in index 44d1e7a3c3..af884f6126 100644 --- a/libvirt.spec.in +++ b/libvirt.spec.in @@ -1081,6 +1081,12 @@ exit 1 %define

[libvirt PATCH 5/6] rpm: handle enabling/disabling modular daemons post/postun-install

2021-08-03 Thread Daniel P . Berrangé
We need to enable or disable the modular daemons with systemd after the RPM install/uninstall. Signed-off-by: Daniel P. Berrangé --- libvirt.spec.in | 70 + 1 file changed, 70 insertions(+) diff --git a/libvirt.spec.in b/libvirt.spec.in index

[libvirt PATCH 2/6] rpm: restart virtnwfilter/virnetworkd if configs change

2021-08-03 Thread Daniel P . Berrangé
Currently we restart libvirtd if the nwfilter/network configs have changed. We need to take account of possibility that the modular daemons are in use instead though. Signed-off-by: Daniel P. Berrangé --- libvirt.spec.in | 4 1 file changed, 4 insertions(+) diff --git a/libvirt.spec.in

Re: [PATCH] vmx: Parse vm.genid

2021-08-03 Thread John Ferlan
On 8/2/21 7:00 AM, Michal Prívozník wrote: On 7/30/21 2:02 PM, Richard W.M. Jones wrote: On Thu, Jul 29, 2021 at 10:30:30AM +0200, Michal Privoznik wrote: The VMware metadata file contains genid but we are not parsing and thus reporting it in domain XML. However, it's not as straightforward

[libvirt PATCH 4/6] rpm: macroize logic for enabling/disabling daemons post/postun-install

2021-08-03 Thread Daniel P . Berrangé
The patterns for enabling/disabling daemons post/postun-install has a bit of duplication across the different part of the spec, due to the number of socket units involved. This is going to get much worse with the need to enable/disalbe modular daemons, so benefits from macroization.

[libvirt PATCH 1/6] rpm: macroize logic for restarting daemons post-transaction

2021-08-03 Thread Daniel P . Berrangé
The patterns for restarting daemons post-transaction has a bit of duplication across the different part of the spec. This is going to get much worse with the need to restart modular daemons, so benefits from macroization. Signed-off-by: Daniel P. Berrangé --- libvirt.spec.in | 42

[libvirt PATCH 0/6] rpm: enable modular daemons by default in Fedora 35 / RHEL 9

2021-08-03 Thread Daniel P . Berrangé
Daniel P. Berrangé (6): rpm: macroize logic for restarting daemons post-transaction rpm: restart virtnwfilter/virnetworkd if configs change rpm: restart modular daemons on upgrade rpm: macroize logic for enabling/disabling daemons post/postun-install rpm: handle enabling/disabling

[libvirt PATCH 5/6] qemu: virtiofs: kill the whole process group

2021-08-03 Thread Ján Tomko
Send TERM/KILL to virtiofsd and its child processes too and do not exit until they are all dead. https://bugzilla.redhat.com/show_bug.cgi?id=1940276 Signed-off-by: Ján Tomko --- src/qemu/qemu_virtiofs.c | 2 +- src/util/virpidfile.c| 7 ++- src/util/virprocess.c| 5 - 3 files

[libvirt PATCH 3/6] util: introduce virProcessGroupGet

2021-08-03 Thread Ján Tomko
Signed-off-by: Ján Tomko --- src/util/virprocess.c | 17 + src/util/virprocess.h | 1 + 2 files changed, 18 insertions(+) diff --git a/src/util/virprocess.c b/src/util/virprocess.c index c01c8e267b..bbfa4dbdf0 100644 --- a/src/util/virprocess.c +++ b/src/util/virprocess.c @@

[libvirt PATCH 2/6] util: Introduce virProcessGroupKill

2021-08-03 Thread Ján Tomko
Signed-off-by: Ján Tomko --- src/util/virprocess.c | 17 + src/util/virprocess.h | 1 + 2 files changed, 18 insertions(+) diff --git a/src/util/virprocess.c b/src/util/virprocess.c index d58e983b56..c01c8e267b 100644 --- a/src/util/virprocess.c +++ b/src/util/virprocess.c @@

[libvirt PATCH 4/6] util: virPidFileForceCleanupPath: add group argument

2021-08-03 Thread Ján Tomko
Add a version of virPidFileForceCleanupPath that takes a 'group' bool argument and propagate it all the way down to virProcessKillPainfullyDelay. Signed-off-by: Ján Tomko --- src/libvirt_private.syms | 1 + src/qemu/qemu_process.c | 3 ++- src/util/virpidfile.c| 8 +++-

[libvirt PATCH 1/3] vircgroup: introduce virCgroupGetInode function

2021-08-03 Thread Pavel Hrdina
For new feature Fibre Channel VMID we will need to get inode of the VM root cgroup as it is used in the new kernel API together with VMID. Signed-off-by: Pavel Hrdina --- src/libvirt_private.syms | 1 + src/util/vircgroup.c | 37 + src/util/vircgroup.h

[PATCH 5/7] conf: Store SCSI bus length in virDomainDef

2021-08-03 Thread Michal Privoznik
Libvirt assumes that a SCSI bus can fit up to 8 devices (including controller itself), except for so called wide bus which can accommodate up to 16 devices (again, including controller). This plays important role when computing 'drive' address in virDomainDiskDefAssignAddress(). So far, the only

Re: [PATCH] qemu_migration: check for interface type 'hostdev'

2021-08-03 Thread Michal Prívozník
On 8/3/21 3:59 PM, Laine Stump wrote: > On 7/29/21 5:42 AM, Michal Prívozník wrote: >> On 7/28/21 6:17 PM, Kristina Hanicova wrote: >>> When we try to migrate vm, we check if it contains only devices >>> that are able to migrate. If a hostdev device is not able to >>> migrate we raise an error

[libvirt PATCH 1/6] virProcessKillPainfullyDelay: use 'rc' variable

2021-08-03 Thread Ján Tomko
Use 'rc' to store the return value of virProcessKill, to separate the value check from the function call. Signed-off-by: Ján Tomko --- src/util/virprocess.c | 6 +- 1 file changed, 5 insertions(+), 1 deletion(-) diff --git a/src/util/virprocess.c b/src/util/virprocess.c index

[libvirt PATCHv2 0/6] kill whole virtiofsd process group (virtio-fs epopee)

2021-08-03 Thread Ján Tomko
v2 of: https://listman.redhat.com/archives/libvir-list/2021-June/msg00570.html Ján Tomko (6): virProcessKillPainfullyDelay: use 'rc' variable util: Introduce virProcessGroupKill util: introduce virProcessGroupGet util: virPidFileForceCleanupPath: add group argument qemu: virtiofs: kill

[libvirt PATCH 3/3] qemu: implement support for Fibre Channel VMID

2021-08-03 Thread Pavel Hrdina
Based on kernel commit messages the interface is /sys/class/fc/fc_udev_device/appid_store where we need to write the following string "$INODE:$VMID". $INODE is the VM root cgroup inode in hexadecimal and $VMID is user provided string that will be attached to each FC frame for the VM within

Re: [PATCH] qemu_migration: check for interface type 'hostdev'

2021-08-03 Thread Laine Stump
On 7/29/21 5:42 AM, Michal Prívozník wrote: On 7/28/21 6:17 PM, Kristina Hanicova wrote: When we try to migrate vm, we check if it contains only devices that are able to migrate. If a hostdev device is not able to migrate we raise an error with , but it can actually be , so we need to check if

[libvirt PATCH 0/3] add support for Fibre Channel VMID

2021-08-03 Thread Pavel Hrdina
Pavel Hrdina (3): vircgroup: introduce virCgroupGetInode function conf: introduce support for Fibre Channel VMID qemu: implement support for Fibre Channel VMID docs/formatdomain.rst | 13 ++ docs/schemas/domaincommon.rng | 11 + src/conf/domain_conf.c

[libvirt PATCH 2/3] conf: introduce support for Fibre Channel VMID

2021-08-03 Thread Pavel Hrdina
Signed-off-by: Pavel Hrdina --- docs/formatdomain.rst | 13 + docs/schemas/domaincommon.rng | 11 +++ src/conf/domain_conf.c | 5 + src/conf/domain_conf.h | 2 ++ src/conf/domain_validate.c | 19 +++

[PATCH 7/7] DO NOT MERGE

2021-08-03 Thread Michal Privoznik
This is just a example to confirm the previous commit works. I don't think it should be merged, because it modifies a real life example. Signed-off-by: Michal Privoznik --- tests/vmx2xmldata/vmx2xml-esx-in-the-wild-11.vmx | 6 ++ tests/vmx2xmldata/vmx2xml-esx-in-the-wild-11.xml | 5 + 2

[PATCH 3/7] vmx: Rework disk def allocation

2021-08-03 Thread Michal Privoznik
The way we parse VMX configuration is rather unfortunate, especially when it comes to disks. We allocate an array that can handle all possible disks but leave the array counter (ndisks) at zero and increase it only after successful parsing. But, we never size the array down to release unneeded

[PATCH 2/7] vmx2xmltest: Add a test case

2021-08-03 Thread Michal Privoznik
This is an attachment from the following bug: https://bugzilla.redhat.com/show_bug.cgi?id=1738392 Notice that .vmx file has two scsi disks, but only one is reported in the XML. This will be fixed later. Signed-off-by: Michal Privoznik --- .../vmx2xml-esx-in-the-wild-11.vmx| 91

[PATCH 1/7] vmx: Fill virtualHW.version to ESX version mapping

2021-08-03 Thread Michal Privoznik
At the beginning of vmx.c we have a comment that maps virtualHW.version field onto ESX version. However, it wasn't updated in a while. Fill it in using the following kbase article: https://kb.vmware.com/s/article/1003746 Signed-off-by: Michal Privoznik --- src/vmx/vmx.c | 4 1 file

[PATCH 0/7] vmx: Support super wide SCSI bus

2021-08-03 Thread Michal Privoznik
As of vSphere 6.7 there can be up to 64 units on a SCSI bus. Honestly, I'm not a big fan of 5/7 but we want to support three different values and one of them doesn't depend on the driver that's assigning the disk address, but at a runtime information. Thus using xmlopt is not good enough. Any

[PATCH 6/7] vmx: Support super wide SCSI bus

2021-08-03 Thread Michal Privoznik
Since its 6.7 release, vSphere allows up to 64 units on a SCSI bus [1]. The release version translates to virtualHW_version 13 and thus if we are dealing with sufficiently new version we can enable the feature. 1: https://configmax.vmware.com/guest?vmwareproduct=vSphere=vSphere%206.7=1-0

Re: [PATCH v4 0/4] Implement virDomainGetMessages for test driver

2021-08-03 Thread Martin Kletzander
On Mon, Jul 12, 2021 at 07:32:13PM +0800, Luke Yue wrote: v4: - Move testDomainObjCheckTaint to testParseDomains() - Add CPU tainted and deprecation check - Add a new xml with more tainted configs With the modification suggested in 1/4:0 Reviewed-by: Martin Kletzander Luke Yue (4): conf:

[PATCH 4/7] vmx: Drop needless check in virVMXParseDisk()

2021-08-03 Thread Michal Privoznik
After previous patch it can no longer happen that @def will be NULL and *def won't be. Signed-off-by: Michal Privoznik --- src/vmx/vmx.c | 5 - 1 file changed, 5 deletions(-) diff --git a/src/vmx/vmx.c b/src/vmx/vmx.c index 7a934e067d..11b6fcbdf8 100644 --- a/src/vmx/vmx.c +++

Re: [PATCH v4 1/4] conf: domain: Introduce and use virDomainObjGetMessages()

2021-08-03 Thread Martin Kletzander
On Tue, Jul 13, 2021 at 10:54:14AM +0800, Luke Yue wrote: On Mon, 2021-07-12 at 19:32 +0800, Luke Yue wrote: The test driver and qemu driver could share the same code in virDomainGetMessages(), so extract it to a function. Signed-off-by: Luke Yue ---  src/conf/domain_conf.c   | 53

Re: [libvirt PATCH 6/7] nodedev: Handle inactive mdevs with the same UUID

2021-08-03 Thread Boris Fiuczynski
On 8/2/21 5:30 PM, Jonathon Jongsma wrote: On Fri, Jul 30, 2021 at 8:01 AM Boris Fiuczynski wrote: On 7/30/21 9:48 AM, Michal Prívozník wrote: On 7/29/21 9:27 PM, Jonathon Jongsma wrote: On Thu, Jul 29, 2021 at 1:35 PM Boris Fiuczynski wrote: On 7/27/21 4:09 PM, Jonathon Jongsma wrote:

Re: [libvirt PATCH 3/3] virNWFilterParseParamAttributes: Simplify loop

2021-08-03 Thread Jano Tomko
On a %A in %Y, Tim Wiederhake wrote: > ping > Sorry, I thought you already pushed it based on Peter's reply. > On Fri, 2021-07-23 at 11:56 +0200, Tim Wiederhake wrote: >> Signed-off-by: Tim Wiederhake >> --- >>  src/conf/nwfilter_params.c | 7 ++- >>  1 file changed, 2 insertions(+), 5

Re: [libvirt PATCH 3/3] virNWFilterParseParamAttributes: Simplify loop

2021-08-03 Thread Tim Wiederhake
ping On Fri, 2021-07-23 at 11:56 +0200, Tim Wiederhake wrote: > Signed-off-by: Tim Wiederhake > --- >  src/conf/nwfilter_params.c | 7 ++- >  1 file changed, 2 insertions(+), 5 deletions(-) > > diff --git a/src/conf/nwfilter_params.c b/src/conf/nwfilter_params.c > index