Re: [libvirt PATCH 02/10] Revert "qemuxml2xmltest: Convert all acpi-hotplug control related tests to DO_TEST_CAPS_LATEST"

2021-10-24 Thread Ani Sinha
On Sat, 23 Oct 2021, Laine Stump wrote: > On 10/21/21 1:06 PM, Ján Tomko wrote: > > On a Thursday in 2021, Laine Stump wrote: > > > This reverts commit da896d440c7267e0b4575e4a3f2780bebf3fbfca. > > > > > > Signed-off-by: Laine Stump > > > --- > > > ...i-hotplug-bridge-disable.x86_64-latest.xml

[PATCH 9/9] qapi: Extend -compat to set policy for unstable interfaces

2021-10-24 Thread Markus Armbruster
New option parameters unstable-input and unstable-output set policy for unstable interfaces just like deprecated-input and deprecated-output set policy for deprecated interfaces (see commit 6dd75472d5 "qemu-options: New -compat to set policy for deprecated interfaces"). This is intended for

[PATCH 7/9] qapi: Generalize enum member policy checking

2021-10-24 Thread Markus Armbruster
The code to check enumeration value policy can see special feature flag 'deprecated' in QEnumLookup member flags[value]. I want to make feature flag 'unstable' visible there as well, so I can add policy for it. Instead of extending flags[], replace it by @special_features (a bitset of

[PATCH 8/9] qapi: Factor out compat_policy_input_ok()

2021-10-24 Thread Markus Armbruster
The code to check policy for handling deprecated input is triplicated. Factor it out into compat_policy_input_ok() before I mess with it in the next commit. Signed-off-by: Markus Armbruster --- include/qapi/compat-policy.h | 7 + qapi/qapi-visit-core.c | 18 +

[PATCH 4/9] qapi: Tools for sets of special feature flags in generated code

2021-10-24 Thread Markus Armbruster
New enum QapiSpecialFeature enumerates the special feature flags. New helper gen_special_features() returns code to represent a collection of special feature flags as a bitset. The next few commits will put them to use. Signed-off-by: Markus Armbruster --- include/qapi/util.h| 4

[PATCH 2/9] qapi: Mark unstable QMP parts with feature 'unstable'

2021-10-24 Thread Markus Armbruster
Add special feature 'unstable' everywhere the name starts with 'x-', except for InputBarrierProperties member x-origin and MemoryBackendProperties member x-use-canonical-path-for-ramblock-id, because these two are actually stable. Signed-off-by: Markus Armbruster --- qapi/block-core.json | 123

[PATCH 1/9] qapi: New special feature flag "unstable"

2021-10-24 Thread Markus Armbruster
By convention, names starting with "x-" are experimental. The parts of external interfaces so named may be withdrawn or changed incompatibly in future releases. Drawback: promoting something from experimental to stable involves a name change. Client code needs to be updated. Moreover, the

[PATCH 5/9] qapi: Generalize struct member policy checking

2021-10-24 Thread Markus Armbruster
The generated visitor functions call visit_deprecated_accept() and visit_deprecated() when visiting a struct member with special feature flag 'deprecated'. This makes the feature flag visible to the actual visitors. I want to make feature flag 'unstable' visible there as well, so I can add

[PATCH 0/9] Configurable policy for handling unstable interfaces

2021-10-24 Thread Markus Armbruster
Option -compat lets you configure what to do when deprecated interfaces get used. This series extends this to unstable interfaces. Works the same way. Intended for testing users of the management interfaces. It is experimental. To make it possible, I replace the "x-" naming convention by

[PATCH 6/9] qapi: Generalize command policy checking

2021-10-24 Thread Markus Armbruster
The code to check command policy can see special feature flag 'deprecated' as command flag QCO_DEPRECATED. I want to make feature flag 'unstable' visible there as well, so I can add policy for it. To let me make it visible, add member @special_features (a bitset of QapiSpecialFeature) to

[PATCH 3/9] qapi: Eliminate QCO_NO_OPTIONS for a slight simplification

2021-10-24 Thread Markus Armbruster
Signed-off-by: Markus Armbruster --- include/qapi/qmp/dispatch.h | 1 - monitor/misc.c | 3 +-- scripts/qapi/commands.py| 5 + 3 files changed, 2 insertions(+), 7 deletions(-) diff --git a/include/qapi/qmp/dispatch.h b/include/qapi/qmp/dispatch.h index

Re: [PATCH v4 5/5] block: Deprecate transaction type drive-backup

2021-10-24 Thread Markus Armbruster
I neglected to put RFC in the subject.

Re: [PATCH v3 1/5] qapi: Enable enum member introspection to show more than name

2021-10-24 Thread Markus Armbruster
Markus Armbruster writes: > The next commit will add feature flags to enum members. There's a > problem, though: query-qmp-schema shows an enum type's members as an > array of member names (SchemaInfoEnum member @values). If it showed > an array of objects with a name member, we could simply

[PATCH v4 0/5] qapi: Add feature flags to enum members

2021-10-24 Thread Markus Armbruster
PATCH 1+2 add feature flags to enum members. Awkward due to an introspection design mistake; see PATCH 1 for details. PATCH 3+4 implement policy deprecated-input={reject,crash} for enum values. Policy deprecated-output=hide is not implemented, because we can't hide a value without hiding the

[PATCH v4 4/5] qapi: Implement deprecated-input={reject, crash} for enum values

2021-10-24 Thread Markus Armbruster
This copies the code implementing the policy from qapi/qmp-dispatch.c to qapi/qobject-input-visitor.c. Tolerable, but if we acquire more copies, we should look into factoring them out. Signed-off-by: Markus Armbruster Reviewed-by: Eric Blake Tested-by: Peter Krempa Acked-by: Peter Krempa ---

[PATCH v4 1/5] qapi: Enable enum member introspection to show more than name

2021-10-24 Thread Markus Armbruster
The next commit will add feature flags to enum members. There's a problem, though: query-qmp-schema shows an enum type's members as an array of member names (SchemaInfoEnum member @values). If it showed an array of objects with a name member, we could simply add more members to these objects.

[PATCH v4 3/5] qapi: Move compat policy from QObject to generic visitor

2021-10-24 Thread Markus Armbruster
The next commit needs to access compat policy from the generic visitor core. Move it there from qobject input and output visitor. Signed-off-by: Markus Armbruster Reviewed-by: Eric Blake --- include/qapi/qobject-input-visitor.h | 4 include/qapi/qobject-output-visitor.h | 4

[PATCH v4 5/5] block: Deprecate transaction type drive-backup

2021-10-24 Thread Markus Armbruster
Several moons ago, Vladimir posted Subject: [PATCH v2 3/3] qapi: deprecate drive-backup Date: Wed, 5 May 2021 16:58:03 +0300 Message-Id: <20210505135803.67896-4-vsement...@virtuozzo.com> https://lists.gnu.org/archive/html/qemu-devel/2021-05/msg01394.html with this TODO: We

[PATCH v4 2/5] qapi: Add feature flags to enum members

2021-10-24 Thread Markus Armbruster
This is quite similar to commit 84ab008687 "qapi: Add feature flags to struct members", only for enums instead of structs. Special feature flag 'deprecated' is silently ignored there. This is okay only because it will be implemented shortly. Signed-off-by: Markus Armbruster Reviewed-by: Eric

Re: [libvirt PATCH 00/13] cgroup and thread management in ch driver.

2021-10-24 Thread Yan Fu
Hi, Could you give a reference link for ch driver please? Thanks, Yan Fu On Fri, Oct 22, 2021 at 11:43 PM Praveen K Paladugu < pra...@linux.microsoft.com> wrote: > This patchset adds support for cgroup management of ch threads. This > version > correctly manages cgroups for vcpu and emulator

[PATCH v5 3/5] conf: add encryption engine property

2021-10-24 Thread Or Ozeri
This commit extends libvirt XML configuration to support a custom encryption engine. This means that becomes valid. The only engine for now is qemu. However, a new engine (librbd) will be added in an upcoming commit. If no engine is specified, qemu will be used (assuming qemu driver is used).

[PATCH v5 2/5] qemu: capablities: Detect presence of 'rbd-encryption' as QEMU_CAPS_RBD_ENCRYPTION

2021-10-24 Thread Or Ozeri
rbd encryption is new in qemu 6.1.0. This commit adds capability probing for it. Signed-off-by: Or Ozeri --- src/qemu/qemu_capabilities.c | 2 ++ src/qemu/qemu_capabilities.h | 1 + tests/qemucapabilitiesdata/caps_6.1.0.x86_64.xml | 1 +

[PATCH v5 1/5] qemu: add disk post parse to qemublocktest

2021-10-24 Thread Or Ozeri
The post parse callback is part of the real (non-test) processing flow. This commit adds it (for disks) to the qemublocktest flow as well. Specifically, this will be needed for tests that use luks encryption, so that the default encryption engine (which is added in an upcoming commit) will be

[PATCH v5 0/5] Add support for librbd encryption

2021-10-24 Thread Or Ozeri
v5: rebased + nit fixes suggested by Peter v4: - added disk post parse to image creation flow in qemublocktest (since more tests failed after adding engine validation) - removed symlink changes - added luks2 and engine documentation - switched to using enum engine instead of int - added

[PATCH v5 5/5] conf: add luks2 encryption format

2021-10-24 Thread Or Ozeri
This commit extends libvirt XML configuration to support luks2 encryption format. This means that becomes valid. Currently librbd is the only engine that supports this new format. Signed-off-by: Or Ozeri --- docs/formatstorageencryption.html.in | 14 +-

[PATCH v5 4/5] qemu: add librbd encryption engine

2021-10-24 Thread Or Ozeri
rbd encryption is new in qemu 6.1.0. This commit adds a new encryption engine property which allows the user to use this new encryption engine. Signed-off-by: Or Ozeri --- docs/formatstorageencryption.html.in | 11 ++- docs/schemas/storagecommon.rng| 1 +