Re: [PATCH v3 3/3] qapi: deprecate drive-backup

2021-11-04 Thread Eric Blake
On Wed, Nov 03, 2021 at 02:29:12PM +0100, Vladimir Sementsov-Ogievskiy wrote: > Modern way is using blockdev-add + blockdev-backup, which provides a > lot more control on how target is opened. > > > Signed-off-by: Vladimir Sementsov-Ogievskiy > Reviewed-by: Kashyap Chamarthy > --- >

[libvirt PATCH] qemu: Do not pass negative ncpus to virCapabilitiesClearHostNUMACellCPUTopology

2021-11-04 Thread Jiri Denemark
It won't cause any harm as cpus is NULL when we pass a negative ncpus, but doing so when the function expects unsigned value is not right. Signed-off-by: Jiri Denemark --- src/conf/capabilities.c | 1 + 1 file changed, 1 insertion(+) diff --git a/src/conf/capabilities.c

[libvirt PATCH] qemu: Check return value of virJSONValueObjectAdd

2021-11-04 Thread Jiri Denemark
The return value was not properly checked in the code for input type evdev. Signed-off-by: Jiri Denemark --- src/qemu/qemu_command.c | 10 ++ 1 file changed, 6 insertions(+), 4 deletions(-) diff --git a/src/qemu/qemu_command.c b/src/qemu/qemu_command.c index 45278c7108..483041f584

[libvirt PATCH] util: Avoid null pointer dereference when setting QoS on OVS

2021-11-04 Thread Jiri Denemark
Signed-off-by: Jiri Denemark --- src/util/virnetdevopenvswitch.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/util/virnetdevopenvswitch.c b/src/util/virnetdevopenvswitch.c index 250726a633..5dab545037 100644 --- a/src/util/virnetdevopenvswitch.c +++

Re: [PATCH 1/2] conf: Introduce TCG domain features

2021-11-04 Thread Daniel P . Berrangé
On Thu, Nov 04, 2021 at 07:08:53PM +0100, Kashyap Chamarthy wrote: > On Thu, Nov 04, 2021 at 01:22:52PM +0100, Michal Privoznik wrote: > > It may come handy to be able to tweak TCG options, in this > > specific case the size of translation block cache size (tb-size). > > Since we can expect more

Re: [PATCH 1/2] conf: Introduce TCG domain features

2021-11-04 Thread Kashyap Chamarthy
On Thu, Nov 04, 2021 at 01:22:52PM +0100, Michal Privoznik wrote: > It may come handy to be able to tweak TCG options, in this > specific case the size of translation block cache size (tb-size). > Since we can expect more knobs to tweak let's put them under > common element, like this: > > >

Re: [PATCH 2/2] qemu: Generate command line for tb-cache feature

2021-11-04 Thread Kashyap Chamarthy
On Thu, Nov 04, 2021 at 01:22:53PM +0100, Michal Privoznik wrote: > Alright, here's the deal: to enable tb-cache one has to use > '-accel tcg,tb-size=' which then conflicts with '-machine > accel=tcg'. But sure, we can use the old -accel in this specific > case. But because of how the tb-size

Re: [PATCH 2/2] qemu: Generate command line for tb-cache feature

2021-11-04 Thread Daniel P . Berrangé
On Thu, Nov 04, 2021 at 01:22:53PM +0100, Michal Privoznik wrote: > Alright, here's the deal: to enable tb-cache one has to use > '-accel tcg,tb-size=' which then conflicts with '-machine > accel=tcg'. But sure, we can use the old -accel in this specific > case. But because of how the tb-size

Re: [PATCH 0/2] Allow tweaking TCG's tb-size

2021-11-04 Thread Kashyap Chamarthy
On Thu, Nov 04, 2021 at 01:22:51PM +0100, Michal Privoznik wrote: [...] > Michal Prívozník (2): > conf: Introduce TCG domain features > qemu: Generate command line for tb-cache feature > > docs/formatdomain.rst | 11 +++ > docs/schemas/domaincommon.rng

[libvirt PATCH v2 15/20] virhostcpu: Add virHostCPUGetCPUID

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/libvirt_private.syms | 1 + src/util/virhostcpu.c| 43 src/util/virhostcpu.h| 2 ++ 3 files changed, 46 insertions(+) diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms index

[libvirt PATCH v2 11/20] cpu: Add virCPUDataNewCopy

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/cpu/cpu.c| 21 + src/cpu/cpu.h| 7 +++ src/libvirt_private.syms | 1 + 3 files changed, 29 insertions(+) diff --git a/src/cpu/cpu.c b/src/cpu/cpu.c index 0c1c7902f0..b5669246b4 100644 --- a/src/cpu/cpu.c +++

[libvirt PATCH v2 09/20] cpu_arm: Implement virCPUDataIsIdentical for arm

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/cpu/cpu_arm.c | 27 +++ 1 file changed, 27 insertions(+) diff --git a/src/cpu/cpu_arm.c b/src/cpu/cpu_arm.c index ac174891b7..c9114d53bf 100644 --- a/src/cpu/cpu_arm.c +++ b/src/cpu/cpu_arm.c @@ -124,6 +124,32 @@

[libvirt PATCH v2 08/20] cpu_arm: No need to protect macro definitions

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/cpu/cpu_arm.c | 7 +++ 1 file changed, 3 insertions(+), 4 deletions(-) diff --git a/src/cpu/cpu_arm.c b/src/cpu/cpu_arm.c index 09ade1d422..ac174891b7 100644 --- a/src/cpu/cpu_arm.c +++ b/src/cpu/cpu_arm.c @@ -39,12 +39,11 @@ #include "virxml.h"

[libvirt PATCH v2 07/20] cpu_x86: Implement virCPUDataIsIdentical for x86

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/cpu/cpu_x86.c | 69 +++ 1 file changed, 69 insertions(+) diff --git a/src/cpu/cpu_x86.c b/src/cpu/cpu_x86.c index a08ac225ef..5ce193e693 100644 --- a/src/cpu/cpu_x86.c +++ b/src/cpu/cpu_x86.c @@ -3332,6 +3332,74

[libvirt PATCH v2 05/20] cpu: Split up virCPUDataParse

2021-11-04 Thread Tim Wiederhake
This makes it possible to call virCPUDataParse with a xmlNodePtr, which will be required by a later patch. Signed-off-by: Tim Wiederhake --- src/cpu/cpu.c| 29 + src/cpu/cpu.h| 2 ++ src/libvirt_private.syms | 1 + 3 files changed, 24

[libvirt PATCH v2 06/20] cpu: Add virCPUDataIsIdentical

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/cpu/cpu.c| 28 src/cpu/cpu.h| 9 + src/libvirt_private.syms | 1 + 3 files changed, 38 insertions(+) diff --git a/src/cpu/cpu.c b/src/cpu/cpu.c index b97d06c7d8..0c1c7902f0 100644 ---

[libvirt PATCH v2 04/20] cpu: Change virCPUArchDataParse to take xmlNodePtr

2021-11-04 Thread Tim Wiederhake
The function does not need a full xmlXPathContextPtr any longer and a later patch will require a call to this function with only a xmlNodePtr available. Signed-off-by: Tim Wiederhake --- src/cpu/cpu.c | 2 +- src/cpu/cpu.h | 2 +- src/cpu/cpu_x86.c | 4 ++-- 3 files changed, 4

[libvirt PATCH v2 02/20] cpu_x86: Simplify x86ParseMSR

2021-11-04 Thread Tim Wiederhake
... by using virXMLProp*() helpers. These only require a xmlNodePtr and do not need a xmlXPathContextPtr. Reflect that in the function signature. Signed-off-by: Tim Wiederhake --- src/cpu/cpu_x86.c | 26 +++--- 1 file changed, 11 insertions(+), 15 deletions(-) diff --git

[libvirt PATCH v2 00/20] Invalidate the cpu flags cache on host cpuid mismatch

2021-11-04 Thread Tim Wiederhake
Many things can affect the availability of cpu features (e.g. software upgrades, kernel versions, kernel command line, etc.) and invalidate the cached capabilities without notice. Add CPUID information to the capabilities cache. Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1953389. V1:

[libvirt PATCH v2 20/20] qemu: Invalidate capabilities cache on host cpuid mismatch

2021-11-04 Thread Tim Wiederhake
See https://bugzilla.redhat.com/show_bug.cgi?id=1953389. Signed-off-by: Tim Wiederhake --- src/qemu/qemu_capabilities.c | 15 --- src/qemu/qemu_capspriv.h | 3 ++- tests/qemucapsprobe.c| 2 +- 3 files changed, 15 insertions(+), 5 deletions(-) diff --git

[libvirt PATCH v2 18/20] virQEMUCaps: Add host cpuid information

2021-11-04 Thread Tim Wiederhake
Many things can affect the availability of cpu flags (e.g. software upgrades, kernel versions, kernel command line, etc.) and invalidate the cached capabilities without notice. Add CPUID information to the capabilities cache. Signed-off-by: Tim Wiederhake --- src/qemu/qemu_capabilities.c | 16

[libvirt PATCH v2 16/20] cpu_x86: Add virCPUDataGetHost

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/cpu/cpu.c| 19 +++ src/cpu/cpu.h| 7 +++ src/libvirt_private.syms | 1 + 3 files changed, 27 insertions(+) diff --git a/src/cpu/cpu.c b/src/cpu/cpu.c index b5669246b4..285c7eee44 100644 --- a/src/cpu/cpu.c +++

[libvirt PATCH v2 19/20] virQEMUCapsCachePriv: Add host cpuid information

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/qemu/qemu_capabilities.c | 4 1 file changed, 4 insertions(+) diff --git a/src/qemu/qemu_capabilities.c b/src/qemu/qemu_capabilities.c index b2d5242264..5fa3111201 100644 --- a/src/qemu/qemu_capabilities.c +++ b/src/qemu/qemu_capabilities.c @@ -4023,6

[libvirt PATCH v2 17/20] cpu_x86: Implement virCPUDataGetHost for x86

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/cpu/cpu_x86.c | 40 1 file changed, 40 insertions(+) diff --git a/src/cpu/cpu_x86.c b/src/cpu/cpu_x86.c index 0dc9a7d9fb..a72eae07dd 100644 --- a/src/cpu/cpu_x86.c +++ b/src/cpu/cpu_x86.c @@ -20,6 +20,9 @@

[libvirt PATCH v2 14/20] cpu_ppc64: Implement virCPUDataNewCopy for ppc64

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/cpu/cpu_ppc64.c | 18 ++ 1 file changed, 18 insertions(+) diff --git a/src/cpu/cpu_ppc64.c b/src/cpu/cpu_ppc64.c index fcd68c8a7c..c7caaa9608 100644 --- a/src/cpu/cpu_ppc64.c +++ b/src/cpu/cpu_ppc64.c @@ -603,6 +603,23 @@

[libvirt PATCH v2 12/20] cpu_x86: Implement virCPUDataNewCopy for x86

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/cpu/cpu_x86.c | 18 ++ 1 file changed, 18 insertions(+) diff --git a/src/cpu/cpu_x86.c b/src/cpu/cpu_x86.c index 5ce193e693..0dc9a7d9fb 100644 --- a/src/cpu/cpu_x86.c +++ b/src/cpu/cpu_x86.c @@ -481,6 +481,23 @@

[libvirt PATCH v2 01/20] cpu_x86: Simplify x86ParseCPUID

2021-11-04 Thread Tim Wiederhake
... by using virXMLProp*() helpers. These only require a xmlNodePtr and do not need a xmlXPathContextPtr. Reflect that in the function signature. Signed-off-by: Tim Wiederhake --- src/cpu/cpu_x86.c | 43 +-- 1 file changed, 17 insertions(+), 26

[libvirt PATCH v2 13/20] cpu_arm: Implement virCPUDataNewCopy for arm

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/cpu/cpu_arm.c | 20 1 file changed, 20 insertions(+) diff --git a/src/cpu/cpu_arm.c b/src/cpu/cpu_arm.c index c9114d53bf..51a3c1f3ee 100644 --- a/src/cpu/cpu_arm.c +++ b/src/cpu/cpu_arm.c @@ -150,6 +150,25 @@

[libvirt PATCH v2 10/20] cpu_ppc64: Implement virCPUDataIsIdentical for ppc64

2021-11-04 Thread Tim Wiederhake
Signed-off-by: Tim Wiederhake --- src/cpu/cpu_ppc64.c | 26 ++ 1 file changed, 26 insertions(+) diff --git a/src/cpu/cpu_ppc64.c b/src/cpu/cpu_ppc64.c index 4909f61ff1..fcd68c8a7c 100644 --- a/src/cpu/cpu_ppc64.c +++ b/src/cpu/cpu_ppc64.c @@ -578,6 +578,31 @@

[libvirt PATCH v2 03/20] cpu_x86: Add x86ParseDataItemList

2021-11-04 Thread Tim Wiederhake
Factor out duplicated code from x86FeatureParse and virCPUx86DataParse. This also consolidates error messages. Signed-off-by: Tim Wiederhake --- src/cpu/cpu_x86.c | 106 ++ 1 file changed, 41 insertions(+), 65 deletions(-) diff --git

Re: [libvirt PATCH 0/3] daemon: allow setting minimum SSF level

2021-11-04 Thread Michal Prívozník
On 11/3/21 2:09 PM, Ján Tomko wrote: > https://bugzilla.redhat.com/show_bug.cgi?id=1431589 > > Ján Tomko (3): > remote: warn on low SSF > daemon: virNetSASLContext: store tcpMinSSF > daemon: add tcp_min_ssf option > > src/libvirt_sasl.syms | 1 + >

Re: [libvirt PATCHv2 0/7] qemu: retire QEMU_CAPS_SPICE_UNIX

2021-11-04 Thread Peter Krempa
On Wed, Nov 03, 2021 at 11:53:24 +0100, Ján Tomko wrote: > Tim already acked v1, but I noticed a failure in the CI in patch > 5/7 because with the latest caps, we try to create a logfile for > one chardev in /tmp. > > Fix that by only testing name-escape with v2.11.0 QEMU caps. > I've heard

Re: [PATCH v2 2/2] qemu: tpm: Extend TPM domain XML with PCR banks to activate

2021-11-04 Thread Stefan Berger
On 11/2/21 05:38, Michal Prívozník wrote: On 11/1/21 6:23 PM, Stefan Berger wrote: So this runs reconfigure on every cold boot of a guest. I wonder whether there's a way to run it just once, when activePcrBanks have changed. For instance, in qemuDomainDefineXMLFlags() the @oldDef is set to

Re: [PATCH v2 0/1] virt-aa-helper: Remove corrupted profile

2021-11-04 Thread Christian Ehrhardt
On Thu, Nov 4, 2021 at 1:07 PM Christian Ehrhardt wrote: > > On Tue, Nov 2, 2021 at 3:04 PM Ioanna Alifieraki > wrote: > > > > This is a v2 of the patches sent previously and hopefully makes things > > simpler. > > (previous patches subject: [PATCH 0/4] virt-aa-helper: Add new option to > >

[PATCH 1/2] conf: Introduce TCG domain features

2021-11-04 Thread Michal Privoznik
It may come handy to be able to tweak TCG options, in this specific case the size of translation block cache size (tb-size). Since we can expect more knobs to tweak let's put them under common element, like this: 128 Signed-off-by: Michal Privoznik ---

[PATCH 0/2] Allow tweaking TCG's tb-size

2021-11-04 Thread Michal Privoznik
*** BLURB HERE *** Michal Prívozník (2): conf: Introduce TCG domain features qemu: Generate command line for tb-cache feature docs/formatdomain.rst | 11 +++ docs/schemas/domaincommon.rng | 15 +++- src/conf/domain_conf.c| 90

[PATCH 2/2] qemu: Generate command line for tb-cache feature

2021-11-04 Thread Michal Privoznik
Alright, here's the deal: to enable tb-cache one has to use '-accel tcg,tb-size=' which then conflicts with '-machine accel=tcg'. But sure, we can use the old -accel in this specific case. But because of how the tb-size argument is defined in QEMU there's no way for us to have a capability check.

Re: [PATCH v2 0/1] virt-aa-helper: Remove corrupted profile

2021-11-04 Thread Christian Ehrhardt
On Tue, Nov 2, 2021 at 3:04 PM Ioanna Alifieraki wrote: > > This is a v2 of the patches sent previously and hopefully makes things > simpler. > (previous patches subject: [PATCH 0/4] virt-aa-helper: Add new option to > remove corrupted). > > This patch aims to address the bug reported in [1]

[PATCH v4 0/3] qapi & doc: deprecate drive-backup

2021-11-04 Thread Markus Armbruster
See 03 commit message for details. 01-02 are preparation docs update. v4: deprecate drive-backup transaction by squashing [PATCH v4 5/5] block: Deprecate transaction type drive-backup Message-Id: <20211025042405.3762351-6-arm...@redhat.com> into PATCH 3 v3: wording fix-ups

[PATCH v4 3/3] qapi: deprecate drive-backup

2021-11-04 Thread Markus Armbruster
From: Vladimir Sementsov-Ogievskiy Modern way is using blockdev-add + blockdev-backup, which provides a lot more control on how target is opened. As example of drive-backup problems consider the following: User of drive-backup expects that target will be opened in the same cache and aio mode

[PATCH v4 1/3] docs/block-replication: use blockdev-backup

2021-11-04 Thread Markus Armbruster
From: Vladimir Sementsov-Ogievskiy We are going to deprecate drive-backup, so don't mention it here. Moreover, blockdev-backup seems more correct in the context. Signed-off-by: Vladimir Sementsov-Ogievskiy Reviewed-by: John Snow Signed-off-by: Markus Armbruster ---

[PATCH v4 2/3] docs/interop/bitmaps: use blockdev-backup

2021-11-04 Thread Markus Armbruster
From: Vladimir Sementsov-Ogievskiy We are going to deprecate drive-backup, so use modern interface here. In examples where target image creation is shown, show blockdev-add as well. If target creation omitted, omit blockdev-add as well. Reviewed-by: Kashyap Chamarthy Signed-off-by: Vladimir