Re: [RFC] Adding docker driver to libvirt

2020-04-14 Thread nshirokovskiy
On 12.04.2020 12:39, Martin Kletzander wrote: > On Thu, Apr 09, 2020 at 03:30:11PM +0300, nshirokovskiy wrote: >> Hi, all. >> >> Does it make sense to add such a driver? I can't say I have a big picture >> of docker functionality in mind but at least con

[RFC] Adding docker driver to libvirt

2020-04-09 Thread nshirokovskiy
Hi, all. Does it make sense to add such a driver? I can't say I have a big picture of docker functionality in mind but at least container lifecycle management and container networking are common to both. Nikolay

Re: [libvirt] [PATCH v2 1/1] qemu: hide details of fake reboot

2020-04-08 Thread nshirokovskiy
On 08.04.2020 16:08, Don Koch wrote: > On Wed, 8 Apr 2020 10:34:08 +0300 > nshirokovskiy wrote: > >> >> >> On 07.04.2020 20:31, Don Koch wrote: >>> On Thu, 19 Dec 2019 13:50:19 +0300 >>> Nikolay Shirokovskiy wrote: >>> >>>> If w

Re: [libvirt] [PATCH v2 1/1] qemu: hide details of fake reboot

2020-04-08 Thread nshirokovskiy
On 07.04.2020 20:31, Don Koch wrote: > On Thu, 19 Dec 2019 13:50:19 +0300 > Nikolay Shirokovskiy wrote: > >> If we use fake reboot then domain goes thru running->shutdown->running >> state changes with shutdown state only for short period of time. At >> least this is implementation details

Re: [RFC] Faster libvirtd restart with nwfilter rules, one more time

2020-04-06 Thread nshirokovskiy
ping On 20.03.2020 12:25, nshirokovskiy wrote: > Hi, all. > > > > Some time ago I posted RFC [1] concerning an issue

Re: RFC: qemu: use uuid instead of name for misc filenames

2020-03-30 Thread nshirokovskiy
On 30.03.2020 13:41, Daniel P. Berrangé wrote: > On Sun, Mar 29, 2020 at 02:33:41PM +0300, nshirokovskiy wrote: >> >> >> On 26.03.2020 20:50, Daniel P. Berrangé wrote: >>> On Fri, Feb 28, 2020 at 10:09:41AM +0300, Nikolay Shirokovskiy wrote: >>>> On

Re: RFC: qemu: use uuid instead of name for misc filenames

2020-03-29 Thread nshirokovskiy
On 26.03.2020 20:50, Daniel P. Berrangé wrote: > On Fri, Feb 28, 2020 at 10:09:41AM +0300, Nikolay Shirokovskiy wrote: >> On 27.02.2020 16:48, Daniel P. Berrangé wrote: >>> On Thu, Feb 27, 2020 at 03:57:04PM +0300, Nikolay Shirokovskiy wrote: Hi, everyone.

[RFC] Faster libvirtd restart with nwfilter rules, one more time

2020-03-20 Thread nshirokovskiy
Hi, all. Some time ago I posted RFC [1] concerning an issue of unresponsive libvird during restart if there is large number of VMs

Re: [PATCH 0/8] qemu: support renaming domains with snapshots/checkpoints

2020-03-16 Thread nshirokovskiy
ping On 03.03.2020 11:19, Nikolay Shirokovskiy wrote: > Nikolay Shirokovskiy (8): > qemu: remove duplicate code for removing remnant files > qemu: qemuDomainRenameCallback: fix sending false undefined event > qemu: rename: support renaming snapshots directory > qemu: rename: support

[libvirt] [PATCH v3 3/5] vz: support domain rename on migrate

2015-08-25 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com Signed-off-by: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com --- src/vz/vz_driver.c |6 ++ src/vz/vz_sdk.c| 16 +--- src/vz/vz_sdk.h|5 - 3 files changed, 15 insertions(+), 12 deletions(-) diff --git

[libvirt] [PATCH v3 5/5] vz: cleanup: define vz format of uuids

2015-08-25 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com vz puts uuids into curly braces. Simply introduce new contstant to reflect this and get rid of magic +2 in code. Signed-off-by: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com --- src/vz/vz_sdk.c | 12 ++-- src/vz/vz_utils.h |

[libvirt] [PATCH v3 1/5] vz: save session uuid on login

2015-08-25 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com This session uuid acts as authN token for different multihost vz operations one of which is migration. Unfortunately we can't get it from server at any time thus we need to save it at login. Signed-off-by: Nikolay Shirokovskiy

[libvirt] [PATCH v3 2/5] vz: add migration backbone code

2015-08-25 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com This patch makes basic vz migration possible. For example by virsh: virsh -c vz:///system migrate --direct $NAME $STUB vz+ssh://$DST/system $STUB could be anything as it is required virsh argument but it is not used in direct migration.

[libvirt] [PATCH v3 4/5] vz: support misc migration options

2015-08-25 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com Migration API has a lot of options. This patch intention is to provide support for those options that can be trivially supported and give estimation for other options support in this commit message. I. Supported. 1. VIR_MIGRATE_COMPRESSED.

[libvirt] [PATCH v3 0/5] vz: add migration support

2015-08-25 Thread nshirokovskiy
NOTE that minimal command to migrate vz domain is like next: virsh -c vz:///system migrate --direct 200 shiny0 --migrateuri vz+ssh://shiny0/system --live --persistent --compressed ==Difference from v1: 1. Patch is quite different. First patchset implements migration thru managed migration

[libvirt] [PATCH v2 3/7] vz: add migration backbone code

2015-07-17 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com This patch makes basic vz migration possible. For example by virsh: virsh -c vz:///system migrate $NAME vz+ssh://$DST/system Vz migration is implemented as peer2peer migration. The reason is that vz sdk do all the job. The question may arise

[libvirt] [PATCH v2 5/7] vz: support migration uri

2015-07-17 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com Signed-off-by: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com --- src/vz/vz_driver.c | 58 --- 1 files changed, 54 insertions(+), 4 deletions(-) diff --git a/src/vz/vz_driver.c

[libvirt] [PATCH v2 2/7] vz: provide a way to get remote session uuid

2015-07-17 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com We need the session uuid of a connection to destination host on source host to perform migration. This patch do all the job to pass this uuid from destination node to source. Signed-off-by: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com

[libvirt] [PATCH v2 6/7] vz: support misc migration options

2015-07-17 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com Migration API has a lot of options. This patch intention is to provide support for those options that can be trivially supported and give estimation for other options support in this commit message. I. Supported. 1. VIR_MIGRATE_COMPRESSED.

[libvirt] [PATCH v2 0/7] vz: add migration support

2015-07-17 Thread nshirokovskiy
NOTE that minimal command to migrate vz domain is like next: virsh -c vz:///system migrate 200 vz+ssh://shiny0/system -p2p --live --persistent --compressed Difference from v1: 1. Patch is quite different. First patchset implements migration thru managed migration scheme. This one goes thru p2p

[libvirt] [PATCH v2 7/7] vz: cleanup: define vz format of uuids

2015-07-17 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com vz puts uuids into curly braces. Simply introduce new contstant to reflect this and get rid of magic +2 in code. Signed-off-by: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com --- src/vz/vz_sdk.c | 12 ++-- src/vz/vz_utils.h |

[libvirt] [PATCH v2 1/7] vz: save session uuid on login

2015-07-17 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com This session uuid acts as authN token for different multihost vz operations one of which is migration. Unfortunately we can't get it from server at any time thus we need to save it at login. Signed-off-by: Nikolay Shirokovskiy

[libvirt] [PATCH v2 4/7] vz: support domain rename on migrate

2015-07-17 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com Signed-off-by: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com --- src/vz/vz_driver.c | 12 ++-- src/vz/vz_sdk.c| 16 +--- src/vz/vz_sdk.h|5 - 3 files changed, 23 insertions(+), 10 deletions(-) diff

[libvirt] [PATCH 4/6] vz: support migration uri

2015-07-13 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com Signed-off-by: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com --- src/vz/vz_driver.c | 52 +++- 1 files changed, 51 insertions(+), 1 deletions(-) diff --git a/src/vz/vz_driver.c

[libvirt] [PATCH 5/6] vz: support misc migration options

2015-07-13 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com Migration API has a lot of options. This patch intention is to provide support for those options that can be trivially supported and give estimation for other options support in this commit message. I. Supported. 1. VIR_MIGRATE_COMPRESSED.

[libvirt] [PATCH 1/6] vz: add migration backbone code

2015-07-13 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com This patch makes basic vz migration possible. For example by virsh: virsh -c vz:///system migrate $NAME vz+ssh://$DST/system Vz migration is implemented thru interface for managed migrations for drivers although it looks like a candadate for

[libvirt] [PATCH 3/6] vz: support domain rename on migrate

2015-07-13 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com --- src/vz/vz_driver.c | 12 +--- src/vz/vz_sdk.c|5 +++-- src/vz/vz_sdk.h|5 - 3 files changed, 16 insertions(+), 6 deletions(-) diff --git a/src/vz/vz_driver.c b/src/vz/vz_driver.c index d5cbdc6..a42597c

[libvirt] [PATCH 6/6] vz: cleanup: define vz format of uuids

2015-07-13 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com vz puts uuids into curly braces. Simply introduce new contstant to reflect this and get rid of magic +2 in code. Signed-off-by: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com --- src/vz/vz_sdk.c | 12 ++-- src/vz/vz_utils.h |

[libvirt] [PATCH 2/6] vz: pass cookies in xml form

2015-07-13 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com This way we can easily keep backward compatibility in the future. Use 2 distinct cookies format: 1 - between phases 'prepare' and 'perform' 2 - between phases 'perform' and 'finish' I see no reason to use unified format like in qemu yet.

[libvirt] [PATCH v2 0/3] driver level connection close event

2015-06-25 Thread nshirokovskiy
Notify of connection close event from parallels driver (possibly) wrapped in the remote driver. Changes from v1: 1. fix comment style issues 2. remove spurious whitespaces 3. move rpc related part from vz patch to second(rpc) patch 4. remove unnecessary locks for immutable closeCallback in first

[libvirt] [PATCH v2 2/3] daemon: relay connection close event related functions

2015-06-25 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com Add conneciton close subscription/unsubscription and event rpc. Now remote driver firing connection close event in 2 cases. 1. connection to daemon closed, as previously 2. as a relay of connection close event from wrapped driver As it

[libvirt] [PATCH v2 3/3] vz: implement connection close notification

2015-06-25 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com Reuse virConnectCloseCallback to implement connection close event functions. This way we automatically meet multi-thread requirements on unregistering/notification. --- src/vz/vz_driver.c | 26 ++ src/vz/vz_sdk.c

[libvirt] [PATCH v2 1/3] remote: move connection close callback to driver level

2015-06-25 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com 1. Introduce connect(Un)RegisterCloseCallback driver functions. 2. virConnect(Un)RegisterCloseCallback now works through driver. 3. virConnectCloseCallback is factored from virConnect but mostly stay the same. Notice however that virConnect

[libvirt] [PATCH] vz: fix SDK event dispatching

2015-06-25 Thread nshirokovskiy
From: Nikolay Shirokovskiy nshirokovs...@virtuozzo.com Current version of SDK event dispatcing is incorrect. For most VM events (add, delete etc) issuer type is PIE_DISPATCHER. Actually analyzing issuer type doesn't have any benifints so this patch get rid of it. All dispatching is done only on