Re: [libvirt] [PATCHv4 09/15] util: rename virFileOperation to virFileOpenAs

2011-03-18 Thread Eric Blake
On 03/11/2011 08:39 AM, Laine Stump wrote: path, mode); goto childerror; } -if (flags VIR_FILE_OP_RETURN_FD) { +{ VIR_FORCE_CLOSE(pair[0]); This VIR_FORCE_CLOSE(pair[0]) should be moved up to the very start of the child

Re: [libvirt] [PATCHv4 09/15] util: rename virFileOperation to virFileOpenAs

2011-03-11 Thread Laine Stump
On 03/09/2011 08:45 PM, Eric Blake wrote: This patch intentionally doesn't change indentation, in order to make it easier to review the real changes. * src/util/util.h (VIR_FILE_OP_RETURN_FD, virFileOperationHook): Delete. (virFileOperation): Rename... (virFileOpenAs): ...and reduce parameters.

Re: [libvirt] [PATCHv4 09/15] util: rename virFileOperation to virFileOpenAs

2011-03-10 Thread Daniel P. Berrange
On Wed, Mar 09, 2011 at 06:45:49PM -0700, Eric Blake wrote: This patch intentionally doesn't change indentation, in order to make it easier to review the real changes. More importantly it removes the hook function now. * src/util/util.h (VIR_FILE_OP_RETURN_FD, virFileOperationHook):

[libvirt] [PATCHv4 09/15] util: rename virFileOperation to virFileOpenAs

2011-03-09 Thread Eric Blake
This patch intentionally doesn't change indentation, in order to make it easier to review the real changes. * src/util/util.h (VIR_FILE_OP_RETURN_FD, virFileOperationHook): Delete. (virFileOperation): Rename... (virFileOpenAs): ...and reduce parameters. * src/util/util.c (virFileOperationNoFork,