Re: [libvirt] RFC: add currentVcpu element

2010-09-28 Thread Eric Blake
On 09/27/2010 11:20 AM, Eric Blake wrote: No change to existing API semantics, although the implementation can wrap old APIs to call the new ones with appropriate flags where appropriate to minimize code duplication. One more API to think about: virDomainGetInfo returns a virDomainInfoPtr,

Re: [libvirt] RFC: add currentVcpu element

2010-09-28 Thread Eric Blake
On 09/27/2010 11:20 AM, Eric Blake wrote: Another question I had, is there a way in QEmu to specifiy a different cpu count from the -smp indicating the startup count ? I wish I knew off-hand, as it would make it easier for me to implement when I get to that part of the patch series :) But

Re: [libvirt] RFC: add currentVcpu element

2010-09-27 Thread Daniel Veillard
On Fri, Sep 24, 2010 at 02:25:30PM -0600, Eric Blake wrote: On 09/23/2010 04:38 PM, Eric Blake wrote: At the library API layer, I plan on adding: virDomainSetMaxVcpus - alter the vcpu xml aspect of a domain for next boot; only affects persistent state As I start to code this, it seems a

Re: [libvirt] RFC: add currentVcpu element

2010-09-27 Thread Eric Blake
On 09/27/2010 10:21 AM, Daniel Veillard wrote: At the XML layer, I'm proposing the addition of a new elementcurrentVcpu: domain ... vcpu2/vcpu currentVcpu1/vcpu ... Hum, we already have an attribute cpuset forvcpu which is used to specify the semantic, I would rather keep an

Re: [libvirt] RFC: add currentVcpu element

2010-09-27 Thread Eric Blake
On 09/27/2010 10:25 AM, Daniel Veillard wrote: using these flags: VIR_SET_VCPU_MAXIMUM = 1 VIR_SET_VCPU_PERSISTENT = 2 such that virDomainSetVcpusFlags(dom,1,0) - same as existing virDomainSetVcpus virDomainSetVcpusFlags(dom,1,VIR_SET_VCPU_MAXIMUM) - error; can't change max on active domain

Re: [libvirt] RFC: add currentVcpu element

2010-09-27 Thread Daniel Veillard
On Mon, Sep 27, 2010 at 10:33:42AM -0600, Eric Blake wrote: On 09/27/2010 10:21 AM, Daniel Veillard wrote: At the XML layer, I'm proposing the addition of a new elementcurrentVcpu: domain ... vcpu2/vcpu currentVcpu1/vcpu ... Hum, we already have an attribute cpuset forvcpu

Re: [libvirt] RFC: add currentVcpu element

2010-09-27 Thread Daniel Veillard
On Mon, Sep 27, 2010 at 11:20:42AM -0600, Eric Blake wrote: On 09/27/2010 10:25 AM, Daniel Veillard wrote: using these flags: VIR_SET_VCPU_MAXIMUM = 1 VIR_SET_VCPU_PERSISTENT = 2 such that virDomainSetVcpusFlags(dom,1,0) - same as existing virDomainSetVcpus

Re: [libvirt] RFC: add currentVcpu element

2010-09-27 Thread Eric Blake
On 09/27/2010 02:26 PM, Daniel Veillard wrote: vcpu current=24/vcpu instead Possible, but consider that we have: domain ... memory256/memory currentMemory128/memory ... /domain So I was modeling aftermemory/currentMemory for consistency. Preferences on whether the parallel element

Re: [libvirt] RFC: add currentVcpu element

2010-09-24 Thread Eric Blake
On 09/23/2010 04:38 PM, Eric Blake wrote: At the library API layer, I plan on adding: virDomainSetMaxVcpus - alter the vcpu xml aspect of a domain for next boot; only affects persistent state As I start to code this, it seems a bit redundant. I can avoid virDomainSetMaxVcpus by

[libvirt] RFC: add currentVcpu element

2010-09-23 Thread Eric Blake
Some hypervisors have the ability to hot-plug VCPUs exposed to the guest. Right now, libvirt XML only has the ability to describe the total number of vcpus assigned to a domain (the vcpu element under domain). It has the following APIs: virConnectGetMaxVcpus - provide maximum that host can