Re: [PATCH 02/10] drivers:crypto: return -ENOMEM on allocation failure.

2017-10-06 Thread Herbert Xu
Allen Pais wrote: > Signed-off-by: Allen Pais Patch applied. Thanks. -- Email: Herbert Xu Home Page: http://gondor.apana.org.au/~herbert/ PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt -- To unsubscribe from

Re: [PATCH 3/3] btrfs: get rid of sector_t and use u64 offset in submit_extent_page

2017-10-06 Thread Liu Bo
On Fri, Oct 06, 2017 at 02:30:00PM +0200, David Sterba wrote: > The use of sector_t in the callchain of submit_extent_page is not > necessary, we'll pass plain u64 and avoid any con(tro)versions of sector_t. > > Signed-off-by: David Sterba > --- > fs/btrfs/extent_io.c | 23

Re: [PATCH 1/3] btrfs: scrub: get rid of sector_t

2017-10-06 Thread Liu Bo
On Fri, Oct 06, 2017 at 02:29:56PM +0200, David Sterba wrote: > The use of sector_t is not necessry, it's just for a warning. Switch to > u64 and rename the variable. The messages are adjusted as well. > > Signed-off-by: David Sterba > --- > fs/btrfs/scrub.c | 14

Re: [PATCH 2/3] btrfs: rename page offset parameter in submit_extent_page

2017-10-06 Thread Liu Bo
On Fri, Oct 06, 2017 at 02:29:58PM +0200, David Sterba wrote: > We're going to remove sector_t and will use 'offset', so this patch > frees the name. > > Signed-off-by: David Sterba > --- > fs/btrfs/extent_io.c | 8 > 1 file changed, 4 insertions(+), 4 deletions(-) >

Re: "BTRFS error (device vda1): couldn't get super buffer head for bytenr x"

2017-10-06 Thread Liu Bo
On Fri, Oct 06, 2017 at 12:25:17PM +0200, Nick Gilmour wrote: > Hi all, > > I have converted .vdi disk (BTRFS) into a .img disk, resized it from > 500GB to 150GB and then copied into a ZFS Volume. I've imported the VM > into VMM and it started normally but an upgrade failed. I've rebooted > and

Re: [PATCH 1/1] Btrfs: heuristic add shannon entropy calculation

2017-10-06 Thread Timofey Titovets
2017-10-06 21:24 GMT+03:00 David Sterba : > On Thu, Oct 05, 2017 at 01:07:26PM +0300, Timofey Titovets wrote: >> Byte distribution check in heuristic will filter edge data >> cases and some time fail to classificate input data >> >> Let's fix that by adding Shannon entropy

Re: [PATCH v8 2/2] btrfs: check device for critical errors and mark failed

2017-10-06 Thread Liu Bo
On Thu, Oct 05, 2017 at 09:56:59PM +0800, Anand Jain wrote: > > > On 10/05/2017 04:11 AM, Liu Bo wrote: > > On Tue, Oct 03, 2017 at 11:59:20PM +0800, Anand Jain wrote: > > > From: Anand Jain > > > > > > Write and flush errors are critical errors, upon which the device fd

Re: [PATCH v8 2/2] btrfs: check device for critical errors and mark failed

2017-10-06 Thread Liu Bo
On Thu, Oct 05, 2017 at 07:07:44AM -0400, Austin S. Hemmelgarn wrote: > On 2017-10-04 16:11, Liu Bo wrote: > > On Tue, Oct 03, 2017 at 11:59:20PM +0800, Anand Jain wrote: > > > From: Anand Jain > > > > > > Write and flush errors are critical errors, upon which the device

Re: [GIT PULL] Btrfs fixes for 4.14-rc4

2017-10-06 Thread Liu Bo
On Fri, Oct 06, 2017 at 11:25:12PM +0100, Tomasz Kłoczko wrote: > On rc3 is possible to observe warning about possible circular locking > dependency which I've reported on btrfs list few days ago: > Thanks for the report, neither this nor the one you reported on rc2 looks like a deadlock to me.

Re: [GIT PULL] Btrfs fixes for 4.14-rc4

2017-10-06 Thread Tomasz Kłoczko
On rc3 is possible to observe warning about possible circular locking dependency which I've reported on btrfs list few days ago: [ 101.326724] == [ 101.326728] WARNING: possible circular locking dependency detected [ 101.326734]

Re: [PATCH v4] btrfs: Remove received_uuid during received snapshot ro->rw switch

2017-10-06 Thread Hans van Kranenburg
On 10/06/2017 10:07 PM, Andrei Borzenkov wrote: > 06.10.2017 20:49, Hans van Kranenburg пишет: >> On 10/06/2017 07:24 PM, David Sterba wrote: >>> On Thu, Oct 05, 2017 at 05:03:47PM +0800, Anand Jain wrote: On 10/05/2017 04:22 PM, Nikolay Borisov wrote: > Currently when a read-only

[ANNOUNCE] fsperf: a simple fs/block performance testing framework

2017-10-06 Thread Josef Bacik
Hello, One thing that comes up a lot every LSF is the fact that we have no general way that we do performance testing. Every fs developer has a set of scripts or things that they run with varying degrees of consistency, but nothing central that we all use. I for one am getting tired of finding

Re: [PATCH v4] btrfs: Remove received_uuid during received snapshot ro->rw switch

2017-10-06 Thread Andrei Borzenkov
06.10.2017 20:49, Hans van Kranenburg пишет: > On 10/06/2017 07:24 PM, David Sterba wrote: >> On Thu, Oct 05, 2017 at 05:03:47PM +0800, Anand Jain wrote: >>> On 10/05/2017 04:22 PM, Nikolay Borisov wrote: Currently when a read-only snapshot is received and subsequently its ro property

Re: [PATCH 1/2] btrfs: fix read_one_chunk() return error code

2017-10-06 Thread David Sterba
On Fri, Oct 06, 2017 at 06:04:42PM +0800, Anand Jain wrote: > EIO is for IO (RW) failures, use correct error return > codes at two locations with in read_one_chunk(). Also > adds a small cleanup. This patch does 3 things, please split it, and drop the cleanup part. 1) switch add_missing_dev to

Re: [PATCH 1/1] Btrfs: heuristic add shannon entropy calculation

2017-10-06 Thread David Sterba
On Thu, Oct 05, 2017 at 01:07:26PM +0300, Timofey Titovets wrote: > Byte distribution check in heuristic will filter edge data > cases and some time fail to classificate input data > > Let's fix that by adding Shannon entropy calculation, > that will cover classification of most other data types.

Re: [PATCH v4] btrfs: Remove received_uuid during received snapshot ro->rw switch

2017-10-06 Thread Hans van Kranenburg
On 10/06/2017 07:24 PM, David Sterba wrote: > On Thu, Oct 05, 2017 at 05:03:47PM +0800, Anand Jain wrote: >> On 10/05/2017 04:22 PM, Nikolay Borisov wrote: >>> Currently when a read-only snapshot is received and subsequently its ro >>> property >>> is set to false i.e. switched to rw-mode the

Re: [PATCH v3 0/5] Enhance tree block validation checker

2017-10-06 Thread David Sterba
On Fri, Sep 29, 2017 at 06:48:44AM +, Qu Wenruo wrote: > The patchset can be fetched from github: > https://github.com/adam900710/linux/tree/checker_enhance > > It's based on David's misc-next branch, with following commit as base: > a5e50b4b444c ("btrfs: Add checker for EXTENT_CSUM") > >

Re: [PATCH v3 5/5] btrfs: tree-checker: Enhance output for check_extent_data_item

2017-10-06 Thread David Sterba
On Fri, Sep 29, 2017 at 06:48:49AM +, Qu Wenruo wrote: > Output the invalid member name and its bad value, along with its > expected value range or alignment. > > Signed-off-by: Qu Wenruo > --- > fs/btrfs/tree-checker.c | 98 >

Re: [PATCH v3 2/5] btrfs: tree-checker: Enhance btrfs_check_node output

2017-10-06 Thread David Sterba
On Fri, Sep 29, 2017 at 06:48:46AM +, Qu Wenruo wrote: > Use inline function to replace macro since we don't need > stringification. > (Macro still exist until all caller get updated) > > And add more info about the error, and replace EIO with EUCLEAN. > > For nr_items error, report if it's

Re: [PATCH v3 1/5] btrfs: Move leaf and node validation checker to tree-checker.c

2017-10-06 Thread David Sterba
On Fri, Sep 29, 2017 at 06:48:45AM +, Qu Wenruo wrote: > It's no doubt the comprehensive tree block checker will become larger > and larger, so move them into their own file is quite reasonable. > > Signed-off-by: Qu Wenruo > --- > fs/btrfs/Makefile | 2 +- >

Re: [PATCH v4] btrfs: Remove received_uuid during received snapshot ro->rw switch

2017-10-06 Thread David Sterba
On Thu, Oct 05, 2017 at 05:03:47PM +0800, Anand Jain wrote: > On 10/05/2017 04:22 PM, Nikolay Borisov wrote: > > Currently when a read-only snapshot is received and subsequently its ro > > property > > is set to false i.e. switched to rw-mode the received_uuid of that subvol > > remains > >

Re: [PATCH 0/5] btrfs-progs: check: original and lowmem mode fix

2017-10-06 Thread David Sterba
On Wed, Sep 27, 2017 at 02:34:35PM +0800, Su Yue wrote: > The head three patches is independent from later two. > Include: > 1) Let check_extent_refs() return error instead of 0 if something wrong >is found in original mode. > 2) repair_root_items() should be called before any repair. Put it >

Re: [PATCH 1/5] btrfs-progs: check: return value of check_extent_refs()

2017-10-06 Thread David Sterba
On Fri, Oct 06, 2017 at 09:38:05AM +0800, Su Yue wrote: > > > On 10/06/2017 01:46 AM, David Sterba wrote: > > On Wed, Sep 27, 2017 at 02:34:36PM +0800, Su Yue wrote: > >> In original check mode(without option "--repair"), check_extent_refs() > >> always returns 0. > >> > >> Add a variable @error

Re: [PATCH v2 2/2] btrfs: Fix transaction abort during failure in btrfs_rm_dev_item

2017-10-06 Thread David Sterba
On Thu, Sep 28, 2017 at 11:45:27AM +0300, Nikolay Borisov wrote: > btrfs_rm_dev_item calls several function under an activa transaction, however > it fails to abort it if an error happens. Fix this by adding explicit > btrfs_abort_transaction/btrfs_end_transaction calls > > Signed-off-by: Nikolay

Re: [PATCH v2 1/2] btrfs: Refactor transaction handling

2017-10-06 Thread David Sterba
On Thu, Sep 28, 2017 at 11:45:26AM +0300, Nikolay Borisov wrote: > If btrfs_transaction_commit fails it will proceed to call cleanup_transaction, > which in turn already does btrfs_abort_transaction. So let's remove the > unnecessary code duplication. Also let's be explicit about handling failure

Re: [PATCH 1/3] btrfs: scrub: get rid of sector_t

2017-10-06 Thread David Sterba
On Fri, Oct 06, 2017 at 09:22:42AM -0600, Edmund Nadolski wrote: > On 10/06/2017 06:29 AM, David Sterba wrote: > > The use of sector_t is not necessry, it's just for a warning. Switch to > > u64 and rename the variable. The messages are adjusted as well. > > > > Signed-off-by: David Sterba

[GIT PULL] Btrfs fixes for 4.14-rc4

2017-10-06 Thread David Sterba
Hi, we have two more fixes for bugs introduced in 4.13. The sector_t problem with 32bit architecture and !LBDAF config seems serious but the number of affected deployments is hopefully low. The clashing status bits could lead to a confusing in-memory state of the whole-filesystem operations if

Re: [PATCH 1/3] btrfs: scrub: get rid of sector_t

2017-10-06 Thread Edmund Nadolski
On 10/06/2017 06:29 AM, David Sterba wrote: > The use of sector_t is not necessry, it's just for a warning. Switch to > u64 and rename the variable. The messages are adjusted as well. > > Signed-off-by: David Sterba > --- > fs/btrfs/scrub.c | 14 +++--- > 1 file

Btrfs progs release 4.13.2

2017-10-06 Thread David Sterba
Hi, btrfs-progs version 4.13.2 have been released. This is a bugfix release for the subvolume listing and deletion commands, and performance improvement for the 'check' command that should decrease running time of some fstests. Changes: * subvol list: * don't list toplevel subvolume among

[PATCH 1/3] btrfs: scrub: get rid of sector_t

2017-10-06 Thread David Sterba
The use of sector_t is not necessry, it's just for a warning. Switch to u64 and rename the variable. The messages are adjusted as well. Signed-off-by: David Sterba --- fs/btrfs/scrub.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git

[PATCH 3/3] btrfs: get rid of sector_t and use u64 offset in submit_extent_page

2017-10-06 Thread David Sterba
The use of sector_t in the callchain of submit_extent_page is not necessary, we'll pass plain u64 and avoid any con(tro)versions of sector_t. Signed-off-by: David Sterba --- fs/btrfs/extent_io.c | 23 --- 1 file changed, 12 insertions(+), 11 deletions(-)

[PATCH 2/3] btrfs: rename page offset parameter in submit_extent_page

2017-10-06 Thread David Sterba
We're going to remove sector_t and will use 'offset', so this patch frees the name. Signed-off-by: David Sterba --- fs/btrfs/extent_io.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/fs/btrfs/extent_io.c b/fs/btrfs/extent_io.c index

[PATCH 0/3] Cleanup sector_t

2017-10-06 Thread David Sterba
David Sterba (3): btrfs: scrub: get rid of sector_t btrfs: rename page offset parameter in submit_extent_page btrfs: get rid of sector_t and use u64 offset in submit_extent_page fs/btrfs/extent_io.c | 31 --- fs/btrfs/scrub.c | 14 +++--- 2 files

"BTRFS error (device vda1): couldn't get super buffer head for bytenr x"

2017-10-06 Thread Nick Gilmour
Hi all, I have converted .vdi disk (BTRFS) into a .img disk, resized it from 500GB to 150GB and then copied into a ZFS Volume. I've imported the VM into VMM and it started normally but an upgrade failed. I've rebooted and got only a blue screen something like a BSOD on Windows. I've changed into

[PATCH 2/2] btrfs: clean up btrfs_report_missing_device() usage

2017-10-06 Thread Anand Jain
This patch makes the following changes.. When -o degraded flag is not set and one of the device is missing then we should log an error instead of warning. So move the check for DEGRADED flag into the same function and rename it. Also does code cleanup around this, including making this function as

[PATCH 1/2] btrfs: fix read_one_chunk() return error code

2017-10-06 Thread Anand Jain
EIO is for IO (RW) failures, use correct error return codes at two locations with in read_one_chunk(). Also adds a small cleanup. Signed-off-by: Anand Jain --- fs/btrfs/volumes.c | 17 ++--- fs/btrfs/volumes.h | 3 +-- 2 files changed, 11 insertions(+), 9

Re: Mounting bad btrfs img file

2017-10-06 Thread Duncan
Eric Wolf posted on Thu, 05 Oct 2017 09:38:18 -0400 as excerpted: > My OS drive had issues with metadata (disk full even though it wasn't > etc), and so I reinstalled my OS and now I'm learning that my backup img > is bad. What steps should I go through to fix it? Ugh... Looks like you just got

"No space left on device"

2017-10-06 Thread Nick Gilmour
Hi all, I'm getting an error "No space left on device" on a VM in VirtualBox. It started as I was trying to convert the .vdi to .img. I wanted to shrink the size of the disk first and I followed the steps from here: