[PATCH 3/4 v2] padata: Add some code comments

2010-05-17 Thread Steffen Klassert
Signed-off-by: Steffen Klassert --- include/linux/padata.h | 53 + kernel/padata.c| 68 2 files changed, 110 insertions(+), 11 deletions(-) diff --git a/include/linux/padata.h b/include/linux/padata

[PATCH 5/6] crypto: Add ablkcipher_walk interfaces.

2010-05-17 Thread David Miller
These are akin to the blkcipher_walk helpers. The main differences in the async variant are: 1) Only physical walking is supported. We can't hold on to kmap mappings across the async operation to support virtual ablkcipher_walk operations anyways. 2) Bounce buffers used for async more ne

[PATCH 4/6] crypto: Add testing for async hashing and update/final.

2010-05-17 Thread David Miller
Extend testmgr such that it tests async hash algorithms, and that for both sync and async hashes it tests both ->digest() and ->update()/->final() sequences. Signed-off-by: David S. Miller --- crypto/testmgr.c | 66 +++-- 1 files changed, 48 ins

[PATCH 3/6] crypto: Add speed tests for async hashing.

2010-05-17 Thread David Miller
These are invoked in the 'mode' range of 400 to 499. The cost of async vs. sync for the software algorithm implementations varies. It can be as low as 16 cycles but as much as a couple hundred. Here two runs of md5 testing, async then sync: testing speed of async md5 test 0 ( 16 byte blocks

[PATCH 2/6] crypto: Fix scatterwalk_done() test.

2010-05-17 Thread David Miller
We are done with the scattergather entry when the walk offset goes past sg->offset + sg->length, not when it crosses a page boundary. There is a similarly queer test in the second half of scatterwalk_pagedone() that probably needs some scrutiny. Signed-off-by: David S. Miller --- crypto/scatte

[PATCH 1/6] hifn_795x: Rename ablkcipher_walk to hifn_cipher_walk.

2010-05-17 Thread David Miller
This is in preparation for the generic ablkcipher_walk helpers that will be added to the crypto layer. Signed-off-by: David S. Miller --- drivers/crypto/hifn_795x.c | 18 +- 1 files changed, 9 insertions(+), 9 deletions(-) diff --git a/drivers/crypto/hifn_795x.c b/drivers/cry

[PATCH 0/6] Add Niagara2 crypto driver

2010-05-17 Thread David Miller
These patches do the work necessary to add the Niagara2 crypto driver. The main enablers are a set of generic ablkcipher_walk helpers, and testing support for async hash algorithms. Some work still remains, in particular tcrypt still can't perf test async ciphers :-/ These changes are also avai

Re: [BUG] SLOB breaks Crypto

2010-05-17 Thread Matt Mackall
On Mon, 2010-05-17 at 23:50 +0200, Adrian-Ken Rueegsegger wrote: > Geert Uytterhoeven wrote: > > On Fri, Mar 19, 2010 at 02:33, Herbert Xu > > wrote: > >> On Thu, Mar 18, 2010 at 10:24:41PM +0100, michael-...@fami-braun.de wrote: > >>> Pekka Enberg schrieb: > Even with CONFIG_DEBUG_SLAB enab

Re: [BUG] SLOB breaks Crypto

2010-05-17 Thread Adrian-Ken Rueegsegger
Geert Uytterhoeven wrote: > On Fri, Mar 19, 2010 at 02:33, Herbert Xu wrote: >> On Thu, Mar 18, 2010 at 10:24:41PM +0100, michael-...@fami-braun.de wrote: >>> Pekka Enberg schrieb: Even with CONFIG_DEBUG_SLAB enabled or with CONFIG_SLUB and CONFIG_SLUB_DEBUG_ON? >>> no, these options hav

Re: [BUG] SLOB breaks Crypto

2010-05-17 Thread Geert Uytterhoeven
On Fri, Mar 19, 2010 at 02:33, Herbert Xu wrote: > On Thu, Mar 18, 2010 at 10:24:41PM +0100, michael-...@fami-braun.de wrote: >> >> Pekka Enberg schrieb: >> > Even with CONFIG_DEBUG_SLAB enabled or with CONFIG_SLUB and >> > CONFIG_SLUB_DEBUG_ON? >> >> no, these options have not been / are not enab

Re: [PATCH 3/4] padata: Add some code comments

2010-05-17 Thread Steffen Klassert
Hi Randy, On Fri, May 14, 2010 at 09:18:57AM -0700, Randy Dunlap wrote: > > Hi Steffen, > > These comments are roughly 90% of the way to being kernel-doc notation, > so how about going the rest of the way, please? > yes of course we can. I read Documentation/kernel-doc-nano-HOWTO.txt, so I nee