[PATCH v2] crypto: AF_ALG - consolidation of duplicate code

2017-08-01 Thread Stephan Müller
Hi Herbert, as agreed, the individual patches from the first submission are now changed. After review of the changes I had to apply to algif_aead and algif_skcipher, I saw that they are all in the category that you agreed that can be rolled into this patch. Though, I documented the changes so

[no subject]

2017-08-01 Thread системы администратор
внимания; Ваши сообщения превысил лимит памяти, который составляет 5 Гб, определенных администратором, который в настоящее время работает на 10.9GB, Вы не сможете отправить или получить новую почту, пока вы повторно не проверить ваш почтовый ящик почты. Чтобы восстановить работоспособность

Re: [Patch V2] crypto: x86/sha1 : Fix reads beyond the number of blocks passed

2017-08-01 Thread Herbert Xu
On Tue, Aug 01, 2017 at 05:38:32PM -0700, Megha Dey wrote: > It was reported that the sha1 AVX2 function(sha1_transform_avx2) is > reading ahead beyond its intended data, and causing a crash if the next > block is beyond page boundary: > http://marc.info/?l=linux-crypto-vger=149373371023377 > >

[PATCH] crypto: x86/sha1 : Fix reads beyond the number of blocks passed

2017-08-01 Thread Megha Dey
It was reported that the sha1 AVX2 function(sha1_transform_avx2) is reading ahead beyond its intended data, and causing a crash if the next block is beyond page boundary: http://marc.info/?l=linux-crypto-vger=149373371023377 This patch makes sure that there is no overflow for any buffer length.

Re: [PATCH] crypto: ccp - avoid uninitialized variable warning

2017-08-01 Thread Gary R Hook
On 07/31/2017 03:49 PM, Arnd Bergmann wrote: The added support for version 5 CCPs introduced a false-positive warning in the RSA implementation: drivers/crypto/ccp/ccp-ops.c: In function 'ccp_run_rsa_cmd': drivers/crypto/ccp/ccp-ops.c:1856:3: error: 'sb_count' may be used uninitialized in this

Re: [PATCH] crypto: ccp - avoid uninitialized variable warning

2017-08-01 Thread Gary R Hook
On 08/01/2017 03:35 PM, Arnd Bergmann wrote: On Tue, Aug 1, 2017 at 4:52 PM, Gary R Hook wrote: On 07/31/2017 03:49 PM, Arnd Bergmann wrote: The added support for version 5 CCPs introduced a false-positive warning in the RSA implementation: drivers/crypto/ccp/ccp-ops.c:

Re: [PATCH] crypto: ccp - select CONFIG_CRYPTO_RSA

2017-08-01 Thread Gary R Hook
On 07/31/2017 04:10 PM, Arnd Bergmann wrote: Without the base RSA code, we run into a link error: ERROR: "rsa_parse_pub_key" [drivers/crypto/ccp/ccp-crypto.ko] undefined! ERROR: "rsa_parse_priv_key" [drivers/crypto/ccp/ccp-crypto.ko] undefined! Like the other drivers implementing RSA in

Re: [PATCH] crypto: ccp - avoid uninitialized variable warning

2017-08-01 Thread Arnd Bergmann
On Tue, Aug 1, 2017 at 4:52 PM, Gary R Hook wrote: > On 07/31/2017 03:49 PM, Arnd Bergmann wrote: >> >> The added support for version 5 CCPs introduced a false-positive >> warning in the RSA implementation: >> >> drivers/crypto/ccp/ccp-ops.c: In function 'ccp_run_rsa_cmd': >>

Re: [PATCH v3 net-next 1/4] tcp: ULP infrastructure

2017-08-01 Thread Tom Herbert
On Mon, Jul 31, 2017 at 3:16 PM, Dave Watson wrote: > On 07/29/17 01:12 PM, Tom Herbert wrote: >> On Wed, Jun 14, 2017 at 11:37 AM, Dave Watson wrote: >> > Add the infrustructure for attaching Upper Layer Protocols (ULPs) over TCP >> > sockets. Based on a

Re: [PATCH v5 5/6] ntb: ntb_hw_intel: use io-64-nonatomic instead of in-driver hacks

2017-08-01 Thread Jon Mason
On Wed, Jul 26, 2017 at 05:19:16PM -0600, Logan Gunthorpe wrote: > Now that ioread64 and iowrite64 are available in io-64-nonatomic, > we can remove the hack at the top of ntb_hw_intel.c and replace it > with an include. > > Signed-off-by: Logan Gunthorpe > Cc: Jon Mason

Re: [PATCH] crypto: ccp - avoid uninitialized variable warning

2017-08-01 Thread Gary R Hook
On 07/31/2017 03:49 PM, Arnd Bergmann wrote: The added support for version 5 CCPs introduced a false-positive warning in the RSA implementation: drivers/crypto/ccp/ccp-ops.c: In function 'ccp_run_rsa_cmd': drivers/crypto/ccp/ccp-ops.c:1856:3: error: 'sb_count' may be used uninitialized in this

[PATCH v3] crypto: caam: Remove unused dentry members

2017-08-01 Thread Fabio Estevam
Most of the dentry members from structure caam_drv_private are never used at all, so it is safe to remove them. Since debugfs_remove_recursive() is called, we don't need the file entries. Signed-off-by: Fabio Estevam --- Changes since v2: - Add missing space Changes since

Re: [PATCH] staging/ccree: Declare compiled out fuctions static inline

2017-08-01 Thread Gilad Ben-Yossef
On Mon, Jul 31, 2017 at 12:17 PM, RishabhHardas wrote: > From: RishabhHardas > > Sparse was giving out a warning for symbols 'cc_set_ree_fips_status' and > 'fips_handler' > that they were not declared and need to be made static. This patch

[PATCH] X.509: Recognize the legacy OID 1.3.14.3.2.29 (sha1WithRSASignature)

2017-08-01 Thread Carlo Caione
From: Carlo Caione sha1WithRSASignature is a deprecated equivalent of sha1WithRSAEncryption. It originates from the NIST Open Systems Environment (OSE) Implementor's Workshop (OIW). It is supported for compatibility with Microsoft's certificate APIs and tools, particularly

Re: [PATCH v2] crypto: caam: Remove unused dentry members

2017-08-01 Thread Horia Geantă
On 7/31/2017 3:22 PM, Fabio Estevam wrote: > Most of the dentry members from structure caam_drv_private > are never used at all, so it is safe to remove them. > > Since debugfs_remove_recursive() is called, we don't need the > file entries. > > Signed-off-by: Fabio Estevam >

Re: [PATCH 00/16] crypto: AF_ALG - consolidation

2017-08-01 Thread Herbert Xu
On Tue, Aug 01, 2017 at 11:15:50AM +0200, Stephan Müller wrote: > > Shall I only make the change during the merger or add these changes to the > modification of algif_skcipher/algif_aead? Either way is fine. Cheers, -- Email: Herbert Xu Home Page:

Re: [PATCH 00/16] crypto: AF_ALG - consolidation

2017-08-01 Thread Stephan Müller
Am Dienstag, 1. August 2017, 11:08:33 CEST schrieb Herbert Xu: Hi Herbert, > > How about you separate into three patches? The first two make > changes to algif_skcipher/algif_aead so that they can be merged, > and the last one does the actual merging. > Ok, I can do that. How would you want to

Re: [PATCH 00/16] crypto: AF_ALG - consolidation

2017-08-01 Thread Herbert Xu
On Tue, Aug 01, 2017 at 11:01:54AM +0200, Stephan Müller wrote: > Am Dienstag, 1. August 2017, 10:58:58 CEST schrieb Herbert Xu: > > Hi Herbert, > > > > This split makes no sense. I don't see why you can't merge them > > into a single patch if it's just rearranging the code. > > If you want to

Re: [PATCH 00/16] crypto: AF_ALG - consolidation

2017-08-01 Thread Stephan Müller
Am Dienstag, 1. August 2017, 10:58:58 CEST schrieb Herbert Xu: Hi Herbert, > > This split makes no sense. I don't see why you can't merge them > into a single patch if it's just rearranging the code. If you want to merge all into one patch, I am fine. I thought that separating all out makes

Re: [PATCH 00/16] crypto: AF_ALG - consolidation

2017-08-01 Thread Herbert Xu
On Mon, Jul 31, 2017 at 02:04:58PM +0200, Stephan Müller wrote: > Hi, > > with the update of the algif_aead and algif_skcipher memory management, > a lot of code duplication has been introduced deliberately. > > This patch set cleans up the low-hanging fruits. The cleanup of the > recvmsg RX SGL

[PATCH] crypto: AF_ALG - consolidate common code in recvmsg

2017-08-01 Thread Stephan Müller
The recvmsg handler has the following common code that is consolidated: * af_alg_alloc_areq: allocation of the request data structure for the cipher operation * af_alg_get_rsgl: creation of the RX SGL anchored in the request data structure The request data structure is extended by the field