Re: [PATCH] Add kernel parameter to blacklist modules

2016-06-13 Thread Rusty Russell
Prarit Bhargava writes: > Blacklisting a module in linux has long been a problem. The process of > blacklisting a module has changed over time, and it seems that every OS > does it slightly differently and depends on the age of the init system > used on that OS. Hi Prarit, I don't mind

[PATCH] x86/KASLR: remove x86 hibernation restrictions

2016-06-13 Thread Kees Cook
With the commit "Fix 64-bit code passing control to image kernel", there is no longer a problem with hibernation resuming a KASLR-booted kernel image. Signed-off-by: Kees Cook --- Depends on: https://lkml.org/lkml/2016/6/13/442 --- Documentation/kernel-parameters.txt | 10 -- arch/x86/bo

[RESEND PATCH v5 1/1] ARM64: ACPI: Update documentation for latest specification version

2016-06-13 Thread Al Stone
The ACPI 6.1 specification was recently released at the end of January 2016, but the arm64 kernel documentation for the use of ACPI was written for the 5.1 version of the spec. There were significant additions to the spec that had not yet been mentioned -- for example, the 6.0 mechanisms added to

[RESEND PATCH v5 0/1] ARM64: ACPI: Update documentation for latest specification version

2016-06-13 Thread Al Stone
This is a resend only: Ping? Last ping was 26 May; there has been zero response since then. Already have one ACK from Lorenzo; another from an arm64 maintainer would be really helpful. The ACPI 6.1 specification was recently released at the end of January 2016, but the arm64 kernel documentatio

[PATCHv3 1/7] EDAC, altera: Check parent status for Arria10 EDAC block

2016-06-13 Thread tthayer
From: Thor Thayer In preparation for the Arria10 ECC modules, check the status of the parent in the device tree to ensure the block is enabled. Skip if no parent phandle is set in the device tree. Signed-off-by: Thor Thayer --- v2 No change v3 Move check into validate_parent_available(). ---

[PATCHv3 2/7] EDAC, altera: Add panic flag check to A10 IRQ

2016-06-13 Thread tthayer
From: Thor Thayer In preparation for additional memory module ECCs, the IRQ function will check a panic flag before doing a kernel panic on double bit errors. ECCs on buffers will not cause a kernel panic on DBERRs. Signed-off-by: Thor Thayer --- v2 New patch. Add panic flag to IRQ function. v

Re: [RESEND PATCH 1/3] rfkill: Create "rfkill-airplane-mode" LED trigger

2016-06-13 Thread Pavel Machek
On Mon 2016-06-13 17:10:02, João Paulo Rechi Vita wrote: > On 13 June 2016 at 17:01, Pavel Machek wrote: > > On Mon 2016-06-13 15:59:35, João Paulo Rechi Vita wrote: > >> On 13 June 2016 at 15:00, Pavel Machek wrote: > >> > Hi! > >> > > >> >> > João, that means you should send a patch to add the

[PATCHv3 4/7] Documentation: dt: socfpga: Add Arria10 Ethernet binding

2016-06-13 Thread tthayer
From: Thor Thayer Add the device tree bindings needed to support the Altera Ethernet FIFO buffers on the Arria10 chip. Signed-off-by: Thor Thayer --- v2 No Change v3 Change to common compatible string based on maintainer comments Add local IRQ values. --- .../bindings/arm/altera/socfpga-

[PATCHv3 5/7] EDAC, altera: Add Arria10 ECC memory init functions

2016-06-13 Thread tthayer
From: Thor Thayer In preparation for additional memory module ECCs, add the memory initialization functions and helper functions used for memory initialization. Signed-off-by: Thor Thayer --- v2: Specify INTMODE selection -> IRQ on each ECC error. Insert functions above memory-specific func

[PATCHv3 6/7] EDAC, altera: Add Arria10 Ethernet EDAC support

2016-06-13 Thread tthayer
From: Thor Thayer Add Altera Arria10 Ethernet FIFO memory EDAC support. Update to support a common compatibility string for all ethernet FIFOs in the DT. Signed-off-by: Thor Thayer --- v2 Remove (void *) cast from altr_edac_device_of_match[] Addition of panic flag to ethernet private data.

[PATCHv3 7/7] ARM: dts: Add Arria10 Ethernet EDAC devicetree entry

2016-06-13 Thread tthayer
From: Thor Thayer Add the device tree entries needed to support the Altera Ethernet FIFO buffer EDAC on the Arria10 chip. Signed-off-by: Thor Thayer --- v2 No change v3 Add interrupts for SBERR and DBERR. --- arch/arm/boot/dts/socfpga_arria10.dtsi | 16 1 file changed, 16

[PATCHv3 3/7] EDAC, altera: Share Arria10 check_deps & IRQ functions

2016-06-13 Thread tthayer
From: Thor Thayer In preparation for additional memory module ECCs, the IRQ and check_deps() functions are being made available to all the memory buffers. Move them outside of the OCRAM only area. Signed-off-by: Thor Thayer --- v2 New patch. Move shared functions outside OCRAM only area. v3 C

[PATCHv3 0/7] Add Ethernet EDAC & peripheral init functions

2016-06-13 Thread tthayer
From: Thor Thayer This patch set adds the Ethernet EDAC and memory initialization functions for Altera's Arria10 peripherals. The ECC memory init functions are common to all the peripheral memory buffers. Thor Thayer (7): EDAC, altera: Check parent status for Arria10 EDAC block EDAC, altera:

Re: [RESEND PATCH 1/3] rfkill: Create "rfkill-airplane-mode" LED trigger

2016-06-13 Thread João Paulo Rechi Vita
On 13 June 2016 at 17:01, Pavel Machek wrote: > On Mon 2016-06-13 15:59:35, João Paulo Rechi Vita wrote: >> On 13 June 2016 at 15:00, Pavel Machek wrote: >> > Hi! >> > >> >> > João, that means you should send a patch to add the ::rfkill suffix. >> >> > >> >> >> >> IMO "airplane" (or maybe "airpla

Re: [RESEND PATCH 1/3] rfkill: Create "rfkill-airplane-mode" LED trigger

2016-06-13 Thread Pavel Machek
On Mon 2016-06-13 15:59:35, João Paulo Rechi Vita wrote: > On 13 June 2016 at 15:00, Pavel Machek wrote: > > Hi! > > > >> > João, that means you should send a patch to add the ::rfkill suffix. > >> > > >> > >> IMO "airplane" (or maybe "airplane-mode") is a better suffix, as it > >> reflects the la

Re: [PATCH v16 6/6] ARM: socfpga: fpga bridge driver support

2016-06-13 Thread atull
On Fri, 10 Jun 2016, Trent Piepho wrote: > On Fri, 2016-02-05 at 15:30 -0600, at...@opensource.altera.com wrote: > > Supports Altera SOCFPGA bridges: > > * fpga2sdram > > * fpga2hps > > * hps2fpga > > * lwhps2fpga > > > > Allows enabling/disabling the bridges through the FPGA > > Bridge Frame

Re: [RESEND PATCH 1/3] rfkill: Create "rfkill-airplane-mode" LED trigger

2016-06-13 Thread João Paulo Rechi Vita
On 13 June 2016 at 15:00, Pavel Machek wrote: > Hi! > >> > João, that means you should send a patch to add the ::rfkill suffix. >> > >> >> IMO "airplane" (or maybe "airplane-mode") is a better suffix, as it >> reflects the label on the machine's chassis. I'll name it >> "asus-wireless::airplane" a

Re: [RESEND PATCH 1/3] rfkill: Create "rfkill-airplane-mode" LED trigger

2016-06-13 Thread Pavel Machek
Hi! > > João, that means you should send a patch to add the ::rfkill suffix. > > > > IMO "airplane" (or maybe "airplane-mode") is a better suffix, as it > reflects the label on the machine's chassis. I'll name it > "asus-wireless::airplane" and send this through platform-drivers-x86, > as this is

Re: [PATCH v4 01/44] dma-mapping: Use unsigned long for dma_attrs

2016-06-13 Thread Luis R. Rodriguez
On Mon, Jun 13, 2016 at 09:00:41AM -0700, Christoph Hellwig wrote: > On Fri, Jun 10, 2016 at 04:49:47PM +0200, Luis R. Rodriguez wrote: > > Do we not expect the number of argument to grow ? This "cleanup" would > > do away with such possibilities, and then require adding the API later, > > and this

Re: [PATCH v4 01/44] dma-mapping: Use unsigned long for dma_attrs

2016-06-13 Thread Christoph Hellwig
On Fri, Jun 10, 2016 at 04:49:47PM +0200, Luis R. Rodriguez wrote: > Do we not expect the number of argument to grow ? This "cleanup" would > do away with such possibilities, and then require adding the API later, > and this requiring a full set of collateral evolutions again when this > is needed.

Re: [RESEND PATCH 1/3] rfkill: Create "rfkill-airplane-mode" LED trigger

2016-06-13 Thread João Paulo Rechi Vita
On 9 June 2016 at 08:43, Johannes Berg wrote: > On Thu, 2016-05-19 at 09:16 +0200, Pavel Machek wrote: > (...) >> LED >> subsystem seems to use suffix of LED name to do that. So if we >> standartize, lets say "::rfkill" suffix for this, it should work and >> follow existing practice. > [...] >>

Re: [RFC PATCH v1 10/18] x86/efi: Access EFI related tables in the clear

2016-06-13 Thread Tom Lendacky
On 06/13/2016 07:03 AM, Matt Fleming wrote: > On Thu, 09 Jun, at 11:16:40AM, Tom Lendacky wrote: >> >> So maybe something along the lines of an enum that would have entries >> (initially) like KERNEL_DATA (equal to zero) and EFI_DATA. Others could >> be added later as needed. > > Sure, that works

Re: [RFC PATCH v1 10/18] x86/efi: Access EFI related tables in the clear

2016-06-13 Thread Matt Fleming
On Thu, 09 Jun, at 01:33:30PM, Tom Lendacky wrote: > > I was trying to play it safe here, but as you say, the firmware should > be using our page tables so we can get rid of this call. The problem > will actually be if we transition to a 32-bit efi. The encryption bit > will be lost in cr3 and so

Re: [PATCH 16/23] arm64: ilp32: introduce binfmt_ilp32.c

2016-06-13 Thread Zhangjian (Bamvor)
Hi, again I found another issue in binfmt_ilp32.c. We are using the ELF_ET_DYN_BASE for ilp32 application. The default ELF_ET_DYN_BASE is calculated by TASK_SIZE_64. IIUC, we should define the following things in binfmt_ilp32.c which is the same value as aarch32: +#undef ELF_ET_DYN_BASE +#define

Re: [RFC PATCH v1 10/18] x86/efi: Access EFI related tables in the clear

2016-06-13 Thread Matt Fleming
On Mon, 13 Jun, at 01:03:22PM, Matt Fleming wrote: > > Would we need a new function? Couldn't we just have a new > FIXMAP_PAGE_* constant? e.g. would something like this work? > > --- > > enum memremap_owner { > KERNEL_DATA = 0, > BOOT_DATA, > }; > > void __init * > early_memremap(r

[PATCH] Add kernel parameter to blacklist modules

2016-06-13 Thread Prarit Bhargava
Blacklisting a module in linux has long been a problem. The process of blacklisting a module has changed over time, and it seems that every OS does it slightly differently and depends on the age of the init system used on that OS. The current Fedora/systemd procedure is to use rd.blacklist=module

Re: [RFC PATCH v1 10/18] x86/efi: Access EFI related tables in the clear

2016-06-13 Thread Matt Fleming
On Thu, 09 Jun, at 11:16:40AM, Tom Lendacky wrote: > > So maybe something along the lines of an enum that would have entries > (initially) like KERNEL_DATA (equal to zero) and EFI_DATA. Others could > be added later as needed. Sure, that works for me, though maybe BOOT_DATA would be more applica

Re: [PATCH 4/4] pinctrl.txt: Reflow/wrap paragraph describing GPIO interaction

2016-06-13 Thread Linus Walleij
On Fri, Jun 10, 2016 at 9:16 AM, Andrew Jeffery wrote: > Signed-off-by: Andrew Jeffery Patch applied. Yours, Linus Walleij -- To unsubscribe from this list: send the line "unsubscribe linux-doc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.or

Re: [PATCH 3/4] pinctrl.txt: s/have/has/ in GPIO driver interaction description

2016-06-13 Thread Linus Walleij
On Fri, Jun 10, 2016 at 9:16 AM, Andrew Jeffery wrote: > Signed-off-by: Andrew Jeffery Patch applied. Yours, Linus Walleij -- To unsubscribe from this list: send the line "unsubscribe linux-doc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.or

Re: [PATCH 1/4] drivers-on-gpio.txt: Fix paths to GPIO driver source files

2016-06-13 Thread Linus Walleij
On Fri, Jun 10, 2016 at 9:16 AM, Andrew Jeffery wrote: > Signed-off-by: Andrew Jeffery Patch applied. Yours, Linus Walleij -- To unsubscribe from this list: send the line "unsubscribe linux-doc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.or

Re: [PATCH 2/4] pinctrl.txt: Fix grammar in pinmux request list

2016-06-13 Thread Linus Walleij
On Fri, Jun 10, 2016 at 9:16 AM, Andrew Jeffery wrote: > Signed-off-by: Andrew Jeffery Patch applied. Yours, Linus Walleij -- To unsubscribe from this list: send the line "unsubscribe linux-doc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.or