Re: [RFC PATCH v2 07/20] x86: Provide general kernel support for memory encryption

2016-09-06 Thread Borislav Petkov
On Mon, Aug 22, 2016 at 05:36:46PM -0500, Tom Lendacky wrote: > Adding general kernel support for memory encryption includes: > - Modify and create some page table macros to include the Secure Memory > Encryption (SME) memory encryption mask > - Update kernel boot support to call an SME routine t

Re: [PATCH] Documentation/CodingStyle

2016-09-06 Thread Jonathan Corbet
On Sat, 3 Sep 2016 08:13:13 +0200 Bruno Raoult wrote: > I am new here, so feel free to tell me if I am wrong. Welcome! > I am participating to Eulyptula challenge, and of course had a look on > Documentation/CodingStyle. > > As I use GNU/Emacs (yes, I know, Evil Tool, according to Linus :-), I

Re: [PATCH] doc: ioctl: Add some clarifications to botching-up-ioctls

2016-09-06 Thread Jonathan Corbet
On Sat, 03 Sep 2016 00:44:02 +0200 Arnd Bergmann wrote: > On Friday, September 2, 2016 3:42:24 PM CEST Laura Abbott wrote: > > - The guide currently says to pad the structure to a multiple of > > 64-bits. This is not necessary in cases where the structure contains > > no 64-bit types. Clarify

Re: [PATCH 1/3] doc-rst:c-domain: fix sphinx version incompatibility

2016-09-06 Thread Jonathan Corbet
On Wed, 31 Aug 2016 17:29:30 +0200 Markus Heiser wrote: > +if major >= 1 and minor < 4: > +# indexnode's tuple changed in 1.4 > +# > https://github.com/sphinx-doc/sphinx/commit/e6a5a3a92e938fcd75866b4227db9e0524d58f7c > +self.indexnode[

Re: [PATCH 1/3] doc-rst:c-domain: fix sphinx version incompatibility

2016-09-06 Thread Markus Heiser
Am 06.09.2016 um 14:19 schrieb Jonathan Corbet : > On Wed, 31 Aug 2016 17:29:30 +0200 > Markus Heiser wrote: > >> +if major >= 1 and minor < 4: >> +# indexnode's tuple changed in 1.4 >> +# >> https://github.com/sphinx-doc/sphinx/commit/e6a5a3a92e938f

Re: [PATCH 2/3] doc-rst:c-domain: function-like macros arguments

2016-09-06 Thread Jonathan Corbet
So I'm going into total nit-picking territory here, but since I'm looking at it and I think the series needs a respin anyway... On Wed, 31 Aug 2016 17:29:31 +0200 Markus Heiser wrote: > +m = c_funcptr_sig_re.match(sig) > +if m is None: > +m = c_sig_re.match(sig) > +

Re: [PATCH 3/3] doc-rst:c-domain: function-like macros index entry

2016-09-06 Thread Jonathan Corbet
On Wed, 31 Aug 2016 17:29:32 +0200 Markus Heiser wrote: > For function-like macros, sphinx creates 'FOO (C function)' entries. > With this patch 'FOO (C macro)' are created for function-like macros, > which is the same for object-like macros. As others have pointed out, we generally want to hide

Re: [PATCH 1/3] doc-rst:c-domain: fix sphinx version incompatibility

2016-09-06 Thread Jonathan Corbet
On Tue, 6 Sep 2016 14:24:11 +0200 Markus Heiser wrote: > Should I send a new patch .. or could you fix it? Please just regenerate the series and I'll apply it. Thanks, jon -- To unsubscribe from this list: send the line "unsubscribe linux-doc" in the body of a message to majord...@vger.kernel.

Re: [PATCH 1/3] documentation/scsi: Remove nodisconnect parameter

2016-09-06 Thread Jonathan Corbet
On Sat, 27 Aug 2016 12:29:59 +1000 Finn Thain wrote: > The driver that used the 'nodisconnect' parameter was removed in > commit 565bae6a4a8f ("[SCSI] 53c7xx: kill driver"). Related documentation > was cleaned up in commit f37a7238d379 ("[SCSI] 53c7xx: fix removal > fallout"), except for the rema

Re: [PATCH] x86: fix memory ranges in mm documentation

2016-09-06 Thread Jonathan Corbet
On Tue, 23 Aug 2016 09:00:45 +0100 Lorenzo Stoakes wrote: > This is a trivial fix to correct upper bound addresses to always be > inclusive. Previously, the majority of ranges specified were inclusive with a > small minority specifying an exclusive upper bound. This patch fixes this > inconsisten

Re: [PATCH 1/3] doc-rst:c-domain: fix sphinx version incompatibility

2016-09-06 Thread Jani Nikula
On Tue, 06 Sep 2016, Jonathan Corbet wrote: > On Wed, 31 Aug 2016 17:29:30 +0200 > Markus Heiser wrote: > >> +if major >= 1 and minor < 4: >> +# indexnode's tuple changed in 1.4 >> +# >> https://github.com/sphinx-doc/sphinx/commit/e6a5a3a92e938fcd75866

Re: [PATCH] docs: make kernel-doc handle varargs properly

2016-09-06 Thread Jonathan Corbet
On Sat, 27 Aug 2016 11:43:18 +0300 Jani Nikula wrote: > On Fri, 26 Aug 2016, Jonathan Corbet wrote: > > As far as I can tell, the handling of "..." arguments has never worked > > right, so any documentation provided was ignored in favor of "variable > > arguments." This makes kernel-doc handle

Re: sparc: bpf_jit: Rename jump labels in bpf_jit_compile()

2016-09-06 Thread Jean Delvare
Hi Peter, On Mon, 5 Sep 2016 13:58:38 +0200, Peter Zijlstra wrote: > On Mon, Sep 05, 2016 at 01:54:45PM +0200, Jean Delvare wrote: > > On Mon, 5 Sep 2016 13:37:04 +0200, Peter Zijlstra wrote: > > > I have it in my local .gitconfig, and recommend it to people who send me > > > patches. > > > > Wha

Re: sparc: bpf_jit: Rename jump labels in bpf_jit_compile()

2016-09-06 Thread Peter Zijlstra
On Tue, Sep 06, 2016 at 04:34:13PM +0200, Jean Delvare wrote: > > [diff "default"] > > xfuncname = "^[[:alpha:]$_].*[^:]$" > > OK, I see. As mentioned somewhere else, it fails for labels which have > comments. Heh, There's labels that have comments? > My worry is that you recommending i

Re: [PATCH 1/3] doc-rst:c-domain: fix sphinx version incompatibility

2016-09-06 Thread Markus Heiser
Am 06.09.2016 um 15:34 schrieb Jani Nikula : > On Tue, 06 Sep 2016, Jonathan Corbet wrote: >> On Wed, 31 Aug 2016 17:29:30 +0200 >> Markus Heiser wrote: >> >>> +if major >= 1 and minor < 4: >>> +# indexnode's tuple changed in 1.4 >>> +# >>> https://

Re: [PATCH 3/3] docs: Pull HSI documentation together

2016-09-06 Thread Jonathan Corbet
On Tue, 23 Aug 2016 02:20:19 +0200 Sebastian Reichel wrote: > Thanks for doing this. I like the resulting HTML. I'm a bit confused > by the rendering of the struct sections, though. Initially I thought > the blue box with "struct xyz" is an empty table (= there are no > members). [Getting back t

[PATCH 5/5] docs: Don't format internal MPT docs

2016-09-06 Thread Jonathan Corbet
This is the driver API document, so the internal stuff is just noise here. Signed-off-by: Jonathan Corbet --- Documentation/driver-api/message-based.rst | 18 -- 1 file changed, 18 deletions(-) diff --git a/Documentation/driver-api/message-based.rst b/Documentation/driver-api/m

[PATCH 2/5] docs: split up the driver book

2016-09-06 Thread Jonathan Corbet
We don't need to keep it as a single large file anymore; split it up so that it is easier to manage and the individual sections can be read directly as plain files. Signed-off-by: Jonathan Corbet --- Documentation/driver-api/basics.rst| 120 + Documentation/driver-api/drivers.rst

[PATCH 0/5 V2] The beginning of a proper driver-api book

2016-09-06 Thread Jonathan Corbet
This short series convers device-drivers.tmpl into the RST format, splits it up, and sets up the result under Documentation/driver-api/. For added fun, I've taken one top-level file (hsi.txt) and folded it into the document as a way of showing the direction I'm thinking I would like things to go.

[PATCH 1/5] Docs: sphinxify device-drivers.tmpl

2016-09-06 Thread Jonathan Corbet
Perform a basic sphinx conversion of the device-drivers docbook and move it to its own directory. Signed-off-by: Jonathan Corbet --- Documentation/DocBook/Makefile| 2 +- Documentation/DocBook/device-drivers.tmpl | 521 Documentation/driver-api/drivers.rst

[PATCH 4/5] docs: split up serial-interfaces.rst

2016-09-06 Thread Jonathan Corbet
It never made sense to keep these documents together; move each into its own file. Drop the section numbering on hsi.txt on its way to its own file. Suggested-by: Sebastian Reichel Signed-off-by: Jonathan Corbet --- Documentation/driver-api/hsi.rst | 88 Documentati

[PATCH 3/5] docs: Pull the HSI documentation together

2016-09-06 Thread Jonathan Corbet
The HSI subsystem documentation was split across hsi.txt and the device-drivers docbook. Now that the latter has been converted to Sphinx, pull in the HSI document so that it's all in one place. Acked-by: Sebastian Reichel Signed-off-by: Jonathan Corbet --- Documentation/driver-api/serial-inte

Re: sparc: bpf_jit: Rename jump labels in bpf_jit_compile()

2016-09-06 Thread Joe Perches
On Tue, 2016-09-06 at 16:47 +0200, Peter Zijlstra wrote: > On Tue, Sep 06, 2016 at 04:34:13PM +0200, Jean Delvare wrote: > > > [diff "default"] > > >         xfuncname = "^[[:alpha:]$_].*[^:]$" > > OK, I see. As mentioned somewhere else, it fails for labels which have > > comments.  > Heh, There's

Re: [PATCH 1/3] doc-rst:c-domain: fix sphinx version incompatibility

2016-09-06 Thread Mauro Carvalho Chehab
Em Tue, 6 Sep 2016 17:10:53 +0200 Markus Heiser escreveu: > Am 06.09.2016 um 15:34 schrieb Jani Nikula : > > > On Tue, 06 Sep 2016, Jonathan Corbet wrote: > >> On Wed, 31 Aug 2016 17:29:30 +0200 > >> Markus Heiser wrote: > >> > >>> +if major >= 1 and minor < 4: > >>> +

Re: [RFC PATCH v2 09/20] x86: Add support for early encryption/decryption of memory

2016-09-06 Thread Borislav Petkov
On Mon, Aug 22, 2016 at 05:37:10PM -0500, Tom Lendacky wrote: > This adds support to be able to either encrypt or decrypt data during > the early stages of booting the kernel. This does not change the memory > encryption attribute - it is used for ensuring that data present in > either an encrypted

Re: [RFC] fs: add userspace critical mounts event support

2016-09-06 Thread Bjorn Andersson
On Fri 02 Sep 21:11 PDT 2016, Linus Torvalds wrote: Linus, I reversed the order of your questions/answers to fit my answer better. > On Fri, Sep 2, 2016 at 5:20 PM, Luis R. Rodriguez wrote: > > > > Thoughts ? > What are the drivers that need this, and why can't those drivers just > be fixed to n

Re: [RFC] fs: add userspace critical mounts event support

2016-09-06 Thread Linus Torvalds
On Tue, Sep 6, 2016 at 10:46 AM, Bjorn Andersson wrote: > > Linus, I reversed the order of your questions/answers to fit my answer > better. Nobody has actually answered the "why don't we just tie the firmware and module together" question. Really. If the driver doesn't work without the firmware

[RFC PATCH 3/4] futex: Throughput-optimized (TO) futexes

2016-09-06 Thread Waiman Long
This patch introduces a new futex implementation called throughput-optimized (TO) futexes. The goal of this new futex type is to provide locking throughput that is higher than wait-wake futexes especially on systems with a large number of CPUs and the lock owners are unlikely to sleep. The downside

[RFC PATCH 4/4] futex, doc: TO futexes document

2016-09-06 Thread Waiman Long
This patch adds a new document file on how to use the TO futexes. Signed-off-by: Waiman Long --- Documentation/00-INDEX |2 + Documentation/to-futex.txt | 124 2 files changed, 126 insertions(+), 0 deletions(-) create mode 100644 Documentati

[RFC PATCH 1/4] futex: Add futex_set_timer() helper function

2016-09-06 Thread Waiman Long
This patch adds a new futex_set_timer() function to consolidate all the sleeping hrtime setup code. Signed-off-by: Waiman Long --- kernel/futex.c | 51 --- 1 files changed, 24 insertions(+), 27 deletions(-) diff --git a/kernel/futex.c b/kernel/f

[RFC PATCH 0/4] futex: Introducing throughput-optimized futexes

2016-09-06 Thread Waiman Long
This patchset introduces a new futex implementation called throughput-optimized (TO) futexes. It is similar to PI futexes in its calling convention, but provides better throughput than the wait-wake futexes by encouraging lock stealing and optimistic spinning. The timeout parameter, however, isn't

[RFC PATCH 2/4] futex: Rename futex_pi_state to futex_state

2016-09-06 Thread Waiman Long
The futex_pi_state structure will be overloaded in later patches to store state information about non-PI futexes. So the structure name itself is no longer a good description of its purpose. This patch renames it to futex_state, a more generic name. Some of the functions that process the futex sta

Re: [RFC] fs: add userspace critical mounts event support

2016-09-06 Thread Bjorn Andersson
On Tue 06 Sep 11:32 PDT 2016, Linus Torvalds wrote: > On Tue, Sep 6, 2016 at 10:46 AM, Bjorn Andersson > wrote: > > > > Linus, I reversed the order of your questions/answers to fit my answer > > better. > > Nobody has actually answered the "why don't we just tie the firmware > and module togethe

Re: [RFC] fs: add userspace critical mounts event support

2016-09-06 Thread Linus Torvalds
On Tue, Sep 6, 2016 at 2:11 PM, Bjorn Andersson wrote: > On Tue 06 Sep 11:32 PDT 2016, Linus Torvalds wrote: > >> On Tue, Sep 6, 2016 at 10:46 AM, Bjorn Andersson >> Nobody has actually answered the "why don't we just tie the firmware >> and module together" question. > > The answer to this depend

Re: [RFC] fs: add userspace critical mounts event support

2016-09-06 Thread Luis R. Rodriguez
On Sat, Sep 03, 2016 at 11:10:02AM -0700, Dmitry Torokhov wrote: > On Sat, Sep 3, 2016 at 11:01 AM, Linus Torvalds > wrote: > > On Sat, Sep 3, 2016 at 10:49 AM, Dmitry Torokhov > > wrote: > >> > >> Unfortunately module loading and availability of firmware is very > >> loosely coupled. > > > > The

Re: [RFC] fs: add userspace critical mounts event support

2016-09-06 Thread Bjorn Andersson
On Tue 06 Sep 14:52 PDT 2016, Luis R. Rodriguez wrote: > We already have MODULE_FIRMWARE(), we could have MODULE_FIRMWARE_REQ() or > something like it to help annotate the the driver was only functional with the > firmware, punt things to kmod to deal with the requirements. That implies that a si

Re: [RFC] fs: add userspace critical mounts event support

2016-09-06 Thread Luis R. Rodriguez
On Tue, Sep 06, 2016 at 11:32:05AM -0700, Linus Torvalds wrote: > On Tue, Sep 6, 2016 at 10:46 AM, Bjorn Andersson > wrote: > > > > Linus, I reversed the order of your questions/answers to fit my answer > > better. > > Nobody has actually answered the "why don't we just tie the firmware This is

Re: [RFC] fs: add userspace critical mounts event support

2016-09-06 Thread Luis R. Rodriguez
On Tue, Sep 06, 2016 at 02:50:51PM -0700, Linus Torvalds wrote: > On Tue, Sep 6, 2016 at 2:11 PM, Bjorn Andersson > wrote: > > On Tue 06 Sep 11:32 PDT 2016, Linus Torvalds wrote: > > > >> On Tue, Sep 6, 2016 at 10:46 AM, Bjorn Andersson > >> Nobody has actually answered the "why don't we just tie

Re: [RFC] fs: add userspace critical mounts event support

2016-09-06 Thread Luis R. Rodriguez
On Tue, Sep 06, 2016 at 03:28:47PM -0700, Bjorn Andersson wrote: > On Tue 06 Sep 14:52 PDT 2016, Luis R. Rodriguez wrote: > > > We already have MODULE_FIRMWARE(), we could have MODULE_FIRMWARE_REQ() or > > something like it to help annotate the the driver was only functional with > > the > > firm

[PATCH v4 2/5] firmware: annotate thou shalt not request fw on init or probe

2016-09-06 Thread Luis R. Rodriguez
Thou shalt not make firmware calls early on init or probe. systemd already ripped support out for the usermode helper a while ago, there are still users that require the usermode helper, however systemd's use of the usermode helper exacerbated a long lasting issue of the fact that we have many dri

Re: [PATCH 2/3] doc-rst:c-domain: function-like macros arguments

2016-09-06 Thread Markus Heiser
Am 06.09.2016 um 14:27 schrieb Jonathan Corbet : > So I'm going into total nit-picking territory here, but since I'm looking > at it and I think the series needs a respin anyway... > > On Wed, 31 Aug 2016 17:29:31 +0200 > Markus Heiser wrote: > >> +m = c_funcptr_sig_re.match(sig) >> +