On Tue, 2016-09-20 at 09:42 -0400, Waiman Long wrote:
> This patch introduces a new futex implementation called
> throughput-optimized (TO) futexes.
nit: 'TO' sounds way too much like timeout... TP? You even use 'to' as
shorthand for timeout in the next patch.
> /*
> ->>
On Mon, Sep 19, 2016 at 09:53:49PM +1000, Balbir Singh wrote:
I presume you've tested with CONFIG_NODES_SHIFT of 8 (255 nodes?)
Oh yes, definitely.
The large number of possible nodes does not come into play here.
--
Reza Arbab
--
To unsubscribe from this list: send the line "unsubscribe linu
On Mon, Sep 19, 2016 at 11:59:35AM +0530, Aneesh Kumar K.V wrote:
Movable node also does.
memblock_set_bottom_up(true);
What is the impact of that. Do we need changes equivalent to that ? Also
where are we marking the nodes which can be hotplugged, ie where do we
do memblock_mark_hotplug(
Hi Leon,
On Fri, Sep 16, 2016 at 12:26 AM, Leon Romanovsky wrote:
> On Wed, Sep 14, 2016 at 12:36:19PM +0530, Parav Pandit wrote:
>> Hi Dennis,
>>
>> Do you know how would HFI1 driver would work along with rdma cgroup?
>>
>> Hi Matan, Leon, Jason,
>> Apart from HFI1, is there any other concern?
>
On Tue, Sep 20, 2016 at 11:08:44AM +0200, Jesper Dangaard Brouer via
iovisor-dev wrote:
> Hi all,
>
> As promised, I've started documenting the XDP eXpress Data Path):
>
> [1]
> https://prototype-kernel.readthedocs.io/en/latest/networking/XDP/index.html
>
> IMHO the documentation have reached
On 09/20/16 at 06:03pm, Jonathan Corbet wrote:
> On Mon, 19 Sep 2016 13:59:46 +0800
> Baoquan He wrote:
>
> > This is v10 post. In this patchset patch 1/3 is added to give more details
> > about nr_cpus and maxcpus in kernel-parameters.txt. This is suggested by
> > Jonathan since the description
On Tue, 20 Sep 2016 08:36:29 -0300
Mauro Carvalho Chehab wrote:
> This patch series update the kernel-docs.txt file, removing broken links,
> adding
> newer ones and ordering documents in published date.
OK, I'm still unconvinced about the value of this file, but, if people
want to keep it up t
On Mon, 19 Sep 2016 08:07:34 -0300
Mauro Carvalho Chehab wrote:
> That's the 4th version of this series. It also contains a second patch series
> with more ReST conversions and documentation improvements.
> This patchset merges the content of a second patch series:
>
> [PATCH 00/17] Improv
On Tue, 20 Sep 2016 12:49:59 +0900
Masanari Iida wrote:
> This patch fix typos "the the" found in Documentation/filesystems.
So this patch doesn't apply.
> Signed-off-by: Masanari Iida
> ---
> Documentation/filesystems/autofs4-mount-control.txt | 10 +-
In particular, this one fails.
On Mon, 19 Sep 2016 13:59:46 +0800
Baoquan He wrote:
> This is v10 post. In this patchset patch 1/3 is added to give more details
> about nr_cpus and maxcpus in kernel-parameters.txt. This is suggested by
> Jonathan since the description of them is unclear so that people can't see
> what's the ex
On Tue, 20 Sep 2016 09:04:20 -0700
Andrey Smirnov wrote:
> - if (dma_mapping_error(cp->dev, dma_handle)) {
> + if (dma_mapping_error(cp->dev, mapping)) {
Interesting, that has been wrong for the entire git era; another patch
fixed that line a few years ago, but left the w
Em Tue, 20 Sep 2016 13:00:33 -0600
Jonathan Corbet escreveu:
> On Tue, 20 Sep 2016 20:56:35 +0200
> Markus Heiser wrote:
>
> > > I submitted one patch fixing it. Not sure if it got merged by Jon
> > > or not.
> >
> > Ups, I might have overseen this patch .. as Jon said, its hard to
> > follo
On Tue, 20 Sep 2016 20:56:35 +0200
Markus Heiser wrote:
> > I submitted one patch fixing it. Not sure if it got merged by Jon
> > or not.
>
> Ups, I might have overseen this patch .. as Jon said, its hard to
> follow you ;)
>
> I tested the above with Jon's docs-next, so it seems your patch i
Am 19.09.2016 um 17:00 schrieb Mauro Carvalho Chehab :
>> Hmm, as far as I see, the output is not correct ... The output of
>> functions with a function pointer argument are missing the
>> leading parenthesis in the function definition:
>>
>> .. c:function:: struct v4l2_m2m_ctx * v4l2_m2m_ctx_
On 09/20/2016 12:17 AM, Winkler, Tomas wrote:
>
>
>> -Original Message-
>> From: Jonathan Corbet [mailto:cor...@lwn.net]
>> Sent: Monday, September 19, 2016 19:14
>> To: Shuah Khan
>> Cc: Dutt, Sudeep ; Dixit, Ashutosh
>> ; Winkler, Tomas ;
>> t...@linutronix.de; w...@iguana.be; li...@ro
On 09/19/2016 10:05 AM, Jonathan Corbet wrote:
> On Mon, 19 Sep 2016 08:47:33 -0600
> Shuah Khan wrote:
>
>> Move auxdisplay examples to samples and remove it from Documentation
>> Makefile. Create a new Makefile to build auxdisplay. It can be built
>> from top level directory or from auxdisplay
On 09/19/2016 10:10 AM, Jonathan Corbet wrote:
> On Mon, 19 Sep 2016 08:47:34 -0600
> Shuah Khan wrote:
>
>> Move laptops examples to samples and remove it from Documentation
>> Makefile. Create a new Makefile to build laptops. It can be built
>> from top level directory or from laptops directory
On 09/19/2016 10:02 AM, Jonathan Corbet wrote:
> On Mon, 19 Sep 2016 08:47:32 -0600
> Shuah Khan wrote:
>
>> Move accounting examples to samples and remove it from Documentation
>> Makefile. Create a new Makefile to build accounting. It can be built
>> from top level directory or from accounting
Fix a type in example variable name.
Signed-off-by: Andrey Smirnov
---
Documentation/DMA-API-HOWTO.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Documentation/DMA-API-HOWTO.txt b/Documentation/DMA-API-HOWTO.txt
index 781024e..d08a56a 100644
--- a/Documentation/DMA-API-H
The futex_pi_state structure will be overloaded in later patches to
store state information about non-PI futexes. So the structure name
itself is no longer a good description of its purpose. This patch
renames it to futex_state, a more generic name.
Some of the functions that process the futex sta
This patch adds a new futex_set_timer() function to consolidate all
the sleeping hrtime setup code.
Signed-off-by: Waiman Long
---
kernel/futex.c | 51 ---
1 files changed, 24 insertions(+), 27 deletions(-)
diff --git a/kernel/futex.c b/kernel/f
v1->v2:
- Adds an explicit lock hand-off mechanism.
- Adds timeout support.
- Simplifies the required userspace code.
- Fixes a number of problems in the v1 code.
This patchset introduces a new futex implementation called
throughput-optimized (TO) futexes. It is similar to PI futexes in i
This patch adds the timeout support in other futex types to TO
futexes. However, the timeout isn't as precise as the other futex
types due to the fact timer expiration can't currently be detected
when the thread is waiting in the serialization mutex.
Signed-off-by: Waiman Long
---
kernel/futex.c
This patch adds a new document file on how to use the TO futexes.
Signed-off-by: Waiman Long
---
Documentation/00-INDEX |2 +
Documentation/to-futex.txt | 140
2 files changed, 142 insertions(+), 0 deletions(-)
create mode 100644 Documentati
This patch introduces a new futex implementation called
throughput-optimized (TO) futexes. The goal of this new futex
type is to maximize locking throughput at the expense of fairness
and deterministic latency. Its throughput is higher than that of
the wait-wake futexes especially on systems with a
- Use lower case for sections, as this is the standard used on
the other ReST files;
- The latest version of this document is at the Kernel source, and
not at the listed URL. So, move it to the end of the doc.
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/kernel-docs.txt | 15 ++
This patch series update the kernel-docs.txt file, removing broken links, adding
newer ones and ordering documents in published date.
IMHO, after this patch series, kernel-docs.txt will be in a better shape and
could be useful to help new Kernel developers by providing them some extra
references.
From: Richard Sailer
Background/Reasoning:
Books:
--
* Linux Kernel Networking by Rami Rosen
While some parts are quite short and could be
more carefully explained it's still a good recomendation
for understanding linux kernel networking, (IMHO)
* Linux Treiber entwickeln:
It su
Add two books from my own bookshelf. I found them useful by
the time I bought; so it could be useful to others ;)
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/kernel-docs.txt | 16
1 file changed, 16 insertions(+)
diff --git a/Documentation/kernel-docs.txt b/Documenta
From: Richard Sailer
The dots at the ends of the list elements introduced
unnecesarry newlines in the "compiled" document.
While this was not "mission critical" it's not nice to look at
either.
[mche...@s-opensource.com: rebased to apply before rename]
Signed-off-by: Richard Sailer
Signed-off
Instead of using a random order, place the books on publication
date, from the newest to the oldest.
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/kernel-docs.txt | 92 ++-
1 file changed, 47 insertions(+), 45 deletions(-)
diff --git a/Documentat
There are three places where it mentions in-kernel docs.
Move them to a separate topic.
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/kernel-docs.txt | 91 ++-
1 file changed, 47 insertions(+), 44 deletions(-)
diff --git a/Documentation/kernel-d
It is a way better to have a timestamp to help identifying
when something is too old.
So, retrieve the dates marked on the existing documents.
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/kernel-docs.txt | 52 +++
1 file changed, 43 insertions(+
The Linux Kernel - This book is for Kernel 2.0.33
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/kernel-docs.txt | 17 -
1 file changed, 17 deletions(-)
diff --git a/Documentation/kernel-docs.txt b/Documentation/kernel-docs.txt
index 3c335bd58934..3b48deddd977 100644
---
Reorder the on-line documents based on their timestamp or
copyright notes. More updated documents come first.
While here, add the number of pages for POSIX4 document.
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/kernel-docs.txt | 536 +-
1 file
From: Richard Sailer
This introduces a consistent indenting of 4 spaces for all
lists.
[mche...@s-opensource.com: rebased to apply before rename]
Signed-off-by: Richard Sailer
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/kernel-docs.txt | 1222 --
There are still some broken docs: the URLs point to somewhere,
however, the texts are not there anymore. I was able to
find the texts on other URLs for some of those, but they're all
too old. So, just get rid of them.
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/kernel-docs.txt | 41 --
- remove LDD versions 1 and 2, as there's already an entry for
LDD3;
- add a link between LDD online and published entries.
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/kernel-docs.txt | 31 ++-
1 file changed, 2 insertions(+), 29 deletions(-)
diff --git
Em Tue, 20 Sep 2016 02:40:21 +0200
Richard Sailer escreveu:
> I think kernel-docs.rst should be kept. (Or at least another/updated
> file fullfilling this purpose should exist) Therefore I put
> some effort into updating it.
>
> This patch relies on Mauros:
>[Patch v2 ...] Create a book fo
Hi all,
As promised, I've started documenting the XDP eXpress Data Path):
[1] https://prototype-kernel.readthedocs.io/en/latest/networking/XDP/index.html
IMHO the documentation have reached a stage where it is useful for the
XDP project, BUT I request collaboration on improving the documentatio
On Mon, Sep 19, 2016 at 08:07:56AM -0300, Mauro Carvalho Chehab wrote:
> Add cross references for the documents mentioned at HOWTO and
> are under the Documentation/ directory, using the ReST notation.
>
> It should be noticed that HOWTO also mentions the /README file.
> We opted to not touch it,
On Mon, Sep 19, 2016 at 08:07:51AM -0300, Mauro Carvalho Chehab wrote:
> - use ReST markups for section headers;
> - add cross-references to the options;
> - mark code blocks;
> - a few minor changes to make Sphinx happy.
>
> Signed-off-by: Mauro Carvalho Chehab
> ---
> Documentation/stable_kern
42 matches
Mail list logo