[PATCH v2 0/3] taint: Add taint for randstruct

2018-02-19 Thread Kees Cook
This cleans up the taint flags and documentation before adding a new one for randstruct. This v2 reverts the #define->enum change as some architectures include TAINT flags in assembly source, which cannot use enums. Patch 3/3 reads: Since the randstruct plugin can intentionally produce extremely

[PATCH v2 1/3] taint: Convert to indexed initialization

2018-02-19 Thread Kees Cook
This converts to using indexed initializers instead of comments, adds a comment on why the taint flags can't be an enum, and make sure that no one forgets to update the taint_flags when adding new bits. Signed-off-by: Kees Cook --- include/linux/kernel.h | 1 +

[PATCH v2 2/3] taint: Consolidate documentation

2018-02-19 Thread Kees Cook
This consolidates the taint bit documentation into a single place with both numeric and letter values. Additionally adds the missing TAINT_AUX documentation. Signed-off-by: Kees Cook --- Documentation/sysctl/kernel.txt | 53 +

[PATCH v2 3/3] taint: Add taint for randstruct

2018-02-19 Thread Kees Cook
Since the randstruct plugin can intentionally produce extremely unusual kernel structure layouts (even performance pathological ones), some maintainers want to be able to trivially determine if an Oops is coming from a randstruct-built kernel, so as to keep their sanity when debugging. This adds

Re: [PATCH v2] irqchip/gic-v3-its: Add workaround for ThunderX2 erratum #174

2018-02-19 Thread Jayachandran C
On Sun, Jan 21, 2018 at 11:35:34AM +, Marc Zyngier wrote: > On Sun, 21 Jan 2018 07:00:48 +, > Jayachandran C wrote: > > > > On Thu, Jan 18, 2018 at 10:58:20AM +0530, Ganapatrao Kulkarni wrote: > > > This erratum is observed on the ThunderX2 GICv3 ITS. When a > > > MOVI command is used to

Re: [Intel-gfx] [PATCH 0/6] Add support for in-line nested struct comments

2018-02-19 Thread Daniel Vetter
On Fri, Feb 16, 2018 at 11:48:14AM -0200, Mauro Carvalho Chehab wrote: > This series fix two bugs at kernel-doc.rst examples and add support > for in-line nested struct comments. > > It also converts one documentation at intel_dpio_phy to use it, > in order to give a practical example about how

Re: [PATCH 00/23] kconfig: move compiler capability tests to Kconfig

2018-02-19 Thread Ulf Magnusson
Hello, On Sun, Feb 18, 2018 at 11:13 PM, Sam Ravnborg wrote: > Hi Masahiro. > > On Sat, Feb 17, 2018 at 03:38:28AM +0900, Masahiro Yamada wrote: >> I brushed up the implementation in this version. >> >> In the previous RFC, CC_HAS_ was described by using 'option shell=', >>

Re: [PATCH 1/1] mm, compaction: correct the bounds of __fragmentation_index()

2018-02-19 Thread Robert Harris
> On 19 Feb 2018, at 13:10, Mel Gorman wrote: > > On Mon, Feb 19, 2018 at 12:26:39PM +, Robert Harris wrote: >> >> >>> On 19 Feb 2018, at 09:47, Mel Gorman wrote: >>> >>> On Sun, Feb 18, 2018 at 04:47:55PM +, robert.m.har...@oracle.com wrote:

Re: [PATCH] linux-next: SLIMbus: doc: Fix a warning "Title underline too short"

2018-02-19 Thread Matthew Wilcox
On Mon, Feb 19, 2018 at 10:55:50PM +0900, Masanari Iida wrote: > Driver and Controller APIs: > --- > +--- > .. kernel-doc:: include/linux/slimbus.h Is this the right fix? Shouldn't we rather delete the : instead? We don't normally have a colon at

Re: [PATCH] linux-next: SLIMbus: doc: Fix a warning "Title underline too short"

2018-02-19 Thread Jonathan Corbet
On Mon, 19 Feb 2018 22:55:50 +0900 Masanari Iida wrote: > This patch fixes a warning during "make xmldocs" > > Documentation/driver-api/slimbus.rst:93: > WARNING: Title underline too short. > > Signed-off-by: Masanari Iida Applied, thanks. jon

Re: [RFC PATCH 0/3] Introduce Linux kernel labs documentation

2018-02-19 Thread Jonathan Corbet
On Mon, 19 Feb 2018 14:53:22 +0100 Octavian Purdila wrote: > We noticed that some APIs we used don't have kernel doc comments. > Would it be appropriate to add them as separate patches in this > series? Absolutely, though they should generally go through the appropriate

[PATCH] linux-next: SLIMbus: doc: Fix a warning "Title underline too short"

2018-02-19 Thread Masanari Iida
This patch fixes a warning during "make xmldocs" Documentation/driver-api/slimbus.rst:93: WARNING: Title underline too short. Signed-off-by: Masanari Iida --- Documentation/driver-api/slimbus.rst | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [RFC PATCH 0/3] Introduce Linux kernel labs documentation

2018-02-19 Thread Octavian Purdila
On Mon, Feb 19, 2018 at 1:22 AM, Jonathan Corbet wrote: > On Sun, 11 Feb 2018 20:05:43 +0200 > Daniel Baluta wrote: > >> The Linux kernel labs documentation is a collection of "labs" for >> various device driver topics. For each topic there are two parts:

Re: [PATCH 1/1] mm, compaction: correct the bounds of __fragmentation_index()

2018-02-19 Thread Mel Gorman
On Mon, Feb 19, 2018 at 12:26:39PM +, Robert Harris wrote: > > > > On 19 Feb 2018, at 09:47, Mel Gorman wrote: > > > > On Sun, Feb 18, 2018 at 04:47:55PM +, robert.m.har...@oracle.com wrote: > >> From: "Robert M. Harris" > >> > >>

Re: [PATCH 1/1] mm, compaction: correct the bounds of __fragmentation_index()

2018-02-19 Thread Michal Hocko
On Mon 19-02-18 12:14:26, Robert Harris wrote: > > > > On 19 Feb 2018, at 08:26, Michal Hocko wrote: > > > > On Sun 18-02-18 16:47:55, robert.m.har...@oracle.com wrote: > >> From: "Robert M. Harris" > >> > >> __fragmentation_index() calculates a

Re: [PATCH 1/1] mm, compaction: correct the bounds of __fragmentation_index()

2018-02-19 Thread Robert Harris
> On 19 Feb 2018, at 09:47, Mel Gorman wrote: > > On Sun, Feb 18, 2018 at 04:47:55PM +, robert.m.har...@oracle.com wrote: >> From: "Robert M. Harris" >> >> __fragmentation_index() calculates a value used to determine whether >> compaction

Re: [PATCH 1/1] mm, compaction: correct the bounds of __fragmentation_index()

2018-02-19 Thread Robert Harris
> On 19 Feb 2018, at 08:26, Michal Hocko wrote: > > On Sun 18-02-18 16:47:55, robert.m.har...@oracle.com wrote: >> From: "Robert M. Harris" >> >> __fragmentation_index() calculates a value used to determine whether >> compaction should be

Re: [PATCH 0/6] Add support for in-line nested struct comments

2018-02-19 Thread Jani Nikula
On Sun, 18 Feb 2018, Jonathan Corbet wrote: > On Fri, 16 Feb 2018 11:48:14 -0200 > Mauro Carvalho Chehab wrote: > >> his series fix two bugs at kernel-doc.rst examples and add support >> for in-line nested struct comments. >> >> It also converts one

Re: [PATCH 1/1] mm, compaction: correct the bounds of __fragmentation_index()

2018-02-19 Thread Mel Gorman
On Sun, Feb 18, 2018 at 04:47:55PM +, robert.m.har...@oracle.com wrote: > From: "Robert M. Harris" > > __fragmentation_index() calculates a value used to determine whether > compaction should be favoured over page reclaim in the event of allocation > failure. The

[PATCH] doc: Rename .system_keyring to .builtin_trusted_keys

2018-02-19 Thread Philipp Hahn
Commit d3bfe84129f65e0af2450743ebdab33d161d01c9 changed the name but did not update the documentation. Fixes: d3bfe84129f65e0af2450743ebdab33d161d01c9 --- Documentation/admin-guide/module-signing.rst | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git

[PATCH] doc: admin-guide/module-signing.rst fixes

2018-02-19 Thread Philipp Hahn
Two trivial corrections for the module signing documentation. Philipp Hahn (2): doc: Rename .system_keyring to .builtin_trusted_keys doc: module-signing.rst: Fix reST formatting Documentation/admin-guide/module-signing.rst | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) --

[PATCH] doc: module-signing.rst: Fix reST formatting

2018-02-19 Thread Philipp Hahn
Move the _if_ outside the verbatim string. Make key ring name as a verbatim string. --- Documentation/admin-guide/module-signing.rst | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/Documentation/admin-guide/module-signing.rst

Re: Inline emphasis warnings (more)

2018-02-19 Thread Markus Heiser
> Am 19.02.2018 um 10:31 schrieb Jani Nikula : > >> modified include/linux/kernel.h >> @@ -638,8 +638,10 @@ do { >>\ >> * trace_printk - printf formatting in the ftrace buffer >> * @fmt: the

[PATCH v2] doc: admin-guide/module-signing.rst fixes

2018-02-19 Thread Philipp Hahn
Two trivial corrections for the module signing documentation. v2: Add missing Signed-off-by Philipp Hahn (2): doc: Rename .system_keyring to .builtin_trusted_keys doc: module-signing.rst: Fix reST formatting Documentation/admin-guide/module-signing.rst | 10 +- 1 file changed, 5

[PATCH v2] doc: module-signing.rst: Fix reST formatting

2018-02-19 Thread Philipp Hahn
Move the _if_ outside the verbatim string. Make key ring name as a verbatim string. Signed-off-by: Philipp Hahn --- Documentation/admin-guide/module-signing.rst | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH v2] doc: Rename .system_keyring to .builtin_trusted_keys

2018-02-19 Thread Philipp Hahn
Commit d3bfe84129f65e0af2450743ebdab33d161d01c9 changed the name but did not update the documentation. Fixes: d3bfe84129f65e0af2450743ebdab33d161d01c9 Signed-off-by: Philipp Hahn --- Documentation/admin-guide/module-signing.rst | 10 +- 1 file changed, 5

Re: [PATCH 1/1] mm, compaction: correct the bounds of __fragmentation_index()

2018-02-19 Thread Michal Hocko
On Sun 18-02-18 16:47:55, robert.m.har...@oracle.com wrote: > From: "Robert M. Harris" > > __fragmentation_index() calculates a value used to determine whether > compaction should be favoured over page reclaim in the event of allocation > failure. The calculation