Hi Khalid,
On Fri, Mar 4, 2016 at 4:42 AM, Khalid Aziz wrote:
> On 03/02/2016 06:33 PM, Julian Calaby wrote:
>>
>> Hi Khalid,
>>
>> A couple of other comments:
>>
>> On Thu, Mar 3, 2016 at 5:54 AM, Khalid Aziz
>> wrote:
>>>
>>>
&
+ if (prev)
> + vma = prev;
> +
> + vma->vm_flags &= ~VM_SPARC_ADI;
> + if (end > vma->vm_end) {
> + change_protection(vma, addr, vma->vm_end,
> + vma-&g
Hi Khalid,
On Thu, Mar 3, 2016 at 11:25 AM, Khalid Aziz wrote:
> Thanks, Julian! I really appreciate your feedback.
No problem!
> My comments below.
>
> On 03/02/2016 04:08 PM, Julian Calaby wrote:
>>
>> Hi Khalid,
>>
>> On Thu, Mar 3, 2016 at 7:39 AM, Khali
oid __user *) addr;
> + info.si_trapno = 0;
> + force_sig_info(SIGSEGV, &info, current);
> +}
> +
Should this be ifdef'd too?
> void do_privop(struct pt_regs *regs)
> {
> enum ctx_state prev_state = exception_enter();
> diff --git a/kernel/sys
> the caller has not acquired the airplane-mode control beforehand, the
> operation fails.
>
> Signed-off-by: João Paulo Rechi Vita
This looks sane to me.
Reviewed-by: Julian Calaby
Thanks,
--
Julian Calaby
Email: julian.cal...@gmail.com
Profile: http://www.google.com/profiles/julian.
cur;
> +
> + rfkill_apm_owned = false;
> + data->is_apm_owner = false;
> + rfkill_apm_led_trigger_event(state);
Also, this code is duplicated from the _RELEASE op above. Would it
make sense to factor it out into a separate function?
> + }
&g
Hi João,
On Tue, Feb 9, 2016 at 2:41 AM, João Paulo Rechi Vita wrote:
> Factor all assignments to rfkill_global_states[].cur into a single
> function rfkill_update_global_state().
>
> Signed-off-by: João Paulo Rechi Vita
Looks sane to me.
Reviewed-by: Julian Calaby
> --
Hi João,
On Tue, Feb 9, 2016 at 2:41 AM, João Paulo Rechi Vita wrote:
> The "claim" sysfs interface has been removed, so its documentation now
> lives in the "removed" folder.
>
> Signed-off-by: João Paulo Rechi Vita
Looks right to me.
Reviewed-by: Julian Cal
Hi João,
On Tue, Feb 9, 2016 at 2:41 AM, João Paulo Rechi Vita wrote:
> Signed-off-by: João Paulo Rechi Vita
Looks sane to me.
Reviewed-by: Julian Calaby
> ---
> net/rfkill/core.c | 1 -
> 1 file changed, 1 deletion(-)
>
> diff --git a/net/rfkill/core.c b/net/rfkill/core
Hi João,
On Tue, Feb 9, 2016 at 2:41 AM, João Paulo Rechi Vita wrote:
> Signed-off-by: João Paulo Rechi Vita
Looks right to me.
Reviewed-by: Julian Calaby
> ---
> net/rfkill/core.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/net/rfkill/c
10 matches
Mail list logo