VERY URGENT.

2014-08-28 Thread umar akmel
My Dear Good Friend. Compliment of the season, how are you and your family? Hope All is well. I am Mr Umar Akmel, the accountant general in the accounts unit Bank of Africa (BOA-BF) Ouagadougou Burkina Faso. I got your contact from the Burkina Faso chambers of commerce have some fund to claim in m

[PATCH] i2c-designware: Add support for ACPI i2c device

2014-08-28 Thread Carl Peng
AMD platform i2c bus controllers are ACPI devices, this patch is to add a ACPI glue for Designware core, make it support i2c bus controller with ACPI interface. Signed-off-by: Carl Peng --- drivers/i2c/busses/Kconfig | 12 + drivers/i2c/busses/Makefile | 1 +

[PATCH] i2c-designware: Add support for ACPI i2c device

2014-08-28 Thread Carl Peng
AMD platform i2c bus controllers are ACPI devices, this patch is to add a ACPI glue for Designware core, make it support i2c bus controller with ACPI interface. Signed-off-by: Carl Peng --- drivers/i2c/busses/Kconfig | 12 + drivers/i2c/busses/Makefile | 1 +

[PATCH 8/8] mfd: as3722: Rid driver of superfluous I2C device ID structure

2014-08-28 Thread Lee Jones
Also remove unused second probe() parameter 'i2c_device_id'. Acked-by: Grant Likely Signed-off-by: Lee Jones --- drivers/mfd/as3722.c | 12 ++-- 1 file changed, 2 insertions(+), 10 deletions(-) diff --git a/drivers/mfd/as3722.c b/drivers/mfd/as3722.c index 39fa554..cb2fcf9 100644 --- a

[PATCH RESEND 0/8] i2c: Relax mandatory I2C ID table passing

2014-08-28 Thread Lee Jones
Hi Wolfram, Placing this firmly back on your plate. I truly hope we don't miss another merge-window. This patch-set has the support of some pretty senior kernel maintainers, so I hope acceptance shouldn't be too difficult. As previously discussed I believe it should be okay for an I2C device dr

[PATCH 5/8] i2c: Export i2c_match_id() for direct use by device drivers

2014-08-28 Thread Lee Jones
When there was no other way to match a I2C device to driver i2c_match_id() was exclusively used. However, now there are other types of tables which are commonly supplied, matching on an i2c_device_id table is used less frequently. Instead of _always_ calling i2c_match_id() from within the framewo

[PATCH 6/8] i2c: Provide a temporary .probe2() call-back type

2014-08-28 Thread Lee Jones
This will aid the seamless removal of the current probe()'s, more commonly unused than used second parameter. Most I2C drivers can simply switch over to the new interface, others which have DT support can use its own matching instead and others can call i2c_match_id() themselves. This brings I2C'

[PATCH 1/8] i2c: Add pointer dereference protection to i2c_match_id()

2014-08-28 Thread Lee Jones
Here we're providing dereference protection for i2c_match_id(), which saves us having to do it each time it's called. We're also stripping out the (now) needless checks in i2c_device_match(). This patch paves the way for other, similar code trimming. Acked-by: Grant Likely Signed-off-by: Lee Jo

[PATCH 4/8] i2c: Make I2C ID tables non-mandatory for DT'ed devices

2014-08-28 Thread Lee Jones
Currently the I2C framework insists on devices supplying an I2C ID table. Many of the devices which do so unnecessarily adding quite a few wasted lines to kernel code. This patch allows drivers a means to 'not' supply the aforementioned table and match on DT match tables instead. Acked-by: Grant

[PATCH 3/8] i2c: Match using traditional OF methods, then by vendor-less compatible strings

2014-08-28 Thread Lee Jones
This function provides a single call for all I2C devices which need to match firstly using traditional OF means i.e by of_node, then if that fails we attempt to match using the supplied I2C client name with a list of supplied compatible strings with the ',' string removed. The latter is required d

[PATCH 7/8] mfd: 88pm860x: Move over to new I2C device .probe() call

2014-08-28 Thread Lee Jones
As part of an effort to rid the mostly unused second parameter for I2C related .probe() functions and to conform to other existing frameworks we're moving over to a temporary replacement .probe() call-back. Acked-by: Grant Likely Signed-off-by: Lee Jones --- drivers/mfd/88pm860x-core.c | 5 ++--

[PATCH 2/8] i2c: Add the ability to match device to compatible string without an of_node

2014-08-28 Thread Lee Jones
A great deal of I2C devices are currently matched via DT node name, and as such the compatible naming convention of ',' has gone somewhat awry - some nodes don't supply one, some supply an arbitrary string and others the correct device name with an arbitrary vendor prefix. In an effort to correct

[PATCH v2 5/9] i2c: core: Convert to dev_pm_domain_attach|detach()

2014-08-28 Thread Ulf Hansson
Previously only the ACPI power domain was supported by the i2c bus. Let's convert to the common attach/detach functions for power domains, which currently means we are extending the support to include the generic power domain as well. Cc: linux-i2c@vger.kernel.org Signed-off-by: Ulf Hansson ---