Re: [PATCH 0/3] ptrace RSE handling - take 2

2007-12-12 Thread Roland McGrath
All looks good to me! Thanks, Roland - To unsubscribe from this list: send the line "unsubscribe linux-ia64" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html

RE: [PATCH 4 of 4] Add efi_guidtest_set to reduce duplication

2007-12-12 Thread Luck, Tony
> Would you like me to regenerate patch 1/4 without the reformatting of > those tests, so they maintain the original long-lines? I'm not a big fan of the 80 column rule ... but this file is a bit out of control ... and all the other bizarre formatting that you fixed up looks like an improvement.

RE: [PATCH 4 of 4] Add efi_guidtest_set to reduce duplication

2007-12-12 Thread Luck, Tony
> This is a list of duplicated tests. Using a #define makes it easier to add > new > ones and harder to introduce an error. The next new one to be added here is likely to be a check for the PALO table (http://www.dig64.org/home/DIG-PALO_09a.pdf) ... but it is unclear whether this fits the patter

Re: [PATCH] arch_ptrace_stop

2007-12-12 Thread Roland McGrath
> Mutter. These would be better as static inlines. A macro just invites > variable-unused warnings on non-ia64 and outright compilation errors on > ia64. Speaking from experience... > > static inline void arch_ptrace_stop(int exit_code, siginfo_t *info) > { > } > #define arch_ptrace_stop arch_p

Re: [PATCH 1/3] Rename TIF_PERFMON_WORK back to TIF_NOTIFY_RESUME

2007-12-12 Thread stephane eranian
Petr, On Dec 12, 2007 12:07 PM, Petr Tesarik <[EMAIL PROTECTED]> wrote: > > I'm making a mental note to review this later for optimization. AFAICS > fetching the pfm_needs_checking field is not too costly, but of course > it's an extra memory reference (and possibly a cache miss). > Yes. The TIF

[PATCH] ia64: honor notify_die() returning NOTIFY_STOP

2007-12-12 Thread Jan Beulich
This requires making die() and die_if_kernel() return a value, and their callers to honor this (and be prepared that it returns). Signed-off-by: Jan Beulich <[EMAIL PROTECTED]> arch/ia64/ia32/ia32_support.c |5 +++-- arch/ia64/kernel/traps.c | 35 +++ a

Re: [PATCH 2 of 4] Spelling/punctuation fixes

2007-12-12 Thread Aron Griffis
I guess I forgot my signoff on this one, if it matters for spelling fixes... # HG changeset patch # User Aron Griffis <[EMAIL PROTECTED]> # Date 1197470463 18000 # Node ID 049467433cda01769d2f8c276fcfeb7d216658d7 # Parent 1161690ae81590dec4e97c52f07cf1798c11a97b Spelling/punctuation fixes Woah i

[PATCH] ia64: make flush_tlb_kernel_range() an inline function

2007-12-12 Thread Jan Beulich
This fixes an unused variable warning in mm/vmalloc.c. Signed-off-by: Jan Beulich <[EMAIL PROTECTED]> include/asm-ia64/tlbflush.h |6 +- 1 file changed, 5 insertions(+), 1 deletion(-) --- linux-2.6.24-rc5/include/asm-ia64/tlbflush.h2007-12-12 12:27:38.0 +0100 +++ 2.6.24

[PATCH] ia64: remove dead code

2007-12-12 Thread Jan Beulich
Neither __cpu_down() nor __cpu_die() are being referenced without CONFIG_HOTPLUG_CPU. Signed-off-by: Jan Beulich <[EMAIL PROTECTED]> arch/ia64/kernel/smpboot.c | 11 --- 1 file changed, 11 deletions(-) --- linux-2.6.24-rc5/arch/ia64/kernel/smpboot.c 2007-12-12 12:27:11.0 +010

[PATCH 1 of 4] Make efi.c fit in 80 columns

2007-12-12 Thread Aron Griffis
# HG changeset patch # User Aron Griffis <[EMAIL PROTECTED]> # Date 1197428035 18000 # Node ID 1161690ae81590dec4e97c52f07cf1798c11a97b # Parent 3085cb07495e9e6c275c816342b27225d5f6529d Make efi.c fit in 80 columns This patch is purely whitespace changes to make the code fit in 80 columns, plus f

[PATCH 4 of 4] Add efi_guidtest_set to reduce duplication

2007-12-12 Thread Aron Griffis
# HG changeset patch # User Aron Griffis <[EMAIL PROTECTED]> # Date 1197470701 18000 # Node ID 81b2361265e2950b6a627c00e36a27aa43e3fdb5 # Parent cc913b598bc641c5584bff8ad379d4e213367076 Add efi_guidtest_set to reduce duplication This is a list of duplicated tests. Using a #define makes it easier

[PATCH 3 of 4] Add /* never reached */ annotation

2007-12-12 Thread Aron Griffis
# HG changeset patch # User Aron Griffis <[EMAIL PROTECTED]> # Date 1197470595 18000 # Node ID cc913b598bc641c5584bff8ad379d4e213367076 # Parent 049467433cda01769d2f8c276fcfeb7d216658d7 Add /* never reached */ annotation As written, this loop could be for (;;) instead of do while (md). The tests

[PATCH 2 of 4] Spelling/punctuation fixes

2007-12-12 Thread Aron Griffis
# HG changeset patch # User Aron Griffis <[EMAIL PROTECTED]> # Date 1197470463 18000 # Node ID 049467433cda01769d2f8c276fcfeb7d216658d7 # Parent 1161690ae81590dec4e97c52f07cf1798c11a97b Spelling/punctuation fixes Woah is not a word ;-) diff -r 1161690ae815 -r 049467433cda arch/ia64/kernel/efi.c

[PATCH 0 of 4] cleanups for efi.c

2007-12-12 Thread Aron Griffis
These trivial patches clean up efi.c. There are no functionality changes introduced by these patches. 1/4 - fix whitespace, fit in 80 columns, repair some indentation 2/4 - spelling and punctuation 3/4 - add /* never reached */ to a couple returns 4/4 - use a #define to reduce code duplication O

[PATCH 3/3] Synchronize RBS on PTRACE_ATTACH

2007-12-12 Thread Petr Tesarik
When attaching to a stopped process, the RSE must be explicitly synced to user-space, so the debugger can read the correct values. Signed-off-by: Petr Tesarik <[EMAIL PROTECTED]> CC: Roland McGrath <[EMAIL PROTECTED]> CC: Tony Luck <[EMAIL PROTECTED]> --- arch/ia64/kernel/ptrace.c | 57 +++

[PATCH 2/3] Synchronize kernel RSE to user-space and back

2007-12-12 Thread Petr Tesarik
This is base kernel patch for ptrace RSE bug. It's basically a backport from the utrace RSE patch I sent out several weeks ago. please review. when a thread is stopped (ptraced), debugger might change thread's user stack (change memory directly), and we must avoid the RSE stored in kernel to overr

[PATCH 1/3] Rename TIF_PERFMON_WORK back to TIF_NOTIFY_RESUME

2007-12-12 Thread Petr Tesarik
Since the RSE synchronization will need a TIF_ flag, but all work-to-be-done bits are already used, so we have to multiplex TIF_NOTIFY_RESUME again. Signed-off-by: Shaohua Li <[EMAIL PROTECTED]> Signed-off-by: Petr Tesarik <[EMAIL PROTECTED]> Cc: Tony Luck <[EMAIL PROTECTED]> --- arch/ia64/kern

[PATCH 0/3] ptrace RSE handling - take 2

2007-12-12 Thread Petr Tesarik
This patch series fixes handling of RSE by ptrace. Second try. I've incorporated the comments from the last round (with the exception of a dedicated bit for perfmon). Again, comments welcome (merging into GIT even more welcome ;), Petr Tesarik - To unsubscribe from this list: send the line "unsu

Re: [PATCH 1/3] Rename TIF_PERFMON_WORK back to TIF_NOTIFY_RESUME

2007-12-12 Thread Petr Tesarik
Stephane Eranian wrote: > Hello, > > On Thu, Dec 06, 2007 at 05:51:21PM +0100, Petr Tesarik wrote: >> The RSE synchronization will need a TIF_ flag, but all work-to-be-done >> bits are already used, so we'll have to multiplex TIF_NOTIFY_RESUME >> again. >> > > Yes, I knew this was coming. I think