Re: 2.6.21-mm1: many processes end up in D state

2007-05-05 Thread Tejun Heo
Mikael Pettersson wrote: I.e. no freezing of ports... Your patch to delete the 'return 1;' on error is correct, and makes the code match exactly the behaviour of previous versions of sata_promise, except for the additional error decoding. ahci and sata_sil24 do the return in this

[PATCH 03/11] libata-acpi: s/CONFIG_SATA_ACPI/CONFIG_ATA_ACPI/

2007-05-05 Thread Tejun Heo
ACPI applies to both SATA and PATA. Drop the 'S' from the config variable. Signed-off-by: Tejun Heo [EMAIL PROTECTED] --- drivers/ata/Kconfig| 26 +- drivers/ata/Makefile |2 +- drivers/ata/libata.h |2 +- include/linux/libata.h |2 +- 4 files

[PATCH 07/11] libata-acpi: clean up ata_acpi_exec_tfs()

2007-05-05 Thread Tejun Heo
This patch cleans up ata_acpi_exec_tfs() and its friends. * Rename taskfile_array to ata_acpi_gtf and make it __packed as it's used as argument to ACPI method, and use pointer to ata_acpi_gtf and number of taskfiles to represent _GTF taskfiles instead of a pointer casted into unsigned long

[PATCH 09/11] libata: reimplement ACPI invocation

2007-05-05 Thread Tejun Heo
This patch reimplements ACPI invocation such that, instead of exporting ACPI details to the rest of libata, ACPI event handlers - ata_acpi_on_resume() and ata_acpi_on_devcfg() - are used. These two functions are responsible for determining whether specific ACPI method is used and when. On

[PATCH 02/11] libata: during revalidation, check n_sectors after device is configured

2007-05-05 Thread Tejun Heo
Device might be resized during ata_dev_configure() due to HPA or (later) ACPI _GTF. Currently it's worked around by caching n_sectors before turning off HPA. The cached original size is overwritten if the device is reconfigured without being hardreset - which always happens after configuring

[PATCH 11/11] libata-acpi: implement _GTM/_STM support

2007-05-05 Thread Tejun Heo
Implement _GTM/_STM support. acpi_gtm is added to ata_port which stores _GTM parameters over suspend/resume cycle. A new hook ata_acpi_on_suspend() is responsible for storing _GTM parameters during suspend. _STM is executed in ata_acpi_on_resume(). With this change, invoking _GTF is safe on

[PATCH 08/11] libata-acpi: miscellaneous cleanups

2007-05-05 Thread Tejun Heo
* Add missing LOCKING: and RETURNS: to function comment. * Don't conditionalize warning messages with ata_msg_probe(). Print directly with KERN_WARNING. * Drop duplicate debug messages. Signed-off-by: Tejun Heo [EMAIL PROTECTED] --- drivers/ata/libata-acpi.c | 51

[PATCHSET] libata: improve ATA ACPI support, take#2

2007-05-05 Thread Tejun Heo
Hello, all. This is the second take of improve-ATA-ACPI-support patchset. Changes from the last take[L] are... * s/atadev/dev/ * s/do_drive_get_GTF/ata_dev_get_GTF/ * s/do_drive_set_taskfiles/ata_dev_set_taskfiles/ As I wrote in the previous thread, I don't think automatically matching ACPI

[PATCH 01/11] libata: separate out ata_dev_reread_id()

2007-05-05 Thread Tejun Heo
Separate out ata_dev_reread_id() from ata_dev_revalidate(). ata_dev_reread_id() reads IDENTIFY page and determines whether the same device is still there. ata_dev_revalidate() reconfigures after reread completes. This will be used by ACPI update. Signed-off-by: Tejun Heo [EMAIL PROTECTED] ---

[PATCH 04/11] libata-acpi: clean up parameters and misc stuff

2007-05-05 Thread Tejun Heo
This patch cleans up libata-acpi such that it looks similar to other libata files. This patch doesn't introuce any behavior changes. * make libata-acpi functions take ata_device instead of ata_port + device index * s/atadev/dev/ * de-indent local variable declarations Signed-off-by: Tejun Heo

[PATCH 05/11] libata-acpi: add ATA_FLAG_ACPI_SATA port flag

2007-05-05 Thread Tejun Heo
Whether a controller needs IDE or SATA ACPI hierarchy is determined by the programming interface of the controller not by whether the controller is SATA or PATA, or it supports slave device or not. This patch adds ATA_FLAG_ACPI_SATA port flags which tells libata-acpi that the port needs SATA ACPI

[PATCH 1/2] ATA: sata_promise, do not freeze ports

2007-05-05 Thread Jiri Slaby
If no objections, here comes the revert of the return 1 issue. -- sata_promise, do not freeze ports revert return 1 thing in the error isr, that causes port freezing, so that the system is unusable when exception is thrown. See http://lkml.org/lkml/2007/4/30/268 Cc: Jeff Garzik [EMAIL

Re: SATA SB600 works in 2.6.20.4 but not in 2.6.21-rc5 with irqpoll parameter

2007-05-05 Thread Tejun Heo
Matí­as Alejandro Torres wrote: May be it disables MSI for some other device/bridge/what ever: Right, that device gotta be PCI-e or PCI-x bridge and the disk controller lives in a different bus. Please apply the attached patch. This one really should fix the problem. :-) -- tejun diff --git

Re: [PATCH 1/2 pata-2.6] ide: make void and rename ide_dma_lostirq() method

2007-05-05 Thread Bartlomiej Zolnierkiewicz
On Tuesday 24 April 2007, Sergei Shtylyov wrote: Since ide_dma_lostirq() method's result is discarded, make it return 'void'. While at it, rename the method to dma_lost_irq(), drop the '__' prefix from the default method's name, and do some cleanups in this method driver-wise: - in

Re: [PATCH 2/2 pata-2.6] ide: make void and rename ide_dma_timeout() method

2007-05-05 Thread Bartlomiej Zolnierkiewicz
On Tuesday 24 April 2007, Sergei Shtylyov wrote: Since ide_dma_timeout() method's result is discarded, make it return 'void'. While at it, drop 'ide_' from the method's name, drop the '__' prefix from the default method's name, and do some cleanups in this method driver-wise: - in

Re: [PATCH] use mutex instead of semaphore in IDE driver

2007-05-05 Thread Bartlomiej Zolnierkiewicz
On Thursday 26 April 2007, Matthias Kaehlcke wrote: the IDE driver uses a semaphore as mutex. use the mutex API instead of the (binary) semaphore Signed-off-by: Matthias Kaehlcke [EMAIL PROTECTED] applied - To unsubscribe from this list: send the line unsubscribe linux-ide in the body of a

Re: [PATCH pata-2.6] hpt366: simplify UltraDMA filtering

2007-05-05 Thread Bartlomiej Zolnierkiewicz
On Monday 30 April 2007, Sergei Shtylyov wrote: Simplify UltraDMA mode filtering in the driver: - make use of the newly introduced 'udma_mask' field of 'ide_pci_device_t' to set the correct hwif-ultra_mask, modifying init_setup_hpt366() to select the correct mask based on the chip

Re: [PATCH pata-2.6 fix queue] hpt366: don't check enablebits for HPT36x

2007-05-05 Thread Bartlomiej Zolnierkiewicz
On Friday 04 May 2007, Sergei Shtylyov wrote: HPT36x chip don't seem to have the channel enable bits, so prevent the IDE core from checking them... Signed-off-by: Sergei Shtylyov [EMAIL PROTECTED] applied - To unsubscribe from this list: send the line unsubscribe linux-ide in the body of a

[git patches] IDE updates

2007-05-05 Thread Bartlomiej Zolnierkiewicz
Updates/fixes for host drivers. Please pull from: master.kernel.org:/pub/scm/linux/kernel/git/bart/ide-2.6.git/ to receive the following updates: drivers/ide/cris/ide-cris.c|9 +- drivers/ide/legacy/ide-cs.c|1 + drivers/ide/pci/aec62xx.c | 22 +--

Re: [PATCH pata-2.6] hpt366: simplify UltraDMA filtering

2007-05-05 Thread Sergei Shtylyov
Hello. Bartlomiej Zolnierkiewicz wrote: Simplify UltraDMA mode filtering in the driver: - make use of the newly introduced 'udma_mask' field of 'ide_pci_device_t' to set the correct hwif-ultra_mask, modifying init_setup_hpt366() to select the correct mask based on the chip revision; -

Re: [PATCH pata-2.6 fix queue] hpt366: don't check enablebits for HPT36x

2007-05-05 Thread Sergei Shtylyov
Hello. Bartlomiej Zolnierkiewicz wrote: HPT36x chip don't seem to have the channel enable bits, so prevent the IDE core from checking them... Signed-off-by: Sergei Shtylyov [EMAIL PROTECTED] applied I'm getting 403 Forbidden trying to browse this patch (and

Re: [PATCH pata-2.6] hpt366: simplify UltraDMA filtering (take 2)

2007-05-05 Thread Bartlomiej Zolnierkiewicz
On Saturday 05 May 2007, Sergei Shtylyov wrote: Simplify UltraDMA mode filtering in the driver: - make use of the newly introduced 'udma_mask' field of 'ide_pci_device_t' to set the correct hwif-ultra_mask, modifying init_setup_hpt366() to select the correct mask based on the chip

Re: [PATCH pata-2.6 fix queue] hpt366: don't check enablebits for HPT36x

2007-05-05 Thread Bartlomiej Zolnierkiewicz
On Saturday 05 May 2007, Sergei Shtylyov wrote: Hello. Bartlomiej Zolnierkiewicz wrote: HPT36x chip don't seem to have the channel enable bits, so prevent the IDE core from checking them... Signed-off-by: Sergei Shtylyov [EMAIL PROTECTED] applied I'm getting 403 Forbidden

[PATCH] sata_nv: fix ADMA freeze/thaw/irq_clear issues

2007-05-05 Thread Robert Hancock
This patch fixes some problems with ADMA-capable controllers with regard to freeze, thaw and irq_clear libata callbacks. Freeze and thaw didn't switch the ADMA-specific interrupts on or off, and more critically the irq_clear function didn't respect the restriction that the notifier clear

Re: 2.6.21-mm1: many processes end up in D state

2007-05-05 Thread Mikael Pettersson
On Sat, 05 May 2007 17:30:51 +0200, Tejun Heo wrote: Mikael Pettersson wrote: I.e. no freezing of ports... Your patch to delete the 'return 1;' on error is correct, and makes the code match exactly the behaviour of previous versions of sata_promise, except for the additional error