Re: Bug: get EXT3-fs error Allocating block in system zone

2007-12-18 Thread Marco Gatti
Linus Torvalds schrieb: On Mon, 10 Dec 2007, Marco Gatti wrote: I didn't compile completly. drivers/scsi/scsi_lib.c:1565:1: error: unterminated #else Heh. That #else should be an #endif, of course. It is a bit strange that it still tries to do IO to high memory. Either the whole 64 bit

Re: Questions about SATA hotplug in linux 2.6

2007-12-18 Thread Tejun Heo
Shane Huang wrote: Hi Jeff and Tejun: I want to continue this discussion with some questions: From: Tejun Heo wrote: Jeff Garzik wrote: Shane Huang wrote: 1. If users unplug one SATA HDD(no-root partition) or SATA ODD when the system is running, then plug it back to the same SATA

RE: Questions about SATA hotplug in linux 2.6

2007-12-18 Thread Shane Huang
Hi Tejun: Do you guys think it's normal? It not, how to make SATA hotplug work on different SATA port? Should it be supported by BIOS or hardware? If you connect it to a different port, the original device will die and new device will appear. That's the expected behavior. In the log, I

Re: ATA bus error with external hd on esata

2007-12-18 Thread Zsolt Barat
Jean-Louis Dupond schrieb: Greg Freemyer schreef: On Dec 17, 2007 5:53 AM, Andrew Morton [EMAIL PROTECTED] wrote: On Sat, 15 Dec 2007 21:10:47 +0100 Zsolt Barat [EMAIL PROTECTED] wrote: Zsolt Barat schrieb: hi list, Let's cc the IDE development list.

Re: ATA bus error with external hd on esata

2007-12-18 Thread Zsolt Barat
Greg Freemyer schrieb: On Dec 17, 2007 5:53 AM, Andrew Morton [EMAIL PROTECTED] wrote: On Sat, 15 Dec 2007 21:10:47 +0100 Zsolt Barat [EMAIL PROTECTED] wrote: Zsolt Barat schrieb: hi list, Let's cc the IDE development list. i just bought a MyBook called

Re: sata_mv not working with a RocketRaid 2220

2007-12-18 Thread Jean-Louis Dupond
Noticed it yet its not the best driver around, but its weird it almost can initialize 1 device on the controller (sdb), and the rest totally fails. Tried to put each disk in a JBOD, but that doesn't fix it neither. Anyway thank you for the reply. Think i'll get some better controller :) Mark

Re: [PATCH 1/5] libata: separate out ata_acpi_gtm_xfermask() from pacpi_discover_modes()

2007-12-18 Thread Jeff Garzik
applied patches 1-5 to #upstream, thanks for resending - To unsubscribe from this list: send the line unsubscribe linux-ide in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [patch 1/9] drivers/ata/libata-eh.c: fix printk warning

2007-12-18 Thread Jeff Garzik
[EMAIL PROTECTED] wrote: From: Andrew Morton [EMAIL PROTECTED] drivers/ata/libata-eh.c: In function `ata_port_pbar_desc': drivers/ata/libata-eh.c:215: warning: long long unsigned int format, long unsigned int arg (arg 4) Cc: Jeff Garzik [EMAIL PROTECTED] Signed-off-by: Andrew Morton [EMAIL

Re: [patch 2/9] pata_hpt37x-fix-outstanding-bug-reports-on-the-hpt374-and-37x-cable-detect-checkpatch-fixes

2007-12-18 Thread Jeff Garzik
[EMAIL PROTECTED] wrote: From: Andrew Morton [EMAIL PROTECTED] WARNING: line over 80 characters #70: FILE: drivers/ata/pata_hpt37x.c:850: + struct pci_dev *pdev_0 = pci_get_slot(pdev-bus, pdev-devfn - 1); ERROR: else should follow close brace '}' #78: FILE:

Re: [PATCH 01/15] libata: make atapi_request_sense() use sg

2007-12-18 Thread Jeff Garzik
Tejun Heo wrote: atapi_request_sense() is now the only left user of ata_sg_init_one(). Convert it to use sg interface. Signed-off-by: Tejun Heo [EMAIL PROTECTED] Cc: Rusty Russel [EMAIL PROTECTED] --- drivers/ata/libata-scsi.c |4 +++- 1 files changed, 3 insertions(+), 1 deletions(-) diff

Re: [PATCH 05/15] libata: rename ATA_PROT_ATAPI_* to ATAPI_PROT_*

2007-12-18 Thread Jeff Garzik
Tejun Heo wrote: ATA_PROT_ATAPI_* are ugly and naming schemes between ATA_PROT_* and ATA_PROT_ATAPI_* are inconsistent causing confusion. Rename them to ATAPI_PROT_* and make them consistent with ATA counterpart. Signed-off-by: Tejun Heo [EMAIL PROTECTED] --- drivers/ata/libata-core.c |

Re: [PATCH 07/15] change-data_xfer

2007-12-18 Thread Jeff Garzik
Tejun Heo wrote: Depending on how many bytes are transferred as a unit, PIO data tranasfer may consume more bytes than requested. Knowing how much data is consumed is necessary to determine how much is left for draining. This patch update -data_xfer such that it returns the number of consumed

Re: [PATCH 08/15] libata: improve ATAPI draining

2007-12-18 Thread Jeff Garzik
Tejun Heo wrote: For misc ATAPI commands which transfer variable length data to the host, overflow can occur due to application or hardware bug. Such overflows can be ignored safely as long as overflow data is properly drained. libata HSM implementation has this implemented in

Re: [PATCH 12/15] libata: make qc-nbytes include extra buffers

2007-12-18 Thread Jeff Garzik
Tejun Heo wrote: qc-nbytes didn't use to include extra buffers setup by libata core layer and my be odd. This patch makes qc-nbytes include any extra buffers setup by libata core layer and guaranteed to be aligned on 4 byte boundary. This value is to be used to program the host controller. As

Re: [PATCH 13/15] libata: implement ATAPI drain buffer

2007-12-18 Thread Jeff Garzik
Tejun Heo wrote: Misc ATAPI commands may try to transfer more bytes than requested. For PIO which is performed by libata HSM, this is worked around by draining extra bytes from __atapi_pio_bytes(). This patch implements drain buffer to perform draining for DMA and PIO-over-DMA cases. One page

Re: [PATCH 1/1] [LibATA] sata_mv: Remove dumplicated host template

2007-12-18 Thread Jeff Garzik
Saeed Bishara wrote: The mv5_sht and mv6_sht structures are identical. This patch removes one of those structures and renames the other to mv_sht. Signed-off-by: Saeed Bishara [EMAIL PROTECTED] --- drivers/ata/sata_mv.c | 22 ++ 1 files changed, 2 insertions(+), 20

Re: [PATCH 2/2] [libata] sata_mv: Support integrated controllers

2007-12-18 Thread Jeff Garzik
[EMAIL PROTECTED] wrote: From: Saeed Bishara [EMAIL PROTECTED] Marvell's Orion SoC includes SATA controllers based on Marvell's PCI-to-SATA 88SX controllers. The integrated SATA unit is connected directly to the internal bus of the Orion SoC, and not via PCI. This patch extends the libATA

Re: [PATCH] pata_pcmcia: Minor cleanups and support for dual channel cards

2007-12-18 Thread Jeff Garzik
Alan Cox wrote: Signed-off-by: Alan Cox [EMAIL PROTECTED] applied #upstream - To unsubscribe from this list: send the line unsubscribe linux-ide in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [patch 9/9] pata_legacy: restructure and revamp

2007-12-18 Thread Jeff Garzik
[EMAIL PROTECTED] wrote: From: Alan Cox [EMAIL PROTECTED] Rework the pata_legacy driver to have an internal way to plug multiple legacy interface types and designs into the driver. This driver supports - Generic legacy ISA on primary/secondary and tertiary ports - BIOS or

Re: [PATCH 1/2] [libata] sata_mv: Remove PCI dependency

2007-12-18 Thread Jeff Garzik
[EMAIL PROTECTED] wrote: From: Saeed Bishara [EMAIL PROTECTED] The integrated SATA controller is connected directly to the SoC's internal bus, not via PCI interface. this patch removes the dependency on the PCI interface. Signed-off-by: Saeed Bishara [EMAIL PROTECTED] --- drivers/ata/Kconfig

Re: [PATCH 1/2] [libata] sata_mv: Remove PCI dependency

2007-12-18 Thread Jeff Garzik
[EMAIL PROTECTED] wrote: From: Saeed Bishara [EMAIL PROTECTED] The integrated SATA controller is connected directly to the SoC's internal bus, not via PCI interface. this patch removes the dependency on the PCI interface. Signed-off-by: Saeed Bishara [EMAIL PROTECTED] --- drivers/ata/Kconfig

Merged some Alan patches...

2007-12-18 Thread Jeff Garzik
I just moved the following changes from #for-testing (which auto-propagates to -mm along with other stuff) into #upstream, queueing for 2.6.25: Applied: Author: Alan [EMAIL PROTECTED] Date: Tue Oct 2 13:53:05 2007 -0700 libata: fix (hopefully) all the remaining problems with devices

[PATCH 0/7] sg_ring: a ring of scatterlist arrays

2007-12-18 Thread Rusty Russell
This patch series is the start of my attempt to simplify and make explicit the chained scatterlist logic. It's not complete: my SATA box boots and seems happy, but all the other users of SCSI need to be updated and checked. But I've gotten far enough to believe it's worth persuing. Cheers,

[PATCH 1/7] sg_ring: introduce sg_ring: a ring of scatterlist arrays.

2007-12-18 Thread Rusty Russell
This patch introduces 'struct sg_ring', a layer on top of scatterlist arrays. It meshes nicely with routines which expect a simple array of 'struct scatterlist' because it is easy to break down the ring into its constituent arrays. The sg_ring header also encodes the maximum number of entries,

[PATCH 3/7] sg_ring: blk_rq_map_sg_ring as a counterpart to blk_rq_map_sg.

2007-12-18 Thread Rusty Russell
blk_rq_map_sg_ring as a counterpart to blk_rq_map_sg. Obvious counterpart to blk_rq_map_sg. Signed-off-by: Rusty Russell [EMAIL PROTECTED] --- block/ll_rw_blk.c | 55 include/linux/blkdev.h |1 + 2 files changed, 56 insertions(+), 0

[PATCH 4/7] sg_ring: dma_map_sg_ring() helper

2007-12-18 Thread Rusty Russell
Obvious counterpart to dma_map_sg. Note that this is arch-independent code; sg_rings are backwards compatible with simple sg arrays. Signed-off-by: Rusty Russell [EMAIL PROTECTED] --- drivers/base/dma-mapping.c | 13 + include/linux/dma-mapping.h |4 2 files changed, 17

[PATCH 5/7] sg_ring: Convert core scsi code to sg_ring.

2007-12-18 Thread Rusty Russell
If nothing else, the simplification of this logic shows why I prefer sg_ring over scatterlist chaining. Signed-off-by: Rusty Russell [EMAIL PROTECTED] diff --git a/drivers/block/cciss_scsi.c b/drivers/block/cciss_scsi.c --- a/drivers/block/cciss_scsi.c +++ b/drivers/block/cciss_scsi.c @@

[PATCH 6/7] sg_ring: libata simplification

2007-12-18 Thread Rusty Russell
[This patch has been obsoleted: Tejun has a more complete one, but it's not in mainline yet, so this serves to make the next patch apply]. libata separates the single buffer case from the scatterlist case internally. It's not clear that this is necessary. Remove the ATA_QCFLAG_SINGLE flag, and

[PATCH 7/7] sg_ring: convert core ATA code to sg_ring.

2007-12-18 Thread Rusty Russell
ATA relies so heavily on scsi that it needs to be converted at the same time. ATA adds padding to scatterlists in scsi commands, but because there was no good way of appending to those scatterlists, it had to use boutique iterators to make sure the padding is included. With sg_ring, ATA can

[PATCH 2/7] sg_ring: use in virtio.

2007-12-18 Thread Rusty Russell
Using sg_rings, we can join together scatterlists returned by other subsystems, without needing to allocate an extra element for chaining. This helps the virtio_blk device which wants to prepend and append metadata to the request's scatterlist. As an added bonus, the old virtio layer used to pass