Re: [RFC-UGLYPATCH] ata: small optimization in linux/libata.h

2008-02-15 Thread Mikael Pettersson
Tejun Heo writes: > Harvey Harrison wrote: > >>> I know it's ugly, but I had it done anyways. The one real problem I have > >>> with it is that if link and ap->pmp_link ever get changed to different > >>> types > >>> the compiler will not even warn as we cast away to (char *). To make it >

Re: IDE cdrom problem with PLEXTOR DVDR PX-608AL

2008-02-15 Thread Borislav Petkov
On Thu, Feb 14, 2008 at 02:42:58PM +0100, Boris Petkov wrote: > On 2/14/08, Bartlomiej Zolnierkiewicz <[EMAIL PROTECTED]> wrote: > > On Thursday 14 February 2008, Borislav Petkov wrote: > > > On Thu, Feb 14, 2008 at 12:37:50AM +0100, Hans-Peter Jansen wrote: > > > > > > [Added Bart to CC] > > > > >

Re: 2.6.26-git0: IDE oops during boot

2008-02-15 Thread Kamalesh Babulal
Yinghai Lu wrote: > On Thu, Feb 14, 2008 at 1:46 AM, Kamalesh Babulal > <[EMAIL PROTECTED]> wrote: >> Bartlomiej Zolnierkiewicz wrote: >> > Hi, >> > >> > On Tuesday 12 February 2008, Kamalesh Babulal wrote: >> >> Bartlomiej Zolnierkiewicz wrote: >> >>> Hi, >> >>> >> >>> On Monday 11 February

[Bug 8006] a likely logging error in "cdrom/sbpcd.c"

2008-02-15 Thread bugme-daemon
http://bugzilla.kernel.org/show_bug.cgi?id=8006 [EMAIL PROTECTED] changed: What|Removed |Added AssignedTo|linux-ide@vger.kernel.org |[EMAIL PROTECTED] Status|NE

Re: "ide=reverse" do we still need this?

2008-02-15 Thread Matthew Wilcox
On Thu, Feb 14, 2008 at 12:16:42PM -0500, Bill Davidsen wrote: > There are any number of things you can do when the system is booted, but > the only thing you can do when the system won't boot is use kernel boot > options. Greg's not removing your option to boot the system using an old kernel to

Re: [PATCH 0/4] ide: generic packet command representation

2008-02-15 Thread Jan Engelhardt
On Feb 12 2008 01:09, Bartlomiej Zolnierkiewicz wrote: > >> On a different note, i noticed ide-scsi might also need a cleanup >> similar to the other drivers. It is next on my TODO list in case >> you don't have anything with a higher prio. > >I was actually hoping that you'll continue unifying AT

Re: [PATCH 0/4] ide: generic packet command representation

2008-02-15 Thread Alan Cox
> So, why is ide-scsi still in the tree? Is there some use case besides > cdrecord? (Which can use /dev/hda already without the ide-scsi blob...) With old IDE only ide-scsi can handle some of the more obscurely weird devices, and some tape drives fail with ide-tape but work with ide-scsi + osst/s

Re: [PATCH 09/11] ata: fix sparse warning in pata_marvell.c

2008-02-15 Thread Jan Engelhardt
On Feb 13 2008 21:14, Harvey Harrison wrote: >drivers/ata/pata_marvell.c:88:2: warning: returning void-valued expression This is interesting. Why did not gcc warn us about this? (foo.c:3: warning: "return" with a value, in function returning void) - To unsubscribe from this list: send the line

Spurious completions during NCQ

2008-02-15 Thread Hugo Mills
I'm getting these on my Dell Latitude D830: Feb 15 13:06:00 willow kernel: ata1.00: exception Emask 0x2 SAct 0x4 SErr 0x0 action 0x2 frozen Feb 15 13:06:00 willow kernel: ata1.00: spurious completions during NCQ issue=0x0 SAct=0x4 FIS=004040a1:0002 Feb 15 13:06:00 willow kernel: ata1.00:

Re: Spurious completions during NCQ

2008-02-15 Thread Calvin Walton
On Fri, 2008-02-15 at 13:46 +, Hugo Mills wrote: > I'm getting these on my Dell Latitude D830: > > Feb 15 13:06:00 willow kernel: ata1.00: exception Emask 0x2 SAct 0x4 SErr 0x0 > action 0x2 frozen > Feb 15 13:06:00 willow kernel: ata1.00: spurious completions during NCQ > issue=0x0 SAct=0x4

Re: pci_get_device_reverse(), why does Calgary need this?

2008-02-15 Thread Greg KH
On Fri, Feb 15, 2008 at 09:48:27AM +0200, Muli Ben-Yehuda wrote: > In conclusion, our usage doesn't seem lika a good fit for the probe > approach, although it could probably converted provided we got the > ordering right with regards to regular PCI device > initialization. Doesn't seem to be worth

Re: Spurious completions during NCQ

2008-02-15 Thread Hugo Mills
On Fri, Feb 15, 2008 at 10:00:00AM -0500, Calvin Walton wrote: > On Fri, 2008-02-15 at 13:46 +, Hugo Mills wrote: > > I'm getting these on my Dell Latitude D830: > > > > Feb 15 13:06:00 willow kernel: ata1.00: exception Emask 0x2 SAct 0x4 SErr > > 0x0 action 0x2 frozen > > Feb 15 13:06:00 wil

Re: Spurious completions during NCQ

2008-02-15 Thread Michael Tokarev
Hugo Mills wrote: > On Fri, Feb 15, 2008 at 10:00:00AM -0500, Calvin Walton wrote: >> On Fri, 2008-02-15 at 13:46 +, Hugo Mills wrote: >>> I'm getting these on my Dell Latitude D830: >>> >>> Feb 15 13:06:00 willow kernel: ata1.00: exception Emask 0x2 SAct 0x4 SErr >>> 0x0 action 0x2 frozen >>>

Re: pci_get_device_reverse(), why does Calgary need this?

2008-02-15 Thread Sam Ravnborg
On Fri, Feb 15, 2008 at 07:20:08AM -0800, Greg KH wrote: > On Fri, Feb 15, 2008 at 09:48:27AM +0200, Muli Ben-Yehuda wrote: > > In conclusion, our usage doesn't seem lika a good fit for the probe > > approach, although it could probably converted provided we got the > > ordering right with regards

Re: [RFC-UGLYPATCH] ata: small optimization in linux/libata.h

2008-02-15 Thread Jeff Garzik
Harvey Harrison wrote: diff --git a/include/linux/libata.h b/include/linux/libata.h index 2845983..f0e1178 100644 --- a/include/linux/libata.h +++ b/include/linux/libata.h @@ -1211,7 +1211,7 @@ static inline struct ata_link *ata_port_next_link(struct ata_link *link) return ap->pm

Re: [PATCH] SCSI: fix data corruption caused by ses v2

2008-02-15 Thread James Bottomley
On Wed, 2008-02-13 at 16:25 -0800, Yinghai Lu wrote: > one system: initrd get courrupted: > > RAMDISK: Compressed image found at block 0 > RAMDISK: incomplete write (-28 != 2048) 134217728 > crc error > VFS: Mounted root (ext2 filesystem). > Freeing unused kernel memory: 388k freed > init_special_

Re: pci_get_device_reverse(), why does Calgary need this?

2008-02-15 Thread yong xue
2008/2/15, Sam Ravnborg <[EMAIL PROTECTED]>: > On Fri, Feb 15, 2008 at 07:20:08AM -0800, Greg KH wrote: > > On Fri, Feb 15, 2008 at 09:48:27AM +0200, Muli Ben-Yehuda wrote: > > > In conclusion, our usage doesn't seem lika a good fit for the probe > > > approach, although it could probably conver

Re: ST31000340NS (1000G) Capacity equal 33MB issue.

2008-02-15 Thread Mark Lord
Richard Liu wrote: Dear Mark: 2008/2/15, Mark Lord <[EMAIL PROTECTED]>: Richard Liu wrote: > Hello all: > > I bought a Seagate ES.2 ST31000340NS (1000GB) and run at Gentoo > Linux kernel 2.6.24. > But Linux kernel report the disk size only 33MB. > I tried Intel ICH5 and Sil3112, but

[BUID_FAILURE] next-20080215 Build failure caused by ide: rework PowerMac media-bay support

2008-02-15 Thread Kamalesh Babulal
The linux-next-20080215 kernel build fails on the powerpc with following error CC arch/powerpc/platforms/powermac/setup.o In file included from arch/powerpc/platforms/powermac/setup.c:66: include/asm/mediabay.h:29: error: syntax error before 'ide_hwif_t' include/asm/mediabay.h:2

Re: [PATCH] pata_cs5536.c bugfix

2008-02-15 Thread Jeff Garzik
Martin K. Petersen wrote: Fix speed negotiation for secondary device. Signed-off-by: Martin K. Petersen <[EMAIL PROTECTED]> applied - To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.

Re: [libata-dev #upstream-fixes] pata_legacy: don't call ata_host_detach() after initialization failure

2008-02-15 Thread Jeff Garzik
Tejun Heo wrote: ata_host_detach() detaches an attached port and shouldn't be called on a port which hasn't been attached yet. pata_legacy incorrectly calls ata_host_detach() on unattached port after initialization failure causing oops. Fix it. Signed-off-by: Tejun Heo <[EMAIL PROTECTED]> Cc:

Re: [PATCH] pata_scc.c: add thaw ops

2008-02-15 Thread Jeff Garzik
Akira Iguchi wrote: This patch adds default thaw ops and fixes the freeze/thaw inconsistency. Signed-off-by: Kou Ishizaki <[EMAIL PROTECTED]> Signed-off-by: Akira Iguchi <[EMAIL PROTECTED]> --- diff -pu linux-2.6.25-rc1/drivers/ata/pata_scc.c linux-2.6.25-rc1_mod/drivers/ata/pata_scc.c --- lin

Re: [PATCH 06/11] ata: sparse fixes for pata_amd.c

2008-02-15 Thread Jeff Garzik
Harvey Harrison wrote: drop return statement. drivers/ata/pata_amd.c:149:2: warning: returning void-valued expression Commit ce54d1616302117fa98513ae916bbe1c02ea pata_amd: update mode selection for NV PATAs added the initializer for nv_mode_filter but missed deleting the previously set mod

Re: [PATCH] scsi: align shost->hostdata to cacheline

2008-02-15 Thread James Bottomley
On Fri, 2008-02-15 at 07:49 +0900, Tejun Heo wrote: > James Bottomley wrote: > > On Thu, 2008-02-14 at 18:48 +0900, Tejun Heo wrote: > >> shost->hostdata can contain arbitrary data including DMA target > >> buffers. Align it to cacheline. > >> > >> Signed-off-by: Tejun Heo <[EMAIL PROTECTED]> > >

Re: [PATCH 1/3] ata: make ata_scsiop_inq_89 static in libata-scsi.c

2008-02-15 Thread Jeff Garzik
Harvey Harrison wrote: Signed-off-by: Harvey Harrison <[EMAIL PROTECTED]> --- drivers/ata/libata-scsi.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) applied 1-2 of 3 - To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to [EMAIL PROTE

Re: Regression: kernel 2.6.24{,.1} ahci problem, does not boot (resend)

2008-02-15 Thread Malte Schröder
On Fri, 15 Feb 2008 08:35:10 +0900 Tejun Heo <[EMAIL PROTECTED]> wrote: > Malte Schröder wrote: > > Hello, > > on one of my machines neither 2.6.24 nor 2.6.24.1 work. > > The system is 64bit on Athlon X2 and ATI-Chipset (SB600). > > > > Extract from the kernel messages during boot: > > > > [ 6

Re: pci_get_device_reverse(), why does Calgary need this?

2008-02-15 Thread Greg KH
On Fri, Feb 15, 2008 at 04:31:40PM +0100, Sam Ravnborg wrote: > On Fri, Feb 15, 2008 at 07:20:08AM -0800, Greg KH wrote: > > On Fri, Feb 15, 2008 at 09:48:27AM +0200, Muli Ben-Yehuda wrote: > > > In conclusion, our usage doesn't seem lika a good fit for the probe > > > approach, although it could p

Re: [PATCH 1/3] ata: make ata_scsiop_inq_89 static in libata-scsi.c

2008-02-15 Thread Harvey Harrison
On Fri, 2008-02-15 at 13:51 -0500, Jeff Garzik wrote: > Harvey Harrison wrote: > > Signed-off-by: Harvey Harrison <[EMAIL PROTECTED]> > > --- > > drivers/ata/libata-scsi.c |2 +- > > 1 files changed, 1 insertions(+), 1 deletions(-) > > applied 1-2 of 3 > Any particular objection to 3/3? Ha

[PATCH] ata: fix sparse warnings in pata_legacy.c

2008-02-15 Thread Harvey Harrison
Use ld_qdi and ld_winbond to avoid shadowing static int variables qdi and winbond. The ld_ prefix refers to legacy_data. drivers/ata/pata_legacy.c:777:21: warning: symbol 'qdi' shadows an earlier one drivers/ata/pata_legacy.c:128:12: originally declared here drivers/ata/pata_legacy.c:811:21: warn

[PATCH 5/11v2] ata: replace macro with static inline in libata.h

2008-02-15 Thread Harvey Harrison
Move to using a static inline which will force the same typechecking that min_t/max_t do (in this case, short). As a bonus, avoid a ton of sparse warnings like: drivers/ata/pata_ali.c:176:14: warning: symbol '__x' shadows an earlier one drivers/ata/pata_ali.c:176:14: originally declared here Due

Re: [RFC-UGLYPATCH] ata: small optimization in linux/libata.h

2008-02-15 Thread Christer Weinigel
On Thu, 14 Feb 2008 11:16:18 -0800 Harvey Harrison <[EMAIL PROTECTED]> wrote: > Original: > if (++link - ap->pmp_link < ap->nr_pmp_links) > Next: > if ((char*)++link - (char *)ap->pmp_link < ap->nr_pmp_links * > sizeof(*link)) return link; Ungh. Why not rewrite it as (untested):

Re: [PATCH 01/11] ata: fix sparse warning in ata_piix.c

2008-02-15 Thread Jeff Garzik
Harvey Harrison wrote: drivers/ata/ata_piix.c:1655:8: warning: symbol 'rc' shadows an earlier one drivers/ata/ata_piix.c:1616:6: originally declared here Signed-off-by: Harvey Harrison <[EMAIL PROTECTED]> --- drivers/ata/ata_piix.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) a

[git patches] libata fixes

2008-02-15 Thread Jeff Garzik
Got another couple sata_mv fixes pending too... coming soon. Please pull from 'upstream-linus' branch of master.kernel.org:/pub/scm/linux/kernel/git/jgarzik/libata-dev.git upstream-linus to receive the following updates: drivers/ata/ata_piix.c |2 +- drivers/ata/libata-core.c |1

Re: [PATCH] SCSI: fix data corruption caused by ses v2

2008-02-15 Thread Yinghai Lu
On Friday 15 February 2008 07:53:06 am James Bottomley wrote: > On Wed, 2008-02-13 at 16:25 -0800, Yinghai Lu wrote: > > one system: initrd get courrupted: > > > > RAMDISK: Compressed image found at block 0 > > RAMDISK: incomplete write (-28 != 2048) 134217728 > > crc error > > VFS: Mounted root (

Re: [PATCH 5/11v2] ata: replace macro with static inline in libata.h

2008-02-15 Thread Alan Cox
> > NAK. This is a sparse bug, fix sparse. > > Yes, fair enough, but that's not all the patch is about. > > 1) it's using a max_t and min_t to force the comparisons as shorts, why > not just make it a static inline? Because max_t and min_t also force the comparsion types > 2) the static inline

Re: [PATCH 5/11v2] ata: replace macro with static inline in libata.h

2008-02-15 Thread Harvey Harrison
On Fri, 2008-02-15 at 22:53 +, Alan Cox wrote: > > > NAK. This is a sparse bug, fix sparse. > > > > Yes, fair enough, but that's not all the patch is about. > > > > 1) it's using a max_t and min_t to force the comparisons as shorts, why > > not just make it a static inline? > > Because max_t

Re: [PATCH 5/11v2] ata: replace macro with static inline in libata.h

2008-02-15 Thread Alan Cox
On Fri, 15 Feb 2008 14:06:55 -0800 Harvey Harrison <[EMAIL PROTECTED]> wrote: > Move to using a static inline which will force the same typechecking > that min_t/max_t do (in this case, short). As a bonus, avoid a ton > of sparse warnings like: > > drivers/ata/pata_ali.c:176:14: warning: symbol

[PATCH] ata: fix sparse warning in libata.h

2008-02-15 Thread Harvey Harrison
Avoids lots of these, also is more readable. include/linux/libata.h:1210:13: warning: potentially expensive pointer subtraction Change the subtraction to addition on the other side of the comparison. Thanks to Christer Weinigel for the suggestion. Signed-off-by: Harvey Harrison <[EMAIL PROTECTE

Re: [PATCH 5/11v2] ata: replace macro with static inline in libata.h

2008-02-15 Thread Harvey Harrison
On Fri, 2008-02-15 at 22:30 +, Alan Cox wrote: > On Fri, 15 Feb 2008 14:06:55 -0800 > Harvey Harrison <[EMAIL PROTECTED]> wrote: > > > Move to using a static inline which will force the same typechecking > > that min_t/max_t do (in this case, short). As a bonus, avoid a ton > > of sparse warn

Re: [PATCH] ata: fix sparse warning in libata.h

2008-02-15 Thread Tejun Heo
Harvey Harrison wrote: > Avoids lots of these, also is more readable. > include/linux/libata.h:1210:13: warning: potentially expensive pointer > subtraction > > Change the subtraction to addition on the other side of the comparison. > > Thanks to Christer Weinigel for the suggestion. > > Signed

Re: [PATCH 5/11v2] ata: replace macro with static inline in libata.h

2008-02-15 Thread Harvey Harrison
On Sat, 2008-02-16 at 00:05 +, Alan Cox wrote: > On Fri, 15 Feb 2008 15:08:50 -0800 > Harvey Harrison <[EMAIL PROTECTED]> wrote: > > > On Fri, 2008-02-15 at 22:53 +, Alan Cox wrote: > > > > > NAK. This is a sparse bug, fix sparse. > > > > > > > > Yes, fair enough, but that's not all the p

Re: [PATCH 5/11v2] ata: replace macro with static inline in libata.h

2008-02-15 Thread Harvey Harrison
From: Harvey Harrison <[EMAIL PROTECTED]> Subject: [PATCH 3/3] ata: simplify clock divisor logic in pata_amd.c Current code is essentially choosing between dividing by 1 or dividing by two, make the conditions a little more obvious. As a bonus, removes a sparse error: drivers/ata/pata_amd.c:59:11

Re: [PATCH 5/11v2] ata: replace macro with static inline in libata.h

2008-02-15 Thread Alan Cox
On Fri, 15 Feb 2008 15:08:50 -0800 Harvey Harrison <[EMAIL PROTECTED]> wrote: > On Fri, 2008-02-15 at 22:53 +, Alan Cox wrote: > > > > NAK. This is a sparse bug, fix sparse. > > > > > > Yes, fair enough, but that's not all the patch is about. > > > > > > 1) it's using a max_t and min_t to fo