[PATCH] sata_fsl: fix build with ATA_VERBOSE_DEBUG

2008-02-22 Thread Anton Vorontsov
: Anton Vorontsov <[EMAIL PROTECTED]> --- drivers/ata/sata_fsl.c |8 +--- 1 files changed, 5 insertions(+), 3 deletions(-) diff --git a/drivers/ata/sata_fsl.c b/drivers/ata/sata_fsl.c index 9ac36df..93789bf 100644 --- a/drivers/ata/sata_fsl.c +++ b/drivers/ata/sata_fsl.c @@ -335,7

Re: [PATCH v4 0/3] OF-platform PATA driver

2008-01-15 Thread Anton Vorontsov
s spotted by Stephen. Great news, thank you! -- Anton Vorontsov email: [EMAIL PROTECTED] backup email: [EMAIL PROTECTED] irc://irc.freenode.net/bd2 - To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to [EMAIL PROTECTED] More majordomo inf

[PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2008-01-09 Thread Anton Vorontsov
This patch adds localbus and pata nodes to use CF IDE interface on MPC8349E-mITX boards. Patch also updates defconfig and adds some code to probe localbus. Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> Acked-by: Olof Johansson <[EMAIL PROTECTED]> --- arch/powerpc/boot/dts/mpc8

[PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2008-01-09 Thread Anton Vorontsov
This driver nicely wraps around pata_platform library functions, and provides OF platform bus bindings to the PATA devices. Also add || PPC to the PATA_PLATFORM's "depends on" Kconfig entry, needed for PA Semi Electra. Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]&

[PATCH 1/3] [libata] pata_platform: make probe and remove functions device type neutral

2008-01-09 Thread Anton Vorontsov
Split pata_platform_{probe,remove} into two pieces: 1. pata_platform_{probe,remove} -- platform_device-dependant bits; 2. __ptata_platform_{probe,remove} -- device type neutral bits. This is done to not duplicate code for the OF-platform driver. Signed-off-by: Anton Vorontsov <[EMAIL PROTEC

[PATCH v4 0/3] OF-platform PATA driver

2008-01-09 Thread Anton Vorontsov
ntext pio-mode means "pio mode the bus already configured for"; - New optional patch that renames pata_platform_info's ioport_shift to reg_shift. Changes since RFC: - nuked drivers/ata/pata_platform.h; - powerpc bits: proper localbus node added. -- Anton Vorontsov email: [EMAI

Re: [PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-12-15 Thread Anton Vorontsov
On Sun, Dec 16, 2007 at 01:09:22AM +1100, Stephen Rothwell wrote: > On Fri, 14 Dec 2007 21:24:38 +0300 Anton Vorontsov <[EMAIL PROTECTED]> wrote: > > > > + prop = (u32 *)of_get_property(dn, "reg-shift", NULL); > > This cast is unnecessary. > > > +

[PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-12-14 Thread Anton Vorontsov
This patch adds localbus and pata nodes to use CF IDE interface on MPC8349E-mITX boards. Patch also adds code to probe localbus. Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> Acked-by: Olof Johansson <[EMAIL PROTECTED]> --- arch/powerpc/boot/dts/mpc8349emitx.d

[PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-12-14 Thread Anton Vorontsov
This driver nicely wraps around pata_platform library functions, and provides OF platform bus bindings to the PATA devices. Also add || PPC to the PATA_PLATFORM's "depends on" Kconfig entry, needed for PA Semi Electra. Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]&

[PATCH 1/3] [libata] pata_platform: make probe and remove functions device type neutral

2007-12-14 Thread Anton Vorontsov
Split pata_platform_{probe,remove} into two pieces: 1. pata_platform_{probe,remove} -- platform_device-dependant bits; 2. __ptata_platform_{probe,remove} -- device type neutral bits. This is done to not duplicate code for the OF-platform driver. Signed-off-by: Anton Vorontsov <[EMAIL PROTEC

[PATCH v3 0/3] OF-platform PATA driver

2007-12-14 Thread Anton Vorontsov
;s used to pass pio_mask to the __pata_platform_probe. That is, in ata-generic context pio-mode means "pio mode the bus already configured for"; - New optional patch that renames pata_platform_info's ioport_shift to reg_shift. Changes since RFC: - nuked drivers/ata/pata_platfo

Re: [PATCH v2 1/4] [libata] pata_platform: make probe and remove functions device type neutral

2007-12-05 Thread Anton Vorontsov
On Tue, Dec 04, 2007 at 08:06:25PM +0300, Anton Vorontsov wrote: > Split pata_platform_{probe,remove} into two pieces: > 1. pata_platform_{probe,remove} -- platform_device-dependant bits; > 2. __ptata_platform_{probe,remove} -- device type neutral bits. > > This is done to not dup

Re: [PATCH v2 2/4] [libata] pata_of_platform: OF-Platform PATA device driver

2007-12-04 Thread Anton Vorontsov
On Tue, Dec 04, 2007 at 02:01:21PM -0600, Olof Johansson wrote: > On Tue, Dec 04, 2007 at 10:49:21PM +0300, Anton Vorontsov wrote: > > tristate "Generic platform device PATA support" > > - depends on EMBEDDED || ARCH_RPC > > + depends on EMBEDDED || ARCH_PPC

Re: [PATCH v2 2/4] [libata] pata_of_platform: OF-Platform PATA device driver

2007-12-04 Thread Anton Vorontsov
On Tue, Dec 04, 2007 at 12:48:26PM -0600, Olof Johansson wrote: > Hi, > > On Tue, Dec 04, 2007 at 08:07:19PM +0300, Anton Vorontsov wrote: > > This driver nicely wraps around pata_platform library functions, [..] > There's a typo in the dependencies for PATA_PLATFORM

Re: [PATCH v2 3/4] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-12-04 Thread Anton Vorontsov
On Tue, Dec 04, 2007 at 01:16:57PM -0600, Olof Johansson wrote: > Hi, > > On Tue, Dec 04, 2007 at 08:07:26PM +0300, Anton Vorontsov wrote: > > diff --git a/arch/powerpc/boot/dts/mpc8349emitx.dts > > b/arch/powerpc/boot/dts/mpc8349emitx.dts > > index 5072f6d..c459b

[PATCH v2 4/4] [libata] pata_platform: s/ioport_shift/reg_shift/g

2007-12-04 Thread Anton Vorontsov
shifting is meaningless for ctl register. This patch should make Sergei Shtylyov a bit more happy. ;-) Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> --- arch/arm/mach-rpc/riscpc.c |2 +- arch/blackfin/mach-bf527/boards/ezkit.c |2 +- arch/blackfin/mach

[PATCH v2 3/4] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-12-04 Thread Anton Vorontsov
This patch adds localbus and pata nodes to use CF IDE interface on MPC8349E-mITX boards. Patch also adds code to probe localbus. Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> --- arch/powerpc/boot/dts/mpc8349emitx.dts| 18 +- arch/powerpc/platforms/83xx/mpc834x

[PATCH v2 2/4] [libata] pata_of_platform: OF-Platform PATA device driver

2007-12-04 Thread Anton Vorontsov
This driver nicely wraps around pata_platform library functions, and provides OF platform bus bindings to the PATA devices. Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> --- drivers/ata/Kconfig| 10 drivers/ata/Makefile |1 + drivers/ata/pata_of_plat

[PATCH v2 1/4] [libata] pata_platform: make probe and remove functions device type neutral

2007-12-04 Thread Anton Vorontsov
Split pata_platform_{probe,remove} into two pieces: 1. pata_platform_{probe,remove} -- platform_device-dependant bits; 2. __ptata_platform_{probe,remove} -- device type neutral bits. This is done to not duplicate code for the OF-platform driver. Signed-off-by: Anton Vorontsov <[EMAIL PROTEC

[PATCH v2 0/4] OF-platform PATA driver

2007-12-04 Thread Anton Vorontsov
t_shift to reg_shift. Changes since RFC: - nuked drivers/ata/pata_platform.h; - powerpc bits: proper localbus node added. -- Anton Vorontsov email: [EMAIL PROTECTED] backup email: [EMAIL PROTECTED] irc://irc.freenode.net/bd2 - To unsubscribe from this list: send the line "unsubscribe linux-ide&quo

Re: [PATCH 0/3] OF-platform PATA driver

2007-12-02 Thread Anton Vorontsov
On Sat, Dec 01, 2007 at 09:57:55PM -0600, Olof Johansson wrote: > On Sun, Dec 02, 2007 at 02:58:10AM +0300, Anton Vorontsov wrote: > > On Sat, Dec 01, 2007 at 05:54:49PM -0500, Jeff Garzik wrote: > > while (1) { > > send_patches(); > > > > if (ack_

Re: [PATCH 0/3] OF-platform PATA driver

2007-12-01 Thread Anton Vorontsov
On Sat, Dec 01, 2007 at 05:54:49PM -0500, Jeff Garzik wrote: > Anton Vorontsov wrote: > > Hi all, > > > > Here is the second spin of the OF-platform PATA driver and > > related patches. > > > > Changes since RFC: > > - nuked drivers/ata/pata_platfor

Re: [PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-11-30 Thread Anton Vorontsov
On Fri, Nov 30, 2007 at 02:43:50PM +0300, Sergei Shtylyov wrote: > Anton Vorontsov wrote: > > >>>Remaining question: any preferred name for that property? pio-mode okay? > >>>It's assuming that PIO6 capable bus supports PIO0 as well, thus no mask. > > >

Re: [PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-11-30 Thread Anton Vorontsov
On Fri, Nov 30, 2007 at 02:05:01PM +0300, Sergei Shtylyov wrote: > Anton Vorontsov wrote: > > >>>Remaining question: any preferred name for that property? pio-mode okay? > >>>It's assuming that PIO6 capable bus supports PIO0 as well, thus no mask. > > >

Re: [PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-11-30 Thread Anton Vorontsov
On Fri, Nov 30, 2007 at 01:17:22PM +0300, Sergei Shtylyov wrote: > Anton Vorontsov wrote: > > >Remaining question: any preferred name for that property? pio-mode okay? > >It's assuming that PIO6 capable bus supports PIO0 as well, thus no mask. > >I've a

Re: [PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-11-28 Thread Anton Vorontsov
On Wed, Nov 28, 2007 at 07:11:19PM +0300, Sergei Shtylyov wrote: > Anton Vorontsov wrote: > > >>>>This driver nicely wraps around pata_platform library functions, > >>>>and provides OF platform bus bindings to the PATA devices. > > >>>

Re: [PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-11-28 Thread Anton Vorontsov
On Tue, Nov 27, 2007 at 10:32:58PM +0100, Arnd Bergmann wrote: > On Tuesday 27 November 2007, Olof Johansson wrote: > > On Tue, Nov 27, 2007 at 06:39:08PM +0300, Anton Vorontsov wrote: > > > This driver nicely wraps around pata_platform library functions, > > > a

Re: [PATCH 0/3] OF-platform PATA driver

2007-11-28 Thread Anton Vorontsov
On Wed, Nov 28, 2007 at 06:51:51PM +0900, Paul Mundt wrote: > On Tue, Nov 27, 2007 at 06:37:08PM +0300, Anton Vorontsov wrote: > > Here is the second spin of the OF-platform PATA driver and > > related patches. > > > So either the patches are missing, or I wasn't CC&

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Anton Vorontsov
On Tue, Nov 27, 2007 at 09:07:14PM +0300, Sergei Shtylyov wrote: > Anton Vorontsov wrote: > > >>>>>2. "ioport" because shift^Wstride ;-) applies only to the io range > >>>>>(yes, it's obvious, but worth open-wording, no?). > > >&

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Anton Vorontsov
On Tue, Nov 27, 2007 at 08:34:11PM +0300, Sergei Shtylyov wrote: > Anton Vorontsov wrote: > > >>>2. "ioport" because shift^Wstride ;-) applies only to the io range > >>> (yes, it's obvious, but worth open-wording, no?). > > >> Contraryw

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Anton Vorontsov
, to memory range. By io range I meant "I/O base", in contrast to "CTL base". There is no need to apply shifting for CTL. That's why ioport-* appeared in the first place. -- Anton Vorontsov email: [EMAIL PROTECTED] backup email: [EMAIL PROTECTED] irc://irc.freenode.net/bd2 -

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Anton Vorontsov
s bad to list every needs-to-fixup board in the common > >driver. It also feels not so great creating something like > >pata-platform-stride-{1,2,4,...} compatible stuff. Heh. > >I didn't propose neither of that. :-) Yup, that was "by the way"... >All I w

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Anton Vorontsov
On Tue, Nov 27, 2007 at 06:49:13PM +0300, Sergei Shtylyov wrote: > Hello. Hi Sergei, > Anton Vorontsov wrote: > > >This patch adds localbus and pata nodes to use CF IDE interface > >on MPC8349E-mITX boards. > > >Patch also adds code to probe localbus. >

[PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Anton Vorontsov
This patch adds localbus and pata nodes to use CF IDE interface on MPC8349E-mITX boards. Patch also adds code to probe localbus. Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> --- arch/powerpc/boot/dts/mpc8349emitx.dts| 17 - arch/powerpc/platforms/83xx/mpc834x

[PATCH 1/3] [libata] pata_platform: make probe and remove functions device type neutral

2007-11-27 Thread Anton Vorontsov
Split pata_platform_{probe,remove} into two pieces: 1. pata_platform_{probe,remove} -- platform_device-dependant bits; 2. __ptata_platform_{probe,remove} -- device type neutral bits. This is done to not duplicate code for the OF-platform driver. Signed-off-by: Anton Vorontsov <[EMAIL PROTEC

[PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-11-27 Thread Anton Vorontsov
This driver nicely wraps around pata_platform library functions, and provides OF platform bus bindings to the PATA devices. Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> --- drivers/ata/Kconfig| 10 + drivers/ata/Makefile |1 + drivers/ata/pata_of_plat

[PATCH 0/3] OF-platform PATA driver

2007-11-27 Thread Anton Vorontsov
sly. ;-) Good luck, -- Anton Vorontsov email: [EMAIL PROTECTED] backup email: [EMAIL PROTECTED] irc://irc.freenode.net/bd2 - To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce pata node, make use pata_of_platform driver

2007-11-25 Thread Anton Vorontsov
On Sat, Nov 24, 2007 at 09:57:46PM +0100, Arnd Bergmann wrote: > On Friday 23 November 2007, Anton Vorontsov wrote: > > > > +static struct of_device_id mpc834x_ids[] = { > > +   { .compatible = "pata-platform", }, > > +   {},

Re: [RFC][PATCH 0/3] OF-platform PATA driver

2007-11-25 Thread Anton Vorontsov
On Sat, Nov 24, 2007 at 04:26:13PM +0900, Paul Mundt wrote: > On Fri, Nov 23, 2007 at 07:49:33PM -0500, Jeff Garzik wrote: > > Anton Vorontsov wrote: > > >Here is the PATA Platform driver using OF infrastructure. > > > > > >Mostly it's just a wrapper around

Re: [RFC][PATCH 0/3] OF-platform PATA driver

2007-11-25 Thread Anton Vorontsov
On Sat, Nov 24, 2007 at 09:50:07PM +0100, Arnd Bergmann wrote: > On Friday 23 November 2007, Anton Vorontsov wrote: > > Here is the PATA Platform driver using OF infrastructure. > > > > Mostly it's just a wrapper around a bit modified pata_platform > > driver.

[PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-11-23 Thread Anton Vorontsov
Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> --- drivers/ata/Kconfig| 10 + drivers/ata/Makefile |1 + drivers/ata/pata_of_platform.c | 88 3 files changed, 99 insertions(+), 0 deletions(-) create mode

[PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce pata node, make use pata_of_platform driver

2007-11-23 Thread Anton Vorontsov
Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> --- arch/powerpc/boot/dts/mpc8349emitx.dts|9 +++-- arch/powerpc/platforms/83xx/mpc834x_itx.c | 17 + 2 files changed, 24 insertions(+), 2 deletions(-) diff --git a/arch/powerpc/boot/dts/mpc8349emitx.dts

[RFC][PATCH 0/3] OF-platform PATA driver

2007-11-23 Thread Anton Vorontsov
Hi all, Here is the PATA Platform driver using OF infrastructure. Mostly it's just a wrapper around a bit modified pata_platform driver. Patches are well split for the easier review: First one factors out platform_device specific bits and modifies pata_platform to be a library-alike driver (wit

[PATCH 1/3] [libata] pata_platform: make probe and remove functions device type neutral

2007-11-23 Thread Anton Vorontsov
Split pata_platform_{probe,remove} into two pieces: 1. pata_platform_{probe,remove} -- platform_device-dependant bits 2. __ptata_platform_{probe,remove} -- device type neutral bits. This is done to not duplicate code for the OF-platform driver. Signed-off-by: Anton Vorontsov <[EMAIL PROTEC