[PATCH 4/4] Input: synaptics-rmi4 - switch to using i2c_transfer()

2014-01-09 Thread Dmitry Torokhov
Instead of using 2 separate transactions when reading from the device let's use i2c_transfer. Because we now have single point of failure I had to change how we collect statistics. I elected to drop control data from the stats and only track number of bytes read/written for the device data. Also,

[PATCH 2/4] Input: synaptics-rmi4 - rework transport device allocation

2014-01-09 Thread Dmitry Torokhov
Instead of allocating common and private part of transport device separately make private wrap common part and get rid of private data pointer in the transport device. Also rename rmi_i2c_data -> rmi_i2c_xport and data -> rmi_i2c. Signed-off-by: Dmitry Torokhov --- drivers/input/rmi4/rmi_bus.h

[PATCH 3/4] Input: synaptics-rmi4 - fix I2C functionality check

2014-01-09 Thread Dmitry Torokhov
When adapter does not support required functionality (I2C_FUNC_I2C) we were returning 0 to the upper layers, making them believe that device bound successfully. Signed-off-by: Dmitry Torokhov --- drivers/input/rmi4/rmi_i2c.c | 9 - 1 file changed, 4 insertions(+), 5 deletions(-) diff --

[PATCH 1/4] Input: synaptics-rmi4 - split of transport ops into a separate structure

2014-01-09 Thread Dmitry Torokhov
Split off transport operations from rmi_transport_dev into a separate structure that will be shared between all devices using the same transport and use const pointer to access it. Change signature on transport methods so that length is using the proper tyep - size_t. Also rename rmi_transport_in

Re: [PATCH] input: synaptics-rmi4 - rmi_driver.h tidy up

2014-01-09 Thread Dmitry Torokhov
On Thu, Jan 09, 2014 at 05:59:38PM -0800, Christopher Heiny wrote: > This is a trivial change to remove an unused macro, and change CONFIG_PM to > CONFIG_PM_SLEEP. > > Signed-off-by: Christopher Heiny > Cc: Dmitry Torokhov > Cc: Benjamin Tissoires Applied, thank you. > > --- > > drivers/in

Re: [PATCH] input: synaptics-rmi4 - fix F01 DOM formatting

2014-01-09 Thread Dmitry Torokhov
On Thu, Jan 09, 2014 at 12:21:33PM -0800, Christopher Heiny wrote: > Use a sensible format string for the date of manufacture formatting. > > Signed-off-by: Christopher Heiny > Cc: Dmitry Torokhov > Cc: Benjamin Tissoires Applied, thank you. > > --- > > drivers/input/rmi4/rmi_f01.c | 5 ++-

[PATCH] add support for ALPS v7 protocol device

2014-01-09 Thread Qiting Chen
Here is the patch of supporting ALPS v7 protocol device. v7 device is a clickpad device. Device info: Device ID = 0x73, 0x03, 0x0a Firmware ID = 0x88, 0xb*, 0x** Support function of v7 device: - Cursor - Tap, double tap, tap drag, 2finger tap - Pan, pinch - Button click: v7 device

[PATCH] input: synaptics-rmi4 - rmi_driver.h tidy up

2014-01-09 Thread Christopher Heiny
This is a trivial change to remove an unused macro, and change CONFIG_PM to CONFIG_PM_SLEEP. Signed-off-by: Christopher Heiny Cc: Dmitry Torokhov Cc: Benjamin Tissoires --- drivers/input/rmi4/rmi_driver.h | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/input/rm

[PATCH 1/2] input: appletouch: parametrize and set saner defaults for fuzz and threshold

2014-01-09 Thread Clinton Sprain
From: Clinton Sprain Dials back the default fuzz and threshold settings for most devices using this driver, based on values from user feedback from forums and bug reports. This increases smoothness and movement granularity. No changes were made for the older devices that use the driver, as I did

[PATCH 2/2] input: appletouch: use better cursor movement smoothing algorithm

2014-01-09 Thread Clinton Sprain
From: Clinton Sprain Implements a new algorithm used to smooth cursor movement, using the inertia of the cursor's prior movements to modulate the next cursor movement. This further mitigates the 'stepping' users see when moving the cursor diagonally. A 'legacy' module parameter has been added in

[PATCH 0/2] input: appletouch: fixes for jagged/uneven cursor movement

2014-01-09 Thread Clinton Sprain
From: Clinton Sprain For many devices, the appletouch driver can make the trackpad feel insensitive and cursor movement will tend to jerk in steps. This is particularly noticeable when moving the cursor diagonally. This can greatly impact the trackpad's usability. The proposed changes address th

Re: [PATCH v2] input: synaptics-rmi4 - use snprintf instead of sprintf in rmi_i2c.c

2014-01-09 Thread Christopher Heiny
On 01/09/2014 02:25 PM, Dmitry Torokhov wrote: Input: synaptics-rmi4 - fix disabling gpio config in i2c transport From: Dmitry Torokhov We need to pass into pdata->gpio_config() gpio_data which is already a pointer, and not its address. Signed-off-by: Dmitry Torokhov --- drivers/input/rmi4/r

Re: [PATCH v2] input: synaptics-rmi4 - use snprintf instead of sprintf in rmi_i2c.c

2014-01-09 Thread Dmitry Torokhov
On Thu, Jan 09, 2014 at 02:11:00PM -0800, Christopher Heiny wrote: > On 01/09/2014 01:38 PM, Christopher Heiny wrote: > >On 01/09/2014 01:29 PM, Dmitry Torokhov wrote: > >>On Thu, Jan 09, 2014 at 01:23:37PM -0800, Christopher Heiny wrote: > On 01/09/2014 12:04 AM, Dmitry Torokhov wrote: > >

Re: [PATCH v2] input: synaptics-rmi4 - use snprintf instead of sprintf in rmi_i2c.c

2014-01-09 Thread Christopher Heiny
On 01/09/2014 01:38 PM, Christopher Heiny wrote: On 01/09/2014 01:29 PM, Dmitry Torokhov wrote: On Thu, Jan 09, 2014 at 01:23:37PM -0800, Christopher Heiny wrote: >On 01/09/2014 12:04 AM, Dmitry Torokhov wrote: > >On Wed, Jan 08, 2014 at 05:18:39PM -0800, Christopher Heiny wrote: > >>This is

Re: [PATCH v2] input: synaptics-rmi4 - use snprintf instead of sprintf in rmi_i2c.c

2014-01-09 Thread Christopher Heiny
On 01/09/2014 01:29 PM, Dmitry Torokhov wrote: On Thu, Jan 09, 2014 at 01:23:37PM -0800, Christopher Heiny wrote: >On 01/09/2014 12:04 AM, Dmitry Torokhov wrote: > >On Wed, Jan 08, 2014 at 05:18:39PM -0800, Christopher Heiny wrote: > >>This is a trivial change to replace the sprintf loop with

Re: [PATCH v2] input: synaptics-rmi4 - use snprintf instead of sprintf in rmi_i2c.c

2014-01-09 Thread Dmitry Torokhov
On Thu, Jan 09, 2014 at 01:23:37PM -0800, Christopher Heiny wrote: > On 01/09/2014 12:04 AM, Dmitry Torokhov wrote: > >On Wed, Jan 08, 2014 at 05:18:39PM -0800, Christopher Heiny wrote: > >>This is a trivial change to replace the sprintf loop with snprintf using > >>up-to-date format capability. >

Re: [PATCH v2] input: synaptics-rmi4 - use snprintf instead of sprintf in rmi_i2c.c

2014-01-09 Thread Christopher Heiny
On 01/09/2014 12:04 AM, Dmitry Torokhov wrote: On Wed, Jan 08, 2014 at 05:18:39PM -0800, Christopher Heiny wrote: This is a trivial change to replace the sprintf loop with snprintf using up-to-date format capability. Hmm, how about we do this instead: Input: synaptics-rmi4 - clean up debug ha

Re: [PATCH 0/5] HID logitech DJ fixes and preps for enabling extended features

2014-01-09 Thread Benjamin Tissoires
On 09/01/14 16:08, Andrew de los Reyes wrote: > In general, I'm positive on the change to fix the USB3 issue (yay!), > and for the others I'm happy it's going upstream. It seem to open up > the possibility of user-space drivers, which is great, even though we > don't need this on our team. > > One

[PATCH 3/3] Input: zforce: add devicetree support

2014-01-09 Thread Heiko Stübner
This makes the zforce driver usable on devicetree-based platforms too. Signed-off-by: Heiko Stuebner --- drivers/input/touchscreen/zforce_ts.c | 57 +++-- 1 file changed, 55 insertions(+), 2 deletions(-) diff --git a/drivers/input/touchscreen/zforce_ts.c b/drivers

[PATCH 0/3] Input: add dt support to zforce driver

2014-01-09 Thread Heiko Stübner
This adds the binding documentation and necessary parsing code to make zforce based touchscreen usable on devicetree platforms. Heiko Stuebner (3): dt-bindings: bindings for zforce touchscreens Input: zforce: Use internal pdata pointer instead of dev_get_platdata Input: zforce: add devicetre

[PATCH 2/3] Input: zforce: Use internal pdata pointer instead of dev_get_platdata

2014-01-09 Thread Heiko Stübner
When the device is initialized from devicetree the platformdata is created locally making dev_get_platdata return NULL. Therefore directly use the internal pointer to the pdata instead. Signed-off-by: Heiko Stuebner --- drivers/input/touchscreen/zforce_ts.c |6 +++--- 1 file changed, 3 inse

[PATCH 1/3] dt-bindings: bindings for zforce touchscreens

2014-01-09 Thread Heiko Stübner
Binding documentation for Neonode zForce infrared touchscreens. Signed-off-by: Heiko Stuebner --- .../bindings/input/touchscreen/zforce_ts.txt | 30 .../devicetree/bindings/vendor-prefixes.txt|1 + 2 files changed, 31 insertions(+) create mode 100644 Do

Re: [PATCH 0/5] HID logitech DJ fixes and preps for enabling extended features

2014-01-09 Thread Andrew de los Reyes
In general, I'm positive on the change to fix the USB3 issue (yay!), and for the others I'm happy it's going upstream. It seem to open up the possibility of user-space drivers, which is great, even though we don't need this on our team. One thing I want to double-check: on some devices (T651, at l

Re: [PATCH v2] input: synaptics-rmi4 - use snprintf instead of sprintf in rmi_i2c.c

2014-01-09 Thread Christopher Heiny
On 01/09/2014 12:48 PM, Dmitry Torokhov wrote: Christopher Heiny wrote: >On 01/09/2014 12:28 AM, Dmitry Torokhov wrote: >>On Thu, Jan 09, 2014 at 12:04:54AM -0800, Dmitry Torokhov wrote: >>>On Wed, Jan 08, 2014 at 05:18:39PM -0800, Christopher Heiny wrote: This is a trivial change to rep

Re: [PATCH v2] input: synaptics-rmi4 - use snprintf instead of sprintf in rmi_i2c.c

2014-01-09 Thread Dmitry Torokhov
Christopher Heiny wrote: >On 01/09/2014 12:28 AM, Dmitry Torokhov wrote: >> On Thu, Jan 09, 2014 at 12:04:54AM -0800, Dmitry Torokhov wrote: >>> On Wed, Jan 08, 2014 at 05:18:39PM -0800, Christopher Heiny wrote: This is a trivial change to replace the sprintf loop with snprintf >using up

Re: [PATCH v2] input: synaptics-rmi4 - use snprintf instead of sprintf in rmi_i2c.c

2014-01-09 Thread Christopher Heiny
On 01/09/2014 12:28 AM, Dmitry Torokhov wrote: On Thu, Jan 09, 2014 at 12:04:54AM -0800, Dmitry Torokhov wrote: On Wed, Jan 08, 2014 at 05:18:39PM -0800, Christopher Heiny wrote: This is a trivial change to replace the sprintf loop with snprintf using up-to-date format capability. Hmm, how ab

[PATCH] input: synaptics-rmi4 - fix F01 DOM formatting

2014-01-09 Thread Christopher Heiny
Use a sensible format string for the date of manufacture formatting. Signed-off-by: Christopher Heiny Cc: Dmitry Torokhov Cc: Benjamin Tissoires --- drivers/input/rmi4/rmi_f01.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/input/rmi4/rmi_f01.c b/drivers/in

Re: [PATCH 1/2] HID: sony: Add force feedback for the Dualshock 4

2014-01-09 Thread Frank Praznik
On 1/9/2014 01:42, si...@mungewell.org wrote: However I am seeing some weird behaviour in whether FF/LED actually functions. It seems that in a 'complete' kernel installation the driver does not present FF or LED. Found the problem (or at least a solution), there is no entry in 'hid-core.c' --

Re: [PATCH V1] input: use device managed memory in da9052 touchscreen driver

2014-01-09 Thread Dmitry Torokhov
--- > This patch is relative to linux-next repository tag next-20140109 > > Many thanks to Huqiu Liu who instigated this patch. > > drivers/input/touchscreen/da9052_tsi.c | 62 > > 1 file changed, 30 insertions(+), 32 deletions(-) > > d

Re: [PATCH] Input: gamepad - use independent axes for analog D-Pad buttons

2014-01-09 Thread David Herrmann
Hi Dmitry On Mon, Dec 30, 2013 at 7:50 PM, Dmitry Torokhov wrote: > On Mon, Dec 30, 2013 at 12:44:21PM +0100, David Herrmann wrote: >> Hi >> >> On Mon, Dec 30, 2013 at 12:20 PM, Antonio Ospite >> wrote: >> > On Sun, 29 Dec 2013 16:52:09 -0800 >> > Dmitry Torokhov wrote: >> > >> >> Hi Antonio, >

Re: [PATCHv6] staging/iio/adc: change the MXS touchscreen driver implementation

2014-01-09 Thread Alexandre Belloni
Hi, Sorry to chime in only now but it seems that this series is breaking the touchscreen calibration on 3.13 (and -rc7 is out so it might be too late). At first, I though I became a terrible clicker ;) but I found some evidences: xinput_calibrator is complaining about misclicks, debug output: DE

[PATCH V1] input: use device managed memory in da9052 touchscreen driver

2014-01-09 Thread Anthony Olech
driver are: devm_kzalloc() devm_input_allocate_device() devm_request_threaded_irq() Suggested-by: Huqiu Liu Signed-off-by: Anthony Olech --- This patch is relative to linux-next repository tag next-20140109 Many thanks to Huqiu Liu who instigated this patch. drivers/input/touchscreen

Re: [PATCH 2/2] HID: sony: Add LED controls for Dualshock 4

2014-01-09 Thread Antonio Ospite
On Fri, 3 Jan 2014 16:03:46 -0500 (EST) Frank Praznik wrote: > This patch builds on the previous patch and adds controls for the light Just use "Add controls for ..." > bar on the Dualshock 4. The light bar contains a red, green and blue LED > that can independently vary in brightness from 0

Re: [PATCH 1/2] HID: sony: Add force feedback for the Dualshock 4

2014-01-09 Thread Antonio Ospite
On Fri, 3 Jan 2014 16:03:10 -0500 (EST) Frank Praznik wrote: Hi Frank, just some notes about the style. > This patch adds force feedback support for Sony's Dualshock 4 controller. You can just use the imperative form in the long commit message too: "Add force feedback support for Sony's Dual

Re: [PATCH v2] input: synaptics-rmi4 - use snprintf instead of sprintf in rmi_i2c.c

2014-01-09 Thread Dmitry Torokhov
On Thu, Jan 09, 2014 at 12:04:54AM -0800, Dmitry Torokhov wrote: > On Wed, Jan 08, 2014 at 05:18:39PM -0800, Christopher Heiny wrote: > > This is a trivial change to replace the sprintf loop with snprintf using > > up-to-date format capability. > > Hmm, how about we do this instead: And another s

Re: [PATCH] input synaptics-rmi4: move rmi_f01 query register parsing to its own function

2014-01-09 Thread Dmitry Torokhov
On Tue, Jan 07, 2014 at 05:02:10PM -0800, Christopher Heiny wrote: > In the near future, query register parsing is going to get a lot more > complicated. It's also going to be needed by the reflash code. Now is the > time to move this from the F01 initialization into its own function, > while the

Re: [PATCH] input synaptics-rmi4 trivial: rmi_f01.c tidy-up

2014-01-09 Thread Dmitry Torokhov
On Tue, Jan 07, 2014 at 04:07:42PM -0800, Christopher Heiny wrote: > This has two trivial changes: > > 1) use CONFIG_PM_SLEEP instead of CONFIG_PM for consistency. > > 2) Update the copyright date. > > Signed-off-by: Christopher Heiny > Cc: Dmitry Torokhov > Cc: Benjamin Tissoires Applied, t

Re: [PATCH] input: synaptics-rmi4 - cleanup rmi_i2c_probe()

2014-01-09 Thread Dmitry Torokhov
On Wed, Jan 08, 2014 at 02:11:32PM -0800, Christopher Heiny wrote: > Moves i2c_check_functionality to occur before the gpio_config() call. This > can catch some issues that would otherwise result in mysterious problems > in gpio_config(). > > Reduces debugging output; updates remaining output to

Re: [PATCH v2] input: synaptics-rmi4 - use snprintf instead of sprintf in rmi_i2c.c

2014-01-09 Thread Dmitry Torokhov
On Wed, Jan 08, 2014 at 05:18:39PM -0800, Christopher Heiny wrote: > This is a trivial change to replace the sprintf loop with snprintf using > up-to-date format capability. Hmm, how about we do this instead: Input: synaptics-rmi4 - clean up debug handling in rmi_i2c From: Dmitry Torokhov Kern